Dxtory "Problem"?? Kann nicht in 30 FPS recorden

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Dxtory "Problem"?? Kann nicht in 30 FPS recorden

    Anzeige
    Hey, das hört sich jetzt vielleicht komsich an, aber immer, wenn ich versuche mit DXTory in 30 fps zu recorden habe ich erstens ingame fps einbrüche und die aufnahme ruckelt dementsprechend ebenso. Hab dann mal spaßeshalber versucht mit 200 fps zu recorden, und siehe da: Die ingamefpseinbrüche gingen weg und die aufnahme sah auch halbwegs flüssig aus. 60 fps ist so der beste Wert für mich zu recorden (lagarith)
    Liegt es vielleicht daran, dass ich mit vsync zocke? Schalte das vsync nicht ab, weil ich dann imenses tearing hätte ( da 60Hz-Monitor)
    Aber habe ich daduch nicht nen sichbaren qualitätsverlust, wenn ich dann hinterher mit x264 encode? Oder löst der encoder das irgendwie gschickter, anstatt die frames zu kicken?
    Hoffe, dass mir der ein oder andere vielleicht helfen kann. Danke schonmal im Vorraus :)
  • Julien schrieb:

    Notfalls VSync ausschalten und per DXTory auf 60 FPS begrenzen, das hilft auch.

    Ne nix begrenzen. Auch kein Framelimiter.

    Nix begrenzen. Komplett frei. Dann läufts am besten.

    Schalte das vsync nicht ab, weil ich dann imenses tearing hätte ( da 60Hz-Monitor)


    Doch schalte es ab. vsync bremst nur unnötig aus. Außerdem profitiert auch die Engine des Spiels davon. Denn je mehr fps du hast, desto flüssiger läuft dein Spiel - spürbar! Auch von der Steuerung her spürbar! Also das bissl Tearing akzeptieren und dafür ne flüssigere Engine haben.

    Wichtig ist anzuhaken:
    Synchronous Surface Lock und Wait for available Buffer .
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Anzeige
    Hallo,
    also erstmal Julien, ich kann mich an dieses tearing leider nicht bei spielen wie mw2 oder mw3 gewöhnen. Das sieht dann so dermaßen schwammig aus und macht keinen spaß :(
    Demon: Mit vsync läuft das bild aber sehr flüssig. Wenn ich vsync ausstelle geht sozusagen nichtst mehr, ganz ehrlich! Dann werden mir zwar 91 fps angezeigt, aber das bild sieht so schwammig aus...
    Gleiches ist übrigens auch bei Black ops 2 zu beobachten. Wenn ich dort (dieses spiel besitzt keine limitierung auf 91 fps) 90 fps anhake, dann läuft das spiel wieder unglaublich unflüssig und schwammig, was ein gutes aiming unmöglich machen.
    Wenn ich allerdings die fps-zahl auf unbegrenz festlege, und 125-200 fps habe, läuft es flüssig. Ich denke ich muss weiterhin mit der aufnahme in 60 fps arbeiten, da die ingame fps und die fertige rohdatei sonst murks wird. Achja demon, könntest du mir erklären welche vorteile es mit sich bringt, wenn ich die beiden von dir vorgeschlagenen optionen anhake, gegenüber einer aufnahme ohne das ankreuzen dieser optionen?

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von ShocksCinemaHD ()

  • ShocksCinemaHD schrieb:

    Wenn ich allerdings die fps-zahl auf unbegrenz festlege, und 125-200 fps habe, läuft es flüssig.

    Na also. Und das ratet man dir doch ;)

    Vsync aus. Framelimiter aus. Problem solved, besseres Spielerlebnis dank mehr frames. Und der Netcode eines Spiels findet mehr FPS auch besser, als weniger fps...

    achja: Ich habn 27" Monitor und nutze kein vsync, sehe das Problem nicht, eher das alles viel flüssiger läuft wenn man nix limitiert.

    Achja demon, könntest du mir erklären, welche vorteile es hat, wenn ich die beiden, vorgeschlagenen optionen, gegenüber einer aufnahe ohne das ankreuzen dieser optionen hat?


    Klick die Wörter halt an. Habs extra im Lexikon verfasst.

    Nicht auf Surface zu locken kann schon unflüssige Aufnahme bedeuten ;)
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Das heißt trotz aus erzwungenem vsync limitiert dich das Spiel auf 60fps, da es einen nicht abschaltbaren Framelimiter besitzt? Tja scheiß Konsolenorientierung neuzeitiger Spiele sag ich da nur....

    Schalte Triple Buffering an (Dreifach Puffer) beim Grafikkartentreiber. Könnte helfen.

    Bei DXTory es mit besagten Haken probieren.
    Aktuelle Projekte/Videos


  • Die Lösung ist aber behindert.

    Packt deine HDD überhaupt die 60fps zu halten?

    Derbe CPU Belastung und HDD Belastung für nonsens und der Encode braucht dann auch länger, da du es auf 30fps runtercodieren tust (geh ich mal von aus, es auf 60fps zu belassen wäre auch unnötig, yt gibt nur 30)

    Probier es doch mal mit dem was ich sagte..
    Aktuelle Projekte/Videos


  • ja, tut sie
    Jedenfalls resultieren aus "deinen" einstellungstipps nur ne instabile fps zahl und ruckler. Vllt. kommt ihr bei euren spielen mit leichtem tearing klar, aber so wie es auf 91 fps ind mw2 und mw3 ist geht das mal gar nicht.
    Werd wohl weiterhin in 60 fps aufnehmen und dann in 30 encodieren müssen. :/ :)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ShocksCinemaHD ()

  • ShocksCinemaHD schrieb:

    Jedenfalls resultieren aus "deinen" einstellungstipps nur ne instabile fps zahl und ruckler

    Das weist aber eig. drauf hin, das die HDD mit der Schreibleistung doch nicht so ganz hinterher kommt.

    Ohne SyncLock beeinträchtigt es nicht die ingameFPS wenn die HDD nicht hinterher kommt, aber es werden alle frames gedropt die die HDD so schnell nicht schreiben konnte, was sich unter sehr negativen Rucklern in der Videoaufnahme dann äußert.
    Aktuelle Projekte/Videos


  • Hab den log schonmal gepostet
    Dort sagtest du mir bereits, dass es nur an den audioeinstellungen was zu pfeilen gibt.

    @Demon

    Würde die platte nicht hinterherkommen hätte ich bei einer aufnahme mit 60 oder sogar 200 fps ja wohl massive fps einbrüche und die fertige datei würde ruckeln.
    Ich denke weiterhin, dass vsync drann schuld ist, und was ich nicht ändern kann, das kann ich nunmal nicht ändern.
    So demon, jetzt nochmal, glaubst du, dass ich bemerkbare qualitätsverluste hätte, wenn ich in 60fps aufnehmen und von MeGUI in 30 fps runterencodieren lassen würde?

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von ShocksCinemaHD ()

  • Ich habs noch nicht ausprobiert, aber auch ich hab diese FPS-Einbrüche bei manchen Spielen...

    Ein altes Spiel von 2004 läuft hier mit 60fps, nimmt perfekt mit 30fps auf und alles funktioniert. Ein anderes Spiel läuft mit 54-60fps und kaum starte ich die Aufnahme (alles 1080p) geht das runter auf 24fps und erholt sich nicht.

    Problem dabei: Lass ich das in 720p und im Fenster laufen ists genauso, 60fps ohne Aufnahme, maximal 26fps mit... nebenher sehe ich auf einem GPU-Monitor sogar das die GPU-Auslastung bei 60fps auf nahezu 100% liegt, kaum startet die Aufnahme geht das auf 60% zurück... meine GPU wird quasi "unterfordert" weil DXTory das Spiel bremst... Haken bei Limitierungen sind raus, aber auch das limitieren auf 58/59fps (Tipp aus dem dxtory-Forum) hilft nichts.

    Habe noch nicht ausprobiert mal mit 60fps aufzunehmen...

    VSync stell ich übrigens nicht ab da es sonst störendes tearing gibt, ich hab leider empfindliche Augen und seh das sofort (kann deswegen DLP-Beamer nicht lange im dunklen ertragen, Regenbogen-Effekt).

    Am Tripple-Buffering kanns ja nicht liegen, oder? Das hab ich im Treiber nämlich mal irgendwann aktiviert.

    Festplatte scheidet aus da auch im "Streaming-Modus" die FPS einbricht (und da schreibt DXTory ja nix auf HDD).

    Surface-Lock und Buffer sind angehakt, Threads auf 2 und als Codec Lagarith. Wozu ist eigtl. die Option "Synchronize Video FPS"?

    Werd mir aber eh bald ne neue Grafikkarte holen und nehme an das sich das Problem dann erledigen wird (mehr GPU-Power = mehr FPS, alte Spiele nehmen ja mit stabilen 30fps auf im gegensatz zu neuen Spielen), interessieren würd mich aber trotzdem ob Tripple-Buffering evtl. einen Einfluss auf die Aufnahme-FPS hat.

    // EDiT: Das alte Spiel hat kein Anti-Alias (und lässt es auch nicht erzwingen durch den Treiber), neuere Spiele haben es jedoch, könnte das evtl. bremsen? Ich weiß ja nicht was DXTory an GPU/Speicher-Anforderungen an die Grafikkarte stellt.
    ——YouTube————————————————————————————————————————————
    — Endlos-Projekte: Minecraft (SinglePlayer), Craft The World, Banished, Besiege, Sims4
    — ..Abgeschlossen: Leisure Suit Larry 6+7, Dishonored, Surface 2+3, Mirrors Edge, uvm
    — . Kurz- Projekte: The Tower, Fighting Is Magic, Euro Truck Simulator 2, uvm
    — ......Retro-Ecke: Day Of The Tentacle, Flight Of The Amazon Queen, NFS: HP2, uvm
    ————————————————————————————————————————————TbMzockt.de—

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von TbMzockt ()

  • TbMzockt schrieb:

    VSync stell ich übrigens nicht ab da es sonst störendes tearing gibt, ich hab leider empfindliche Augen und seh das sofort (kann deswegen DLP-Beamer nicht lange im dunklen ertragen, Regenbogen-Effekt).

    Genau das ist aber am häufigsten die Ursache, warum es zu Problemen kommt. Ausschalten. Ich rate dazu dringenst ;D

    Am Tripple-Buffering kanns ja nicht liegen, oder? Das hab ich im Treiber nämlich mal irgendwann aktiviert.


    Ist auch anzuraten wenn man schon vsync nimmt..

    Aber mit vsync bremste dir halt nur die ganze engine aus. Weniger flüssiges Spiel, und größerer input delay als nötig. Man merkts einfach auch an der flüssigkeit der steuerung.

    Werd mir aber eh bald ne neue Grafikkarte holen und nehme an das sich das Problem dann erledigen wird (mehr GPU-Power = mehr FPS, alte Spiele nehmen ja mit stabilen 30fps auf im gegensatz zu neuen Spielen), interessieren würd mich aber trotzdem ob Tripple-Buffering evtl. einen Einfluss auf die Aufnahme-FPS hat.


    Wenn die Aufnahme das so runter bremst, nützt dir eine neue Grafikkarte auch nicht viel. Dann liegts ja nicht an ihr.
    FPS Reduzierung der Aufnahme geschieht durch HDD und CPU Belastung. Bei GZDooM in 2048x1152, 30fps, bei einem i7 3770k @ 4,2 ghz, GF GTX 680, und nem RAID 0 mit 350 mbyte/s schreibend bei FFDShow uncompressed YV12 reduziert sich die ingame FPS durch die Aufnahme sogar gar nicht.
    Die Grafikkarte energiemodusmäßig auch nicht auf adaptiv stellen, sondern HÖCHSTLEISTUNG. Denn sonst idlet das ding auf in meinem Falle 3xx mhz rum, weil sie sich bei altem Spiel nicht gefordert fühlt und büße dadurch aufs heftigste fps ein. Und wenn die Aufnahme die GPU auf 60% runterzieht, wird das evtl dann schon wegen der Aufnahme so sein das die GPU im Idle Takt kleben bleibt. Daher den Energiemodus unbedingt auf höchstleistung. Ganz wichtig!
    abschließend:
    vsync aus, framelimiter aus => perfekte performance. Dumm das letzteres bei manchen Spielen halt nicht geht ..
    Aktuelle Projekte/Videos


  • Eine Framelimitation ist gar nicht mal so ungewöhnlich bei manchen Spielen. Musste ich auch des öfteren Feststellen. Indiana Jones und der Tum von Babel konnte ich nur mit einer Framelimitierung aufnehmen. Weil ohne hat sich das Spiel selbst voll aufgehangen. Also das war mehr ein "wie weit kann Dr. Jones sich sich hinwegruckeln" als ein flüssiges Spiel xD

    Viele Spiele brauchen das und andere wiederum nicht.

    Ob das Ding nun DXTory Framelimiter heißt, Afterburner Limiter oder bei FRAPS als "Lock Framerate while recoding"

    Alles das gleiche im Endeffekt nachher. Sorgt bei manchen Spielen für eine flüssigere Aufnahme. Kann aber auch zum Verhängnis werden. Daher auch mal mein Tipp dazu: Ausprobieren ob es für Abhilfe schafft bei Spielerucklern während der Aufnahme ;D
  • Kenne dieses Problem nur zu gut mit Pro Evolution Soccer 2014.
    Ingame ist absolut nichts einstellbar. Weder AA, noch Vsync(ist immer an/60fps). Vsync lässt sich auch nicht durch CCC oder RadeonPro beeinflussen.
    Wenn ich mit normalen Einstellungen die Aufnahme beginne, dann ruckelts. Setze ich aber den Haken bei "Limit Video FPS" und auf 60, dann ist das Spiel und die Aufnahme einwandfrei.

    Und kurioserweise, im Gegensatz zu dem was DeMoN sagt, ist die Spielsteuerung besser als wenn ich nicht aufnehme. Ich verstehe nicht warum, aber es ist so.
    Spiel das jetzt, traurigerweise irgendwie, nur noch mit Aufnahme :D