Video wird pixelig trotz guter Einstellungen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Video wird pixelig trotz guter Einstellungen

    Anzeige
    Hallo Miteinander,
    ich habe ein kleines Problem.

    Undzwar Schneide und Exportiere ich meine Videos mit Vegas nach MeGUI. Soweit alles okay. Das Endformat ist MKV für die Videodatei und Vorbis OGG für die Tonspuren. FLAC habe ich seit letztem Jahr nicht mehr genutzt, weil es immer Probleme auf Youtube gab. Wie dem auch sei, wenn ich nun ein Video von mir ansehe habe ich immer wieder Stellen in denen es "unscharf" "schwammig" oder auch "verpixelt" ist. Oft fällt es mir auf, wenn gerade viel passiert. Beispiel CoD viele schnelle Bewegungen etc.

    Jetzt Frage ich mich woran das liegen kann. Ich nehme in 1080p über DXTory mit dem Losless Lagarith Codec auf. Die Auflösung ist echt und wird auch nicht beim Bearbeiten verzerrt oder sonstiges. Meine aktuellen x264 Einstellungen findet Ihr hier:
    Spoiler anzeigen
    program --preset veryslow --crf 20 --output "output" "input"
    . Zuvor habe ich den crf-Wert auf 21.5 gehabt und die preset-Einstellung auf slow. Ich merke aber darin keinen Unterschied. Klar die Werte sind Minimal auseinander, dass ist mir bewusst aber selbst bei meinen ersten Config-Settings mit einem crf-Wert von 24.5 und Preset von slow fällt mir kaum ein Unterschied bei den Videos auf. Es wirkt immer gleich gut/schlecht wenn die unschärfe auftritt.

    Liegt es an mir oder ist es normal das Youtube so spackt? Wenn ich andere Videos angucke ist es meist nicht so wie bei mir.
    Ich habe hier mal ein Beispielvideo für Euch.


    Ab 1:43 wenn ich zurück in den Raum gehe wirkt es aufeinmal unscharf und leicht pixelig und kurz darauf wird es wieder schärfer.

    youtube.com/watch?feature=play…lpage&v=cMY0c82bu2M#t=103



    Ich würde mich echt mega über ein paar Antworten freuen.

    MfG dakujYa

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von dakujYa ()

  • Anzeige
    Was soll das Resampling der Videospur sein und wo ist diese Einstellung zu finden?
    *+ Edit: Okay ich habe noch nie was an dieser Einstellung gemacht, die einstellung steht auf Intelligentes Resampling und ich muss sagen das ich keinen Unterschied in der Videovorschau feststellen kann. Also nicht so wie es im Tutorialvideo welches ich auf YT gefunden habe.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von dakujYa ()

  • Blutengel2002 schrieb:

    Hast du das Resampling der Videospur deaktiviert (in Vegas) ?

    Das ist nur nötig, wenn man zu blöd ist in den Projekteinstellungen von Vegas die gleiche FPS Rate einzugeben wie auch das Quellmaterial hat :P

    FLAC habe ich seit letztem Jahr nicht mehr genutzt, weil es immer Probleme auf Youtube gab.

    Gibt es nicht. Halte die Spuren synchron. Das ist für jedes Audioformat wichtig. Youtube mag das nicht wenn die differenzieren.

    [ Text-Tutorial ] Automatisierungs Skripte (AVISynth, Batch, FFMpeg)

    Das bietet dir einen Audioexport, das dein Audio so exportiert wird, das er 100% identisch zur Videolänge ist.


    Skalier auf 2048x1152 hoch. 1080 bekommt nur maximal 6000 bitrate von yt.
    Aktuelle Projekte/Videos


  • De-M-oN schrieb:

    Blutengel2002 schrieb:

    Hast du das Resampling der Videospur deaktiviert (in Vegas) ?

    Das ist nur nötig, wenn man zu blöd ist in den Projekteinstellungen von Vegas die gleiche FPS Rate einzugeben wie auch das Quellmaterial hat :P

    FLAC habe ich seit letztem Jahr nicht mehr genutzt, weil es immer Probleme auf Youtube gab.

    Gibt es nicht. Halte die Spuren synchron. Das ist für jedes Audioformat wichtig. Youtube mag das nicht wenn die differenzieren.

    [ Text-Tutorial ] Automatisierungs Skripte (AVISynth, Batch, FFMpeg)

    Das bietet dir einen Audioexport, das dein Audio so exportiert wird, das er 100% identisch zur Videolänge ist.


    Skalier auf 2048x1152 hoch. 1080 bekommt nur maximal 6000 bitrate von yt.



    Okay, danke De-M-oN. Das mit dem Audio werde ich mir mal zu gemüte führen.
    Nur habe ich das mit der Videoqualität nicht ganz verstanden.
    Wenn ich das Video höher skaliere als die original Auflösung bekomme ich erst dann die eigentlichen 1080p wie es eigentlich sein sollte?
    Wird diese Auflösung als "Original" auf Youtube angesehen oder erst ab 4k+?
    Gibt es hier ein Tutorial was Du empfehlen kannst, denn ich weiß nicht wie ich ran gehen soll. Oder ist es so einfach wie ich es mir gerade denke? Also einfach nur die Auflösung der Vegas-Eigenschaften ändern?



    Vielen Dank für die Hilfe


    Gruß dakujYa
  • Die Auflösung in Vegas bleibt dem Quellmaterial gleichend.

    In das Script bei MeGUI ergänzt du:

    Quellcode

    1. Spline64Resize(2048,1152)


    Wenn ich das Video höher skaliere als die original Auflösung bekomme ich erst dann die eigentlichen 1080p wie es eigentlich sein sollte?

    Nö, jedoch bekommste dann einen wertigeren Encode angeboten von Youtube überhalb 1080.
    Bei 1080 mit nur max 6000 bitrate braucht man bei halbwegs komplexem Material leider keine Wunder erwarten bei deren ineffizienten Codiereinstellungen vor allem. Die höhere Stufe über 1080 wird dir yt dann besser codieren. Kleinere Stufen profitieren ein Tick auch von besser aufgelöstem Quellmaterial, von daher wird die 1080 minimal besser ausfallen.
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Okay... danke
    ähm, wo muss ich das genau Einstellen. also in der Config wohl möglich oder?

    Oder in das Script wenn ich das Video sette, also da wo ich auch audio=true eingeben muss?
    Muss ich das immer wieder eingeben, so mache ich das schon ewig und das ist irwo ein wenig nervig. Oder kann man das als preset speichern?



    Danke nochmal, ich wüsste echt nicht wie ich es sonst beheben soll.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von dakujYa ()

  • dakujYa schrieb:

    Oder in das Script wenn ich das Video sette, also da wo ich auch audio=true eingeben muss?

    Ja klar ins Script.

    Nutze auch hier am besten die alternative Scripterstellung, wo ich dich erneut wieder hierauf verweise:

    [ Text-Tutorial ] Automatisierungs Skripte (AVISynth, Batch, FFMpeg)


    Bei MeGUI kannste den Resize ins Avisynth Profil eintragen, dann ist der immer da.
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Hey das ist ja das gleiche Problem was ich auch habe bzw. mir auffällt. Hatte das ja mit den Presets von Demon gemacht, allerdings seh ich gerade das du ihm
    "Spline64Resize(2048,1152)" empfiehlst".
    In deinem MeGUI Tutorial Thread ist in den Presets aber überall Lanczos4, gibt es da einen Unterschied beim hoch skalieren?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von CPlay ()

  • Lanczos4 empfehle ich mittlerweile nicht mehr für Youtube. Die Schärfe und die Ringing neigung heben die Dateigröße an und neigt bei youtube leichter zu blockartefakte bei deren knappen bitrate.

    Wenn die GUI vom Sagaras für die Scripterstellung fertig ist, wird denk ich eh mal neues Video kommen - sowieso mal nötig. Dann wird sich ein wenig was ändern.

    Spline16Resize(2048,1152) wenn du kein Ringing willst. Ist weniger scharf, was sich aber positiv auf Dateigröße und weniger blocking auf yt äußern dürfte.
    Aktuelle Projekte/Videos


  • Was sind denn die mit abstand besten Einstellungen um eine perverse Videoqualität hinzu bekommen wie du sie hast De-M-oN?
    Wenn ich mir meine Videos ansehe bekomme ich nen leichten Anfall. total pixelig etc. Das hier ist das perfekte Beispiel dafür: youtube.com/watch?v=gjRrnLh1U4…=UUfNzxytJ6cOzcHjmQXp5ykg
    Alles ist pixelig, aber das sollte mitm einen Settings nicht vorkommen, ja dein ResizeCommand ist noch nicht bei dem Video angewendet worden, aber selbst damit sieht es nicht so pralle aus. Irwas mache ich doch falsch. Dateigröße spielt bei meiner Leitung keine Rolle. Mehr als 3h Zeit für nen Video bei einer Größe von 30min möchte ich aber auch nicht ausgeben. Da muss doch ein guter Mix zu finden sein ;(

    - Wenn ich nicht mit meiner Videoqualli zufrieden bin wie sollen es dann meine Abonnenten sein?

    Trotzdem danke an der Stelle. Musss meinen Koffer weiter packen :D

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von dakujYa ()

  • Ich bin wieder da und habe direkt wieder ein Problem :D
    Mein neustes Video hat wieder diesen pregnannten "pixeligen, verschmierenden" Fehler, aber ich weiss nicht woran es liegt.

    Selbst wenn ich auf die höschste Auflösung einstelle und das Video im kleinsten Fenster wiedergebe, merke ich sofort wie es auf einmal schwammig pixelig wird bei 09:00 Sekunden wird.
    youtu.be/0TEQUccPEOU

    Ich verstehe nicht warum das so ist, die Fertigen Videos sind auf dem PC in einer Top Quallität nur auf Youtube wird es so ranzig.
    Ganz schlimm ist es wenn viel Vegetation (Grass, Plazen etc.) vorkommen. Dann wirkt es so als wenn das Video auf 144p abgespielt würde.

    Beispiel: youtu.be/0TEQUccPEOU


    Danke für jeden hilfreichen Beitrag :)
  • Skalierung auf 3200x1800 vornehmen, um Original zu erhalten.

    1080 hat nur max 6000 Bitrate und bei derart komplexem Material, vor allem bei sowas:

    Ganz schlimm ist es wenn viel Vegetation (Grass, Plazen etc.) vorkommen.

    wirds halt blockig, wenn die Bitrate zu knapp ist.

    Das ist nunmal alles andere als gut komprimierbar was du da hast.

    youtube.com/watch?v=3Oy8rCo523A

    Auf Original schalten und freuen ;D
    Aktuelle Projekte/Videos


  • dakujYa schrieb:

    Ganz schlimm ist es wenn viel Vegetation (Grass, Plazen etc.) vorkommen. Dann wirkt es so als wenn das Video auf 144p abgespielt würde.

    Genau das ist der Haken. Viele kleine Details wie eben Gräser und so was erfordern unglaublich viel Bitrate, damit daraus kein Pixelmatsch wird. Und die 1080p-Qualitätsstufe kommt eben da recht schnell an ihre Grenzen. :S
  • Danke, danke. Super schnelle Antworten :)
    Ich werde es sofort ausprobieren.
    Werde mich dann gleich/nachher nochmal melden um nochmal richtiges Feedback abzugeben.

    -----------------------------------------



    Also ich habe jetzt die crop Einstellung wie gesagt auf 3200x1800 eingestellt.
    Aber leider ist das Video nicht soviel besser geworden, sprich es wirkt ncoh ein wenig schwammig, pixelig etc.

    youtube.com/watch?v=9xPq2IUteIw&feature=youtu.be

    *Musik war Radio und die Ruckler kommen davon, dass ich ncoh ein anderes Video im Background gerendert habe.


    Sollte ich lieber auf 720p umsteigen mit so einer hohen crop-Einstellung?
    Ich weiß nicht warum das so ist aber es gibt Youtuber, wie ungespielt die 720p hochladen und das sieht mehr nach HD aus als das was ich abliefer. ;(

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von dakujYa () aus folgendem Grund: Update!