MeGUI - Farbenbug

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MeGUI - Farbenbug

    Anzeige
    Hallo an alle,
    neben einem anderen Problem, welches ja zur Zeit in einem anderen Thread diskutiert wird, habe ich auch wieder das bereits beschriebene Problem mit MeGUI. Ich habe jetzt zum Test einmal eine Aufnahme gemacht, bei dem das Geschehen in der Nacht stattfindet, es also relativ dunkel ist. Beim Encoden mit MeGUI wird dabei das Bild allerdings verfärbt und es sieht "röter" aus, als es sein sollte. Im Video ist es zwar nicht ganz so schlimm, wie früher, aber die Änderung in den Farben ist immer deutlich sichtbar.
    Ich habe das Video direkt aus der avi-Datei, die mir FRAPS ausgespuckt hat, mit MeGUI encodet und habe auch keine besonderen Einstellungen vorgenommen. Woran kann das also liegen?
    (Wie gesagt, das Problem tritt nur auf, wenn das Bild sehr dunkel ist.)
  • Anzeige

    MoTiGames schrieb:

    Wusste ich nicht, dass man bei FRAPS überhaupt einstellen kann, in welchem Farbraum man aufnehmen möchte. Würde mich mal interessieren, wo man das einstellen kann.

    Du kannst mit FRAPS auch RGB aufnehmen ;D Dafür gibt es ja den Schalter: "Force lossless RGB capture (may be slower)"

    Dann sieht das gestochen Scharf aus das Bild und hat den richtigen Farbbereich vom Spiel. ABER... Der kann deaktiviert werden, weil du erstens deine HDD damit entlasten tust, zweitens es eh nix bringt da YT auf YV12 konvertiert und drittens würdeste dich dann noch mehr aufregen warum das so komisch aussieht ;D

    Welchen Player nutzt du denn für deine Quellvideos zum schauen?
  • Sagaras schrieb:

    MoTiGames schrieb:

    Wusste ich nicht, dass man bei FRAPS überhaupt einstellen kann, in welchem Farbraum man aufnehmen möchte. Würde mich mal interessieren, wo man das einstellen kann.

    Du kannst mit FRAPS auch RGB aufnehmen ;D Dafür gibt es ja den Schalter: "Force lossless RGB capture (may be slower)"

    Dann sieht das gestochen Scharf aus das Bild und hat den richtigen Farbbereich vom Spiel. ABER... Der kann deaktiviert werden, weil du erstens deine HDD damit entlasten tust, zweitens es eh nix bringt da YT auf YV12 konvertiert und drittens würdeste dich dann noch mehr aufregen warum das so komisch aussieht ;D

    Welchen Player nutzt du denn für deine Quellvideos zum schauen?

    Also die Quellvideos schaue ich eigentlich immer im Aufnahmeprogramm an, da ich da sehe, wie sie aussehen. Sollte ich sie mir aber doch mal extra anschauen wollen, dann nehm ich den Windows Media Player, der spielt die eigentlich immer genauso ab, wie ich die aufgenommen habe.
  • sourceforge.net/projects/mpc-h…0200ac1d1d9c&source=accel

    Den benutzen, sicherstellen das in Optionen - Ausgabe der DirectShow Ausgaberenderer auf Enhanced Video Renderer (custom presenter) steht.

    Bei Nvidia drauf achten das es so eingestellt ist, das es nach Videoplayer geht:



    Das zum Thema Helligkeit jedenfalls. Und Nvidia hat auch eine Einstellung wegen Farbrange 0-255 oder 16-235. Da auch vom Videoplayer entscheiden lassen.
    Bei AMD gibts da ebenfalls Dinge dazu. Sämtliche Filter ausschalten und 0-255.

    So dann: Welchen CRF benutzt du? Welches x264 preset benutzt du? Wird eine Auflösungsskalierung vorgenommen?
    ggf mal aq-strength 1.25 probieren.
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Danke für die Hilfe. Das Problem scheint wirklich an der Einstellung der Grafikkarte zu liegen. Habe jetzt den Punkt "Lebendigkeit der Farbe" einfach mal deaktiviert und danach hab ich es nicht mehr bemerkt. Also selbst wenn es noch kleine Rötungen in den Videos geben sollte, sind diese jetzt so gering, dass ich sie nicht mehr sehe.

    War also wohl eher eine Einstellungssache an der Grafikkarte.