Audacity - Fehlende Aufnahme mittendrin

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Audacity - Fehlende Aufnahme mittendrin

    Anzeige
    Hallo meine sehr verehrten Helferlein,

    ich habe ein Problem und konnte mit der SuFu nichts finden; sorry im Voraus wenn ich was übersehen habe.

    Also: Ich nehme wie sonst auch mit FRAPS das Spiel auf, und mit Audacity meine Stimme. Läuft auch alles schön und gut - Anfang und Ende kontrolliere ich direkt, und ist auch vorhanden.
    Scheinbar hat er vernünftig aufgenommen.
    Doch beim schneiden fällt mir dann auf, dass der Kommentar nicht zum Spiel passt, was daran liegt, dass irgendwo mittendrin, aber nur an einer Stelle,die Aufnahme komplett fehlt. Es ist auch keine Lücke vorhanden, sondern das Programm setzt einfach beides zusammen; so als würde ich die Aufnahme kurz pausieren und wieder aufnehmen.

    Das "Fehlteil" ist auch nirgends zu finden, es ist wirklich ganz weg.

    Vielleicht habe ich ja ein magisches Wort gesagt ohne es zu merken... :D

    Habt ihr eine Ahnung? Habe mich schon durchs ganze Netz gewühlt, selbst im Audacity-Forum wurde ich nicht fündig...

    Meine Vermutung war ja, dass irgendwas mit den Festplatten und/oder dem Ram nicht stimmt, aber müsste dann nicht alles komplett hängen?
    (Übrigens habe ich auch dieses Problem, ist aber ein anderes Thema. Manchmal hängt der ganze Rechner für 1-2 Minuten, egal was ich mache. Ob Surfen oder aufnehmen...er laggt für die beschriebene Zeit.
    Ich dachte erst das hängt zusammen, aber als es zu dem oben beschriebenen Problem kam, ist nichts dergleichen passiert.)


    So, ich hoffe ich habe ausführlich genug berichtet; falls nicht, ich sag euch alles! ;)


    Vielen vielen Dank im Voraus!

    Gruß Recky

    EDIT: Ich habe gesehen, dass Audacity nach dem Update jetzt unter "Qualität->Standard-Sampleformat" "32-bit float stehen hat. Habs direkt auf 16-bit geändert, da ich meine mich zu erinnern, immer in 16-bit und 44100 Hz aufzunehmen...sowohl in Audacity als auch Windows. Kann es damit was zu tun haben? Müsste es dann nicht einfach asynchron sein und "verschoben"?
    Süchtig machende Lets Plays!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Recky ()

  • Hatte ich auch schon, wenn deine CPU komplett ausgelastet ist (war bei mir der Fall) oder deine Festplatte nicht schnell genug die Rohdaten schreibt (hier dank SSD unmöglich) dann kommts vor das Audacity nicht hinterher kommt dem Puffer im RAM zu leeren und aufs Temporäre Laufwerk zu schreiben, in diesem Fall fehlt einfach ein Stück (bei mir nur wenige Sekunden aber währenddessen stand der komplette Rechner, ich nehme auf einem extra Rechner den Ton auf).

    Da hilft ausser evtl. zu schauen ob man bei Audacity irgendwo den Puffer größer machen kann oder dem Programm höhere CPU-Priorität zuzuordnen eigentlich nichts, ist halt ein Fehler im Design wenn ein (zu kleiner) Puffer irgendwann einfach voll läuft und sich quasi selber überschreibt (nehme an es wird wohl ein Ringpuffer sein, sowas ist üblich wenn man ins RAM aufnimmt und das ganze dann möglichst schnell versucht auf HDD wegzuschreiben, macht mein DVCapture-Programm auch mit meiner DV-Cam so, dort gibts allerdings eine Anzeige und wenn die bei 100% ist fliegen eben Frames raus)
    ——YouTube————————————————————————————————————————————
    — Endlos-Projekte: Minecraft (SinglePlayer), Craft The World, Banished, Besiege, Sims4
    — ..Abgeschlossen: Leisure Suit Larry 6+7, Dishonored, Surface 2+3, Mirrors Edge, uvm
    — . Kurz- Projekte: The Tower, Fighting Is Magic, Euro Truck Simulator 2, uvm
    — ......Retro-Ecke: Day Of The Tentacle, Flight Of The Amazon Queen, NFS: HP2, uvm
    ————————————————————————————————————————————TbMzockt.de—

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von TbMzockt ()

  • A) Eine Mediainfo der Frapsaufnahme und der Audacityaufnahme bitte einmal.
    B) Um welches Spiel handelt es sich? Vllt ist es eines dieser sogenanten "Sorgenspiele". ^^
    C) Genaue Festplattengeschwindigkeit per CristalDiskMark wäre sehr hilfreich für einige.
    D) Welche Programm außer Audacity verwendest du? Speziell für den Soundmix der Audiospuren.

    32 vs 16 Bit bedeutet für den normalen Let's Player nur mehr Speicherverbrauch auf der Festplatte. Jedoch kein höheren Qualitätsfaktor an sich. Und gerade bei Stereo nicht.

    Musik CDs die man im Laden kaufen kann haben alle. Aber auch wirklich ALLE nur Stereo, 16 Bit und 44100Hz. Nicht mehr und nicht weniger. Auch vollkommen unkomprimiert als PCM. Obwohl ich mich heute noch als Programmierer frage wo sich bei WAV PCM sich was moduliert xD

    Ja, Microsoft hat schon komische Bezeichnungen verwendet ^^ Im jeden Header einer WAV steht z.B. RIFF (Resource Independent File Format). Eigentlich wäre es korrekter wenn da IFF stehen würde für (Interchangable File Format). Microsoft selbst hat sich da nämlich etwas abgeschaut und ich sag mal (etwas Zweckempfremdet ;D ), denn eigentlich ist es eine leichte Abwandlung des Commondore Amiga. Die Grundstrucktur findet man sogar beim MID Format wieder.

    Die Geschichte des Waves Sounds ist sehr interessant, wenn man denn interessiert ist.

    Ein Let's Player sollte aber Grundsätzlich 2 Arten von Wave unterscheiden:
    A) Das normale WAV Format ala 32 Bit das eine Maximalgröße von 4 GB annehmen kann, bevor Aufnahmeprogramme automatisch selbst auf ...
    B) schalten und daraus Wave64 machen. Das übersteigt dann die Grenze der 4 GB Marke. Damit kann man dann ca. gut 3 Milliarden Jahre Audio aufnehmen am Stück ohne eine Pause einzulegen ;D

    Variante A) kann mit 44100Hz, 16Bit und Stereo maximal ca. 6,75 Stunden am Stück aufnehmen und ist somit meist ausreichend für den Let's Play Bereich.

    Erfolgt Variante B), so ist es Seitens MeGUI nicht möglich die Audiospur per DirectShow System zu laden (WAVSource), da Wave64 nicht erkannt wird damit.
  • Anzeige
    manual.audacityteam.org/man/Recording_Preferences << "Latency" > "Audio to Buffer".

    Per Default puffert er genau 100ms des Tons, einfach mal auf 500ms stellen und gucken ob noch Aussetzer bei hoher CPU-Belastung auftreten.
    ——YouTube————————————————————————————————————————————
    — Endlos-Projekte: Minecraft (SinglePlayer), Craft The World, Banished, Besiege, Sims4
    — ..Abgeschlossen: Leisure Suit Larry 6+7, Dishonored, Surface 2+3, Mirrors Edge, uvm
    — . Kurz- Projekte: The Tower, Fighting Is Magic, Euro Truck Simulator 2, uvm
    — ......Retro-Ecke: Day Of The Tentacle, Flight Of The Amazon Queen, NFS: HP2, uvm
    ————————————————————————————————————————————TbMzockt.de—
  • Hi,
    erstmal danke für die zahlreiche und schnelle Hilfe.
    Da ich jedoch gerade sowohl encodiere als auch Hochlade, kann ich die Festplatte nicht testen.. Die anderen Fragen werde ich aber gern beantworten, so gut ich kann.
    Später editiere ich den Rest dann rein, wird aber erst morgen sein.

    Julien schrieb:

    Welche Version hast du denn davon? Und lässt sich der Fehler reproduzieren? Passiert er nach einer bestimmten Zeit oder bei einer bestimmten Systemauslastung?

    - Version 2.0.5 (soweit ich weiß momentan die aktuelle)
    - Nein, leider tritt er immer irgendwann mitten im Part auf. Manchmal gar nicht....habe auch schon 2-3 Minuten eine Sprachaufnahme gemacht um zu schauen...Fehler trat nicht auf.
    - So wie ich es im Schnittprogramm [Sony Vegas Pro 12.0 (64-bit)] bemerke, relativ zum Ende hin...würd sagen immer so zwischen 60%-80%, wenn 0%= Anfang und 100%= Ende vom Video. Hoffe man versteht es^^.
    Ist aber sehr grob geschätzt...

    Sagaras schrieb:

    A) Eine Mediainfo der Frapsaufnahme und der Audacityaufnahme bitte einmal.

    B) Um welches Spiel handelt es sich? Vllt ist es eines dieser sogenanten "Sorgenspiele". ^^

    C) Genaue Festplattengeschwindigkeit per CristalDiskMark wäre sehr hilfreich für einige.

    D) Welche Programm außer Audacity verwendest du? Speziell für den Soundmix der Audiospuren.

    A) Hab einfach eine der Frapsaufnahmen genommen, habe keine Unterschiede feststellen können - da ich FRAPS alle 4GB splitten lasse.

    Fraps-Aufnahme:
    Spoiler anzeigen
    Allgemein
    Vollständiger Name : F:\FRAPS AUFNAHMEN\Dust\1\DustAET 0000-00-00 00-00-00-00.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Dateigröße : 3,91 GiB
    Dauer : 2min 29s
    Gesamte Bitrate : 224 Mbps

    Video
    ID : 0
    Format : Fraps
    Codec-ID : FPS1
    Dauer : 2min 29s
    Bitrate : 223 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 30,000 FPS
    ColorSpace : YUV
    BitDepth/String : 8 bits
    Bits/(Pixel*Frame) : 3.577
    Stream-Größe : 3,88 GiB (99%)

    Audio
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 2min 29s
    Bitraten-Modus : konstant
    Bitrate : 1 536 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 27,4 MiB (1%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 998 ms (29,95 Video-Frames)

    Audacity-Aufnahme:
    Spoiler anzeigen
    Allgemein
    Vollständiger Name : G:\ORDNER FÜR VEGAS\Kommentar\Dust\1.wav
    Format : Wave
    Dateigröße : 137 MiB
    Dauer : 27min
    Modus der Gesamtbitrate : konstant
    Gesamte Bitrate : 706 Kbps

    Audio
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 27min
    Bitraten-Modus : konstant
    Bitrate : 705,6 Kbps
    Kanäle : 1 Kanal
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 137 MiB (100%)


    B) Erst Black Mesa, aktuell Dust: An Elysian Tail. Vorher bei meinem SNES-Emulator ZSNES lief alles gut. (Bei den vorigen Projekten)
    C) So, hab jetzt mal den Testlauf gemacht, hier die Werte. Vorab-Info auf welcher Platte ich was mache:
    Festplatte C: Windows/Fraps
    Festplatte F: Aufnahmen von FRAPS landen hier.
    Festplatte G: Spiele/Steam/Audacity; auch die Audacity-Aufnahmen landen hier. Vielleicht sollte ich Audacity auch auf C installieren und die Aufnahmen auf F oder G speichern?

    Jetzt die Werte:

    Festplatte C:
    Spoiler anzeigen
    -----------------------------------------------------------------------
    CrystalDiskMark 3.0.3 x64 (C) 2007-2013 hiyohiyo
    Crystal Dew World : crystalmark.info/
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

    Sequential Read : 126.977 MB/s
    Sequential Write : 113.409 MB/s
    Random Read 512KB : 41.797 MB/s
    Random Write 512KB : 57.112 MB/s
    Random Read 4KB (QD=1) : 0.508 MB/s [ 124.1 IOPS]
    Random Write 4KB (QD=1) : 1.075 MB/s [ 262.4 IOPS]
    Random Read 4KB (QD=32) : 0.682 MB/s [ 166.5 IOPS]
    Random Write 4KB (QD=32) : 1.068 MB/s [ 260.8 IOPS]

    Test : 1000 MB [C: 49.6% (48.4/97.7 GB)] (x5)
    Date : 2013/11/23 12:53:52
    OS : Windows 7 Ultimate SP1 [6.1 Build 7601] (x64)


    Festplatte F:
    Spoiler anzeigen
    -----------------------------------------------------------------------
    CrystalDiskMark 3.0.3 x64 (C) 2007-2013 hiyohiyo
    Crystal Dew World : crystalmark.info/
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

    Sequential Read : 176.216 MB/s
    Sequential Write : 171.252 MB/s
    Random Read 512KB : 49.165 MB/s
    Random Write 512KB : 83.626 MB/s
    Random Read 4KB (QD=1) : 0.567 MB/s [ 138.5 IOPS]
    Random Write 4KB (QD=1) : 1.212 MB/s [ 295.9 IOPS]
    Random Read 4KB (QD=32) : 0.656 MB/s [ 160.1 IOPS]
    Random Write 4KB (QD=32) : 1.237 MB/s [ 302.0 IOPS]

    Test : 1000 MB [F: 49.9% (1394.5/2794.4 GB)] (x5)
    Date : 2013/11/23 13:01:22
    OS : Windows 7 Ultimate SP1 [6.1 Build 7601] (x64)


    Festplatte G:
    Spoiler anzeigen
    -----------------------------------------------------------------------
    CrystalDiskMark 3.0.3 x64 (C) 2007-2013 hiyohiyo
    Crystal Dew World : crystalmark.info/
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

    Sequential Read : 177.906 MB/s
    Sequential Write : 163.584 MB/s
    Random Read 512KB : 41.228 MB/s
    Random Write 512KB : 75.133 MB/s
    Random Read 4KB (QD=1) : 0.438 MB/s [ 107.0 IOPS]
    Random Write 4KB (QD=1) : 0.939 MB/s [ 229.2 IOPS]
    Random Read 4KB (QD=32) : 0.601 MB/s [ 146.6 IOPS]
    Random Write 4KB (QD=32) : 0.944 MB/s [ 230.6 IOPS]

    Test : 1000 MB [G: 23.2% (649.4/2794.4 GB)] (x5)
    Date : 2013/11/23 13:07:22
    OS : Windows 7 Ultimate SP1 [6.1 Build 7601] (x64)

    D) Bevor ich zu knapp antworte, hole ich aus und beschreibe meinen Workflow:
    1. Aufnahme mit FRAPS und Audacity.
    2. Abmischung per Sony Vegas Pro 12.0 (64-bit)
    -> schon in der Timeline bzw beim probehören merke ich das "Problem". Trotzdem der Rest^^
    3. Frameserver anschmeißen, per MeGUI encoden.
    4. Muxen und fertig.

    Danke übrigens für den Exkurs =)

    TbMzockt schrieb:


    manual.audacityteam.org/man/Recording_Preferences << "Latency" > "Audio to Buffer".

    Per Default puffert er genau 100ms des Tons, einfach mal auf 500ms stellen und gucken ob noch Aussetzer bei hoher CPU-Belastung auftreten.

    Danke, werd ich mal testen.
    Süchtig machende Lets Plays!


    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Recky ()

  • Noch eine ganz kurze Frage: Tritt das wärend des Ingames auf oder bei Cutscenes nur oder Menü etc? Mal drauf geachtet was genau fehlt?

    Was du aber machen kannst ist dein FRAPS Sound via Systemsoundeinstellung auf 44100Hz, 16 Bit, Stereo zu stellen.
    Die Hertz Zahl ist wie die FPS bei nem Video und kann für Asynchronität sorgen im schlimmsten Fall.
    Deine Audacity Aufnahme ist ok und kann so bleiben ^^ Nur halt den FRAPS Sound noch ändern.

    Sehr sehr böse ist es auch zu splitten, wärend deine Audacity Aufnahme weitermachst. Gerade bei NTFS formatierten Festplatten kann man das abschalten und komplett eine Aufnahme machen ohne einen 4 GB Split. Für FAT32 Dateisysteme kann man das machen. Bleibt ja auch nix anderes übrig dort ;D
    Du wirst mit Sicherheit massig Datein haben für dein Video. Völlig unnötig und sehr Zeitaufwendig.
    Daher wäre es interessant zu erfahren warum du den 4 GB Split angehakt hast? ^^

    Festplatten sind auch Ok so weit. Da musste nix ändern.

    Ja, wenn meine erste Frage ganz oben noch beantwortet wird, könnte man es vllt abwegen das z.B. die Cutscenes nicht aufgenommen werden, da Bink oder Smacker oder was weiß ich die nicht von FRAPS erfasst werden. Oder das Menü das nicht aufnehmbar ist mit FRAPS, da keine geeignete Oberfläche vorhanden ist für die Aufnahme.

    Falsche oder doppelte Tastenbelegung für Aufnahme vllt?

    (Übrigens habe ich auch dieses Problem, ist aber ein anderes Thema. Manchmal hängt der ganze Rechner für 1-2 Minuten, egal was ich mache. Ob Surfen oder aufnehmen...er laggt für die beschriebene Zeit.

    Da würde ich gerne mal wissen was alles im Hintergrund läuft bei dir. Also im Taskmanager unter Prozesse und Dienste mal schauen und unten alle Benutzer anzeigen anklicken. Das man auch alle Prozesse sieht. Eventuell kommen diese Freezes durch Virenscanner oder hohe Systemauslastungen wie Windows Update etc. Wenn die Ganze Power des Rechners woanders hineinfließen tut und wirklich alles auf MAX sag ich mal arbeitet, dann kann es auch mal zum Stillstand kommen und zwars so lange bis die Verarbeitung durchgelaufen ist und der Rechner den Speicher wieder frei gibt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sagaras ()

  • Sagaras schrieb:

    Noch eine ganz kurze Frage: Tritt das wärend des Ingames auf oder bei Cutscenes nur oder Menü etc? Mal drauf geachtet was genau fehlt?
    Immer Ingame. Aber es fehlt ja nix von dem Fraps-Video, sondern ein teil der Audacity-Aufnahme. Und da w es fehlt läuft das Spiel aktiv, dh. ich zocke. Bisher konnte ich nix anderes feststellen.

    Sagaras schrieb:

    Was du aber machen kannst ist dein FRAPS Sound via Systemsoundeinstellung auf 44100Hz, 16 Bit, Stereo zu stellen.

    Sorry, ich steh ein wenig aufm Schlauch...wo genau mach ich das? Meinst du unter "Wiedergabegeräte->Lautsprecher->Eigenschaften, Erweitert"? Oder muss dazu FRAPS laufen? Das lief tatsächlich über 24bit und 48000Hz.

    Sagaras schrieb:

    Daher wäre es interessant zu erfahren warum du den 4 GB Split angehakt hast? ^^


    Das ist ein guter Punkt. Hatte bisher immer den Haken raus, dh eine Datei nur. Seit ich das erste Mal das beschriebene Lagg-Problem bei Black Mesa hatte, habe ich rumgefummelt und die Splittung aktiviert. Ebenfalls hatte ich immer mit 60FPS aufgenommen, was ich jetzt nurnoch mit 30FPS mache. Habe jetzt den $GB Split deaktiviert.

    Sagaras schrieb:

    Ja, wenn meine erste Frage ganz oben noch beantwortet wird, könnte man es vllt abwegen das z.B. die Cutscenes nicht aufgenommen werden, da Bink oder Smacker oder was weiß ich die nicht von FRAPS erfasst werden. Oder das Menü das nicht aufnehmbar ist mit FRAPS, da keine geeignete Oberfläche vorhanden ist für die Aufnahme.



    Falsche oder doppelte Tastenbelegung für Aufnahme vllt?

    Wie gesagt...die Fraps-Aufnahme ist komplett. Audacity ist hier das Problem...und die Aufnahme läuft bis ich das Spiel beende und die Aufnahme stoppe.

    Sagaras schrieb:

    Da würde ich gerne mal wissen was alles im Hintergrund läuft bei dir. Also im Taskmanager unter Prozesse und Dienste mal schauen und unten alle Benutzer anzeigen anklicken. Das man auch alle Prozesse sieht.

    Okay, seit neuestem schalte ich den Virenscanner (Antivir) immer aus. Ich simuliere mal eine Aufnahme, nur dass ich die Aufnahme nicht starte und mach nen Screen. Editiere ich aber später mal rein. Ist das OK wenn ich dir wieder eine PN schreibe? Möchte ja niemanden belästigen^^°


    Vielen Dank nochmal und schöne Grüße
    Recky
    Süchtig machende Lets Plays!


  • Könnte es nicht schlicht und einfach auch sein, dass da der Audacity-Hotkey für die Aufnahmepause gedrückt wurde und seltsamerweise gewirkt hat?
    Mal so in den Raum geworfen. Wobei es bei mir mit dem Alten PC auch vorkam, das nach der Stop Taste ein Großteil der Aufnahme weg war, nur nicht Mittendrin.
    YGNOTY Entertainment Präsentiert:



    Deadfall Adventures-------Tormentum
    Hitman 2: Silent Assassin-------Sleeping Dogs


    „Dumme Fragen gibt es nicht, dumm ist nur, wer nicht fragt.“
  • YGNOTY schrieb:

    Könnte es nicht schlicht und einfach auch sein, dass da der Audacity-Hotkey für die Aufnahmepause gedrückt wurde und seltsamerweise gewirkt hat?
    Danke für die Hilfe, aber das ist unmöglich. Denn die Hotkeys funzen nur dann, wenn das Audacity-Fenster auch geöffnet ist; dies ist es nicht wenn ich es minimiere und dann das Spiel starte ;)

    Trotzdem danke^^

    //EDIT:

    Antwort an Shinigami: Nein, das war eines der ersten Dinge die ich kontrolliert habe. Autopegel ist aus. Hatte ich nie an. Nehme ja schon länger mit Audacity auf, das Problem habe ich erst seit ca. 2-3 Wochen...hatte ich aber nur bei Black Mesa, die anderen Projekte liefen über Emulator...
    Süchtig machende Lets Plays!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Recky ()

  • Recky schrieb:

    Sorry, ich steh ein wenig aufm Schlauch...wo genau mach ich das? Meinst du unter "Wiedergabegeräte->Lautsprecher->Eigenschaften, Erweitert"? Oder muss dazu FRAPS laufen? Das lief tatsächlich über 24bit und 48000Hz.

    Könnte das nicht schon das Problem gewesen sein?

    48000Hz vs 44100Hz ist fast so wie 30 FPS vs 25 FPS. Also der Sachverhalt ist der gleiche. Folgt meist zu Asyncronität. Bedeutet das eine von beiden Spuren länger sein kann.
    Ist also besser wenn alles gleich eingestellt ist, dann gibt es auch weniger ärger mit sowas.
    Zweitens kann es auch sein durch den Split den du machst. De-M-oN hatte das Problem bei seiner Descent 3 Reihe die er ungewollt splitten musste, da sich die Auflösung von Menü und Ladescreen zum eigentlichen Ingame ständig geändert hat. Bei jedem neuen File das angelegt wurde, war der Sound je nach Aufnahmeprogramm länger oder kürzer. Bei der Zusammensetzung war es demnach auch kürzer als die Audiospur. Lösung für sein Problem war dann mein Scriptprogramm das die einzelnen Files korrekt abgeschlossen hat. Es waren für jedes File immer unterschiedliche Soundabschlüsse zum Videoabschluss. Differenzen waren im Millisekundenbereich. Aber hat sich halt addiert im Endeffekt. Ohne Korrektur hatte er schon fast 3 Minuten oder so bei ner Halben Stunde eingebüst.
    Daher meine Empfehlung wenn du schon Splittest mein Scriptmaker zu verwenden um die Frapsspur zu korrigieren und zusammenzusetzen als ein File oder halt gleich komplett ohne Splitting aufzunehmen ^^
    Mein Programm findeste bei Tutorials.
  • Sagaras schrieb:

    Könnte das nicht schon das Problem gewesen sein?



    48000Hz vs 44100Hz ist fast so wie 30 FPS vs 25 FPS. Also der Sachverhalt ist der gleiche. Folgt meist zu Asyncronität. Bedeutet das eine von beiden Spuren länger sein kann.

    Ist also besser wenn alles gleich eingestellt ist, dann gibt es auch weniger ärger mit sowas.

    Hm kann ich mir irgendwie nicht so richtig vorstellen, weil es immer so war und nie Probleme gemacht hat. Und jetzt plötzlich? Naja habs jetzt ja geändert, wenn ich es richtig verstanden habe. In FRAPS konnte ich ja nix ändern, ist ja "nur" mein Lautsprecher gewesen. Bin auch alles andere durchgegangen und ggf. geändert.


    So, habe jetzt mal die Daten aus dem Task-Manager.

    Versuch 1, wo ich das Spiel und die Aufnahme gestartet habe und auf den Desktop zurück gegangen bin (nicht repräsentativ, weil er sich natürlich dann aufhängt):


    Versuch 2, wo ich alle relevanten Programme gestartet habe, nur das Spiel nicht und keine Aufnahme. Außerdem ist der Turbomodus von TuneUp aktiv:



    Ich werd einfach mal paar Tests machen. Noch eine Info: ich hatte einen alten Nvidia-Treiber (310.70) installiert, weil damit weniger Laggs auftreten. Ganz weg sind sie auch nicht. Hatte davor 331.65, und werde gleich den aktuellen (331.82) installieren. Mache das dan per Neuinstallation (man hat ja auch die Möglichkeit nur upzudaten, mach ich aber nicht). Empfiehlt es sich immer den neuesten Treiber zu nehmen, wenn alles läuft? Oder lieber erst dann updaten wenn irgendwo Probleme auftreten?

    Genau so verhält es sich mit Windows. Habe durch Zufall entdeckt, dass ich die Option [Nie nach Updates suchen] aktiviert hatte; daraufhin habe ich ihn manuell suchen lassen und nu zeigt er mir 117 wichtige Updates an^^ Meint ihr es macht Sinn Windows immer aufm aktuellsten Stand zu halten? Ich frage deshalb, weil ich vor langer Zeit, glaube zu Beginn von Win7, mal geupdatet habe und daraufhin viele Fehler auftraten...mir klingelt da so ein Satz "Never change a running system". Nur ist es bei mir ja aktuell so...ganz so "running" ist es ned. Was meint ihr, bzw du Sagaras?
    Süchtig machende Lets Plays!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Recky ()

  • Aufnahmesoftware sollte man generell updaten. Grafikkartentreiber muss man abwegen können ob man ältere Treiber nutzt oder nicht. Einige Spiele laufen unter Umständen nur mit älteren wie bei der Geforce 8600GS. Version 169.25 ist dort der ältere Treiber und es laufen dann Spiele wie Dungeon Keeper 2 ohne Probleme. Man muss nicht mal die 3D Beschleunigung deaktivieren dann. Bei neueren Grafiktreiberversionen ist das so das bei dem Spiel z.B. ein Schwarzer Schleier auftritt, den man schnell als "Spiel geht nicht unter dem OS" bezeichnet, obwohl der Grafiktreiber das verursachen tut. Den Grafiktreiber downzugraden ist eine der Altbewärtesten Dinge um bestimmte alte Games wieder korrekt zu spielen. Neu ist nicht immer gleich gut. Wie gesagt, den Verwendungszweck muss man abwegen können.
    Bei Windows Updates verhält es sich ähnlich. Bei einigen Systemen kommt z.B. das Spiel Dungeon Siege nicht mit Service Pack 2 klar bei Vista. Das Spiel lässt sich nicht mehr ausführen dann. Nur mit SP1 oder gar keinen SP. Nur da lässt sich das Game ausführen unter Vista. Auch bei Updates muss man abwegen können welche man brauch und welche die Games beeinflussen von ihrer Funktionalität her. Daher update ich auch immer bewusst manuell und niemals automatisch. Automatisch wird mir sonst zum Verhängnis bei einigen Sachen ^^

    Zu deiner Prozessliste:
    GoogleUpdate.exe ? Ich hab mich auch schon immer gefragt was das Ding tut, da Google ja ne Website ist und man eigentlich eine Website von Zuhause aus nicht updaten brauch ^^ Ist also Schwachsinn das Teil da. Meist wird es automatisch mitinstalliert bei Google Earth oder Google Chrome. Sollte es dennoch drauf sein ohne das man die zwei genannten Sachen hat, würde ich das Teil als Sicherheitsrisiko kennzeichnen. Es ist technisch signiert, woraufhin Antivirenprogramme es nicht als Sicherheitsrisiko kennzeichnen.

    TuneUp Prozesse. TuneUp bringt einen mehr schaden als alles andere. Vor allem wenn man nicht weiß was man da tut. Der Boost, Optimizer und solche Sachen bei TuneUp sind einfach nur unnötig und können unter umständen die Leistung des OS negativ beeinflussen. Also Finger weg von solchen Sachen. Von TuneUp muss gar nix im Hintergrund laufen. Wirklich absolut gar nix. Das kann man so einstellen und auch abändern. Wie gesagt, sowas wie Boost oder Speicheroptimierung von TuneUp bringen meist nicht den Effekt den man haben will. Aber wenn man daran glaubt, kann ich eh nix sagen dazu XD Das ist wie als wenn man nem christlichen Prister sagt, das es Gott nicht gibt, er aber daran glaubt das es ihn doch gibt. xD Das kann man dann ja wissenschaftlich ausdiskutieren. ;D

    Einige Nvidia Dienste können auf Manuell gestellt werden und nicht automatisch. Dann werden diese nur Aktiv wenn man sie brauch. Weil der Sinn das NVIDIA Treiber als Hintergrundprogramme laufen im Task ist mehr als Merkwürdig. Denn Grafiktreiber laufen immer und müssen nicht im TaskManager erst stehen. Die NVIDIA Karten lassen sich sowieso alle über den Control Panel einstellen und konfigurieren und der ist immer da wenn NVIDIA Treiber drauf sind.

    Antivirenprogramme.... ja, das sollte man ja als Let's Player wissen das die bei der Aufnahme deaktiviert sein sollten. Weil es ja sonst Speichertechnische Probleme geben würde.

    Das wars erst mal.

    Eins noch: Warum versuchst du gleichzeitig aufzunehmen mit Audacity? Audacity immer als erstes starten und als letztes beenden. Weil diese Aufnahme auf die Aufnahme des Spiels justiert werden muss. Und da hat man am besten mehr Material, als zu wenig.

    Eins kannste aber mal ausprobieren: Anstatt in Sony Vegas zu mischen, einfach in Audacity selbst mischen. Also Tonspuren reinladen, justieren und als WAV wieder speichern lassen. Audacity fragt dann ob alle Spuren die im aktuellen Projekt sind gemixt werden sollen. Einfach mit Ja bestätigen und dann bekommste eine gemischte WAV Spur wieder.
    Dann könnte man unter Umständen auch Sony Vegas ausschließen.
  • Okay, ich werde deinem Rat folgen und einige Prozesse rauswerfen.

    Zum Thema TuneUp: habe diesen "Turbomodus" nie benutzt, erst nachdem da der Fehler auftrat wollte ich es mal testen...habs bisher nicht getan und lass es dann auch sein. Die Prozesse landen auch aufm Müll dann.


    Mit Antivir hatte ich NIE Probleme, aber vllt. hatte ich auch einfach nur Glück. Ab jetzt achte ich da aber besonders drauf^^

    Sagaras schrieb:

    Eins noch: Warum versuchst du gleichzeitig aufzunehmen mit Audacity? Audacity immer als erstes starten und als letztes beenden. Weil diese Aufnahme auf die Aufnahme des Spiels justiert werden muss. Und da hat man am besten mehr Material, als zu wenig.


    Wie kommst du da drauf? Genau so wie du es am Ende beschreibst mach ich es: Audacity und FRAPS öffnen, Audacity Aufnahme starten, Spiel Starten, Aufnehmen, Aufnahme beenden, Spiel beenden, dann erst Audacity aufnahme stoppen und beenden [oder neue Aufnahme ;)]

    Sagaras schrieb:

    Eins kannste aber mal ausprobieren: Anstatt in Sony Vegas zu mischen, einfach in Audacity selbst mischen. Also Tonspuren reinladen, justieren und als WAV wieder speichern lassen. Audacity fragt dann ob alle Spuren die im aktuellen Projekt sind gemixt werden sollen. Einfach mit Ja bestätigen und dann bekommste eine gemischte WAV Spur wieder.

    Dann könnte man unter Umständen auch Sony Vegas ausschließen.

    Versteh ich grad nicht so ganz...ich glaube das basiert auf deiner falschen Annahme, worauf ich eben eingegangen bin. Weil ich ja nur EINE Aufnahme starte, brauch ich in Audacity nix zu mischen.

    Vielen Dank für die ausführlichen Erklärungen, da kann ich wenigstens nach und nach abarbeiten und "perfektionieren".
    Süchtig machende Lets Plays!


  • Recky schrieb:

    Versteh ich grad nicht so ganz...ich glaube das basiert auf deiner falschen Annahme, worauf ich eben eingegangen bin. Weil ich ja nur EINE Aufnahme starte, brauch ich in Audacity nix zu mischen.

    Das war nicht auf die Annahme von mir bezogen ;D Es soll nur mal in Audacity gemischt werden einmal um Sony Vegas als Fehlerquelle auszuschließen. Kann ja nämlich auch mal sein das einige Files in Vegas falsch geladen werden. Besonders mit der 44100Hz und 48000Hz Geschichte. Können aber auch andere Faktoren sein die ich jetzt nicht weiß, da ich Sony Vegas ja nicht habe.

    Bei 48KHz und 44,1KHz sieht das so aus:
    30 Minuten Aufnahme ergeben: 1800 Sek

    1800 Sek * 48000Hz = 86400000 Samples

    ABER deine Mikrofonspur hatte nur 44100Hz. Bedeutet es kann von Vegas sein das folgendes passiert:

    86400000 Samples / 44100 = 1959,184 Sek

    Das entspricht 159,184 Sek mehr als die andere Spur. Sofern beide Tonspuren wirklich exakt 30 Minuten gehen ;D

    Bedeutet die 44100Hz Spur ist länger geworden um sich der 48KHz anzupassen.
    Und bei 30 Minuten sind es schon fast 2 Minuten mehr ^^
  • So langsam verzweifel ich.
    Habe jetzt alles so gut es ging gemacht (die TuneUp und GoogleUpdate-Prozesse ließen sich nicht schließen) und daraufhin einen Testlauf gemacht. Dazu habe ich einfach bisl Minecraft gespielt und so getan als würd ich aufnehmen, nur dass ich halt dünnschiss geredet hab (also noch mehr als sonst xD). Lief alles bestens, habe knapp 50 Minuten aufgenommen, alles gut. Audacityaufnahme ist genau um das Stück länger, bis ich die FRAPS Aufnahme starte. Alles normal, und gut.

    Denkste. Eben "richtig" aufgenommen, diesmal Dust. Nach kürzester Zeit der erste Lag, aber Audacity hat weiter aufgenommen. Später dann wieder, woraufhin ich gespeichert habe um zu gucken wie es aussieht.
    Und siehe da: Fraps-Aufnahme konstant, hat die Laggs mit aufgenommen. Rund 10 Minuten lang.
    Audacity-Aufnahme, schon in Audacity zu sehen: Knapp 8,5 Minuten. Nu wollte ich natürlich wissen wo es aussetzt. Es scheint so, als würde die Audacity Aufnahme ca. 30 Sekunden oder so vor dem Lagg stoppen.
    Kann wenn ich das in Vegas zusammenlege nicht genau ausmachen wo die Fehler sitzen.

    Gerade habe ich aber etwas erstaunliches bemerkt: Als ich in Vegas in der Timeline springe um alles rauszufinden, hängt sich der PC auf. Selbst beim schreiben dieses Posts hängts. Also alles. Kurz nachdem es geht und ich in Vegas weitermache, das Gleiche nochmal. Alles hängt.

    Mittlerweile habe ich Vegas geschlossen und wollte Musik hören (Musik ist auf der Festplatte G)...Findet er nicht. Kurz geschaut und siehe da: Unter "Computer" bzw. früher "Arbeitsplatz" taucht die Festplatte nicht mehr auf! Das hatte ich schonmal, aber da hab ich nix gespielt. Nach nem Neustart des PCs gehts wieder.

    So langsam machts keinen Spaß mehr.

    Ich glaube so langsam können wir sagen, dass diese Festplattenprobleme Schuld sind.


    //EDIT: Eine ganz dumme Frage. Kann es sein, dass das Mikrofon am USB 3.0 er Port hängt und deshalb die Probleme macht? Beim suchen nach dem Fehler "Festplatte verschwindet" bin ich auf sowas ähnliches gestoßen, dass ein USB Port dran schuld sein kann. Und das ist so mit das Einzige was ich geändert habe...

    WIEDER NEU: Beim schreiben des Posts hat er sich wieder kurz erhangen...und es ist kein Mikrofon mehr angeschlossen. Somit können wir es ausschließen oder?Es hängt nur das Kabel noch dran, ist aber nicht am Mic angesteckt.
    Ich werde nachdem ich den Post abgeschickt hab mal den USB Port für das Kabel wechseln...
    Süchtig machende Lets Plays!


    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Recky ()

  • Wenn man das so liest, denkt man du hast nen Virus der dir das Leben schwer macht xD

    Festplattenlaufwerke sollten in der Regel ja nicht verschwinden. Wackelkontakt an den Verbindungsenden? Kabelbruch? Eventuell auch Ruhezustand der Festplatte, das diese erst wieder anspringen muss?

    Das Laggen im Spiel kommt durch den FRAPS Hook vermutlich. Vllt da mal Alternativ eine andere Aufnahmesoftware verwenden wie MSI Afterburner oder DXTory. Die nehmen beide von der Aufnahmetechnik her anders auf als FRAPS. Es wird sich anders eingehookt im Spiel. Einfach mal probieren. Mit Afterburner würde ich anfangen, da Kostenlos. Lagarith rein und los gehts. Schau dir dann bitte die entsprechenden Tutorials an im Forum.

    Die Laggs kann ich mir vorstellen werden dir zum Verhängnis. Eventuell hast du da ein Spiel was nicht grad gut klar kommt mit FRAPS. Bei MSI Afterburner, sowie DXTory hättest du die Möglichkeit ohne Audacity Mikrofon und Spielsound aufzunehmen die dann auch seperat vorliegen bei der Aufnahme. Zwei Fliegen mit einer Klappe sozusagen.

    Somit kannste FRAPS und Audacity als Problem beseitigen. Wie gesagt, probier MSI Afterburner erst mal, da Kostenlos. DXTory wäre aber weitaus besser und effizienter bei der Aufnahme. Aber jedes Aufnahmeprogramm hat seine Berechtigungsexistens. Kann man nie genug haben ;D Ich hab z.B. 4 Aufnahmeprogramme xD DXTory, Afterburner, FRAPS und den Camtasia Recorder 8. Alle die keine eigenen guten Lossless Aufnahmen geben, habe ich mit Lagarith bestückt. Sollte man also abwegen ^^

    Wenn du mehrere Probleme seitens Windows hast die völlig unerklärlich sind, dann mach dir so gut es geht eine Sicherung vom C Laufwerk und formatier und installier Windows einfach neu. Weil solltest du Softwarespezifische Probleme haben, wäre es meist das heitere Rätselraten was den Fehler hervorgerufen haben könnte. TuneUp könnte in diesem Fall schon den Fehler gemacht haben. Denkbar wäre es. Oder deine Hardware geht langsam aber sicher zu neige durch Verschleiß oder Defekt. Bei externen Festplatten kann auch die Platine hinten defekt sein nur. Da wo das Teil mit Strom versorgt wird und man auch den USB anschließt. Sollte das der Fall sein (Bitte vorher alles andere ausschließen dann), dann Gehäuse aufbrechen und die Festplatte dort in den Rechner einbauen. (Sofern kein Laptop)

    Probier es aber erst mal mit MSI Afterburner und lass Audacity weg dabei. Beide Audiospuren lassen sich dort auch seperat aufnehmen. DXTory hätte ich vllt vorgezogen, kostet aber ca. 30 Euro. Musste wissen.
  • Sagaras schrieb:

    Wenn man das so liest, denkt man du hast nen Virus der dir das Leben schwer macht xD
    War einer der ersten Gedanken, weshalb ich erstmal nen Virenscan gemacht hab - nichts gefunden.

    Sagaras schrieb:

    Festplattenlaufwerke sollten in der Regel ja nicht verschwinden. Wackelkontakt an den Verbindungsenden? Kabelbruch? Eventuell auch Ruhezustand der Festplatte, das diese erst wieder anspringen muss?

    Auch geprüft. Nein, nein. Ruhezustand habe ich ausgeschaltet, nachdem der Fehler aufgetreten ist. Trotzdem nix... ;(

    Sagaras schrieb:

    Die Laggs kann ich mir vorstellen werden dir zum Verhängnis. Eventuell hast du da ein Spiel was nicht grad gut klar kommt mit FRAPS. Bei MSI Afterburner, sowie DXTory hättest du die Möglichkeit ohne Audacity Mikrofon und Spielsound aufzunehmen die dann auch seperat vorliegen bei der Aufnahme. Zwei Fliegen mit einer Klappe sozusagen.



    Somit kannste FRAPS und Audacity als Problem beseitigen.

    Werd ich vielleicht auch mal in Erwägung ziehen. Wobei ich das schonmal getan habe, hab da nicht durchgeblickt. Eigentlich ist es ja sehr einfach, aber er hat bei mir ned aufgenommen. Also MSi meine ich. Kein OSD und keine Aufnahmen...naja. Werds nochmal probieren^^

    Sagaras schrieb:

    TuneUp könnte in diesem Fall schon den Fehler gemacht haben. Denkbar wäre es.

    Jup, das wird erstmal deinstalliert. Aber auch hier: ich hatte das Tool ewig, seit aufsetzen des PCs. Nie Probleme. Naja, heißt ja nix. Ist vielleicht ein bisl wie die Aussage "ich rauche seit 30 Jahren, nie hatte ich Lungenkrebs..und jetzt plötzlich? Nö am rauchen liegt es nicht."



    Sagaras schrieb:

    Oder deine Hardware geht langsam aber sicher zu neige durch Verschleiß oder Defekt. Bei externen Festplatten kann auch die Platine hinten defekt sein nur.

    Sind alles interne Festplatten. Sind eigentlich nicht alt...nichtmal nen Jahr glaube ich. Als ich mit LP begann hab ich mir die beiden gekauft. Naja, defekt kann ja trotzdem sein.

    Sagaras schrieb:

    Probier es aber erst mal mit MSI Afterburner und lass Audacity weg dabei.

    Ich glaube das brauch ich nicht. Allein beim schreiben und so weiter, der PC hängt immer mal wieder. Und das ohne dass ich FRAPS, Audacity oder nen Spiel laufen hab. Hmmm...*grummel*
    Süchtig machende Lets Plays!