MeGUI - nur 1 Minute Audio bei 15 Minuten Video erhalten.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MeGUI - nur 1 Minute Audio bei 15 Minuten Video erhalten.

    Anzeige
    Ich hasse kleine Fehlerchen, gerade am frühen morgen.
    Und zwar habe ich wie gewohnt auch mit einem Tutorial von euch entsprechend meine Aufnahme encodiert mit MeGUI.
    Mein Problem ist jedoch, dass aus meinem 15 Minuten Video ich nur eine 1 Minute und 13 Sekunden Audio .ogg erhalten habe. WTF?

    Wo ist der Fehler passiert?
  • eventuell hattest du noch eine CUT datei im audiobereich drin (von ner vergangenen verarbeitung) und dementsprechend wurde das audio geschnitten

    Ansonsten mal die neuste log im MeGUI ordner im ordner logs posten
  • Anzeige
    Die Logs sind recht lang, hoffentlich passend die hier soweit rein von der Zeichenlänge her.
    Insgesamt gibt es 3 Logs die ich ggf. Separat in einem Posting schreiben muss:

    Hier der erste und kürzeste:

    Spoiler anzeigen
    [Warning] Log
    -[Warning] Versions
    --[Information] [13.12.2013 07:45:22] MeGUI: 2418
    --[Information] [13.12.2013 07:45:22] Operating System: Windows 7 Ultimate Edition x64 SP1 (6.1.65536.7601)
    --[Information] [13.12.2013 07:45:22] .Net Framework: 4.5 (4.5.50709)
    --[Information] [13.12.2013 07:45:22] AviSynth: 2.5.8.5 (21-12-2008)
    --[Information] [13.12.2013 07:45:22] AvisynthWrapper: (02-01-2009)
    --[Warning] [13.12.2013 07:45:22] Haali Matroska Splitter not installed properly.
    --[Warning] [13.12.2013 07:45:22] Therefore DSS2() and certain functions of FFVideoSource() and the HD Streams Extractor may also not work.
    --[Warning] [13.12.2013 07:45:22] Please download and install it from haali.su/mkv/
    --[Warning] [13.12.2013 07:45:22] Haali DSS2: not installed
    --[Information] [13.12.2013 07:45:22] ICSharpCode.SharpZipLib: 0.85.5.452 (07-08-2008)
    --[Information] [13.12.2013 07:45:22] LinqBridge: 1.0.0.0 (28-05-2009)
    --[Information] [13.12.2013 07:45:22] MediaInfo: 0.7.64.0 (05-07-2013)
    --[Information] [13.12.2013 07:45:22] MediaInfoWrapper: 0.7.61.0 (06-01-2013)
    --[Information] [13.12.2013 07:45:22] MessageBoxExLib: 1.0.2218.28317 (19-12-2008)
    --[Information] [13.12.2013 07:45:22] SevenZipSharp: 0.64.3890.29348 (02-01-2011)
    --[Information] [13.12.2013 07:45:22] 7z: 9.20 (18-11-2010)
    -[Information] Update detection
    --[Information] [13.12.2013 07:45:23] Connecting to server: megui.xvidvideo.ru/auto/
    --[Information] [13.12.2013 07:45:23] There are 6 files which can be updated.
    --[Information] [13.12.2013 07:45:28] Updating core. File 1/6.
    --[Information] [13.12.2013 07:45:30] Updating mediainfo. File 2/6.
    --[Information] [13.12.2013 07:45:32] Updating x264. File 3/6.
    --[Information] [13.12.2013 07:45:36] Updating mp4box. File 4/6.
    --[Information] [13.12.2013 07:45:39] Updating tsmuxer. File 5/6.
    --[Information] [13.12.2013 07:45:42] Updating ffmpeg. File 6/6.
    --[Information] [13.12.2013 07:45:47] Update completed
    --[Information] [13.12.2013 07:45:47] Files which have been successfully updated: 6


    Der 2. Passt hier nicht rein, steht dann gleich unten als neuen Posting.

    Vorgegangen bin ich recht Simpel.
    MeGUI geöffnet und unter Tools auf AviSynth Creator gegangen und durchlaufen gelassen.
    Erst habe ich zuerst die OneClick Encoder-Variante genommen nachdem ich das Video eingefügt habe,
    beim 2. mal DirectShowSource und in soweit nichts umgestellt und auf SAVE gedrückt.

    Dann noch kurz bei Video Output die Bezeichnung geändert, und MKV eingestellt.
    Bei Audio Input habe ich das Roh-Video ausgewählt, und den Rest soweit gelassen. Als Encoder steht hier Vorbis und OGG Format.
    Dann in die Queue gepackt, und Encoden gelassen.

    Nur bei der Video-Queue sagte er mir "Incorrect Colorspace", dass das Video nicht in YU12 sei, und ob ich einen entsprechenden Eintrag am Ende des Scripts packen will.

    Achja ich musste auch noch ein Update vom Programm machen.
    Aktuell habe ich die Version: 2427


    EDIT: Habe gerade noch mal das Audio Encoded, aber diesmal unter Conf. etwas umgestellt.
    Da ich heute Morgen dort alles so gelassen habe wie es war, habe ich die Sample Rate auf Change to 44100 Khz
    und bei Preferred Decoder anstatt NicAudio auf FFAudioSource gestellt.

    Jetzt hat er die vollen 15 Minuten Audio und die mkv mit der ogg geMuxed, und Endproduktion hat nun bis zum Ende Ton :)
  • Comp4ny schrieb:

    Erst habe ich zuerst die OneClick Encoder-Variante genommen nachdem ich das Video eingefügt habe

    Nein das ist vollkommen falsch.

    Die Log ist unbrauchbar, da warte ich auf deine Anfügung. Wenn die zu groß ist, poste sie hier: pastebin.com

    Bei DirectShowSource vermute ich das du eine Verlustquelle neu codierst. Wenn das unbedingt sein muss mit dem Re-encode einer Verlustquelle, dann nimm File Index, statt DirectShow. Somit läuft es über FFVideoSource als Decoder. Genau das gleiche gilt für den Audio - aber das haste ja auch schon selbst gemerkt das du da FFAudioSource brauchst ^^

    Bei FF vor allem unbedingt auch Haali installieren: free-codecs.com/haali_matroska_splitter_download.htm
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Nur installieren und dich über bessere Kompatibilität freuen.

    Ach daher weht der Wind. Shadowplay ....

    Nimm bitte nicht lossy(verlustbehaftet) auf..

    Das bringt dir nur Qualitätsverlust bei bitratefixiert, bzw größere Dateien bei quantizerbasiert - letzteres benutzt du bei MeGUI. ggf auch bei letzterem zusätzlich mit Qualiverlust verbunden. Audio in jedem Fall.

    Bitte nimm mit DXTory auf (oder FRAPS, oder Bandicam mit verlustfreien Codecs oder MSI Afterburner mit verlustfreien Codecs) aber bitte nicht mit Shadowplay..


    Und bitte maximal nur 30fps und nicht 60.
    Aktuelle Projekte/Videos


  • Ja die Shadowplay Aufnahme dient nur zu Testzwecken, ich versuche da einfach ein wenig zu Experimentieren.
    Der Versuch mit DXTory aufzunehmen bei 30 FPS lässt das Spiel etwas Ruckeliger wirken, werde aber mal weiter schauen.
    Leider sind mir auch so manche Begriffe noch nicht geläufig, um zu Wissen wie ich manches Vermeiden kann / soll, zb. was heißt nicht Verlustbehaftet aufnehmen?
    Bei "bei bitratefixiert, bzw größere Dateien bei quantizerbasiert " kommt nur ein "HÄ?" wenn du verstehst ;)
  • Comp4ny schrieb:

    Der Versuch mit DXTory aufzunehmen bei 30 FPS lässt das Spiel etwas Ruckeliger wirken, werde aber mal weiter schauen.

    Das sollte nicht sein. Bestimmt falsch eingestellt.



    Nicht über die uraltversion wundern, hab nur kb jedes mal neuen screenshot zu machen ;D

    soll ja nur dazu dienen dir zu zeigen das ich gerne eine environment info hätte um deine settings zu sehen.

    zb. was heißt nicht Verlustbehaftet aufnehmen?


    Verlustbehaftet ist ein deutsches Wort. Kennst du die Bedeutung nicht? ^^

    Shadowplay nimmt halt verlustbehaftet auf, DXTory und co benutzen verlustlose kompression.

    Stells dir halt wie MP3 gegen WAV/Audio CD vor.
    Aktuelle Projekte/Videos


  • Manche Wörter hört man einfach zu selten um zu wissen was sie bedeuten ;)

    Spoiler anzeigen
    [Dxtory]
    Version: 2.0.122
    UID: 43216701-4715-46ba-bd48-256662a9af0e

    [Dxtory Files]
    InstallPath: D:\Programme\Dxtory2.0
    AudioStreamSplitter.exe: FileVersion: 1.0.0.0 SHA1: f2f729dc20a4f399704e99beeca855e85e5b9286
    AVIFix.exe: FileVersion: 2.0.0.119 SHA1: 7a09d66397e59a821aa710e53f9e241f77a7792a
    AVIMux.exe: FileVersion: 2.0.0.120 SHA1: 5196d86b22e66459b4dececc675099f8dd16422b
    AVIMuxCore.dll: FileVersion: 2.0.0.3 SHA1: 77f91e5cbdb6516492937b09e8779fbfce339ad0
    Dxtory.exe: FileVersion: 2.0.0.122 SHA1: 00d54133c207095e5295368f24186d933257d2df
    Dxtory64.exe: FileVersion: 1.0.0.60 SHA1: 14e3f06e6f2afb2dcb8dec2813586253fc58d86b
    DxtoryAudioHelper.dll: FileVersion: 1.0.0.79 SHA1: 1e11c70e2f744fe9fcb95402c955d14f3d9503ce
    DxtoryCore.dll: FileVersion: 2.0.0.122 SHA1: bac6c8055f3612f9e7eca5bc32dac79b787e1a86
    DxtoryCore64.dll: FileVersion: 2.0.0.122 SHA1: 11b4a0095aeba166563095c9c4207c868c90ae5b
    DxtoryHK.dll: FileVersion: 2.0.0.121 SHA1: 0917315496e3c6fad5c171ae730cb9f7a3eddda5
    DxtoryHK64.dll: FileVersion: 2.0.0.121 SHA1: ed965a2f95b156329cfe8f12c58415e05ad282c0
    DxtoryMM.dll: FileVersion: 1.0.0.1 SHA1: 82eeaf2ec6ddd70f887ea5e20a80be718600b230
    DxtoryMM64.dll: FileVersion: 1.0.0.1 SHA1: c142da021338ef96d13dc82c70c6ba2a443d1108
    DxtoryVideo.dll: FileVersion: 2.0.0.97 SHA1: b9c1ff13a061e189affef9ae37f5ae142450b189
    DxtoryVideo64.dll: FileVersion: 2.0.0.97 SHA1: 497ef3f62908d7a1f9362fc347198b900fc7c131
    DxtoryVideoSetting.exe: FileVersion: 2.0.0.119 SHA1: adb248b7eca7001e64ba19054807ab6556126a87
    LicReg.exe: FileVersion: 2.0.0.3 SHA1: d68fe1f3b1eb8c3a3e66af99810835f43ca40c59
    RawCapConv.exe: FileVersion: 2.0.0.119 SHA1: fe5c173b64236219c1a464db3ae117a8d53deded
    RCStream.dll: FileVersion: 1.0.0.76 SHA1: 31266452f142cd7c856384945ffc410b2c9c8be9
    unins000.exe: FileVersion: 51.1052.0.0 SHA1: c46876d124ae3b93d64960eda6d6253a33639481
    UpdateChecker.exe: FileVersion: 2.0.0.0 SHA1: 221bd3663f4393b368ebf74d1a892f9379ddbe44

    [System Information]
    CPU: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
    CPU Instruction Set: MMX SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX
    OS: TRIBAL WINDOWS 7 ULTIMATE x64
    OSVersion: 6.1.7601
    OSLanguage: 1031
    ServicePack: Service Pack 1
    Memory0: BANK 2 4,294,967,296 bytes
    Memory1: BANK 3 4,294,967,296 bytes
    TotalMemory: 8,589,934,592 bytes
    Total Physical Memory: 8,478,797,824 bytes
    Available Physical Memory: 5,684,064,256 bytes
    Total Page File: 16,955,686,912 bytes
    Available Page File: 13,587,042,304 bytes
    Total Virtual Memory: 2,147,352,576 bytes
    Available Virtual Memory: 1,758,334,976 bytes
    PerformanceCounterFrequency: 3320419 (0x32AA63)
    VideoCard: Intel(R) HD Graphics 4000 Memory: 2,214,592,512 Processor: Intel(R) HD Graphics Family DriverVer: 9.17.10.2932 DriverDate: 2012-12-12 01-00-00
    VideoCard: NVIDIA GeForce GTX 660 Ti Memory: 2,147,483,648 Processor: GeForce GTX 660 Ti DriverVer: 9.18.13.3193 DriverDate: 2013-11-23 01-00-00
    Display0: 1920x1080 32bits 60Hz
    SoundDevice: NVIDIA High Definition Audio Manufacturer: NVIDIA
    SoundDevice: Realtek High Definition Audio Manufacturer: Realtek
    SoundDevice: Intel(R) Display-Audio Manufacturer: Intel(R) Corporation
    SoundDevice: USB-Audiogerät Manufacturer: (Standard-USB-Audio)
    SoundDevice: NVIDIA Virtual Audio Device (Wave Extensible) (WDM) Manufacturer: NVIDIA
    SoundDevice: Virtual Audio Cable Manufacturer: EuMus Design

    [Audio Device]
    Line 1 (Virtual Audio Cable) - CoreAudioOut
    Realtek Digital Output (Realtek High Definition Audio) - CoreAudioOut
    Lautsprecher (Realtek High Definition Audio) - CoreAudioOut
    Line 2 (Virtual Audio Cable) - CoreAudioOut
    Line 1 (Virtual Audio Cable) - CoreAudioIn, Volume 24
    Mikrofon (USB Microphone ) - CoreAudioIn, Volume 69
    Line 2 (Virtual Audio Cable) - CoreAudioIn, Volume 24

    [Video Codec]
    Dxtory Video Codec FCC:xtor
    Bandi MJPEG Video Decoder FCC:mjpg
    Bandi MPEG-1 Video Decoder FCC:mpeg
    Cinepak Codec von Radius FCC:cvid
    FICV Codec FCC:ficv
    Fraps Video Decompressor FCC:fps1
    Intel IYUV Codec FCC:iyuv
    Lagarith Lossless Codec FCC:lags
    Logitech Video (I420) FCC:i420
    Microsoft RLE FCC:mrle
    Microsoft Video 1 FCC:msvc
    RivaTuner Video Codec FCC:rtv1
    TechSmith Screen Capture Codec FCC:tscc
    TechSmith Screen Codec 2 FCC:tsc2
    Xvid MPEG-4 Codec FCC:xvid

    [Audio Codec]
    Microsoft IMA ADPCM
    Microsoft CCITT G.711
    Microsoft GSM 6.10
    MS-ADPCM
    PCM
    IEEE Float

    [License Information]
    License: Trial

    [Additional Information]
    Dxtory_log.txt: Empty
    ErrorLog.txt: Available Size=2302

    [Global Setting]
    OptionFlag=

    [Ignore List]

    ======================================================================

    [Profile]
    Name: Default
    Path:

    [Overlay]
    Option: Left Top VidoeFPS WriteFileFPS RecordState
    Color: Sleep FF00FF00, Active FFFFBC00, Movie FF00FF00, ScreenShot FF00FF00

    [Folder]
    x I:\Aufnahme Speed: 213MB/sec Free: 893,031,936,000 Total: 1,000,202,039,296 Format: NTFS
    SSFolder:

    [HotKey]
    MovieCapture: F9 (0x00000043)
    PushToTalk: None
    ScreenShotSingle: F11 (0x00000057)
    ScreenShotRepeat: None
    ScreenShotAuto: None
    ToggleStatus: None
    MovieCaptureFrame: None
    ScreenShotCaptureFrame: None

    [Movie]
    Clipping:
    ClipMargin: 0,0,0,0
    ClipSize: 0,0
    Scaling: Percent 100% 0x0
    Codec: Lagarith Lossless Codec, Quality 10000, KeyFrameRate 15, DataRate 0
    FrameRate: 30
    Output: File AVI
    Option:

    [Audio0]
    Enabled: True
    PushToTalk: False
    Device: Lautsprecher (Realtek High Definition Audio)
    Codec: PCM
    Format: PCM 48000 Hz, 16 bit, Stereo

    [Audio1]
    Enabled: True
    PushToTalk: False
    Device: Mikrofon (USB Microphone )
    Codec: PCM
    Format: PCM 48000 Hz, 16 bit, Stereo

    [ScreenShot]
    Clipping:
    ClipMargin: 0,0,0,0
    ClipSize: 0,0
    Scaling: Percent 100% 0x0
    HighSpeedLimit: 0
    RepeatInterval: 1000
    Format: PNG
    JpegQuality: 97
    Option:

    [Advanced]
    Option: ForceCPUProcessing
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 60
    DelayHook: False
    DelayHookTime: 5

    ======================================================================

    [Profile]
    Name: ANNO 2070
    Path: E:\Spiele\ANNO 2070\Anno5.exe

    [Advanced]
    Option: ForceCPUProcessing
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 60
    DelayHook: False
    DelayHookTime: 5

    [LastUsingInformation]
    DateTime: 2013.12.07 01:47:17
    DeviceType: OGL DX7 DX9 DX10.1 DX11
    View0.Type=DX11
    View0.CreateFlag=D3D11_CREATE_DEVICE_SINGLETHREADED
    View0.FeatureLevel=D3D_FEATURE_LEVEL_11_0
    View0.Format=DXGI_FORMAT_R8G8B8A8_UNORM
    View0.Size=126x10
    View0.HWND=0x001B054A
    View0.WindowTitle=Invisible
    View0.ClassName=Invisible

    ======================================================================

    [Profile]
    Name: Entropy
    Path: E:\Spiele\Steam\SteamApps\common\Entropy\Entropy.exe

    [Advanced]
    Option: ForceCPUProcessing
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 60
    DelayHook: False
    DelayHookTime: 5

    [LastUsingInformation]
    DateTime: 2013.12.12 14:58:45
    DeviceType: OGL DX7 DX9
    View0.Type=DX9
    View0.DevType=D3DDEVTYPE_HAL
    View0.BhFlags=D3DCREATE_FPU_PRESERVE D3DCREATE_MULTITHREADED D3DCREATE_HARDWARE_VERTEXPROCESSING
    View0.Format=D3DFMT_A8R8G8B8
    View0.Size=1920x1080
    View0.HWND=0x00190354
    View0.WindowTitle=Entropy
    View0.ClassName=UnityWndClass

    ======================================================================

    [Profile]
    Name: InitEngine
    Path: E:\Spiele\ANNO 2070\InitEngine.exe

    [Advanced]
    Option: ForceCPUProcessing
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 60
    DelayHook: False
    DelayHookTime: 5

    [LastUsingInformation]
    DateTime: 2013.12.07 01:13:59
    DeviceType: DX9
    View0.Type=DX9
    View0.DevType=D3DDEVTYPE_HAL
    View0.BhFlags=D3DCREATE_FPU_PRESERVE D3DCREATE_HARDWARE_VERTEXPROCESSING D3DCREATE_NOWINDOWCHANGES
    View0.Format=D3DFMT_X8R8G8B8
    View0.Size=800x600
    View0.HWND=0x0021052C
    View0.WindowTitle=InitEngine
    View0.ClassName=InitEngine

    ======================================================================

    [Profile]
    Name: War of the Vikings
    Path: E:\Spiele\Steam\SteamApps\common\War of the Vikings\wotv.exe

    [Folder]
    x I:\Aufnahme Speed: 213MB/sec Free: 893,031,936,000 Total: 1,000,202,039,296 Format: NTFS
    SSFolder:

    [Advanced]
    Option: ForceCPUProcessing
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 100
    DelayHook: False
    DelayHookTime: 5

    [LastUsingInformation]
    DateTime: 2013.12.06 23:06:36
    DeviceType: DX11
    View0.Type=DX11
    View0.CreateFlag=0
    View0.FeatureLevel=D3D_FEATURE_LEVEL_11_0
    View0.Format=DXGI_FORMAT_R8G8B8A8_UNORM
    View0.Size=1920x1080
    View0.HWND=0x000D0360
    View0.WindowTitle=War of the Vikings
    View0.ClassName=main_window

    ======================================================================

    [Profile]
    Name: WoT-Client
    Path: E:\Spiele\World_of_Tanks\WorldOfTanks.exe

    [Advanced]
    Option: ForceCPUProcessing
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 60
    DelayHook: False
    DelayHookTime: 5

    [LastUsingInformation]
    DateTime: 2013.12.13 05:33:13
    DeviceType: DX9
    View0.Type=DX9Ex
    View0.DevType=D3DDEVTYPE_HAL
    View0.BhFlags=D3DCREATE_FPU_PRESERVE D3DCREATE_MULTITHREADED D3DCREATE_HARDWARE_VERTEXPROCESSING D3DCREATE_DISABLE_DRIVER_MANAGEMENT
    View0.Format=D3DFMT_A8R8G8B8
    View0.Size=1920x1080
    View0.HWND=0x0004032C
    View0.WindowTitle=WoT-Client
    View0.ClassName=App

    ======================================================================
    VerifyHash: f469863a70a55c99e00c2b264601b996cb304471
  • Gibtn Update dafür. 2.0.124 verbessert auch nochmal die Performance laut changelog.

    Bevor du Änderungen machst, sicherstellen das auf jedem Tab Use Default Setting angehakt ist und oben das default profile gewählt ist.

    Beide Audios auf 44100 reduzieren. Den Lautsprecher auf Stereo belassen, das Mikrofon auf Mono.


    Wie sind die lagarith einstellungen? => neben der Codecauswahl ist ein Button mit 'ner Zange oder so drauf, damit gelangst du in die Konfiguration des Codecs. Hast du da YV12 und Multithreading angehakt?

    @Sheratan: Habs mal ohne MT Haken probiert, da du ja meintest, bei dir isses mit dem MT Haken langsamer. Also das kann ich nicht bestätigen. Bei mir ist Lagarith = Schneckentempo, wenn ich ohne MT habe.

    Bei Advanced den Force CPU haken entfernen und stattdessen Synchronous Surface Lock und Wait for available Buffer anhaken.
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • [X] Enable Null Frames
    [-] Always Suggest RGB for Output ---------- Mode: YV12
    [X] Use Multithreading
    [-] Prevent Upsampling When Decording

    -> Das sind die Einstellungen beim Codec.

    Gilt der letzte Teil ab @Sheratan auch für mich?
    Unter Advance habe ich bei Processing Threads: 2 eingestellt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Comp4ny ()

  • SSM geöffnet, aufgenommenes Video hinzugefügt, keine Einstellungen geändert, und auf den Save-Diskette geklickt.
    Er hat dann ne Datei .avs Datei erstellt, und die wollte ich dann bei MeGUI einfügen
    wo sie rein gehört.

    Bing... Fehlermeldung.

    Ich habe wie gesagt keinerlei Erfahrung mit dem ganzen kram, und meine 5 Videos auf YT habe ich direkt so hochgeladen ohne groß was zu ändern. Jetzt will ich es mal mit dem ganzen Encode-Kram probieren, und bin nur noch am Verzweifeln.
  • Comp4ny schrieb:

    Habe mit SagaraS Scriptmaker nun ne avs erstellt, wollte sie bei MeGUI einfügen,
    gibt ne Fehlermeldung mit "i dont know what "FPS" means, und noch line 18, 19 und 5.


    Diese Fehlermeldung kann nur kommen, wenn ein Videoformat nicht gelesen werden kann. Dann springt für gewöhnlich die Fehlerabfrage ein und versucht ein BlankClip zu erzeugen. Da aber anscheinend schon beim Laden des Videos Probleme gab, gibt es dort schon Fehler.


    Ich demonstriere das mal an den Quellcode:

    Quellcode

    1. Function AVIload (String file) {
    2. Try {
    3. clip0 = (0 == 1) ? FFVideoSource(file, threads=1) : AVISource(file, false)
    4. clip1 = clip0.AssumeFPS(Float(Round(clip0.Framerate*1000))/1000)
    5. Global FPS = clip1.framerate
    6. ... <--- Fehler, Ausführung von Catch
    7. }
    8. Catch (Error) {
    9. Return BlankClip(0, breite, hoehe, "YV12", FPS).KillAudio()
    10. }


    Wenn ab dieser Stelle ein Fehler auftaucht wie im Code gekennzeichnet, so tritt Catch in Kraft und hat natürlich die FPS des Videos im Schlepptau für BlanClip

    Geht der Code bei Try nicht bis Global FPS, geht automatisch nicht die Fehlerabfrage bei Catch. Die Fehlerabfrage sollte nur dafür sein das gewisse Probleme die nach Global FPS kommen mit einen schwarzen Bild kenntlichgemacht werden. Das sollte den Effekt erziehlen das trotzdem weitergearbeitet werden kann und man eventuell Probleme innerhalb von Try identifizieren kann. Um halt den größten effektivesten Erfolg zu versprechen.

    Es ist halt die Frage welche Videos reingeladen werden. Sind es unterschiedliche Videos mit unterschiedlichen Frames ohne die Framerate anzupassen, so entsteht der Fehler das die Framerate nicht übereinstimmt.

    In dem Fall des Threadserstellers handelt es sich um eine Quelle die nicht richtig geladen wird und die FPS nicht erkannt wird.

    Quellcode

    1. Function AVIload (String file) {
    2. Try {
    3. clip0 = (0 == 1) ? FFVideoSource(file, threads=1) : AVISource(file, false) <--- Fehler, Ausführung von Catch
    4. ...
    5. }
    6. Catch (Error) {
    7. Return BlankClip(0, breite, hoehe, "YV12", FPS).KillAudio()
    8. }


    Wenn ab dieser Stelle ein Fehler auftaucht wie im Code gekennzeichnet, so tritt Catch in Kraft und die Variable FPS nicht im Schlepptau. Fehlermeldung dürfte dann klar sein mit (i dont know what "FPS" means)

    Entweder wird versucht eine Verlustquelle zu laden oder das Video ist defekt.

    AVI Datein halt ohne FFMPEGSource2 laden (Es sei denn das diese h264vfw Codecs nutzen oder sonstige Dinge die da nicht reingehören)
    und alle anderen Datein halt mit FFMPEGSource2 laden.

    Weil dann entscheidet sich wie die Videos geladen werden und können entsprechend auch verarbeitet werden.

    Es sei denn das Video ist so komisch und untypisch, das es nicht geht. Eventuell sogar beschädigt/defekt.

    Erbitte deshalb mal eine Mediainfo der Quelldatei.

    Für die Mediainfo einfach auf das Wort klicken und LESEN bitte ^^ Und dann sehen wir weiter was du eventuell falsch machst oder wo sonst deine Probleme sind.