Import Problem bei Sony Vegas Movie Studio HD 11

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Import Problem bei Sony Vegas Movie Studio HD 11

    Anzeige
    Hallo alle zusammen,

    wie oben erwähnt habe ich ein Problem eine Videodatei zu importieren. Wenn ich die datei auf die Timeline ziehe erscheint unten Links der ladebalken mit der meldung:"Spitzen werden aufgebaut", was ja wohl mit dem Sound zu tun hat, ist ja kein Problem, nur bin ich nach ner Stunde bei 20 %, und kein Ende abzusehen. Ich habe das Video mit der HDPVR 2 und Arcsoft Showbiz aufgenommen, ich weiß es gibt die Software Hauppauge Capture, aber da kann ich nicht in MP4 aufnehmen. Erstmal poste ich mal was mir Mediainfo auswirft und vielleicht erkennt ihr ja den Fehler den ich gemacht haben könnte.

    Allgemein
    Vollständiger Name : C:\Users\h\Videos\2013_12_28_20_6_11.MP4
    Format : MPEG-4
    Format-Profil : 3GPP Media Release 4
    Codec-ID : 3gp4
    Dateigröße : 5,74 GiB
    Dauer : 58min
    Gesamte Bitrate : 14,0 Mbps
    Kodierungs-Datum : UTC 2013-12-28 20:04:56
    Tagging-Datum : UTC 2013-12-28 20:04:56

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.0
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 3 frames
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 58min
    Bitrate : 13,9 Mbps
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 59,808 FPS
    originale Bildwiederholungsrate : 59,940 FPS
    minimale Bildwiederholungsrate : 0,130 FPS
    maximale Bildwiederholungsrate : 60,060 FPS
    Standard : Component
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.252
    Stream-Größe : 5,69 GiB (99%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2013-12-28 20:04:56
    Tagging-Datum : UTC 2013-12-28 20:04:56
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 58min
    Bitraten-Modus : konstant
    Bitrate : 93,1 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Stream-Größe : 39,0 MiB (1%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2013-12-28 20:04:56
    Tagging-Datum : UTC 2013-12-28 20:04:56
    mdhd_Duration : 3516996

    Daraufhin habe ich in den Projekteigenschaften olgendes eingestellt bevor ich die Datei importiere.






    Dass manche Sachen der Videodaei, wie z.b. 59 Frames etws übertrieben ist, aber ich habe nicht bemerk, dassdieses Arcsoft Programm die veränderten einstelungen niht übernommen hat, und mich verwirren die vielen Framewerte die mir Mediainfo anzeigt, könnte mir das auch mal einer erklären, auf welchen Wert ich achten muss?

    Wäre echt toll wenn ihr mir helfen könntet, ich muss um 15 Uhr unbedingt die neue Folge noch fertig machen, die sich in dieser Datei befindet. Auch wenn die Datei fast unbrauchbar ist, ich muss die erstmal so nehmen. Beim nächsten mal bin ich denk ich schlauer.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Handicapped Gaming ()

  • Shakur schrieb:

    Modus der Bildwiederholungsrate : variabel
    Das wird Vegas schonmal überhaupt nicht passen - VFR (Variabler Framerate) führt da zu teils enormer Asynchronität.




    Shakur schrieb:

    Bitrate : 93,1 Kbps
    AAC ist zwar dafür bekannt, im Vergleich zu anderen lossy Codecs wie MP3 auch bei niedrigeren Bitraten noch annehmbare Qualität zu erzeugen, aber das ist zu wenig. Wenigstens auf 192 Kbit/s stellen, besser wäre noch mehr.




    Bei deinen Projekteinstellungen in Vegas gäbe es auch einiges zu verbessern, aber das würde wegen der bereits erwähnten VFR des Videos wenig nützen. Daher wäre meine Empfehlung (da du das Video ja offensichtlich unbedingt benötigst), es entweder ggf. zu splitten und direkt hochzuladen (am wenigsten Qualitätsverlust, aber keine Nachbearbeitung) oder mit Avisynth (FFMPEGSource) zu decodieren und dann mit x264 zu encodieren (so könntest du mit Avisynth noch nachbearbeiten).

    Daher wäre es erstmal wichtig zu wissen, ob und in welchem Umfang du nachbearbeiten möchtest. Aber Vegas wird leider definitiv wegfallen.
  • Also in der Datei befinden sich 3 Folgen, die müsste ich schneiden, meinen Audiokommentar hinzufügen, unnötiges rausschneiden und dann verwende ich den Frameserver um es in MeGUI einzufügen. Also ich muss die Datei noch komplett schneiden, das ist das Problem. Ich habe auch noch Premiere Elements 11, wo aber der Frameserver nicht läuft.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Handicapped Gaming ()

  • Ach du Schande, was für ein Wirrwarr. Variable Framerate ist der Tod für jedes Timeline-Programm. 59.808 FPS? Ich halte echt immer weniger von diesem Arcsoft-Käse. :cursing: Aber dann in Vegas 29.808 FPS und Oberes Feld zuerst einzustellen war natürlich auch vollkommen falsch.

    Ich glaube, am meisten kann man noch retten, wenn du auf ein Programm umsteigst, das keine Timeline benötigt. So leid es mir tut, aber mit AviSynth wird man da am ehesten noch was einigermaßen gutes rausbekommen können. :S
  • Anzeige

    Julien schrieb:

    Ach du Schande, was für ein Wirrwarr. Variable Framerate ist der Tod für jedes Timeline-Programm. 59.808 FPS? Ich halte echt immer weniger von diesem Arcsoft-Käse. :cursing: Aber dann in Vegas 29.808 FPS und Oberes Feld zuerst einzustellen war natürlich auch vollkommen falsch.

    Ich glaube, am meisten kann man noch retten, wenn du auf ein Programm umsteigst, das keine Timeline benötigt. So leid es mir tut, aber mit AviSynth wird man da am ehesten noch was einigermaßen gutes rausbekommen können. :S
    Ach so ich habe natürlich 59,808 FPS eingestellt weil es in der Mediainfo ja so steht. Habe das falsche bild genommen. Nur was mach ich jetzt, denn die Kommentar Spur ist auch anders als das Video, weil ich immer erst die Video Aufnahme starte, dann starte ich Audacity und starta da dann die Aufnahme, Also Synchronisiere ich alles ja erst in Vegas mit schneiden. Wi kann ich das nun bewältigen? Ich bin halt noch nicht so der große Experte im schneiden.
  • 59.808 FPS ist ja auch kompletter Käse, weil variable Framerate einfach der größte Mist seit Erfindung der Framerate ist. :wacko: Tut mir leid, aber einen wirklich guten Weg sehe ich da nicht. In Vegas kannst du das garantiert vergessen, in MeGUI kannst du nicht mit Ton schneiden (oder nur extrem aufwändig)... Ich fürchte, da hast du ein Problem.

    Was du machen könntest: Die Videospur kodieren, und zwar so, dass weder Interlaced noch variable Framerate ein Problem sind, dann hinterher die Audiospur damit synchronisieren und das dann muxen. Das ist aber sehr viel Bastelarbeit, bis 15 Uhr sehe ich da leider schwarz.
  • Dann lade dir erstmal das FFMPEG Plugin für Audacity runter, installiere es und zieh dann deine MP4 da rein. Dann bearbeitest du den Sound ggf. nach und exportierst das als WAVE. In MeGUI lädst du das Video im AVS Creator mit FFVideoSource und lädst außerdem das Avisynth Plugin "vfrtocfr" (Download: *Klick*). Das machst du folgendermaßen (mit Anführungszeichen):

    Quellcode

    1. LoadPlugin("Pfad zu vfrtocfr.dll")



    Nun schreibst du folgende Zeilen (wieder mit Anführungszeichen) im Script:


    Quellcode

    1. vfrtocfr(fpsnum=25000)
    2. AudioDub("Pfad zur WAVE")


    Dann speicherst du das Script. Jetzt kannst du mit dem AVS Cutter (siehe Lexikonartikel für die Benutzung) noch schneiden bzw. in mehrere Parts unterteilen. Für letzteres musst du allerdings n AVS Scripte anlegen (n = Anzahl der Parts), die mit Trim den zu encodierenden Frameabschnitt definieren.
  • Damit das nicht zu Missverständnissen führt: In Audacity sollte natürlich auch deine Mikrofonspur sein. ^^

    De-M-oN meinte außerdem, dass FFMPEGSource bereits genügen würde. Außerdem habe ich selbst einen kleinen Fehler gemacht, aussehen sollte das dann so:

    Quellcode

    1. LoadPlugin("Pfad zur ffms2.dll")
    2. v = FFVideoSource("Pfad zum Video", threads=1)
    3. a = WAVSource("Pfad zur WAVE")
    4. AudioDub(v, a)

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Zantos ()

  • Der Fehler der hier gemacht wird ist der Versuch bei einem VFR Video Ton und Video zu trennen. Schlechte Idee ;D

    Audio, sowie Videoquelle müssen mit der gleichen Methode geladen werden, wenn Video und Audio Synchron sein sollen.

    Laden immer von der Hauptquelle. Und die Mikrofonspur dann in AVISynth mischen lassen.

    Das VFRtoCFR Plugin bin ich mir gar nicht so sicher ob das gut ist. Jedenfalls bei Aufnahmen im Interlaced Bereich nicht zu gebrauchen, weil Deinterlacer meist auf die VFR noch eingehen. Ist zwars hier jetzt nicht der Fall, aber sollte mal so nebenbei erwähnt werden.

    Julien schrieb:

    Genau das ist der Haken an der Sache. Es geht zwar irgendwie, aber komfortabel ist anders. Vor allem, wenn man es dann noch probehören will.

    Kann man verschieben. Und ja es geht nur mit nem kleinen Trick. Weil jedes Element Linksbündig angeordnet wird. Eine Verschiebung kann man dann erreichen wenn man den Platz vor dem Sound entweder mit Stille ausfüllt (was bei Audio sehr sehr exakt sogar ist) oder man ordnet es anhand des Videos an, indem das Video an der Stelle getrimmt wird. Erst so ist eine verschiebung nach Links oder Rechts möglich.
    Unkomfortabel gebe ich selbst zu. Aber man kann es so vereinfachen, das man das so baut das man nur noch eine Zahl dafür angeben muss die dafür sorgt.


    Damit Video und Audio des Videos erst mal synchron geladen werden schreibt man folgendes im Script:

    Quellcode

    1. LoadPlugin("MeGUI\Tools\FFMS\ffms2.dll")
    2. file="C:\Users\h\Videos\2013_12_28_20_6_11.MP4"
    3. FFIndex(file)
    4. Audiodub(FFVideoSource(file, threads=1), FFAudioSource(file))


    Damit wird das Video und die Audiospur mit der entsprechenden Länge des VFR geladen.

    Am besten am Ende des Scriptes alles in Übersicht behalten mit Info()
    Also Info() schreibst du immer ganz am Ende des Scriptes. Damit werden dir alle Informationen aufgeführt zum Video und zum Audio wie es in AVISynth erkannt wird.

    Mache das einmal bitte und mach mal ein Bild von der Vorschau des Scriptes. Interessieren würde mich für das weitere Verfahren die Werte der Informationen dort.
  • Quellcode

    1. LoadPlugin("MeGUI\Tools\FFMS\ffms2.dll")
    2. file="C:\Users\h\Videos\2013_12_28_20_6_11.MP4"
    3. FFIndex(file)
    4. Audiodub(FFVideoSource(file, threads=1), FFAudioSource(file))
    5. Info()


    Genau so sollte es aussehen. Und davon lässte dir eine Vorschau anzeigen. Entweder mit MeGUI oder mit VirtualDub. Da stehen dann Informationen oben links. Davon ein Bild machen und hier posten. Aber so das man die Werte lesen kann bitte ^^
  • Erstmal sorry, dass ich mich gestern nicht mehr gemeldet habe, aber ich habe gestern entnervt aufgegeben, habe mir aber alles mitgeschrieben für das nächste mal. Desweiteren vielen Dank an Sagaras, Julien und Zantos, weil ihr euch die Mühe gemacht habt mir zu helfen und ihr echt so lange durchhaltet bis alles zu 100 % klappt. Das find ich echt super hier.

    Jetzt habe ich es ganz anders behoben, ich hatte noch Magix Video Deluxe, da hab ich alles eingefügt, die Tonspur so gezogen dass es für mich Synchron erscheint, hab es da gerendert. War bestimmt etwas unpraktisch, aber es hat geklappt.
    Nun werde ich wieder Hauppauge Capture, welches nur .TS kann, aber wenigstens einstellungen behält. Ich hab nochmal eine Testaufnahme gemacht, könntet ihr mir sagen ob es so passt und mir sagen was man noch verändern könnte?

    Hier die Testaufnahme mit Haupauge Capture:

    Allgemein
    ID : 0 (0x0)
    Vollständiger Name : C:\Users\Shakur\Videos\HDPVR2test.ts
    Format : MPEG-TS
    Dateigröße : 3,26 GiB
    Dauer : 36min
    Modus der Gesamtbitrate : konstant
    Gesamte Bitrate : 12,6 Mbps

    Video
    ID : 1001 (0x3E9)
    Menü-ID : 1 (0x1)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.0
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 3 frames
    Codec-ID : 27
    Dauer : 35min
    Bitrate : 11,8 Mbps
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 29,970 FPS
    Standard : Component
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.428
    Stream-Größe : 2,96 GiB (91%)
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 1002 (0x3EA)
    Menü-ID : 1 (0x1)
    Format : MPEG Audio
    Format-Version : Version 1
    Format-Profil : Layer 2
    Codec-ID : 3
    Dauer : 35min
    Bitraten-Modus : konstant
    Bitrate : 128 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    Video Verzögerung : 10ms
    Stream-Größe : 49,3 MiB (1%)

    Vielen Dank nochmal, ich lerne immer wieder was dazu.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Handicapped Gaming ()

  • Ariakus schrieb:

    Fps Rate auf 30 und Audio Format auf PCM WAVE, wenn möglich. Wenn nicht, dann zumindest die Bitrate erhöhen.
    Ich hab 30 FPS eingestellt, aber das Programm macht daraus immer 29,970 FPS, keine Ahnung wieso. Bei dem Sound kann ich nur noch die Bitrate erhöhen. Ich glaub ich sollte mir mal ne Capture Card zulegen, dann kann ich mit DXTory aufnehmen.
  • Julien schrieb:

    in MeGUI kannst du nicht mit Ton schneiden (oder nur extrem aufwändig)... Ich fürchte, da hast du ein Problem.

    Mit avsP haste eine Live Vorschau, mit Vdub kannste mit F2 aktualisieren

    Ich weiß nicht was deine Definition von extrem aufwändig ist 8| aber egal.

    __

    Kannste besseren Codec als MP2 nehmen? AAC möglichst. Lossless wird mit HDPVR sowieso nich gehen.

    Bitrate von video und audio auf maximum.
    Aktuelle Projekte/Videos


  • De-M-oN schrieb:

    Julien schrieb:

    in MeGUI kannst du nicht mit Ton schneiden (oder nur extrem aufwändig)... Ich fürchte, da hast du ein Problem.

    Mit avsP haste eine Live Vorschau, mit Vdub kannste mit F2 aktualisieren

    Ich weiß nicht was deine Definition von extrem aufwändig ist 8| aber egal.

    __

    Kannste besseren Codec als MP2 nehmen? AAC möglichst. Lossless wird mit HDPVR sowieso nich gehen.

    Bitrate von video und audio auf maximum.
    Ja aber was bringt mir das? Ich brauche doch ne Timeline wo ich Live verschieben kann, denn ich kann nicht gleichzeitig Audacity und HDPVR2 Aufnahme starten, dadurch sind die 2 Tonspuren nie Synchron, ich könnte ja mikro auch mit HDPVR 2 aufnehmen, dann ist der Game und Mikrosound 1 Spur, aber ich brauch seperate Spuren, das kann nur DXTory. Ich versteh nicht wie man das mit MeGUI Synchronisieren kann, ich versteh schon nicht was avsP ist und VDub.
    Also ich mach es so; ich starte die HDPVR aufnahme, dann öffne ich Audacity und Drücke Aufnahme Starten, dann geh ich zum Fernseher zähle 1,2,3 und bewege dabei 3 mal das Spielmenü runter, damit ich hinterher beim schneiden die bewegung des Spielmenüs mit dem gesagten 1,2,3 abgleiche. Wie soll ich das ohne Timeline machen.

    Zu 2. Ich kann nur AAC einstellen, besser gesagt es gibt nichts um den Soundcodec umzustellen. Das Hauppauge zeug ist echt ein Alptraum. Ich hab Spaß am Letsplay, aber das Schneiden nimmt mir den, aus den Asynchron problemen usw.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Handicapped Gaming ()