Virtual Dub Audio Problem (Facecam)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Virtual Dub Audio Problem (Facecam)

    Anzeige
    Guten abend,

    ich habe mich mittlerweile im Forum und über Google zu Tode gesucht, da ich einfach keine Lösung finde. :(
    Mein Problem hierbei liegt an Virtual Dub. Und zwar wollte ich mich mal ans Thema Facecam ranmachen, da die Hardware eh vorhanden ist. Im Forum habe ich gelesen, dass man als Programm Virtual Dub + Lagarith verwenden soll. Ebenso wird das Mikro über das Programm aufgezeichnet. Die Spielaufnahme erfolgt über Dxtory.
    Soweit so gut... mein Problem nun ist, dass meine Mikro Audiospur normal anfängt aber ab ca. 0:30min die Stimme langsam sich verzerrt. Quasi klingt es wie auf Helium (Witzig nur nicht brauchbar
    :S )
    Das zieht sich bis zum Schluss der Aufnahme... und es wird gefüht immer schlimmer..

    Die Webcam ist eine Logitech c270. Aufnahme mit 30fps.
    Unter Audio -> Compression ist momentan no compression ausgewählt.

    danke für jede Hilfe
    :^^:
    lg Tim
  • Das RGB24 wird dich vermutlich reinreiten. Versuche mal auf YV12 bzw. YUY2 umzustellen.

    RGB24 braucht viel Ressourcen. Auch bei der Wiedergabe schon.

    Lagarith ebenfalls auf Mode: YV12 einstellen und Use Multithreading falls noch nicht getan.

    Wichtig ist aber das deine Cam in YV12 aufzeichnet. RGB kann man verwenden wenn du nicht noch nebenbei ein Spiel aufzeichnest.

    Und dann ist die Entscheiden Frage: Wird DirectShow zur Wiedergabe der Cam in Virtual Dub genutzt? Zu sehen bei der Device Auswahl.
  • Anzeige
    Okay, also Lagarith ist schonmal auf YV12 und Multithreading ist auch an.
    Ich sehe grad, dass ich das RGB bei Capture Pin gefunden habe und das wahrscheinlich falsch war, da ich dort nur i420 auswählen kann. 8|

    Directshow steht in Klammern hinter der Logitech Kamera :)


    Schon wieder soviel dazu gelernt :P danke dir jetzt schon ;)
  • Dann geht deine Cam über DirectShow und du kannst DirectShow einstellen irgendwo bei dir. Entweder ist ein Symbol dafür unten in der Taskleiste neben der Uhr oder irgendwo unter deine Startanzeige bei Windows zu finden.

    Auf jedenfall musst du den ffdshow Video Decoder öffnen und unter Codecs mal ganz nach unten scrollen. Da steht RAW video. Deine Quelle deiner CAM überträgt RAW.

    Entweder auf "all supported" oder "disabled" schalten.

    Und dann halt Virtual Dub neu starten. Der Wiedergabemodus deiner Cam wird sich dann anders verhalten und eventuell sogar besser und stabiler laufen.

    Ausprobieren.


    holica schrieb:

    da ich dort nur i420 auswählen kann.

    i420 ist ein YV12 ähnlicher Planer. Macht meine Cam auch nur.
  • Puh, selbst durch Googlen konnt ich leider nicht den Aufenthaltsort dieser Directshow Funktion erkennen. :( Bei der Taskleiste ist nur die Logitech-Webcam Software & anderes Gedöns.
    Zumindest finde ich unter der Windows Suche die Directshow.dll :S

    Der Decoder ist ebenso unauffindbar .. Irgendwie steh ich aufm Schlauch :D komm mir grad wie ein Anfänger vor der das erste mal vor Windows sitzt :rolleyes:


    edit: Hab jetzt mal das RGB in das i420 geändert, richtig?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von holica ()

  • holica schrieb:

    edit: Hab jetzt mal das RGB in das i420 geändert, richtig?

    Ist schon mal korrekt. Kenne keine Kamera die RGB aufnimmt ^^ Jedenfalls nicht im Privatbereich xD

    holica schrieb:

    Puh, selbst durch Googlen konnt ich leider nicht den Aufenthaltsort dieser Directshow Funktion erkennen. :( Bei der Taskleiste ist nur die Logitech-Webcam Software & anderes Gedöns.
    Zumindest finde ich unter der Windows Suche die Directshow.dll :S

    Der Decoder ist ebenso unauffindbar .. Irgendwie steh ich aufm Schlauch :D komm mir grad wie ein Anfänger vor der das erste mal vor Windows sitzt :rolleyes:

    Jetzt hab ich dich damit überfordert vermutlich ^^ Nicht so schlimm. Irgendwo auf deinem Rechner wirst du eine Einstellmöglichkeit haben für die Decoder.

    Der FFDShow Video Decoder wird mittels über eine Verknüpfung aufgerufen. Die Verknüpfung heißt irgendwo bei dir richtig FFDShow Video Decoder.

    Du kannst es aber auch so starten:
    C:\Windows\system32\rundll32.exe ffdshow.ax,configure

    Glaub ich. Weiß jetzt gar nicht wie es unter 64Bit Systemen aussieht. Aber über den FFDShow kannste das einstellen.

    Oder du hast kein FFDShow drauf. Das kann auch sein. In dem Falle würde ich fragen wollen welchen Codec Pack du installiert hast? Falls es so sein sollte.
  • sourceforge.net/projects/ffdsh…est/download?source=files

    Zu verwenden mit einem 32bit Virtualdub.

    Die FFDShow Video Decoder Config findest du im Programmemenü des Windows Startmenüs dann.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Soo,
    gerade mal nachgeschaut die rundll32.exe gefunden, lässt sich aber nicht öffnen. So als auch mit Admin oder sonst wie :huh:
    Hab hier auch gerade ein 64bit OS :(

    Puh, das mit dem Codecs, nya der Rechner ist ziemlich neu. Der einzige Codec woran ich mich erinnern kann, war der Lagarith den ich installierte.
    Wo ich grad danach Google kann ich sagen, dass ich damals mal das Klite auf dem alten Rechner hatte. Was nun hier installiert ist.. da bin ich überfragt
    :wacko:

    edit: Okay da war Demon schneller.. Wollte grad fragen ob das hier was taugt
    :^^:

    edit²: Soo das Prog läuft nun. Ganz unten steht jetzt wie von dir beschrieben "Unkomprimiert" Decoder steht auf deaktiviert. Dort nun "alle unterstützen" korrekt? :)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von holica ()

  • holica schrieb:

    Wo ich grad danach Google kann ich sagen, dass ich damals mal das Klite auf dem alten Rechner hatte. Was nun hier installiert ist.. da bin ich überfragt :wacko:

    Lass klite bloß in jedem Fall weg. FFDShow ist kein codecpack und damit lässt sich alles decodieren. Codecpack bloß die Finger von lassen ;)

    edit²: Soo das Prog läuft nun. Ganz unten steht jetzt wie von dir beschrieben "Unkomprimiert" Decoder steht auf deaktiviert. Dort nun "alle unterstützen" korrekt? :)


    Joa das meinte er.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Wo wir grad schon bei FFDShow sind... Das könnte auch mein Problem mit VDub lösen...

    Habe bei mir nur Haali Media Splitter, MPC-HC, Lagarith, Dxtory und FRAPS installiert an Video Codec Kram. Welche Einstellungen sollte man bei FFDShow denn vornehmen bei der Installation? Da gibt es ja ohne ende Auswahl Zeugs für was wie und wen während der Installation...


    Aktuelle Projekte
    Mass Effect 2 | The Legend of Zelda: Skyward Sword
  • Soo,

    hatte nun endlich wieder Zeit, weiter rum zuexperimentieren. Leider besteht mein Problem immer noch :( Ebenso musste ich feststellen, dass die i420 Funktion nicht funktioniert. Wenn ich das auswähle und die Aufnahme der Cam starten will, sagt er mir nur Videocompressor Error Source Image Format ist not aceptable. :(

    Hab ich irgendwo was übersehen?
    :huh:
  • Bei Capture pin muss I420, YUY2 oder YV12 eingestellt sein. 640x480 bei max. 30 FPS oder weniger.

    Bei Capture filter sollten die Verstärker auf Standard gesetzt werde, sonst muss die Cam einfach zu viel machen. Gerade die Option Hintergrund bei den Verstärkern sollte auf 0 stehen.

    Bei Set Custum video Format halt auch das einstellen was bei Capture Pin eingestellt wurde. Besonders das Farbspektrum muss identisch sein.

    Wiedergabe von I420, YUY2 oder andere 4:2:0 oder 4:2:2 Planer ist halt am schnellsten.

    Bei Capture Pin sind deine Planer für deine Cam gelistet. Die einfach nur zur Sicherheit bei Custum video Format noch mal auswählen.

    Zudem haste bei VDub die Möglichkeit über Overlay oder Preview das ganze anzuzeigen. Mal durchprobieren am besten. Ich glaube ich musste auf Overlay setzen.

    Musste halt mal schauen.
  • Sagaras schrieb:

    Bei Capture pin muss I420, YUY2 oder YV12 eingestellt sein. 640x480 bei max. 30 FPS oder weniger.
    Okay, hab ich. :) (i420)

    Sagaras schrieb:

    Bei Capture filter sollten die Verstärker auf Standard gesetzt werde, sonst muss die Cam einfach zu viel machen. Gerade die Option Hintergrund bei den Verstärkern sollte auf 0 stehen.
    Bei Capture filter öffnet sich mein Logitech Programm, wo ich verschiedene Werte an Helligkeit etc. verstellen kann. Habe dort alles auf Standart gesetzt und Rightsound und Autofokus ausgestellt.

    Sagaras schrieb:

    Bei Set Custum video Format halt auch das einstellen was bei Capture Pin eingestellt wurde. Besonders das Farbspektrum muss identisch sein.
    Dort ist 640x480, i420 YUV 4:2:0 planar eingestellt.

    Sagaras schrieb:

    Wiedergabe von I420, YUY2 oder andere 4:2:0 oder 4:2:2 Planer ist halt am schnellsten.

    Sagaras schrieb:

    Bei Capture Pin sind deine Planer für deine Cam gelistet. Die einfach nur zur Sicherheit bei Custum video Format noch mal auswählen.
    Ist eingestellt.

    Sagaras schrieb:

    Zudem haste bei VDub die Möglichkeit über Overlay oder Preview das ganze anzuzeigen. Mal durchprobieren am besten. Ich glaube ich musste auf Overlay setzen.
    Die Overlay funktion hatte ich schon direkt angemacht gehabt. Also ich kann direkt sehen was die Cam aufzeichnet. :)

    Sagaras schrieb:

    Musste halt mal schauen.
    Okay habe ich... und es hat sich außer das ich denke das die Qualität hochgegangen ist, nichts geändert. Mein Soundproblem besteht immer noch... :huh:

    Neues Problem ist nun dazu gekommen. Wenn ich bei Compression Lagarith auswähle, kommt der Fehler ausm Beitrag zuvor: Videocompressor Error Source Image Format ist not aceptable.

    Also in Kurzform Deine Settings + RGB = Läuft
    Deine Setting + i420 = Fehler


    Ich wusste gar nicht, dass es so schwer ist eine Facecam zum laufen zu bekommen :wacko:
  • Okay, also bei set custom Video Format sagt er mir das die Cam das YUY2 nicht unterstüzt..
    und bei Capture Pin steht ja leider nur rgb und i420. Lagarith wurd Testweise auch auf YUY2 gestellt. Kam aber die gleiche Fehlermeldung..

    Gibt es vilt. noch ein anderes Programm womit man die Cam aufzeichnen kann, welches zu Empfehlen ist? :(
  • Lol. Was hast du denn für ne Cam? xD

    Nicht mal YUY2 Modus mehr. xD Oh man.

    Das ist ja mal echt mies dann ^^

    Lagarith kann nur in RGB32, RGB24, YV12 und YUY2 aufnehmen. Grundsätlich brauchst du auch eine Wiedergabe des Videos, damit Lagarith es abgreifen kann.

    Für dich steht ja quasi eigentlich nur RGB24 zur Verfügung und das zieht nicht nur an der Wiedergabe in VDub, sondern auch beim Aufnehmen auf der Platte.

    An sich hat jede Cam die ich kenne YUY2 Unterstützung gehabt. Das ist ein 4:2:2 Planar und weitaus schonender bei der Wiedergabe.


    Mal was anderes: In wie weit ist es Asyncron bei dir? Gleich am Anfang oder nimmt das stätig zu? Weil dann hätte ich wirklich mal mit 25 FPS probiert aufzunehmen. Eventuell noch Informativ wäre ob es Laggs gibt bei der Cam?
  • Die Cam ist ne Logitech c270 :S Im Forum hier stand das die genügen würde... :huh:
    Okay, nya das ist dann ja schon mal mist :D

    Also Laggs gibts keine, habe mal mit 25fps ein Probe Versuch aufgenommen.. Es ist direkt am Anfang Asynchron. Würde schätzen das Bild ist ca. 2-3sek schneller. :S

    Ich sehe grade mein Problem gabs hier doch schonmal.. nur leider ohne richtige Lösung.. Thema

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von holica ()

  • Dann ist es normal. Ist halt ein Delay und kann später nachgerückt werden. Das sollte nun kein Ding sein. Schlimmer wäre es wenn es zunehmender Asynchron wird.

    2-3 Sek Verzögerung ist ja schon echt heftig dann. Ich dachte eher das es so im Millisekundenbereich ist. Probier es halt so das du den Ton nachrücken kannst nach der Aufnahme.

    Wenn es passen sollte, dann ist es perfekt.

    Es gibt aber halt auch noch Optionen unter Capture -> Timing...

    Eventuell damit etwas rumspielen damit es passt. Ich glaube bei ms kann man auch Negative Werte eintragen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sagaras ()