MeGUI Einstellungen & Rendern mit Adobe Premiere

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MeGUI Einstellungen & Rendern mit Adobe Premiere

    Anzeige
    Hallo,
    ich stehe da vor einem kleinen Problem. Ich habe bis jetzt meine Gameplay-Aufnahmen immer mit Dxtory und dem Lagarith Lossless Codec aufgenommen. Danach habe ich die Datei mit MeGUI und dem AVS Script Creator in eine MP4 gepackt. Die Audiospuren habe ich vorher aus der Aufnahme exportiert und mit Audacity angepasst und bearbeitet (Rauschen entfernen, Lautstärke etc.) - Zum Schluss habe ich die Dateien in Adobe Premiere geladen und geschnitten. Ich habe beim Exportieren immer die gleichen Einstellungen verwendet und war auch immer sehr zufreiden! Kleine Dateigröße, bei guter Qualität. Jetzt habe ich letzten Freitag ein neues Projekt angefangen... alles mit den gleichen Einstellungen. Nach dem Export mit Adobe Premiere musste ich jedoch feststellen, dass die Bildqualität echt zu wünschen übrig lässt. Es sieht eher so nach "Pixelmatsch" aus. Woran kann das liegen?

    Dann hatte ich die Idee, die Aufnahme über MeGUI zu muxen, also die Video- und Audiospur wieder zusammenzuführen. Das Ergebnis war eigentlich zufriedenstellend. Die Aufnahme musste ich nochmal splitten, da ich keine Folgen mehr hochlade, die länger als 15 Min. sind. Das Problem ist allerdings, dass ich immernoch eine Größe von ca. 2,3 GB pro Datei habe und der Upload etwa 6 Stunden dauern würde. Das ist mir einfach zu viel!

    Wie macht ihr das eigentlich? Wie sieht das weitere Vorgehen nach der Aufnahme aus? Das würde mich echt mal interessieren! Ich freue mich über hilfreiche Antworten und bedanke mich schonmal im voraus dafür!

    P.s.: Die Aufnahmen mit Dxtory und dem Lagarith Lossless Codec haben einen leichten Farbverlust, kann das sein?!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Wossi ()

  • Hast du die Aufnahmen also doppelt kodiert? Oder wirklich nur in einen MP4-Container gepackt? Die erste Variante wäre schlecht für die Qualität, die zweite Variante wäre irgendwie unnötig, habe ich das Gefühl. Aber es kann auch sein, dass ich dich da einfach falsch verstehe...

    Wenn die kodierten Dateien nach Pixelmatsch aussehen, dann liegt das meistens daran, dass der YouTube-Encoder zu wenig Bitrate erlaubt. Die einzige Möglichkeit, hier die Qualität zu erhöhen, ist das Hochskalieren des Materials. Optimal wären hier 3200x1800 Pixel, da bleibt am meisten Bildqualität über, allerdings werden die Dateien auch deutlich größer. Für dich reichen vielleicht schon 2560x1440, das ist auch eine bessere Qualitätsstufe und gibt nicht so übermäßig riesige Dateien.

    Und ja, einen gewissen Farbverlust gibt es immer, weil du in RGB spielst und (hoffentlich) nur in YV12 kodierst, weil ja YouTube auch nur YV12 wiedergeben kann.
  • Hey Julien, danke für die Antwort. Also ich habe die aufgenommene *.avi-Datei mit MeGUI und dem AVS Script Creator in einen MP4-Container gepackt, um diesen dann mit Adobe Premiere zu bearbeiten. Das Problem tritt dann eben direkt nach dem Exportieren aus Adobe Premiere auf, also dieser "Pixelmatsch". Die Datei selbst, habe ich noch nicht auf Youtube hochgeladen. Die ganzen Probleme passieren also schon lokal, ohne das ein Upload stattgefunden hat.

    Ja, ich kodiere in YV12 - mit dem Dxtory Codec habe ich jedoch wesentlich bessere Farbergebnisse.
  • Und wenn du einfach direkt den AVI-Container in Premiere importierst, gibt es da eine Fehlermeldung oder wieso musst du das ummuxen? :huh:

    Wenn schon die lokale Datei nach Pixelmatsch aussieht, hast du einfach in Premiere falsch kodiert. Entweder zu wenig Bitrate oder andere Einstellungen falsch getroffen. Wie genau exportierst du das?

    Was für Einstellungen nutzt du bei Lagarith und Dxtory Codec jeweils? Eigentlich sollten die sich nämlich in der Farbe nicht unterscheiden.
  • Anzeige
    Also beim Lagarith Codec habe ich "Enable Null Frames" und "Use Multithreading" aktiviert. Der Mode ist "YV12".
    Wenn ich den Dxtory Codec verwende, dann habe ich als Format "YUV24 - High Quality" und die "Compress"-Option aktiviert.

    ...so, jetzt habe ich mal die originale *.avi-Datei in Premiere laden (ohne vorher zu muxen!). Hier sind meine Export-Einstellungen die sonst eigentlich funktioniert haben:
    dropbox.com/s/4mnf7gswn93y9gj/…remiere-youtube-setup.png

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Wossi ()

  • Das erklärt den Unterschied zwischen Lagarith und Dxtory bei dir: YUV24 ist mehr Farbraum als YV12. ;) Das Pendant wäre YUV420, das wäre vom Bild her gleich und auch das YouTube-Maximum.

    Ansonsten glaube ich auch zu wissen, warum dein Rust-Video matschig aussieht. Einmal die unterschiedlichen Frameraten (Quelle 29.97 FPS, wieso auch immer, und Ausgabe 30 FPS) und dann natürlich noch die etwas niedrige Bitrate. So wie ich das mitbekommen habe, ist Rust ähnlich schwer zu komprimieren wie Arma und so ein Kram, wegen all der Gräser und Bäume und so. Da wirst du mit den 8Mbit/s (die für Starbound natürlich locker ausreichen) nicht sonderlich weit kommen. Entweder sehr viel mehr Bitrate reinpumpen oder auf einen effizienteren Encoder wechseln wären die beiden Möglichkeiten.

    Achja, und der Ton sollte möglichst schon von Anfang an auf 44.1kHz stehen und auch so bleiben, denn mehr unterstützt YouTube eh nicht und das Downsampling ist nicht immer fehlerfrei. ;)
  • Ich habe die Bitrate jetzt mal auf "15/25" gestellt, mal schauen ob das dann besser wird. Die Framerate habe ich dem Original angepasst.
    Muss ich jetzt beim Exportieren die Audiofrequenz auf 44.1 kHz stellen, obwohl das Original mit 48kHz aufgenommen wurde?

    Danke dir nochmals für deine Hilfe!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Wossi ()

  • Es sollte mit mehr Bitrate schon besser aussehen, ja. Aber auch die korrekten Frameraten dürften eine ordentliche Verbesserung bringen, bei diesen 0.03 FPS Abweichung kann es nämlich sehr gern zu diesen Ghosting-Effekten kommen, die alles eben unscharf und schmierig aussehen lassen.

    Meiner Meinung nach wäre es tatsächlich besser, in Premiere mit 44.1kHz zu kodieren. Ich habe das Gefühl, dass der Encoder von YouTube bei Ton manchmal ein bisschen pingelig ist, von daher hätte ich an deiner Stelle lieber selbst die Kontrolle darüber, wie das Downsampling geschieht. Und in Zukunft lieber gleich in 44.1kHz aufnehmen. ;)
  • Hey Julien, ich habe MeGUI erst einmal zur Seite gelegt und gestern mit der originalen Datei noch einige Prozesse durchgeführt. Mit den Bitraten "15/25", sowie der angepassten Framerate hatte ich zwar ein besseres Ergebnis als davor, doch leider hatte die Datei eine Größe von ca. 1,6 GB... danach habe ich mal die Bitraten auf "10/10" gestellt und damit ich nicht wieder 20 Min. warten musste, habe ich nur die erste Minute der Folge gerendert. Ich war echt erstaunt als ich das Ergebnis gesehen habe: Absolut kein "Pixelmatch" und die Größe der Datei war auch voll in Ordnung! Danach habe ich versucht, mit diesen Einstellungen die ganze Folge zu rendern und dann hatte ich erneut das Problem! Lange Rede, kurzer Sinn: Ich habe festgestellt, wenn eine längere Sequenz im Render-Prozess läuft, entsteht dieser "Pixelmatsch". Soll also bedeuten, dass bei 10 Minuten Sequenz der Fehler auftritt und bei 1 Minute überhaupt nicht! Woran könnte das liegen?

    ...und noch etwas ist mir aufgefallen: Die angegebenen 29.97 FPS in Adobe Premiere können gar nicht stimmen. Ich habe mir die Datei im Explorer angesehen und dort stehen auch 30 FPS in den Details. Ebenso sagt mir das die "Media Info"-Option vom Codec-Pack (Rechtsklick).

    Nochmal zu den Farben: Die Farben in der Aufnahme, sehen ziemlich "ausgewaschen" aus, besonders das Gelb. Man erkennt nicht mal mehr das es Gelb ist, es ist eher so ein ganz helles Creme. Welchen Codec könntest Du mir denn für die Aufnahmen empfehlen? Ich würde gern einen benutzen, der eine hohe Farbtreue hat.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Wossi ()

  • Gerade MIT den Dingern, Codecpacks, wird es schlecht laufen. Die installieren dir irgendeinen müll drauf, und überschreiben wichtige Dateien die du durch ne Deinstallation nicht wiederbekommst.
  • Uh uh uh, Codec Pack. Wenn der Demon das hört, fliegen hier wieder Einzelteile durch die Gegend. :P Aber bevor wir nicht wissen, ob das Ding überhaupt dein Arbeiten beeinflusst oder ob es nur still in der Ecke liegt, musst du auch nicht großartig das System neu aufsetzen oder sowas.

    Allerdings können die Probleme, die du mit den Einstellungen hast, auch von Adobe Premiere selbst kommen. Wenn die Mediainfo 30 FPS ausliest und Premiere behauptet, die Quelle hätte 29.97 FPS, dann stimmt ja eins davon nicht. Und vielleicht sind auch die verwaschenen Farben ein Fehler von Premiere - eventuell wandelt da ein Standardfilter die Farben in RGB um, nur um sie dann wieder auf YV12 runterzurechnen. Das nagt auch noch mal an der Qualität. Und wenn eine kurze Sequenz besser kodiert wird als eine lange Sequenz, klingt das auch nicht koscher.

    Mein Tipp wäre daher: Leg doch erst mal Premiere beiseite (auch wenn es ein teures Programm war) und versuch es mit MeGUI. Einfach mal eine Aufnahme durch MeGUI jagen und schauen, was dabei passiert. Wenn du dabei einen CRF von 20 auswählst, wird die Datei zwar auch groß, aber die Qualität sollte erheblich besser sein. Das passende Mittelmaß kannst du ja dann selbst für dich rausfinden. Aber da wärst du nicht mehr davon abhängig, was Premiere heimlich im Hintergrund macht, sondern hättest die Kontrolle über alles. Und genau an dieser Stelle sollte es dann auch nicht mehr zu den Fehlern kommen, die du jetzt andauernd erlebst.
  • Ok, Danke Julien! Dann werde ich das mal versuchen.

    Ich habe bei diesem Projekt auch schon versucht ohne Adobe Premiere zu arbeiten und meine Arbeitsschritte waren folgende:
    - Audiospuren aus der originalen Aufnahme extrahieren und mit Audacity bearbeiten
    - Die Originale Aufnahme mit MeGUI (AVS Script Creator) in einen MP4-Container packen
    - Danach mit MeGUI (MP4 Muxer) die Audio- und Videospur wieder zusammenzufügen

    Bitte korrigiert mich, wenn ich etwas falsch gemacht habe! ;)
    Nach dem o.g. Vorgang hatte ich meine *.mp4-Datei mit einer Größe von ca. 4,23 GB bei guter Qualität, ohne "Pixelmatsche". War das jetzt richtig oder wie geht ihr da vor?!

    P.s.: Ich installiere mir immer das "K-Lite Codec Pack", damit ich viele Formate über den VLC Media Player anschauen kann.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Wossi ()

  • P.s.: Ich installiere mir immer das "K-Lite Codec Pack", damit ich viele Formate über den VLC Media Player anschauen kann.

    Einmal System neu installieren bitte.

    @dein Workflow: deine beschreibung is komisch ^^
    Ich hoffe du meinst mit dem zweiten Punkt das du encodierst.
    Der dritte Punkt, dafür gibts unter dem Video auch noch ne box mit Audio, wo du noch das audio verarbeiten kannst - mit auto encode wird das auch automatisch gemuxt am ende

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DarkHunterRPGx ()

  • tortelini66 schrieb:

    @DarkHunter hinsichtlich der Dateigröße wird wohl ein Encode geschehen.

    ich frag lieber nochmal nach :P bei einigen hier bin ich manchmal nie sicher, was sie genau tun :S