Probleme beim Encodieren mit Adobe Premiere Pro CC

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Probleme beim Encodieren mit Adobe Premiere Pro CC

    Anzeige
    Hallöchen!

    Wie oben im Titel schon steht, habe ich ein paar Probleme beim Exportieren meiner Videos aus Adobe Premiere Pro CC.
    Im Prinzip geht es darum, dass ich bereits vor einigen Tagen mal wieder ein Projekt mit Facecam anfangen wollte. Also habe ich normal aufgenommen (wobei ich meinen iPod für die Aufzeichnung meiner Wenigkeit benutzt habe) und habe auch alles mit der Synchronisation soweit ziemlich gut hinbekommen. Nach dem ich mein Video soweit fertig geschnitten habe, wollte ich es mit folgenden Einstellungen exportieren:

    Format: H264
    Vorgabe: Benutzerdefiniert
    Selbstverstandlich werden Audio und Video exportiert ;)
    Beim Reiter Effekte habe ich soweit nichts verändert (ist vermutlich auch nicht wichtig)
    Reiter Video: 1920x1080p; Framerate 25 FPS; Feldfolge Progressiv; Seitenverhältnis Quadratische Pixel; Fernsehnorm PAL; Profil Hauptoption; Pegel 4,1; Mit maximaler Tiefe rendern ist deaktiviert; Bitratenkodierung VBR, 1 Durchgang; Zielbitrate liegt bei 3 MBit/s; Maximale Bitrate liegt bei 8 MBit/s; der Keyframeabstand ist 72
    Reiter Audio: Audioformat AAC; Audiocodec AAC; Samplerate 48 kHz; Kanäle Stereo; Parametrisches Stereo ist deaktiviert; Audioqualität Hoch; Bitrate liegt bei 320 KBit/s; Priorität ist auf Bitrate
    Reiter Multiplexer: Multiplexer MP4; Streamkompatibilität Standard
    Der nächste Reiter wäre Untertitel aber da habe ich keine, kann von daher wegbleiben
    Reiter FTP ist auch unwichtig

    Soweit zu den Einstellungen beim Export. Das Problem liegt jetzt genau darin, dass das Video nach dem abgeschlossenen Encodiervorgang (dauert gut 50 Minuten bei einer Videolänge von 31 Minuten) im Ordner 0 Byte groß ist und deshalb auch nicht geöffnet und abgespielt werden kann. Das ist äußerst nervig, da ich bestrebt bin, jeden Tag ein Video hochzuladen und es nach fast einer Woche noch immer nicht geht.
    Mein Projekt (in Adobe) ist so aufgebaut, dass am Anfang mein Intro (.mp4; 25 FPS) kommt, anschließend läuft das mit Fraps aufgenommene Material (.avi; 50 FPS) und darüber liegt die mit meinem iPod aufgenommene Facecam (.mov; 30 FPS) für die ich die Effekte Zuschneiden und Schwarz-Weiß benutzt habe.

    Hat irgendjemand ne Lösung für das Problem? Wäre echt super. <3

    MfG, MatorsaLP
  • Nicht gerade zu deinem Problem, aber du solltest dein Spiel nicth mit 50 FPS aufnehmen und den Rest mit 30 und das dann mit 25 FPS kodieren, entscheide dich für 25 oder 30 und mache alles gleich... Youtube gibt dir so oder so nicht mehr als 30 FPS also wäre es unnötiger hardwareverschleiß mit 50 aufzunehmen, das braucht ma nur für Zeitlupen...
    Es wäre langsam mal wieder Zeit diese Signatur zu überarbeiten, ich bin aber wie immer zu faul. Deshalb gibt´s jetzt wieder diesen Platzhaltertext.
    Ihr könntet solange doch mal auf meinem Kanal vorbeischauen: [url]www.youtube.com/Dir3ct0rLP[/url]

  • Mal abgesehen davon, dass du extrem schlechte Kodierungseinstellungen hast, wäre vielleicht eine Mediainfo von dieser ominösen 0KB-Datei interessant. ;)
    Und was für Dateien gibt es sonst noch im Ordner? Ich glaube, Premiere erstellt nämlich erst die Streams selbst und muxt sie später erst in einen MP4-Container.
  • Anzeige
    Ich glaube, das Programm scheint mal ganz gerne rumzuzicken. Habe gerade mit den selben Einstellungen encodiert und es ging plötzlich.

    Wäre dennoch nett, wenn du mir mal DEINE Einstellungen geben könntest, damit die Qualität etwas verbessert werden könnte. :)
    Ich werde mal ne MediaInfo reinstellen, wenn mir noch mal so eine broken Datei mit 0 KB unterkommt.
  • Meine Einstellungen? Ich arbeite ja nicht mal mit Premiere (zumindest nicht mit Gameplay-Material). Aber wenn, dann würde ich erst mal dafür sorgen, dass alle Quellen dieselbe Framerate haben, dann würde ich die Bitrate sehr viel höher schrauben (mindestens mal 15Mbit/s bei 1080p) und bei Variabler Bitrate lieber zwei Durchgänge wählen. Den Ton würde ich auf außerdem 44100Hz begrenzen, weil das eh das YouTube-Maximum ist.
  • Entweder haust das als Lagarith (oder ein anderes Lossless-Format) raus und schmeißt es dann in meGUI oder du frameservst (steht hier im Forum wie) das ganze direkt aus Premiere an meGUI, letzteres ist nämlich der beste für sowas (also das echte x264 und nicht das Mainconcept-Ding was "die großen" alle verwenden)
    ——YouTube————————————————————————————————————————————
    — Endlos-Projekte: Minecraft (SinglePlayer), Craft The World, Banished, Besiege, Sims4
    — ..Abgeschlossen: Leisure Suit Larry 6+7, Dishonored, Surface 2+3, Mirrors Edge, uvm
    — . Kurz- Projekte: The Tower, Fighting Is Magic, Euro Truck Simulator 2, uvm
    — ......Retro-Ecke: Day Of The Tentacle, Flight Of The Amazon Queen, NFS: HP2, uvm
    ————————————————————————————————————————————TbMzockt.de—
  • MatorsaLP schrieb:

    Wäre dennoch nett, wenn du mir mal DEINE Einstellungen geben könntest,


    Ich arbeite auch nicht mit Premiere, kann dir aber dennoch helfen, da du ja gelistet hast, was Premiere anbietet an H.264 Settings.


    Hauptoption ist schonmal blöd. Da nimmste schonmal "hoch".
    "Mit maximaler Tiefe rendern" tolle Wurst. Kann ja vieles bedeuten. Ganz großen Applaus an Adobe.. Kann ich nix zu sagen. Glaube jemand schrieb mal hier das es wohl die Farbhelligkeitsrange beeinflusst. Also ob 0-255 oder 16-235. 16-235 wäre richtig, mehr nimmt yt eh nicht. Sprich falls es das sein sollte, ist es korrekt wenn du das nicht an hast.

    Warum begrenzt du den Encoder auf 8 mbit Bitratenpeak? Wichtig ist doch nur die Schnittgröße. Da man wohl das max peak bitrate ding nicht deaktivieren kann, stelle das höchstmögliche ein. Der Encoder braucht nicht wirklich bei der Peak Bitrate eingeschränkt werden und sollte er auch nicht ^^
    Und selbstverständlich 2 Durchgänge (2pass) Nur 1 Durchgang ist sehr suboptimal.

    3 mbit/s ist viel zu wenig für 1920x1080. Erstrecht bei der Effizienz von MainConcept, statt dem effizienterem x264.
    3 mbit/s - so wenig nimmt ja nicht mal Youtube für 1080p und youtube codiert bereits richtig schlecht.^^
    3 mbit/s ist bei weitem zu wenig. Unbedingt mehr. Mind. 8mbit. Und Maxbitrate wie gesagt - maximum was eintragbar ist.

    Keyframeabstand auf das 10fache der FPS Rate. Bei 25 fps also ein Keyframeabstand von 250 benutzen.

    Audio Samplerate auf 44,1 khz.
    Viel mehr geht ja bei den 3 Einstellungen die Premiere nur hat nicht..
    __
    Aber ja. Besser wäre es Premiere nicht zum codieren zu benutzen.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7