Knistern bei MSI Afterburner

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Knistern bei MSI Afterburner

    Anzeige
    Das ist mal sehr abstrus: Meine Audioaufnahmen Knistern- sowohl ingame als auch Mikro. Aber ausschließelihc bei MSI AFterburner. TS, Skype, Dxtory, Shadowplay - alle haben keine Probleme. Nur Afterburner.

    Version: 3.0.0 Beta 19
    Das Tagebuch eines Dämonischen Abenteures: Nagrach
  • Jop. Das ganze hört sich tatsächlich leicht wie eine fehlerhafte MP3 datei an. (in der Beta 18 btw war das problem noch nicht). Interessant ist das es nach dem Rendern abgemildert wurde und auf YT kaum noch zu hören war - glaub ich.

    Hier mal das Video das ich damit hochgeladen habe:

    Knister Knister Video


    Bei Anachronox im übrigen bei weitem nicht so schlimm wie bei Fresspace Open.
    Das Tagebuch eines Dämonischen Abenteures: Nagrach
  • Anzeige
    Mediainfo:

    Player: Classic Media Player, VLC - beides dasselbe. Ich hab mir das auf YT nur in Punkten angeschaut da ich n Traffic limit hab und etwas sparsam umgehen muss. :/



    Allgemein
    Vollständiger Name : H:\Lets Plays\fs2_open_3_7_0_SSE_2014_04_06_19_22_29_212.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 10,5 GiB
    Dauer : 16min
    Gesamte Bitrate : 93,3 Mbps

    Video
    ID : 0
    Format : Lagarith
    Codec-ID : LAGS
    Dauer : 16min
    Bitrate : 90,5 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 30,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:2
    BitDepth/String : 8 bits
    Bits/(Pixel*Frame) : 1.454
    Stream-Größe : 10,2 GiB (97%)

    Audio #1
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 16min
    Bitraten-Modus : konstant
    Bitrate : 1 411,2 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 163 MiB (2%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 33 ms (1,00 Video-Frame)

    Audio #2
    ID : 2
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 16min
    Bitraten-Modus : konstant
    Bitrate : 1 411,2 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 163 MiB (2%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 33 ms (1,00 Video-Frame)


    Das Tagebuch eines Dämonischen Abenteures: Nagrach
  • Hm. Was kann man dagegen unternehmen. Dxtory hat das problem mit FreespaceOpen das es extrem FPS kostet. (Afterburner ca. 60-80FPs, Dxtory 20-30)

    Mir ist grad ne Idee gekommen. Ich nehm auf eine externe USB3 Festplatte auf. Heute hab ich mal den Port gewechselt, wenn es Bufferprobleme sind... könnte es sein das das an einem Problem mit dem USB Port liegt?. Gestern hatte ich das Problem ja noch nicht...

    Ok. Ich glaub langsam das einfach die Beta 19 komplett verbuggt ist. Hab gerade Port gewechselt und zum testen mal Two worlds aufgenommen. Nach nicht mal einer Minute zeigt mir das OSD eine Aufnahmezeit von 0:00: an, obwohl es vorher mit gezählt hat. Der witz an der sache ist, die aufnahme läuft an sich weiter - ich kann sie gar nicht beenden. Erst wenn ich auf den Desktop gehe und dort meine Aufnahme Taste drücke, und danach Msi Afterburner beende kommt eine ruckelige Aufnahme heraus. Also wohl tatsächlich der Buffer. Frage ist nur: Warum seit heute/gestern?

    Ich teste jetzt mal ein paar Einstellungen durch...

    Ich hab so langsam den Verdacht meine Herrin Eris hat ihre Finger im Spiel. *Hot dog ess*
    Das Tagebuch eines Dämonischen Abenteures: Nagrach

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Nagrach ()

  • Sicherstellen das auch Windows und SK überall auf 44100hz steht.

    Falls du eine SK hast, dann WASAPI Aufnahmegerät wählen und dort WAVE nehmen.

    Bei Onboardsound bleibt dir ja leider nur der lautsprecher mix kanal von windows : /
    __

    Und beim rivatuner -> app detection level auf high und Framebuffer statt viewport als methode nehmen.
    Aktuelle Projekte/Videos


  • Habe irgendwo gelesen, dass die aktuelle Beta Version vom MSI Afterburner wohl sowieso den einen oder anderen Bug in der Audiospur hat.

    Bei anderen Leuten habe ich gelesen, gibt es in den ersten Minuten auch eine Asynchronität zum Bild, die immer schlimmer wird und dann durch zauberhand nach 5-15 Minuten verschwindet und der Ton dann perfekt synchron weiterläuft.

    Vielleicht hängt dieser Fehler auch damit zusammen.

    Würde zum Test einfach mal die Beta 18 probieren, die dieses Problem noch nicht hatte... und wenn er sagt, dass da Komponenten abgelaufen sind, einfach zum Programmstart das Datum zurückstellen.
    Bei mir gibt es die Spiele aus den unbekannten Weiten des Alls
    Zum Kanal

    Momentan im Anflug:
    Dragon Ball: Origins 2
    Action Adventure - NDS - 2010 - Seit 20.05.2017
  • Ich benutz immer noch 2.3.0 ^^

    Die Version funktioniert bestens bei mir. Einzig ist blöd, das der Audio viel zu früh schließt und somit die Audiospur teils 800ms kürzer ist, als die Videospur. Wenn man dann mehrere Videos anhängen will, entsteht natürlich eine Asynchronität, da ja in dem Fall das nächste Audio in dem Beispiel 800ms zu früh ansetzen würde.

    Aber zum Glück gibt es ja SSM. :)
    Aktuelle Projekte/Videos


  • Hm. Also Demon bestätigt praktisch was ich mir schon dachte, wenn man die Entwicklungsgeschichte von der Beta 19 etwas nachschaut isses auch kein wunder. Das Teil wurde Praktisch ein "Auf-die-letzte-Minute-auf-Teufel-komm-raus-Release", da Unwinder wohl etwas RL PRobleme hatte.

    Hm hat das Problem mit der Audiospur die 3.1 auch noch? Naja die hatte aber noch ganz andere Probleme...
    Fürn Avisynth Skript bin ich zu Blöd, und da ich derzeit Praktishc 50 Stunden die Woche fürs Studium eingeplant hab (Ob ichs auch einhalte...?), hab ich grad net den nerv mich mit skripten auch noch zu beschäftigten - außerhalb von GIS und CAD.


    In der Regel mach ich allerdings einfachn Cut nach 15-20 Min aufnahme und fang eine neue Aunfahme an, ist da die Desynch auch noch ein Problem?.

    @Deepstar: Die Beta 18 ist abgelaufen, sonst hätt ich ja gar net gewechselt^^.

    Hab mit Fraps auch mal getestet das ist von der reinen FPS anzahl das Beste - Beim aufnehmen geht die FPS von 125 auf 120 runter. Dxtory bleibt immer noch bei maximal 40FPS, und sobald ich mich in richtung eines 3D Objektes bewege geht sie auf 20-30 runter. Das liegt wohl an der FSO engine.Afterburner hat gut 60-80 FPS.

    Aber Fraps hat keine getrennte Audiostream aufnahme(Oder ich bin zu Blöd sie zu finden), und ich mag das Teil allgemein nicht so. Wie siehst den mit Bandicam aus? (ist mir aber eig zu teuer.)

    Audioeinstellung auf 44100Hz und WASAPI.
    Soundkarte ist ne Soundblaster Z - auch nicht das beste vom besten aber leider hat nur Creative EAX emulation und Baldurs Gate 2 mit EAX ist so ein gewaltiger unterschied^^. (und die Xi-FI waren entweder zu teuer oder zu mies^^)

    Würde es den einen unterschied machen von Stereo Mix auf Rip umzustellen?

    @Deepstar: Die Beta 18 ist abgelaufen, sonst hätt ich das ja schon wieder gemacht.^^
    Das Tagebuch eines Dämonischen Abenteures: Nagrach
  • Hm... es hört sich in der Tat erstmal nach einzelnen fehlenden Samples an. Ich müsste mir heute Abend mal im Audioeditor ansehen, wie es genau an den Stellen aussieht. Das ist jedenfalls meistens der Fall, wenn irgendwas nicht mit dem Lesen bzw. Schreiben der Samples hinterherkommt. Das kann dann prinzipiell überall in der Verarbeitungskette passieren. Von Programmfehler bis Treiberproblem. Aber nach der Beschreibung liegt ein Problem beim Programm nahe.
  • Nagrach schrieb:

    In der Regel mach ich allerdings einfachn Cut nach 15-20 Min aufnahme und fang eine neue Aunfahme an, ist da die Desynch auch noch ein Problem?.


    Das Problem ist ja der schließvorgang der Datei. In dem Moment isses logischerweise egal ob du 2std oder 2min Aufnahme machst.

    Wenn du Aufnahmetaste fürs beenden drückst, dann schließt er Audio deutlich früher als die Videospur.

    Ob das mit neueren Versionen immer noch so ist, kann ich nicht sagen.

    Zu SSM kommt in Kürze ein Tutorial. Musste da nur noch was mit 'nem Song klären xD Aber ich mussn wohl leider austauschen^^ Wird dann in Kürze online sein.


    Der Audio Export ist eig. keine schwierige Sache und kann ja dann die Zeitstelle verlinken wo das dran genommen wird von mir.
    Aktuelle Projekte/Videos


  • Ich hab gerade die 2.3.0 getestet. Knistert aauch und das Video ruckelt extremst... - selbst ingame trotz 80FPS... seeeeeeeehr komisch... bis vor kurzem ging das ja noch alles.

    Allerdings hat hamachi mir am Samstag meinen Win Explorer zerschossen (warum? tja... wüstt ich auch gern) Musste ne Systemwiederhestellung machen... ob da was kaputt gegangen ist? Aber irgendwie seh ich da keinen Zusammenhang aber das Zeitliche passt *verwirrt*.

    Jetzt wirds interessant. Ich hab gerade festgestellt das beim Aufnehmen nur ein CPu kern mit 100% ausgelastet wird, die andenr Praktisch gar nicht. Multithreading ist aktiviert... was zur?

    Ok kurzer Geistesblitz: FSopen verwendet nur Singlecore (Multicore Support ist eine der wenigen Sachen die sie noch nicht einbauen konnten :D), als vermute ich das Afterburner und FSO dann beide über eineen Kern laufen... aber warum? das verwirrt^^. Und warum hat es dann vorher bei spielen wie Anachronox funktioniert? Kriegt Afterburner keine Rechte zum nutzen von mehr Kernen mehr plötzlich? Irgendwo stimmt hier was gewaltig nicht...

    UPDATE: Bei zuweisen von mehr/andere CPU kernen für FSo löst sich tatsächlich das neue Video-Lag Problem. Das Knistern bleibt aber...

    Da das mit den CPU kernen auch bei Dxtory geht nehm ich eben jetzt einfach mit DXtory auf...
    Gelöst isses net will meinen afterburner schon gerne wieder haben^^
    Das Tagebuch eines Dämonischen Abenteures: Nagrach

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Nagrach ()