Open Broadcaster Software Blackscreen bei Game-Aufnahme

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Open Broadcaster Software Blackscreen bei Game-Aufnahme

    Anzeige
    Hallo Leute,
    Ich hatte jetzt vor einiger Zeit vor auf Twitch einen Livestream zu machen und habe mir dafür die Open Broadcaster Software geholt, da die wesentlich einfacher zu bedienen ist. Jetzt hab ich nur ein Problem. Wenn ich eine Szene erstelle und dafür dann die Quelle "Game Aufnahme" dann hab ich (egal bei welchen Programm oder Spiel) immer einen Blackscreen. Also es wird nichts angezeigt. Ich habe heute bereits meinen Grafikkartentreiber aktualisiert, habe die neueste Version der Software, die Einstellungen passen auch alle, die Software benutzt meine zweite und stärkere NVIDIA Geforce GT 650m Grafikkarte und wenn ich einen Rechtsklick auf den Blackscreen mache und auf Projektor gehe, dann steht da nur "Deaktiviert" und Monitor 1 ist ausgegraut. Kann das vielleicht daran liegen und wie löse ich das Problem? Hat da jemand schon Erfahrungen mit?


    L.G.: Kelkrex
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • Ne, also ich hab es ja auch mit Firefox und Minecraft probiert aber da funktioniert es ebenfalls nicht. Outlast habe ich auch im Fenstermodus gehabt und OBS hat es mir auch nicht angezeigt. Also Fenstermodus hilft da auch nicht
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • Erstmal:
    Man kann mit dem Open Broadcaster auch Vollbild aufnehmen. Das ist durchaus möglich.

    Hier mal ein paar Punkte, die bei mir geholfen haben:

    1.) Starte OBS erst nachdem Du das Spiel gestartet hast und erstelle eine neue Szene. Bei Gameaufnahme dann ganz einfach mal auf aktualisieren drücken. Wenn dort dann das Spiel steht, wähle es aus. Dann geh' ingame und starte die Aufnahme um es zu testen. Wenn das Spiel nämlich minimiert ist, dann bekommt man einen Blackscreen.
    2.) Hast Du die aktuelle Version? Bei älteren Versionen ist es durchaus möglich, dass es nicht klappt. Dies war mal als *Bug* gekennzeichnet.
    3.) Manchmal wird das Spiel bei der Gameaufnahme nicht angezeigt. Dies passiert meist bei Games, die Vollbild benutzen. Dazu startest Du das Spiel (nicht nur den Launcher) , minimierst, erstellst eine neue Quelle und benutzt die jeweilige. Auch hier kann es sein, dass mehrere Anläufe nötig sind. Du findest aber schnell raus, wie, indem Du dich ein bisschen rumprobierst.
    4.) Während einer Aufnahme kannst Du auch mit Rechtsklick jeweilige Einstellungen vornehmen (z.B. Bild zentrieren, Schwenken, etc.) Dies ist manchmal sehr wichtig, um beim Streamen optimales Bild zu haben. Vor allem Quellen, die nur im Fenstermodus starten, kann man so leicht auf 16:9 anpassen.
    5.) Es hilft auch Openbroadcaster neuzustarten. Aber bitte hier nicht nur rechtsklick auf das Kreuzchen ~ nein auch den Taskmanager benutzen. Dadurch wird ein optimaler Neustart ermöglicht.
    6.) Kontrolliere bei den Einstellungen doch mal dein Video, Kodierung, etc ~ ob es deinem PC angepasst ist. Außerdem kannst Du auch bei einer Quelle rechtsklick machen und dort die Einstellungen bearbeiten. Klick dich mal durch die verschiedenen Optionen.

    Bei weiteren Fragen ~ einfach nochmal stellen. =^● ⋏ ●^=
  • Anzeige
    1.) Hab ich gemacht aber passiert trotzdem nichts. Immer noch Blackscreen.
    2.) Die neueste Version hab ich.
    3.) Ich hatte es sowohl Vollbild als auch im Fenstermodus probiert doch beides half ebenfalls nichts. Nachdem ich das Spiel minimiert hatte, habe ich auch eine neue Quelle erstellt und das Spiel ausgewählt doch auch das brachte nichts.
    4.) Brauchte ich ja im Moment nicht zu machen, da sowieso kein Bild vorhanden war.
    5.) Hab ich auch schon gemacht, hat aber auch nichts geholfen
    6.) Alle Einstellungen sind korrekt.
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • Bei Laptops mit Intel und nVidia Graka laufen diese im Quicksync oder so :D. Um aber nun auf den eigentlichen Punkt zu kommen. Du musst auf die Intel stellen, da über diese die Monitoranzeige läuft. Außerdem ist die Graka für OBS ziemlich egal da das encoden eh über die CPU läuft.

    Edit: falls du Fraps oder so im Hintergrund noch laufen hast mach es mal aus, hatte damit auch schon Probleme das OBS das Bild nicht aufnehmen wollte ;)
  • Ich hab einen i7 3610QM und eine Uploadgeschwindigkeit von 1,50 Mbps. Habe daher bei der Software auch die maximale Bitrate auf 800 gestellt und die Puffergröße auf 1000. Sollte ausreichen oder?
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Kelkrex ()

  • Das heißt wie sollte ich es nun einstellen oder hätte ich bei der Geschwindigkeit generell kein gutes Bild?
    Achja, bei Qualität hab ich "6" eingestellt und alle häkchen gesetzt. Also sowohl bei "Benutze konstante Bitrate (CBR)" als auch bei "Benutze CBR padding" und "Benutzerdefinierte Puffergröße".
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • unter Einstellungen -> Erweitert -> Video -> x264 CPU Voreinstellungen, dort mal verschiedene Möglichkeiten ausprobieren was dein Laptop schafft.
    Standard ist veryfast = schnelle verarbeitung aber schlechte Kompression -> du brauchst also höhere Bandbreite für bessere Qualität.
    Je weiter du runter gehst des so mehr leistung brauchst du bei der CPU aber auch weniger Bandbreite, da die Daten besser Komprimiert werden.
    Auf 720p ein "gutes" bild zu bekommen, dürfte bei 800kb/s ziemlich schwer, zumal du ja nen Laptop nutzt und diese in der Leistung doch stark begrenzt sind :s.
    Auf 480p dürftest auf medium ein brauchbares Bild bekommen wenn das deine CPU denn packt.
    Musst halt ausprobieren was dein laptop schafft und was für dich ein gutes Bild ist, denn es spielen einige Faktoren mit rein die bei jedem anders sind/varieren.
    Optimal ist natürlich schnelles Inet + schnellen CPU und genugend RAM zum auslagern.