[Hilfe] Kontroller auf DOSbox und kein Sound in VMware unter Win 98 SE

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • [Hilfe] Kontroller auf DOSbox und kein Sound in VMware unter Win 98 SE

    Anzeige
    Hallo,
    ich habe 2 Fragen, es steht ja schon Teils oben drin ^^

    Frage Nummer 1:
    Kann ich ein Game Pad Kontroller über USB auf der Dos Box zum laufen bekommen, dass ich während des LPs nicht auf der Tastatur herum hämmern muss?
    Mit Tastatur spielen ist immer etwas umständlich bei Jump'n run Spielen.

    Frage Nummer 2:
    Über VMware habe ich keinen Sound und ich glaube auch nicht, dass er überhaupt eine Soundkarte gefunden hat, wie kann ich das Sound Problem lösen?
    Habe nun schon viel Zeit investiert das alles überhaupt zum laufen zu bekommen, mit der richtigen Auflösung und einer vernünftigen Farbvielfalt. Nun muss nur noch der Sound funktionieren und das Spiel laufen.

    Wäre schön wenn ihr mir helfen könnt bei meinen Problemchen :)
  • Blaze Fox schrieb:

    Über VMware habe ich keinen Sound und ich glaube auch nicht, dass er überhaupt eine Soundkarte gefunden hat


    Vielleicht schon ein zu Simpler Lösungsvorschlag, aber here we go:

    Hast du deine Soundkarte bei deinem richtigen Windows installiert mit Treibern und so? Viele (vor allem Onboard Soundkarten) werden von Windows erkannt, kann aber Schwierigkeiten mit VMWare geben.
    Ich habe, ohne wirklich Einstellungen in VMWare vorgenommen zu haben, Sound in meiner Virtuellen Maschine. Die Soundeinstellung steht auf "Auto Detect".
  • Blaze Fox schrieb:

    Also ich habe einen Laptop und auf den Stickern rechts und links vom Touchpad ist einer wo drauf steht "ATI Mobility Radeon Premium Graphics", ich bin mir aber nicht ganz sicher ob es nun bedeutet, dass sie extra ist oder On Board.
    Also bei mir ist auch Auto Detect eingestellt.


    Nur eben, das es sich bei ATI Mobility Radeon um eine Grafikkarte und nicht um eine Soundkarte handelt.
  • VMWare simuliert normalerweise eine stink normale Soundblaster-Soundkarte, sprich den Treiber sollte jedes ältere Betriebssystem mitbringen (angefangen von 95 über 98 bis hin zu XP, Vista und 7). Schon mal die VMWare-Tools in der VM installiert?

    Achja, und Sound sollte natürlich für die VM aktiviert sein, man kann Hardware hinzufügen und entfernen wenn die VM heruntergefahren ist, evtl. ist auch dort keine Soundkarte ausgewählt?
    ——YouTube————————————————————————————————————————————
    — Endlos-Projekte: Minecraft (SinglePlayer), Craft The World, Banished, Besiege, Sims4
    — ..Abgeschlossen: Leisure Suit Larry 6+7, Dishonored, Surface 2+3, Mirrors Edge, uvm
    — . Kurz- Projekte: The Tower, Fighting Is Magic, Euro Truck Simulator 2, uvm
    — ......Retro-Ecke: Day Of The Tentacle, Flight Of The Amazon Queen, NFS: HP2, uvm
    ————————————————————————————————————————————TbMzockt.de—
  • @TbMzockt
    Ja die VMware Tools habe ich bereits installiert, sonst hätte ich auch meine Auflösung nicht ändern können sowie ein höheres Farbspektrum als lächerliche 16 Farben zu Anfang.
    Also er erkennt keinerlei Soundkarten, aber in dem Windows 98 SE das installiert ist habe ich 4 Unbekannte Geräte im Geräte Manager.



    Wie soll ich den irgendwelche Treiber in ein Virtuelles Windows Importieren?


    @De-M-oN
    Danke für den Link, habe das Joystick Problem bei meiner DOS Box inzwischen selbst lösen können, aber ich hoffe das es hier auch so simpel sein kann.
    Aber eine Frage hätte ich vorweg noch zu dieser DOS Box Version. Meine alte DOS Box scheint irgend ein DOS Plugin zu vermissen, wenn ich ein Spiel von CD aus starten möchte. Er versucht die CD zu Initialisieren, aber bekommt es nicht hin... DOS sagt mir dann "Pleas install MSCDEX v 2.1 or above."
    Wo finde ich das und wie binde ich es in DOS ein? Oder wurde das mit der Version zu der du mich verlinkt hast behoben?


    Die einzige Lösung die ich aktuell dafür hätte, wäre bei jedem start von DOS Box, das Spiel neu zu installieren über den Install Pfad, leider ist die Start EXE Datei in einem Ordner der CD, auf den ich zugreifen kann, aber DOS Box sich lieber selbständig macht und trotzdem nicht weiter arbeiten kann. Ich weiß leider auch nicht wie ich einen Pfand Mounten kann, der mir sofort im Ordner die EXE Datei laden kann.
    Für all das habe ich schon in einer deutschen Readme gelesen aber nur sehr mager Probleme beheben können.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Blaze Fox ()

  • Also wenn ich das auf dem Screenshot richtig erkenne, hat er ein "PCI Multimedia Audio Device" erkannt. Das war unter Windows 98 die Bezeichnung für Audiogeräte wo die Treiber fehlen.

    Die VMWare Tools hattest du wirklich komplett installiert?

    Ansonsten würde ich einfach versuchen, dem o. g. Gerät eine Art universalen Treiber aus der Windows 98 Treiberdatenbank hinzufügen. Meist kannst du da sowas wie den Soundblaster 16 oder AWE32 von Creative einbinden. Für gewöhnlich funktionieren die.

    Und zu der Geschichte, Treiber in ein "virtuelles Windows importieren", da du VMWare Workstation verwendest und die Tools installiert sind, müsstest du die von deinem richtigen Rechner heruntergeladenen Dateien direkt per Drag&Drop in deine virtuelle Maschine ziehen können.
  • Schau ich habe die Tools Installiert, sonst würde sicher nicht Reinstall VWware Tools dort stehen


    Das ist nun die Frage, ob es eben jenen Treiber auf meiner Installations CD gibt...
    Habe eben mal das VMware Windows die Installations CD durchforsten lassen ohne erfolg, ich schau nun noch einmal ins Internet, ob ich einen passenden Treiber finde und ob ich es schaffe den irgendwie in das Virtuelle Windows zu laden.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Blaze Fox ()

  • Bei VMWare wird einfach die VMTools vergessen worden sein zu installieren ^^

    In der Workstation selbst oben unter VM -> Install VMWare Tools

    Muss erst aktiviert werden bei laufendem Win95/98 in der VM

    Dann installiert er alle Treiber die für die VM nötig sind. Soundtreiber, PCIBridge und sonstige Treiber und Geräte. Auch einen Lauffähigen S3_SVGA Grafiktreiber.



    Ansonsten einen Lauffähigen "Creative Labs Soundblaster 16 oder AWE32" Treiber runterladen.

    Bei der VMWare unter Win95 muss dann die VMX umgeschrieben werden in:

    Brainfuck-Quellcode

    1. In der VMX einzutragen
    2. ----------------------------------
    3. sound.present = "TRUE"
    4. sound.virtualDev = "sb16"
    5. sound.fileName="-1"
    6. sound.autodetect = "FALSE"
    7. sound.baseAddr="0x220"
    8. sound.dma16="7"
    9. sound.dma8="1"
    10. sound.irq="5"
    11. sound.mpu401baseAddr="0x330"
    12. sound.OplBaseAddr="0x388"
    Alles anzeigen


    Damit die Soundtreiber erkannt werden. Danach kann der Treiber installiert werden.

    Den Soundtreiber sollteste im Internet finden. Wenn nicht, kannste mich auch in Skype kontaktieren, da ich ihn hier auch habe als Diskettenformat.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sagaras ()

  • @TE: Einfach einen Standard-Soundblaster-Treiber installieren, das sollte für das "Multimedia-Device" ausreichen.


    Sagaras schrieb:

    In der Workstation selbst oben unter VM -> Install VMWare Tools

    Das stand auch bei meinen VMs dort mit bereits installierten Tools, weiß nicht ob das gefixed wurde aber vor ein paar Jahren als ich zuletzt mit VMWare gearbeitet hab stand halt immer dieser Eintrag im Menü und hat sich auch nach Installation nicht geändert..
    ——YouTube————————————————————————————————————————————
    — Endlos-Projekte: Minecraft (SinglePlayer), Craft The World, Banished, Besiege, Sims4
    — ..Abgeschlossen: Leisure Suit Larry 6+7, Dishonored, Surface 2+3, Mirrors Edge, uvm
    — . Kurz- Projekte: The Tower, Fighting Is Magic, Euro Truck Simulator 2, uvm
    — ......Retro-Ecke: Day Of The Tentacle, Flight Of The Amazon Queen, NFS: HP2, uvm
    ————————————————————————————————————————————TbMzockt.de—
  • Für gewöhnlich, wenn denn alles so funktioniert wie man es sich vorstellt, würde er dann auch das unbekannte Gerät mit dem gelben Fragezeichen entfernen. Lösch mal diesen Sound- Video und Gamecontroller wieder. Ich bin mir gerade nicht sicher, aber hast du irgendwie die Möglichkeit bei Windows 98 manuell einen Treiber für dieses PCI Multimedia Audio Device auszuwählen. Da sollen jetzt nicht die Quellen Internet, CD oder so genutzt werden. Ich habe da einen Knopf in Erinnerung, wie "Einen Treiber aus einer Datenbank wählen" oder sowas in der Art. Das müsste er direkt bei den Quellenangaben als weitere Möglichkeit anbieten.
  • mount d d:\ -t cdrom

    würde in dosbox ein laufwerk d erstellen mit dem inhalt vom richtigen system d:\ und -t cdrom lässt d als cdlaufwerk erstellen.

    mount c d:\blood

    würde in dosbox ein laufwerk c erstellen, mit dem inhalt aus d:\blood von deinem richtigen system.

    Dosbox Daum (meine genannte) liefert eine Menüführung mit. Vllt kommst du mit dieser besser klar. Die Menüführung ist nur für die laufende Sitzung. Willst du dort gemachte Einstellungen permanent haben, kannst du sie übers menü auch via Main - Save current settings permanent speichern.
    Bestimmte Optionen lassen sich nicht via laufenden Betrieb schon übernehmen. In dem Fall müsstest in jedem Fall permanent speichern und die Dosbox neustarten. Darunter dürfte zb ein Soundkartenwechsel fallen.

    Und sie bietet auch Joystick Support - darunter würden auch Gamepads fallen.
    Aktuelle Projekte/Videos


  • Also ich habe in meiner DOSbox zum installieren immer folgendes eingegeben und das hat geklappt (nach Ende der Zeile Enter drücken, den Anfang der als Standard dann da steht lasse ich weg):
    mount c c:\DOSbox Spiele
    c:
    mount d d:\ -t cdrom
    d:
    dir
    install

    und dann geht es los und schickt mich ins Installationsmenü des Spiels.Von da aus kann ich das Spiel auch starten, wenn die Installation abgeschlossen ist. Aber egal was ich dann mache um das Installierte Spiel wieder zu starten, er sagt ständig, das die CD Nicht initialisiert werden kann und ich soll "Pleas install MSCDEX v 2.1 or above." machen.
    Ich weiß nicht wie ich einen Pfad ein geben muss in der DOS Box, dass ich direkt die Exe starten kann, jetzt an meinem Beispiel
  • Bei der DOSBox:
    CD folgendermaßen einbinden lassen:
    mount d d:\ -t cdrom -usecd 0

    ISOs oder sonstige Images lassen sich via Cuesheet (*.cue) laden
    imgmount d D:\Jagged.cue -t cdrom

    Bei der Cue selbst liegt die ISO dann dazu bei. Es lassen sich auch *.NRG Datein von Nero einlesen oder aber auch direkt ISOs ohne Cue.
    Die Cue wird empfohlen. Gerade bei DOSSpiele die Multitracks haben. So wie Tomb Raider 1, wo die Musik auf der CD sitzt als neuer Track.

    Für Laufwerk C: hätte ich an deiner Stelle das ganze automatisch initialisieren lassen.

    Hilfreich dazu wäre es in der DOSBox.config folgendes in der Autoexec Sektion zu schreiben:

    Quellcode

    1. [Autoexec]
    2. @echo off
    3. # . - aktueller Pfad
    4. # .. - Ein Pfad zurück
    5. mount c ..\C\
    6. #Main-/Befehlspfade setzen
    7. #in Laufwerk z ist der DOSBox Befehlsinterpreter
    8. Path c:\;z:\
    9. SET Path=%PATH%
    Alles anzeigen


    Blaze Fox schrieb:

    Ich weiß nicht wie ich einen Pfad ein geben muss in der DOS Box, dass ich direkt die Exe starten kann, jetzt an meinem Beispiel

    Pfade kannst du folgendermaßen ändern:
    • Laufwerkbuchstabe + :
      Laufwerk wechseln
    • CD -Ordner- oder Pfad
      In den angegebenden Ordner wechseln
      Beispiel:
      C:
      CD\
      CD DOS

      = C:\DOS\

      oder
      C:
      CD\
      CD Windows\System\

      = C:\Windows\System\
    • CD ..
      Ein Verzeichnis zurück
    • CD .
      Im Aktuellem Verzeichnis bleiben
    • CD\
      Zum Laufwerkursprung zurück
    • DIR
      aktuelle Verzeichnisliste zeigen
    • DIR /w
      aktuelle Verzeichnisliste im Breitformat zeigen



    Zu dein Windows Problem hatte ich dir schon gepostet was zu tun ist, wenn er Treiber nicht erkennt. Du musst bei VMWare die VMX ändern zu dem Windows was du erstellt hast und diese mit einen Texteditor wie Notepad++ oder dem Standard Notepad von Windows ändern. Weil der wird als Gerät nicht wissen das du Soundblaster 16 hast. Er hat ein Gerät zwars da, aber kann es nicht zuordnen.

    Erst die VMX editieren und dann den entsprechenden Treiber installieren der explizit für Win95/98 ist. Dieser nennt sich wirklich "Creative Sound Blaster 16 oder AWE32". Dazu musst du im Internet schauen ob du Treiber dafür findest.
    Weil VMWare vermutlich in den ach so tollen VM Tools keine Audiotreiber für 95 und 98 gegeben hat.

    Ich musste es bei VMWare 9 z.B. immer ein externen Audiotreiber nehmen und es manuell installieren. Und das geht nun mal nur so.

    In der VMX wird es deklariert und in der VMWare kann es dann installiert werden und wird somit auch erkannt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sagaras ()