Probleme mit .ts, Hauppauge Capture, Windows Movie Maker und MAGIX Video Deluxe 2013

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Probleme mit .ts, Hauppauge Capture, Windows Movie Maker und MAGIX Video Deluxe 2013

    Anzeige
    Hi Leute.

    Ich habe seid einiger Zeit echt Probleme mit meiner Software und den Aufnahmen.
    Zuerst meine Hard- und Software:

    Aufgenommen wird von PlayStation 3 und PlayStation 4.
    Aufnehmen tue ich mit der Hauppauge HD PVR2 über die Software Hauppauge Capture, Vers. 1.0.32168
    Weiterverarbeiten tue mit Magix Video Deluxe 2013 Plus oder dem Windows Movie Maker (nur wenn Magix mal wieder streikt, dazu später)

    Die Software Hauppauge Capture schmeißt swn Dateityp .ts raus. Soll ja nen super Format sein. Aber: es kommt oft vor, dass diese Datein fehlerhaft sind. Es wird dann in unterschiedlicher Länge ein Standbild vor das Video gehängt.
    Wenn ich diese Datei in den VLC Player packe, überspringt er diese Standbildphase (man sieht es unten in der Zeitleiste) und macht dann mit dem eigentlichen Video weiter. Teilweise sind es 18 Minuten Standbild und danach 1 Minute Video.
    Diese defekten Dateien kann man aber im Magix Video Programm als auch im Movie Maker nicht immer bearbeiten. Manchmal ja, manchmal nein. Der Movie Maker stürzt ab, Magix erzeugt ein Video komplett in schwarz. Ich kann also diese Dateien schwer bis gar nicht weiterverarbeiten.
    Des weiteren kommt es bei Magix vor, das auch "heile" .ts Datein nicht richtig eingelesen werden. Es wird in der Vorschau nur ein schwarzes Video angezeigt. Wenn man es dann mal abspielt zur Vorschau wird nur schwarz gezeigt, Ton aber abgegeben. Wenn ich dann zum testen das Video einfach mal rrendere und dadurch eine .mp4 Datei erstelle, ist diese auch nur schwarz. Ich habe in einem anderen Forum gelesen, das es der Grafikkartentreiber sein soll, der die Vorschau nicht richtig erstellen kann. Allerdings wird halt beim rendern auch nur schwarz erzeugt.
    Aber das ist nicht bei allen so. Manche werden ohne Probleme eingelesen und verarbeitet, andere nicht. Sehr willkürlich.
    Und da kommt halt der Movie Maker ins Spiel. Der liest die heilen .ts Dateien ohne Probleme ein und kann sie auch weiterverarbeiten.

    Defekte Dateien werden im Magix entweder erst mit langem schwarzem Bild angezeigt und am Ende dann Video oder komplett schwarze. Wenn am Ende zumindest noch Video angezeigt wird hat man Glück und man kann das schwarze vorne abschneiden. Wenn es komplett schwarz ist, hat man Pach gehabt.
    Im Movie Maker ähnlich. Entweder man sieht ein Standbild und kann es mit Glück abschneiden, oder die Datei wird direkt nach dem schneiden als Fehlerhaft angezeigt.
    Wenn ich versuche die defekte Datei im Movie Maker inzulesen und unverändert zu rendern um evtl eine zu bearbetende mp4 Datei zu bekommen, stürzt der Movie Maker ab.

    Mein PC ist frisch formatiert um alles möglioche an Fehlern auszuschließen. Und leider passieren die gleichen Fehler auch mit meinem Laptop, auf dem ich es auch mal versucht habe um die Fehler einzugrenzen. Leider komme ich aber auf keinen grünen Zweig, da ich im Inet echt wenig bis gar nichts finde, was meinem Problem ähnelt. Ich kann mir gar nicht vorstellen, dass ich der einzige bin, der defekte .ts Dateien aus dem Hauppauge Capture bekommt. Suche auch immer nach updates und Treibern, aber ohne Erfolg. Ich stehe da echt vor einem Rätsel :/

    Den Hauppauge eigenen Konverter in der Software um die Videosdateien in .mp4 umzuwandeln kann man (in meinem Fall zumindest) total vergessen. Er macht es zwar, egal ob heile oder defekte Dateien, aber die haben dann eine soooooooo meise Qualität das man sie getrost wieder löschen kann.

    Vllt hat ja irgendjemand eine Idee, einen Tipp oder sonst irgendwas. Wäre klasse!

    AzuRO
  • Ja, ich weiß das der nix taugt. Aber: damals als wir angefangen sind, war das erstmal ein tool/programm mit dem man ein bisschen rumhandtieren konnte und erste erfahrungen sammeln konnte. Und er funktioniert nach wie vor noch. Aber egal. Verstehe dich!

    Mediainfo:

    Allgemein
    ID : 0 (0x0)
    Vollständiger Name : E:\YouTube\The Last of us\08 - Universität\Konversationen\HDPVR2_20140824_1317.ts
    Format : MPEG-TS
    Dateigröße : 51,6 MiB
    Dauer : 5min 41s
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 1 266 Kbps
    maximale Gesamtbitrate : 5 000 Kbps

    Video
    ID : 4113 (0x1011)
    Menü-ID : 1 (0x1)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.0
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 3 frames
    Codec-ID : 27
    Dauer : 38s 855ms
    Bitrate : 1 009 Kbps
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 59,940 FPS
    Standard : Component
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.018
    Stream-Größe : 4,68 MiB (9%)
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 4352 (0x1100)
    Menü-ID : 1 (0x1)
    Format : MPEG Audio
    Format-Version : Version 1
    Format-Profil : Layer 2
    Codec-ID : 3
    Dauer : 39s 361ms
    Bitraten-Modus : konstant
    Bitrate : 192 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 KHz
    Video Verzögerung : 5min 2s
    Stream-Größe : 923 KiB (2%)
  • Ok. Ich würde dir da den TSMuxer empfehlen. Der ist bei MeGUI mit enthalten. Also MeGUI würde ich dir ebenfalls ans Herz legen.

    MeGUI updaten:
    Nach dem Download von MeGUI startest du ihn und gehst ganz oben in Option -> Settings unter dem Reiter "Extra Configuration"

    Dort stellste AutoUpdate auf "Use development update Server" und speicherst das ganze untern. Danach beenden und neu starten. Dann komplett Updaten erstmal.

    Danach kannste MeGUI beenden und gehst in das MeGUI Installationsverzeichnis. Dort angelangt gehst du in den Tools Ordner. Dort findeste einen Ordner mit dem Namen TSMuxer. Da gehste rein und startest schließlich die TSMuxerGUI.exe

    Dort ziehste deine TS Aufnahmedatei rein und sagst unten bei Output "Demux" und gibst das Zielverzeichnis an. (Er wird dir dann 2 Files erstellen)

    Dann drückst du auf "Start demuxing"


    Jetzt sollteste eine h264 Rohdatei (Video) Datei haben und eine MP2 Audio Datei.

    Diese kannst du dann entweder mit MKVMerge (Ebenfalls bei MeGUI mit bei) in MKV muxen und auf YT hochladen.

    ODER wenn du es bearbeiten willst noch ziehste dir das Programm YAMB oder MP4BoxGUI runter.

    In diesen Programmen versuchst du dann die h264 Rohdatei in ein MP4 Container zu geben.

    Hast du die MP4 (Video) und die MP2 (Audio), kannst du sie eigentlich in jedem Programm bearbeiten. Vegas, Premiere, MeGUI.

    Für Audio würde ich die Audacity empfehlen dann. Willst ja schließlich bestimmt deine Mikrofonspur noch mit deiner Gamespur mischen wollen.

    Die 59.940 FPS des Videos würde ich mit MeGUI und dem Befehl ChangeFPS(30, 1) in 30 FPS wandeln.
    Dann haste danach nicht so große Datein.

    Schneiden kann MeGUI ebenfalls.

    Somit sind alle genannten Programme (bis auf Vegas und Premiere) kostenlos und sehr hochwertig bei der Bearbeitung. Bei Problemen einfach dann noch mal melden. Workflow für dich aber selbst finden am besten.
  • Anzeige
    Du solltest aber definitiv mal die Bitrate der HD-PVR2 auf maximum stellen und die FPS auf 30/29,970 dann hast du deutlich bessere Qualität.

    Ansonsten kann ich die Aussage von Sagaras nur unterschreiben. Immerhin hast du nicht das variable FPS Problem :)


    Aktuelle Projekte
    Mass Effect 2 | The Legend of Zelda: Skyward Sword