Blender Avi Video schwarz in TMPGENC 5

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Blender Avi Video schwarz in TMPGENC 5

    Anzeige
    Aloah zusammen... ich rede gar nicht großartig um den heißen Brei herum.


    Wir haben da mal so ein kleines Intro Video zusammengeklatscht und zwar mit Blender.

    Das Problem ist einfach, nach dem Import des Clips ist es jedoch schwarz im TMPGENC 5, Ton ist aber da - gerendert als AVI

    Wir haben es auch in MPEG gerendert, da hat es funktioniert nur ist die Qualität halt nicht so optimal.

    Wenn es da draußen jmd. geben sollte der sich speziell vielleicht auch mit Blender auskennt, wäre das ein Traum wenn er/sie mich mal anschreiben könnte.

    Mir fehlt da gerade einfach das Know How um hier mehrere Details zu geben / :

    Greetz Riq
  • AVI JPEG nicht nehmen. JPEG ist Verlustbehaftet.

    Wenn dann schon AVI RAW

    Bei AVI RAW wird Unkomprimiert in RGB ausgegeben mit dem internen Windows Codec.

    Übersteigt der ne gewisse Größe können den NLEs nicht lesen.

    Wenn es längere Videos sind (5min +), dann würde ich dazu raten das ganze mit H264 + Lossless Output zu encodieren.

    Ist es unter 5min - , dann würde ich alle Bilder als PNG Datei ausspucken lassen. Da Komprimiert und Lossless + 16Bit Tiefe.

    Danach können die Bilder mit RadVideoTools wieder als Lossless Video zusammengesetzt werden in einen Lossless Container wie MagicYUV, Lagarith oder UTVideo.

    Wie das geht auf folgenden Link beschrieben:
    Blender als freies Editing Programm für Video- und Grafikbearbeitung [Lossless Video Output]


    Dein Schwarzes Bild kommt nur zu stande, weil der Stream in der AVI Datei in deiner NLE nicht decodiert werden kann. Entweder ist der Stream zu groß dafür als das es gehen würde oder kein Filter kann den Stream decodieren.

    Gerade vor dem Windows internen (Uncompressed RGB/YcbCr) Codec sollte man etwas Abstand halten. Der ist nicht grad geeignet für alles. ^^
  • Hallo Sagaras,

    ich bin der Mensch, der mit Blender rumfuckelt und dieses Problem hat :) Ich hätte da jetzt aber noch einige Fragen, die ich durch deinen oberen Post und deinen Blender Guide nicht klären konnte oder vielleicht bin ich zu doof es herauszulesen, schließe ich jetzt auch nicht aus ;)

    Beim Export in das Avi Raw fehlen sämtliche im Projekt genutzten Audio Informationen ... wie bekommt man das denn hinterher wieder zusammen?

    Warum sollte ich das RadVideoTool nutzen? Meine gewohnte Vorgehensweise beim Rendern ist das vorherige Erstellen von PNG-Files, die ich dann mit dem Blender internen Video Editing als Image Stream einpflege, um dann zusätzlich Audio-Files und noch gewisse Effekte drauflege. So habe ich alles aus einer Hand. Gibt es etwas, was das Tool kann oder besser macht als die Blender internen Mittel?

    Zum Test habe ich gestern ein neues Projekt angelegt, mit einer einzigen Scene, einer kleinen Animation die ich als Avi mit einem H.264 Codec render. Da gibts kein Problem ... ich vermute einfach, dass ich ich das vorherige Projekt irgendwie kaputtkonfiguriert habe :D
  • Anzeige
    Das Thema wurde "als erledigt markiert" und deshalb werde ich es nun schließen.
    Falls noch Rückfragen auftauchen, oder ich anderwertig zu früh geschlossen haben sollte, so genügt eine kleine PN des Threaderstellers an mich.

    Weiterführende Fragen anderer User bitte sonst per PN / per eigenem Thread klären. :)
    - Danke!


    #CLOSED