Dxtory mit Xeon E3-1271v3 und EVGA Geforce GTX 980 - Ruckelnde Videos

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Dxtory mit Xeon E3-1271v3 und EVGA Geforce GTX 980 - Ruckelnde Videos

    Anzeige
    Hi,

    ich hoffe dass ich hier im richtigen Bereich bin, so wie ich den Hilfstext oben verstanden habe.

    Ich weis mir nicht mehr zu helfen. Ich versuche mit Dxtory Videos (30 Frames) aufzuzeichnen mit Lagarith (Lieblingscodec) als Codec in Full HD. Das Spiel fängt nicht an zu ruckeln aber die fertigen Videos sehen furchtbar aus. Könnte es sein das Dxtory sich entweder nicht mit der neuen Grafikkartengeneration verträgt oder könnte es an der CPU liegen die keinen MMX Support mehr hat. Angeblich soll Lagarith MMX ja bevorzugen.

    Ein weiteres Mysterium verdeutlichte sich mir auch als ich die Aufnahmeplatte von Seagate (ST3000DM001) aus meinem Vorgängersystem benutzen wollte. (Das Vorgängersystem war ein Phenom II X4 965 mit 8 GB RAM und einer ATI HD 5850). Sie lief dort mit Dxtory flüssig, allerdings habe ich da Videos nur mit kleinem HD aufgezeichnet. Im neuen System lief Sie nicht flüssig. Da brachen die Frames ein auf 10 bis 20. Ich habe dann eine zweite Seagate Platte (ebenfalls eine ST3000DM001), ebenfalls aus meinem alten System, genommen und diese dann mit der ersten als Raid 0 geschaltet. Die Frameinbrüche waren dann weg. Könnten die Platten dann immer noch zu langsam sein für die Full HD Aufnahme? Ich glaube aber persönlich nicht so daran.

    Ich dachte auch dass es eventuell die PCI-Express Lanes sein könnten. Ich habe ein Z97 Board drin von ASRock um genau zu sein das Z97 Extreme 6. Könnten diese bei der Hardware die ich verbaut habe bereits einen Flaschenhals darstellen?

    Ich hatte den Task-Manager zum Testen mal laufen lassen. Die Auslastung im Leistungsfenster war meistens nur so zwischen 20 und 30% bei laufender Aufnahme. Die Festplatten schienen laut dem Windows Performance Monitor auch gut klar zu kommen. Und die Grafikkarte hatte nur knapp 10% Auslastung bei laufender Aufnahme bei älteren Spielen wie z.B Neocron.

    Das letzte Rätsel ist dass ich auch bereits andere Codecs probiert habe wie den eigenen von Dxtory, dann FastCodec, MagicYUV, YUFSoft Lossless Video Codec uvm.
    Bei jedem das gleiche Ergebnis. Die Videos ruckeln. Kann mir jemand aus der Misere heraus helfen?

    Anmerkung: Dxtory ist nicht auf der Aufnahmeplatte sondern auf einer kleinen wo nur Programme und Treiber drauf sind. Es sind derzeit 4 dieser 3 TB Platten im System installiert. Davon 2 eben als Raid. Die anderen beiden beherbergen jeweils einmal das OS (Windows 7 Pro 64 Bit) und die zweite nur die Spiele. Falls noch Fragen bestehen fragt ruhig.

    Ich bin auf Dxtory angewiesen, da ich 3 Tonspuren meistens aufzeichne. Einmal die vom Spiel, dann die vom Mikro und die vom TS3 wenn ich Gäste bzw. eine LPT Session habe. Oder gäbe es da einen adequaten Ersatz? Kosten wären in dem Fall egal.

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Ressorator ()

  • Vllt bist du ja hiervon mit betroffen?

    Was ist mit DXTory los? Performance für'n Arsch geworden

    Probier mal Afterburner mit diesen Settings:

    abload.de/gallery.php?key=jRBPGPYE

    Und MagicYUV mit diesen Settings ausm Bild:

    MagicYUV - Ein neuer Lossless Codec!

    Mit AB gehen allerdings nur 2 Audiospuren, aber bitte trotzdem mal testen um zu wissen ob es an DXTory liegt.
    __

    und bei 360 mbyte/s versteh ich nicht, warum du einen derart cpu belastenden codec wie Lagarith nimmst?^^

    Das RAID 0 ist in der Lage bei 2560x1600, 60fps aufzunehmen bei MagicYUV mit genannten Settings. Also daran liegts nun auf keinen Fall^^ (habe selber ein RAID 0 aus Seagates.
    Aktuelle Projekte/Videos


  • Anzeige
    Ok ich habe nun alles so eingestellt wie du vorgeschlagen hast. Den Thread über Dxtory fand ich aufschlußreich. Manche haben einfach eine alte Version anschließend benutzt. Das Problem ist da aber wohl bei mir dass ich 2.0.122 benutze. Wäre dann da eine neuere Version dann interessant oder lieber eine ältere?

    Wenn ich eine Taste zum starten von AB festlege und diese dann im Spiel drücke passiert nichts. Mag der keine Tasten vom numerischen Block zum starten?

    Naja, ich habe Lagarith eben immer genommen. Vorher habe ich Fraps genommen nur das Problem mit nur einer Tonspur war mir ein Dorn im Auge. Dann bin ich umgestiegen auf Dxtory und hab ganz am Anfang den Dxtory Codec benutzt, dann Lagarith. Und man soll ja nicht immer alles umstellen wenn es gut läuft. Aber da es das ja nicht mehr tut...

    Ok hier ein Nachtrag. Es ist jetzt gerade 9 Uhr. Ich habe im Dxtory Thread gelesen dass man ein Downgrade machen soll von der Software. Ich habe von Version 22 auf 19 zurückgestuft und es scheint alles wieder zu gehen so wie früher auf der alten Maschine. Hinten in Advanced habe ich Limit Video FPS auch ein Häckchen rein gemacht. Eventuell half das auch noch mit, weil das auch als Tip im Thread stand.

    Ich möchte mich ganz artig bei allen bedanken die mir dadurch das restliche Jahr versüßt und meine Hobbykarriere gerettet haben. :)

    Dieser Beitrag wurde bereits 12 mal editiert, zuletzt von Ressorator ()

  • Ressorator schrieb:

    Naja, ich habe Lagarith eben immer genommen. Vorher habe ich Fraps genommen nur das Problem mit nur einer Tonspur war mir ein Dorn im Auge. Dann bin ich umgestiegen auf Dxtory und hab ganz am Anfang den Dxtory Codec benutzt, dann Lagarith. Und man soll ja nicht immer alles umstellen wenn es gut läuft. Aber da es das ja nicht mehr tut...


    Das Ding ist einfach, das du dir mit Lagarith unnötig die fps tiefer machst, weil Lagarith mit seiner Kompressionsstärke recht gut CPU belastet. Die Framekompressionszeit liegt da dann auch einige ms höher als bei magicyuv, welches in meinem falle einen 2560x1600er frame sogar in 8ms komprimiert - Lagarith YV12 ganze 19 bis 22ms !
    Und bei 'nem RAID 0 brauch man nun wirklich nicht einen Codec nehmen der maximale Kompression abzielt ;D

    Wenn ich eine Taste zum starten von AB festlege und diese dann im Spiel drücke passiert nichts. Mag der keine Tasten vom numerischen Block zum starten?


    Das überprüfen bitte:

    MSI Afterburner - Kostenlose Alternative zu FRAPS und DxTory!
    Aktuelle Projekte/Videos


  • Ok ich habe mal den MagicYUV unter Dxtory ausprobiert bei Dragon Age Origins. Bei der Filmsequenz die beginnt wenn man "Neues Spiel" auswählt läuft es mit diesem bis zu der Stelle gut wo die Ansage kam "Und dann kamen die grauen Wächter" ab dann bricht damit das flüssige Aufnehmen sehr stark ein. Mit Lagarith ist das nicht passiert. :( Gäbe es denn noch ne Alternative (zum testen) als Codec?
    Aber ich bin froh das echt wieder alles funktioniert, aber erst mal auf so etwas zu kommen als Lösungsansatz...
    Aber Dank euch allen hier die mir geholfen haben und auch denen die das Forum hier erschaffen haben geht nun alles wieder. :)
  • Klar gibt es. z.B. den DXTory Codec eingestellt auf YUV420 (und beim RAID 0 brauchst ja dann nicht mal den compress haken dann - ohne compress wird das video aber natürlich deutlich größer, aber selbst mit compress wirds gut laufen)

    Aber wirklich performanter wirds erst mit Afterburner, zumal der auch die 64bit Encoder der Codecs nutzen kann.
    Aktuelle Projekte/Videos


  • Hätte auch mal eine kleine Frage :)

    Momentan nehme ich mit Afterburner auf, doch während der Aufnahme sinken die FPS auf max. 25.

    Einem kürzlichen Benchmark nach liegt die Schreibrate bei 120-130 MB/s, die Datenrate der Videos liegen bei 320.000 Kbit/s, das dürfte doch eigentlich kein Problem sein ?(

    Deswegen hab' ich überlegt, wieder mit OBS aufzunehmen (da ich damit keine FPS Einbrüche habe) und wollte fragen, ob man sich den Schritt des After-Encodes eigentlich sparen kann und gleich mit einem entsprechenden CRF aufnehmen kann?

    Bisherige Versuche (crf=18) sahen grausig aus, obwohl ich mit gleichem Faktor die Afterburner Videos encodiere, dazu sei aber gesagt, dass die Testvideos in Full HD und die Afterburner Aufnahmen in QHD+ waren ^^
  • Btw, es gibt ja x264vfw und soll ja ganz nett sein, Problem nur, wenn ich ihn installiere und in Afterburner testen will, dann ensteht eine Datei, die nur ein paar KB groß ist ?(

    Ist der buggy oder nicht kompatibel?

    PS: Lieber TE bitte verzeih', dass ich deinen Thread benutze ^^

    EDIT: Hab's jetzt zum Laufen bekommen (Lösung hier ), nun aber immer noch die Frage, ob es dem After-Encode nachsteht? :)

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von CoRori ()