Tonproblem mit mkvmerge / megui

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Tonproblem mit mkvmerge / megui

    Anzeige
    Moin zusammen.

    Die Wintertage verleiten mich gerade wieder dazu, mal ein wenig neue Software zu probieren. Einfach, aus Langeweilie. :)
    Je nach Grund, nehme ich u.a. die Videos mit Shadowplay auf.

    Schnitt und Render bis jetzt mit Sony Vegas. Alles ok, für meine Zwecke usreichende Qualität.
    Jetzt habe ich mal ein wenig gelesen und folgende Software benutzt, die mir Probleme bereitet.

    Aufnahme Bild und Ingame Sound Shadowplay.
    Sprache Audacity
    Schnitt Vegas
    Von Vegas via Frameserver / Sagaras Scriptmaker zu megui.
    Danach mkvmerge um Bild und Ton zu vereinen :)

    Und da taucht das Problem auf.
    Das fertige Video startet problemlos. Nach 1-2 Sekunden springt dann der Ton um eine Sekunde zurück und das bleibt bis zum Ende des Videos so. Der Ton ist also immer um eine Sekunde versetzt. Am Anfang des Videos aber syncron.

    Woran liegt denn das?

    Welche Infos braucht ihr von mir um das Problem eingrenzen zu können?
  • DerOberNoob schrieb:

    Woran liegt denn das?


    DerOberNoob schrieb:

    Aufnahme Bild und Ingame Sound Shadowplay.


    Da hast du schon denn Grund...
    Shadowplay nimmt in VFR auf..
    Programme wie Vegas brauchen aber CRF

    Sagaras schrieb:

    Und zum Thema Shadowplay und Co.
    Ja, also VFR Aufnahmen sind schon echt Krass was sie den Leuten unterjubeln, wobei man doch eigentlich wissen sollte das die meisten NLEs CFR nur verstehen können. Also allein bei dieser VFR Aufnahme können oder werden mit Sicherheit irgendwann Video Aufnahmen dabei sein die absolut Asynchron sind. Und das liegt dann Hauptsächlich an diesen VFR Kram.
    Das ist schon eines der schwerwiegenden Punkten. Vor allem da es kaum Konvertierer dafür gibt. AVISynth wäre eine Möglichkeit. Ist sogar in meinem SSM mit eingearbeitet so ein VFRtoCFR Wandler. Aber eine Garantie gebe ich dafür nicht.
    Übrigens sind Aufnahmen mit VFR bei der Aufnahme selbst viel performanter, weshalb auch Spiele wie BF4 nicht in Framedrops enden, sondern schön flüssig laufen.
    Hat also nix mit der GPU an der Stelle zu tun.

    Dann als nächstes der klägliche Versuch GPU zur Aufnahme zu nutzen. In der Zwischenzeit sollte sich ja mal so langsam rumgesprochen haben das CPU beim Encodieren schneller ist als eine GPU aufgrund das beim Encodieren wenig bis gar nix parallelisierbar ist. Diese GPU Encoder erschleichen sich ihre gute Encodingperformance auf Kosten schlechter Framequalität im Video später. So nach dem Motto: Quantität statt Qualität.

    Allein aus diesen 2 Gründen ist Shadowplay schon mal eine Software die man nicht empfehlen kann.

    Gibt auch noch ein dritten Grund bezogen auf die Lossy Aufnahme. H264 kann (hab ich vorhin schon mal erwähnt) Lossless aufnehmen. Aber so gut wie die Entwickler von Shadowplay nun mal sind gibt es dafür weder einen Eintrag noch eine andere Art der Möglichkeit das anzugeben. Beim OBS klappt das z.B.
  • Moment. Verstehe ich nun nicht.

    Wenn ich die Videos mit Vegas render, geht es ja und ich habe damit schon rund 400 Videos gerendert.
    Der Ton zickt ja bei megui und mkvmerge.

    Wieso braucht es denn dann CRF und wenn dem so ist, warum springt dann mit VFR den Ton nach genau 2 Sekunden um eine Sekunde nach hinten?

    Edit

    Es passiert aber auch mit OBS und das Tool macht CRF.
    Habe ich zwar nicht oben aufgeführt, aber "u.a." geschrieben. Ich habe es noch mal getestet. Egal ob SP, OBS, DXRory oder Afterburner.
    Passiert immer. Nach 2 Sekunden springt der Ton 1 Sekunde zurück.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DerOberNoob ()