2 kleine aber nervige Fehler beim Rendern mit MeGui

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • 2 kleine aber nervige Fehler beim Rendern mit MeGui

    Anzeige
    Hi.. ist schon eine ganze Weile das ich das Forum besucht hab. Hätte aber eine Frage, wo ihr im besten Fall eine Antwort und eine Problemlösung habt.

    Ich bin derzeit etwas am experimentieren mit meinen MeGui Einstellungen und kann einfach keine Lösung für diesen Fehler finden. Habe bereits im Forum gesucht, nichts gefunden. Unter Google hab ich auch nichts gefunden. Im Grunde ist das Problem folgendes:

    Am Anfang des Videos flackert die Überblendung einmal ganz kurz. Dies ist mir nur im neuen Video aufgefallen. Was aber schon länger existiert, ist der Fehler am Ende. Der Sound wiederholt sich dort nochmal. Die letzte Sekunde wird einfach nochmal hinten dran geschnitten und ich hab absolut keine Ahnung woran es liegt.. Die Aufnahmedatei ist vollkommen intakt und auch in Sony Vegas kann ich diese ohne Probleme bearbeiten und in der Vorschau ist dieser Fehler nicht aufgetreten. Erst beim fertigen Video tritt dieser Fehler auf. Ich hab hier mal ein Video gegen Bots aufgenommen, um das mal zu verdeutlichen. League of Legends wird nicht auf dem Kanal kommen oder so aber da ein Spiel lange dauert, hab ich halt einfach am meisten Bildmaterial, wenn ich dies aufnehme. Bin halt nen Spielekind was sowas angeht Keine Ahnung. Hier das Video: youtube.com/watch?v=5-Vft4Rj_HU Der erste Fehler tritt bei 0:00 auf und der zweite Fehler bei 0:36

    Meine MeGui Einstellungen sind folgende:

    Quality 18, Const. Quality
    Preset: Slow
    File Format: MP4 (hatte mal mkv genutzt, doch unterstützt Youtube das scheinbar nicht mehr)

    Audio:File-Format: MP3
    CBR: 256

    Dateigrößen spielen bei mir keine große Rolle, daher nehme ich lieber etwas mehr als zu wenig, um die Qualität nicht noch weiter in den Keller zu reißen wie man sieht ist direkt am Anfang ein Flackern im Video. Welches ich akzeptieren kann. Ist jetzt keine große Sache, auch wenns nervig ist. Am Ende jedoch ist dieser doppelte Sound. Welcher mich wahnsinnig macht.. fänds toll wenn jemand das Problem schonmal hatte und mir sagen kann "hey, du musst xy deaktivieren" oder so.. fänd ich Spitze

    Vielen Dank im Vorraus
    Freakooo90

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von freakooo90 ()

  • freakooo90 schrieb:

    hatte mal mkv genutzt, doch unterstützt Youtube das scheinbar nicht mehr)

    Wo hastn den Unsinn her :P

    freakooo90 schrieb:

    Was aber schon länger existiert, ist der Fehler am Ende. Der Sound wiederholt sich dort nochmal. Die letzte Sekunde wird einfach nochmal hinten dran geschnitten und ich hab absolut keine Ahnung woran es liegt..

    An Vegas

    freakooo90 schrieb:

    Am Anfang des Videos flackert die Überblendung einmal ganz kurz.

    An Vegas

    freakooo90 schrieb:

    Audio:File-Format: MP3
    CBR: 256


    Da würd ich eher FLAC nehmen, zumal du sagst das dir dateigröße nicht so wichtig ist. FLAC und auf kompressionslevel 8 (smallest file) FLAC ist verlustfreie (lossless) Kompression.
    Aber auch wenns bei Lossy Kompression bleiben soll, würdes besseres als MP3 geben^^

    PS: Du kannst auch mit Avisynth deine Bearbeitung machen:

    Vorteile: Keine Farbkonvertierungen
    Mehr encodiergeschwindigkeit, da weniger Umweg bis zum Encoder
    Keine Bugs.
    Aktuelle Projekte/Videos


  • Danseba schrieb:

    wenn du bei Youtube auf upload gehst und dann mit dem Dateibrowser suchst werden mkvs nicht angezeigt


    Bei mir werden sogar FLACs und avisynth etc angezeigt, steht ja eh auf "alle Dateien" und umstellbar ist da auch nix.

    abload.de/img/unbenannt1738qkiw.png

    Hab da jetzt nichts gemuxt, von daher ist da jetzt keine mkv bei. Aber halt die .264 ungemuxten ;D und meine Scripte etc. Alle Dateien zeigt ja auch entsprechend alles an.
    Aktuelle Projekte/Videos


  • Anzeige
    ​Wo hastn den Unsinn her


    Jedesmal wenn ich versuche Mkv hochzuladen, zeigt mir Youtube an, das es nicht verarbeitet werden kann.. werds jetzt aber nochmal zur Sicherheit versuchen

    Gibt es denn einen Fix, der das Problem löst unter Vegas? Weil soweit ich mich erinnern kann, war das nicht immer so. Ich arbeite schon lange mit Vegas und hab das Problem aber erst seit 3-4 Monaten. Vielleicht hab ich ja was verstellt, ohne es zu merken oder ich habs gemerkt, nur wusste ich nicht, das es diese Fehler verursacht :D

    ​Da würd ich eher FLAC nehmen, zumal du sagst das dir dateigröße nicht so wichtig ist. FLAC und auf kompressionslevel 8 (smallest file) FLAC ist verlustfreie (lossless) Kompression.Aber auch wenns bei Lossy Kompression bleiben soll, würdes besseres als MP3 geben^^


    Das mit dem Audiocodec stimmt. Ich weiß ehrlich gesagt nichtmehr, warum ich damals zu mp3 gewechselt bin.. irgendwas war da aber bin mir nicht mehr sicher.. werde das gleiche Video einfach nochmal in mkv und flac hochladen.. Ergebnisse folgen. Vielleicht löst es ja schon das Problem.
  • Des Weiteren, warum hat das Video nur 720p wenn die Dateigröße nicht so wichtig ist? Gerade bei Youtube ist die Auflösung das wichtigste. Und 720p ist ja lokal schon nicht optimal. Oder hastes nur beim Testvideo so?

    Exportier Audio in Vegas als WAV und mache diese in MeGUI. Anders wirste den Bug nicht los.

    Und der andere Bug liegt auch an Vegas.

    Encodier ein video ohne Vegas und du wirst merken das es an vegas liegt, bzw beim Audio liegts am Frameserver und vegas.

    Man kann aber wie gesagt auch Videos ohne Vegas bearbeiten^^ Und wenn man gar nix bearbeiten tut wäre vegas erstrecht ja überflüssig

    Jedesmal wenn ich versuche Mkv hochzuladen, zeigt mir Youtube an, das es nicht verarbeitet werden kann..


    Hatts bei mir jetzt nicht, aber man muss auch nicht immer alles glauben :P
    Aktuelle Projekte/Videos


  • Okay.. ich render grade in Flac und es scheint der Audio Fehler ist damit weg.. Ich hab keine Ahnung wo der nun hin ist.. hab nix geändert außer den Codec.. Interessant..
    EDIT 1:Außerdem ist jetzt der Fehler am Anfang mit dem Flackern weg.. das macht jetzt aber mal so garkein Sinn.. WTF?!
    EDIT 2: Okay.. jetzt fühle ich mich Dumm.. jetzt hat er ohne Probleme MKV hochgeladen und verarbeitet. Ich schwöre, jedesmal wenn ich es versucht hab, kam entweder nen Fehler, Audio hat gefehlt oder sonst was..

    Des Weiteren, warum hat das Video nur 720p wenn die Dateigröße nicht so wichtig ist? Gerade bei Youtube ist die Auflösung das wichtigste. Und 720p ist ja lokal schon nicht optimal. Oder hastes nur beim Testvideo so?

    Meine Einstellungen sind üblicherweise auf 1280 x 720 gestellt und hochskalieren.. weiß nicht.. denke halt, da es eh nur in 1280 x 720 aufgenommen wurde, bringt es nicht sooo extrem viel wenn ich es hochskaliere.. aber ist gefährliches Halbwissen... habs nie versucht und war eigentlich immer der Meinung das 720p ausreichend ist.. und hochskalieren fühlt sich auch immer etwas Cheaty an.. von wegen "Full-HD bla bla" dabei ist es nur hochskaliert weiß ja nich... (so oft hab ich noch nie "hochskaliert" geschrieben)
  • Du kriegst auf den höheren Qualitätsstufen wesentlich mehr Bitrate. Guck doch mal dein 720p ding an. Youtube macht daraus nur blockpampe.

    720p ist auch lokal ein Defizit, da würd ich direkt schon in höherer Auflösung spielen. Optimale Auflösung für Youtube wäre 3200x1800. Klingt komisch. Ist aber so xD

    Okay.. ich render grade in Flac und es scheint der Audio Fehler ist damit weg.. Ich hab keine Ahnung wo der nun hin ist.. hab nix geändert außer den Codec.. Interessant..
    EDIT 1:Außerdem ist jetzt der Fehler am Anfang mit dem Flackern weg.. das macht jetzt aber mal so garkein Sinn.. WTF?!


    NLE = verbugt. Egal ob vegas, premiere oder sonstwer.
    Der Frameserver hat mit Vegas ebenfalls seine problemchen.

    Lösung: Keine NLE verwenden - videos mit Avisynth bearbeiten. Eben mit dem Script was du für MeGUI machst. Auch die Auflösungsskalierung sollte auf keinen Fall mit Vegas geschehen, da der kein Spline als Skalierer nutzen kann, geschweige denn Lanczos, geschweige denn das man überhaupt die Wahl hat welche Skaliermethode genutzt werden soll - und falls doch, wird wahrscheinlich eh nur maximal bikubisch gehen.. Am besten via Spline100 skalieren. Findest du in SSM ( letsplayforum.de/index.php?page=Thread&threadID=110277 )

    EDIT 2: Okay.. jetzt fühle ich mich Dumm.. jetzt hat er ohne Probleme MKV hochgeladen und verarbeitet. Ich schwöre, jedesmal wenn ich es versucht hab, kam entweder nen Fehler, Audio hat gefehlt oder sonst was..

    Vllt wurde ja die ungemuxte Datei hochgeladen?
    Aktuelle Projekte/Videos


  • Also rätst du mir, trotz das die Aufnahmen nur in 1280 x 720 verfügbar sind, soll ich diese dennoch auf 1080p hochskalieren? Okay.. werde ich mal gucken wie da der Qualitätssprung ist. Über Avisnyth muss ich mich mal schlau machen. Ich bin ja ein Fan vom simplen Schneiden.. Bei Vegas muss ich einfach nur die Stelle raussuchen, S drücken und fertig.. Überblendungen etc sind auch unglaublich einfach.. aber wenn das solche Probleme verursacht, muss ich mir wohl oder übel eine Alternative suchen.. Ich danke schonmal für den Ratschlag :) sind gute Tipps die ich gut gebrauchen kann.
  • ja mindestens. Nur eben nicht via vegas skalieren^^

    Oder du machst 2560x1440, wäre x2 skalierung, sowas ist immer vorteilhaft^^

    Aber du kannst doch auch in besserer Auflösung in zukunft aufnehmen xD Dann hatts der Skalierer auch einfacher^^

    2080x1170 würde für deren 1440er Stufe reichen, wär auch schon deutlich besser als 1920x1080 und nicht so viel drüber.

    Der CRF muss nicht zwangsläufig auf 18 bleiben, kann bei Bedarf also erhöht werden, wenn dir datei doch zu groß werden sollte. Das wichtigste ist eben die Auflösung bei youtube, weil sonst eben einfach die besser codieren Stufen entsprechend fehlen. Und 720p ist halt nur mit 2000 kbit und youtube encodiert mit sau schlechten settings. SSM hat auch presets, die würd ich nutzen, damit auch MT (Multithreading) genutzt wird. Und bei x264 config in MeGUI sollte 10bit Encoding angehakt sein.

    Beim Frameserver solltest du RGB24 wählen, da Vegas jedes eingelesene Video erstmal schön in RGB32 konvertiert^^ Sprich vegas ist auch unnötige Farbkonvertiererei.
    Aktuelle Projekte/Videos


  • ​Aber du kannst doch auch in besserer Auflösung in zukunft aufnehmen xD Dann hatts der Skalierer auch einfacher^^

    Ja.. In 1920 x 1080 aufnehmen.. The Dream.. leider packt das mein PC so garnicht xD ist halt schon ziemlich alt und joa.. Ich würde jetzt auch nicht sagen das ich nun voll durchstarte.. ich kenne halt meine technischen Vorraussetzungen und weiß, das dies nicht so einfach geht :D z.b. SWAT 4 musste ich bei 800x600 aufnehmen.. einfach GG..
    ​Beim Frameserver solltest du RGB24 wählen, da Vegas jedes eingelesene Video erstmal schön in RGB32 konvertiert^^ Sprich vegas ist auch unnötige Farbkonvertiererei.

    Oh okay.. ich dachte immer, da ich mit Dxtory und dort mit YUY2 aufnehme, wäre es besser für die Farben wenn ich dies auch auf dem Frameserver so angebe.. aber wenn Sony Vegas das in RGB umwandelt, ist das ja völliger Quatsch... Gut zu wissen!
  • Mit welchem Codec in DxTory nimmst du auf und mit welchen Einstellungen beim Codec ?Des weiteren wäre die Festplattengeschwindigkeit interessant bzw auch die CPU (für den Codec).


    Codec nehme ich Lagarith Lossless Codec mit eben YUY2, Nuil Frames aktiviert und ja..

    Festplattengeschwindigkeit ist 50 MB/sec

    Prozessor ist AMD Athlon(tm) II X2 220 Processor.. Gurke ich weiß :D als ich mir den pc geholt habe, brauchte ich ihn lediglich für die Ausbildung.. da reichte das :D
  • Lagarith und das auch noch auf ne schwache CPU.
    Dazu noch Nullframes die für ordentliche fps schwankungen sorgen - für aufnahme also absolut unglücklich gewählte option.
    YUY2 - einem 4:2:2 Farbraum, statt YV12 (4:2:0) bei einer HDD die nur 50 mbyte schafft xD.

    Neeee das kann ja nix werden.

    50 mbyte/s ist jetzt nich gerad der burner, aber könnte auch mit magicYUV noch reichen:

    MagicYUV - Ein neuer Lossless Codec!
    mit settings vom Bild

    Alternativ nochmal mit Lagarith probieren (falls die HDD zu schwach ist), aber diesma dann bitte in YV12, multithreading angehakt, und kein haken bei Nullframes xD

    Außerdem würdes doch noch 1600x900 geben. Wäre doch auch schon näher dran an höherer auflösung ^^
    Aktuelle Projekte/Videos


  • Okay.. habe MagicYUV mal ausprobiert.. leider starke fps einbrüche.. denke die Festplatte ist da nicht ausreichend für.. habe es jetzt so eingestellt, YV12 DXtory ohne Nullframes mit Multithreading (war vorher schon aktiv), Frameserver auf RGB24 solange ich mit Vegas bearbeite, MeGui 10 Bit Encoding aktiviert, Flac und MKV nutzen, Audio in Vegas via WAV extra exportieren
    Außerdem würdes doch noch 1600x900 geben. Wäre doch auch schon näher dran an höherer auflösung

    1280 x 720 ist das maximum was ich nehmen kann und selbst das nur in wenigen Spielen (The Binding of Isaac z.b.) Ich will nicht sagen, das mein PC Müll ist, aber.. kommt schon nah ran
  • Doch Lagarith YV12 ohne Nullframes geht.. also quasi wie vorher... ja.. bei dem PC denke ich, hab ich viele Hauptprobleme :D Jedenfalls bedanke ich mich jetzt mal bei euch für die hilfreichen Tipps und Hinweise.. z.b. dafür, das Vegas verbugt ist :/ meh :D aber hat mir echt weitergeholfen! Vieles wusste ich garnicht. Vielen lieben Dank :)