Blau-Grüner Streifen beim rendern mit Magix!?!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Blau-Grüner Streifen beim rendern mit Magix!?!

    Anzeige
    Hey Leute, ich hab das Problem, dass ich beim rendern mit Magix einen blauen bzw. manchmal auch grünen Streifen über die obere Kante verteilt habe. Dies kann man z.B. gut in diesem Video erkennen: youtube.com/watch?v=ot-ahyFpN4A&feature=youtu.be

    Mit Magix rendere ich in folgenden Einstellungen: puu.sh/en6cN/7306b65f7b.png

    Ich hoffe ihr wisst was ich meine, bin mir nicht sicher ob das verständlich war. Ansonsten hoffe ich ihr könnt mir helfen,

    LG Deki
  • wow bei den einstellungen drehts einem aber ja auch den magen um xD

    Warum keine b-frames? Biste denn des wahnsinns? XD
    Max GOP nur 30? auch viel zu kurz. Auf 10-fache der fpsrate setzen. Also bei zb 30fps auf 300 damit.
    Warum kein 2pass?

    Zu dem Rand: Kann nur an Magix oder einem Filter liegen. Vllt ist das Bild ja auch nicht ganz eingepasst worden (zb zu tief gesetzt oder zu klein?
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Von den Einstellungen mal abgesehen, finde ich den Streifen in dem erwähnten Video irgendwie weniger problematisch. Ich musste das Video 3 mal anschauen und deinen Post nochmal durchlesen, bis er mir dabei wirklich aufgefallen ist.

    PS: Einfache und effektive Lösung des ganzen: x264vfw für Videoschnittprogramme (Erklärt an Magix)
    Ich will der aller beste sein,
    Wie keiner vor mir war!
    Ganz allein let's play ich hier
    Mach meinen Traum jetzt wahr!

    Ich spiele schon mein Leben lang,
    doch jetzt ist es soweit.
    Ich weiß ich werd abonniert.
    Ich bin bereit!

  • De-M-oN schrieb:

    wow bei den einstellungen drehts einem aber ja auch den magen um xD

    Warum keine b-frames? Biste denn des wahnsinns? XD
    Max GOP nur 30? auch viel zu kurz. Auf 10-fache der fpsrate setzen. Also bei zb 30fps auf 300 damit.
    Warum kein 2pass?

    Die Einstellungen habe ich damals von dir ALLE bekommen.

    Was bringen die neuen Einstellungen die du genannt hast? Wird dann die Videodatei noch groöer als sie ohnehin schon ist? Und auf was soll ich dieses B-Frame stellen? Und wo aktiviere ich 2pass?

    De-M-oN schrieb:

    Zu dem Rand: Kann nur an Magix oder einem Filter liegen. Vllt ist das Bild ja auch nicht ganz eingepasst worden (zb zu tief gesetzt oder zu klein?

    Das Bild ist genau 1920x1080 gesetzt und auch nicht zu tief o.Ä. Ich hab das Problem auch bei Videos wo das Spiel den gesamten Bildschirm ausfüllt und nicht ein Bild drüber liegt wie in dem Beispiel.
  • Anzeige

    Dekinosu schrieb:

    Die Einstellungen habe ich damals von dir ALLE bekommen.


    Kann nicht sein. Ich habe noch NIE empfohlen keine b-frames zu verwenden. Entweder du hast es umgestellt oder magix ist nicht in der lage einstellungen zu behalten.

    Was bringen die neuen Einstellungen die du genannt hast? Wird dann die Videodatei noch groöer als sie ohnehin schon ist? Und auf was soll ich dieses B-Frame stellen?


    Im Falle quantizer bestimmst du ja selber die kompressionsstärke. Es bleibt aber mehr Qualität über und die Datei wird evtl sogar kleiner, trotz statische quantizerwerte, wenn du effizienter encodierst. mit b-frames wirste sogar unter garantie dateigröße sparen.

    b-frames mindestens auf 3.

    Und wo aktiviere ich 2pass?


    Siehste doch auf deinen gemachten bildern.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • De-M-oN schrieb:

    Entweder du hast es umgestellt oder magix ist nicht in der lage einstellungen zu behalten.

    Wohl eher das Zweite, ich hab mit Sicherheit alles 1zu1 übernommen.

    De-M-oN schrieb:

    Im Falle quantizer bestimmst du ja selber die kompressionsstärke. Es bleibt aber mehr Qualität über und die Datei wird evtl sogar kleiner, trotz statische quantizerwerte, wenn du effizienter encodierst. mit b-frames wirste sogar unter garantie dateigröße sparen.

    Also das mit dem 21-24-26 drin lassen?

    De-M-oN schrieb:

    Siehste doch auf deinen gemachten bildern.

    Achja, da stehts ja


    Hab jetzt alles so eingestellt wie du gesagt hast. Der Streifen ist aber immernoch da.
  • Dekinosu schrieb:

    Wohl eher das Zweite, ich hab mit Sicherheit alles 1zu1 übernommen.


    Wird es denn wenigstens behalten solang das programm läuft, oder isses direkt beim erneuten öffnen der config schon wieder raus? Wenn letzteres würd ich dringend andere Software zu rate ziehen. keine b-frames und eine derart kurze gop ist schon ein mächtiger effizienzschuss zum mond.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Ich bin gerade nochmal am rendern vom gleichen Video weil ich schauen wollte, ob die Datei jetzt größer oder kleiner wird oder gleich bleibt. Ich werd gleich mal nachsehen ob das Ganze diesmal drin bleibt oder nicht, ich editiere das dann gleich hier rein :D Schonmal danke für die besseren Einstellungen!

    Edit: Jo okay, die Datei ist wirklich kleiner und sieht auch besser aus, falls ich mich nich irre. Ansonsten sind die Einstellungen diesmal drin geblieben. Undzwar alle! Danke dafür.

    Leider ist mein Problem immernoch nicht gelöst..

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dekinosu ()

  • Eine Mediainfo von der orginalen Datei und der fertigen Datei wäre hilfreich.

    Übrigens würde ich auf den Target Quality Mode umsteigen, 5 Ref-Frames einstellen und Slice auf 0 stellen. Zumindest wenn du bei MainConcept bleiben willst.

    B-Frames werden übrigens nach jedem Öffnen von Magix wieder auf 0 gesetzt xDD

    Wenn du noch bessere Komprimierung haben willst würde ich auf x264vfw umsteigen: x264vfw für Videoschnittprogramme (Erklärt an Magix)
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • GrandFiredust schrieb:

    Eine Mediainfo von der orginalen Datei und der fertigen Datei wäre hilfreich.

    Hier bitteschön:
    Ausgangsdatei (Rohdatei): puu.sh/enuzh/4580a04296.png
    Fertig gerenderte Datei: puu.sh/enuFZ/afc5c8e877.png

    GrandFiredust schrieb:

    Übrigens würde ich auf den Target Quality Mode umsteigen, 5 Ref-Frames einstellen und Slice auf 0 stellen. Zumindest wenn du bei MainConcept bleiben willst.

    Alles so eingestellt wie du es gesagt hast. Wollte noch fragen wass dieser Single Target Mode ist und was es bringt bzw. was daran besser ist als der Andere. Dadurch wird die Datei nämlich wieder größer und ich denk ich nehm dann doch das, was ich momentan drin hatte. (Hab das grade mal getestet)

    GrandFiredust schrieb:

    B-Frames werden übrigens nach jedem Öffnen von Magix wieder auf 0 gesetzt xDD

    Nein, bei mir stand es gerade immernoch auf 3 wie ich es zuvor eingestellt hatte. Auch nach neuem öffnen des Programms.


    Wie gesagt ist mein Problem damit immer noch nicht gelöst.
  • Dekinosu schrieb:

    GrandFiredust schrieb:




    B-Frames werden übrigens nach jedem Öffnen von Magix wieder auf 0 gesetzt xDD

    Nein, bei mir stand es gerade immernoch auf 3 wie ich es zuvor eingestellt hatte. Auch nach neuem öffnen des Programms.


    Wie gesagt ist mein Problem damit immer noch nicht gelöst.


    B-Frames Einstellung wird nur zurück gesetzt, wenn Perfomance nicht auf 9 (Balanced) steht.
  • Dekinosu schrieb:

    Wollte noch fragen wass dieser Single Target Mode ist und was es bringt bzw. was daran besser ist als der Andere.


    Der Target Quality Mode gibt dem Encoder mehr Freiraum die Quantizer-Faktoren zu setzen. Mit den konstanten Quantizern gibst du dem Encoder vor: i-Frame qp=21 , p-frame qp=24 , b-frame qp=26

    Da du aber nicht weiß ob z.B. ein bestimmter i-Frame einen Faktor von 21 braucht, oder ob nicht z.B. 20 reichen würde, um die gleiche Qualität zu erzielen, kann beim Target Quality Mode der Encoder den Faktor selbst wählen und orientiert sich nur an dem durchschnittlichen Quantzier.

    Dekinosu schrieb:

    Dadurch wird die Datei nämlich wieder größer und ich denk ich nehm dann doch das, was ich momentan drin hatte.


    Das bedeutet, deine Frames brauchen einen kleineren Quantizer, als du angegeben hast, um eine bestimmte Qualität zu erzielen. Wenn dir das zu viel ist, kannst du jedoch beim Constant Quantizer bleiben. Ref-Frames sollten jedoch auf jeden Fall auf 5 bleiben. Die verringern die Dateigröße immer, da viel besser B-Frames angelegt werden können. Slice brauch man nur für Blue-Rays, deshalb sollten die auch draußen bleiben.

    Wenn ich gerade die Mediainfo sehe... Audiobitrate kann ruhig auf 256. Damit nutzt du auch das aus, was Youtube kann.

    Ansonsten sehe ich gerade nichts, was diese Streifen verursachen kann, vllt kann da noch ein anderer helfen :/
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Was haste denn da für ein Hintergrundbild/Muster verwendet?

    Richtiges Bild? Dann wäre ne Mediainfo des Bildes gut zu erfahren.

    Oder ein Magix Muster für Hintergründe?

    Eventuell das du auf den Hintergrund noch irgendwas aktiviert hast?

    z.B. kenn ich von Schrottasia das es bei Bildern wenn man den Schatten z.B. auf 0 stellt, trotzdem ein kleiner schwarzer Strich am Rand des Bildes befindet. Und das bekommt man halt dann nicht richtig weg. Fällt aber nur auf wenn Hintergrundfarbe und Deckfarbe identisch sind.

    Vllt gibt es bei Magix irgendwas ähnliches. Ich weiß ja nicht wie du das Bild/Hintergrund jetzt eingefügt hast oder welche Einstellungen dafür vorgenommen hast. Noch weiß ich nicht mal was über das Bild allgemein. (Mediainfo)

    Also ist es ein regelrechtes Ratespiel und die Hoffnung das mal ein User auftaucht dem das auch schon passiert ist und eine Lösung dafür gefunden hat. ^^
  • Das habe ich aber weiter oben schon erklärt, das hat nichts mit dem Bild zutun, da ich diesen Streifen auch in meinem fertigen Video habe wenn ich ein Spiel rendere das den gesamten Bildschirm ausfüllt und ich demensprechend keinen Rahmen drüber legen muss. Am Rahmen liegt's einfach schlicht und ergreifend nicht, da ich diesen Streifen in jedem meiner Videos zu sehen habe, egal welches Spiel, egal welcher Hintergrund.

    Siehe oben:

    Dekinosu schrieb:

    Ich hab das Problem auch bei Videos wo das Spiel den gesamten Bildschirm ausfüllt und nicht ein Bild drüber liegt wie in dem Beispiel.



  • Ich würde mal einige Encodes ausprobieren mit Magix. XVID mit 2pass, H264 mit 2pass, vllt mal MPEG2 und x264vfw.

    Wenn du bei allen Encodes immer den Streifen drin hast, ist das eine Berechnungs Frage des Bildes unter Magix. Dann würde ich mal die Einstellungen in Magix überprüfen in Sinne von Projekteinstellungen und Co.
  • Hab mal die Einstellungen zurück gesetzt und neu eingestellt. Immernoch da. Den Rest teste ich mal wenn ich später mehr Zeit hab.

    *Edit: Okay es liegt eindeutig an den Einstellungen vom MP4, hab das ganze grade mit AVI gerendert und da tauchte kein Streifen auf.

    Hier nochmal ALLE Einstellungen die ich momentan drin habe, vielleicht sieht ja doch jemand den Fehler:

    puu.sh/esWYJ/e0aba57fcd.png

    puu.sh/esWZ1/5a78a4c96c.png
    puu.sh/esWWx/140754d0c9.png
    puu.sh/esWX1/4caae3b218.png

    puu.sh/esWZ1/5a78a4c96c.png

    Eingeteilt in Video und Audio. Bei Video nochmal unterteilt in Main und Advanced.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Dekinosu ()