Video nach rendern stockend und asynchron? (Magix)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Video nach rendern stockend und asynchron? (Magix)

    Anzeige
    Hallo,

    ich habe auch nach großer hilfe von SagaraS (Danke nochmal) immer noch ein Problem mit meinen Videos.

    Ich nehme meine Videos mit meiner Elgato Capture Card auf. In MP4 und 29,97 FPS ,HD ,16:9. Dann muss ich sie in Avi umwandeln da Magix diese auch nach registrierung nicht nimmt.
    Ich wandel sie also in avi um Die FPS, Auflösung bleiben hab da extra drauf geachtet.

    Nun importiere ich das in Magix Video Deluxe SE und pack meinen Kommentar dazu. Synchroniesiere das. Den guck ich das Video stichweise durch ob die synchronisation überall passt. Dann rendern. In die auflösungen die das Video hat.

    Jetzt gucke ich mir das Fertige Video an und es stockt immer wieder und wird nach ein paar minuten Asynchron warum?

    Kann mir da jemand helfen, langsam verzweifle ich. was hab ich den jetzt beim rendern falsch gemacht?
  • Ganz spontan vermute ich mal unterschiedliche Sampleraten beim Material. Entweder haben Elgato-Aufnahme und Tondatei einen Unterschied oder aber das Projekt in Magix hat eine andere Samplerate (sofern das bei der Version einzustellen geht). Mediainfo installieren, die betreffenden Dateien auslesen, Screenshots von den Magix-Projekteinstellungen machen, dann lässt sich darauf sicherlich schon was erkennen.
  • TalonNEU schrieb:

    Dann muss ich sie in Avi umwandeln



    Nicht gut!! Niemals AVC Streams in den AVI-Container packen, dafür ist der nicht ausgelegt und kann schnell zu Fehlern führen! Mit welchem Programm wandels du die überhaupt um?

    TalonNEU schrieb:

    da Magix diese auch nach registrierung nicht nimmt.



    Da würde ich mal dem Support bescheid sagen. ^^
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Ich nutze format factory. ich wollte es versuchen in MPeg umzuwandeln. Da muss ich halt die einstellungen neu machn. FPS, Bitrate, Seitenverhältnis. halt das ich das format ändere und dadurch nichts asynchron wird. leider failed to convert.

    Ja ich muss es ja umwandel. aber nen anderer LPer meinte, das mein PC das render programm einfach nicht packt.
  • Anzeige
    Die Umwandlung nach AVI ist schon mal der falsche Ansatz. Nicht nur, weil du damit enorm Qualität einbüßt und unnötig Zeit verschwendest, sondern auch, weil du offensichtlich nicht genau weißt, was du tust und dir somit selbst Steine in den Weg legst. An deiner Stelle würde ich lieber rausfinden, warum dein Magix keine MP4-Container einlesen möchte.
  • Mit derselben Methode arbeite ich auch und ich lasse die Aufnahmen von der Elgato Software direkt in mp4 ausgeben. Wenn die Audiospur sich weiter streckt, je länger das Video dauert, dann könnte die verwendete FPS-Rate in der Renderoption ein Grund dafür sein. Achte darauf, dass du auch mit 29,97 FPS renderst, da du ansonsten 0,3 Bilder je Sekunde durch Magix erstellst und so der Ton immer weiter auseinander läuft. Wenn du das Produkt registriert hast, musste den MP4 Codec separat aktivieren, der dich dann aber nichts mehr kostet.

    Ach, und mein PC ist 4 Jahre alt, der hat mit 720p keinerlei Probleme. Ab 1080p kommt der nicht mehr hinterher.
    Wer lust hat: Schommii@YouTube
  • Ich meine mich zu erinnern, dass der Transport-Stream von diesen Aufnahmeboxen noch eine konstante Framerate hat, während die MP4 nach der Umwandlung eine variable Framerate aufweist. Vielleicht sollte man diese Umwandlung also eher vermeiden? Und wenn man danach noch mal in AVI umwandelt, womöglich noch mit einer komplett falschen Framerate, wird es natürlich nur noch schlimmer.
  • TalonNEU schrieb:

    Kann man nicht vllt auch das so machen das Das Elgato Programm die Videos in avi oder so exportiert und nicht in MP4.
    Meines Wissens gibt es nur die Möglichkeiten zwischen M2TS- und MP4-Containern. Kann auch sein dass ich mich irre, weil ich damit nicht arbeite, aber soweit ich mich erinnern kann, waren die M2TS-Dateien sehr viel fehlerfreier als die umgewandelte MP4-Grütze.
  • M2TS wäre ein BluRay Stream dann, was die Entwickler der Software auch nutzen werden um mehr Infos da rein zu ballern ^^
    Aber ich sag es mal so... Ob nun MP4 oder M2TS, beide haben ein AVC Stream und gegebenfalls ein AAC Stream. Der Standard erst mal für diese Container würd ich sagen.
    M2TS kann aber noch wesentlich mehr, weil es ein Transport Stream Container ist was weit mehr verkapseln kann als andere Container. Und es ist ein wesentlicher Standard für alle Heimvideosachen. Man kann es sofort auf BluRay brennen z.B.
    MP4 ebenfalls. Sachen wie IPod und Co. Also so ziemlich jedes Ottonormales Gerät auf dem Markt kann doch heute schon MP4 ^^
    Daran halten sich die Elgato Entwickler auch.

    (Von wegen Lossless oder sowas xD)
    Für Lossless Aufnahmen braucht man schon andere Gerätschaften als eine Capture Box wie die Elgato. Mit interne TV Karten kann man sowas z.B. machen.

    Aber zurück zum Thema.
    Es wurde ja jetzt so ziemlich die einfachste Lösung der Welt genannt. Bei Magix den MP4 Import aktivieren/registrieren. (Als ob das so ein verbotenes Format wäre xD)
    Oder ganz Easy, aber mit mehr Speicheraufwand:
    Lagarith, UTVideo oder MagicYUV installieren (wenn noch nicht vorhanden) + RADTools runterladen.

    Die MP4 kann dann via RADTools ganz easy mit ein Lossless Codec in ein AVI Container gebracht werden. Verlust wäre dann nahezu 0. Allerdings sollte Platz auf der Festplatte sein. Viel Platz. Das Ding nennt sich schließlich nicht umsonst Lossless Codec. Das wird von deinen üblichen MP4/M2TS Aufnahmegrößen dann schon gewaltig abweichen.

    Aber du kannst es dann in Magix laden.

    Ich würde aber eher den ersten Weg wählen. Ich würd Magix aktivieren damit es MP4 laden kann. Sonst ist das ja für dich ja irgendwie Witzlos wegen höheren Zeitaufwand beim 2ten Weg.