Sound Asynchron nach Aufnahme (Elgato)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Sound Asynchron nach Aufnahme (Elgato)

    Anzeige
    Moin da mir das langsam auf den Keks geht hoffe ich das hier jemand vllt noch eine Idee hat.

    Folgendes Problem der Live Commentary von der Elegato ist sehr oft Asynchron ich habe jetzt schon mehrere Einstellungen probiert in Punkto Mikro sowohl mit 44100hz als auch mit 48000hz (beides auf 1 Kanal) hier ma die Media Info der letzten Datei wo es wirklich extrem war

    Media Info
    ​Allgemein
    Vollständiger Name : Skyrim - #190 - Drachenfall - 2015-01-15 11-34-06.mp4
    Format : MPEG-4
    Codec-ID : M4V
    Dateigröße : 1,22 GiB
    Dauer : 39min
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 4 368 Kbps
    Filmname : #190 - Drachenfall
    Aufnahmedatum : 2015-01-15
    Kodierungs-Datum : UTC 2015-01-15 22:19:57
    Tagging-Datum : UTC 2015-01-15 22:19:57

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L3.1
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 2 frames
    Format_Settings_GOP : M=3, N=9
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 39min
    Bitraten-Modus : variabel
    Bitrate : 4 141 Kbps
    maximale Bitrate : 8 000 Kbps
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 29,970 FPS
    minimale Bildwiederholungsrate : 2,503 FPS
    maximale Bildwiederholungsrate : 29,970 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.150
    Stream-Größe : 1,15 GiB (95%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-01-15 22:19:57
    Tagging-Datum : UTC 2015-01-15 22:19:57
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 39min
    Source_Duration/String : 39min
    Bitraten-Modus : konstant
    Bitrate : 216 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Stream-Größe : 63,2 MiB (5%)
    Source_StreamSize/String : 63,2 MiB (5%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-01-15 22:19:57
    Tagging-Datum : UTC 2015-01-15 22:19:57
    mdhd_Duration : 2395298


    Hoffe das es vllt ein paar mitleidende gibt die eine Lösung für das Problem gefunden haben ohne die Software wechseln zu müssen oder Commentary und Video aufnahme einzeln zu tätigen (sprich das ganze nochmals rendern zu müssen)
  • Julien schrieb:

    Naradem schrieb:

    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 29,970 FPS
    minimale Bildwiederholungsrate : 2,503 FPS
    maximale Bildwiederholungsrate : 29,970 FPS

    Das hier kann auch noch zu Problemen führen. Variable Framerate ist oft eine Ursache für Asynchronität, nach Möglichkeit sollte man die für Let's Plays also meiden.

    kann ich leider nicht vermeiden liegt an der Software der Elegato selber wie gesagt die Aufnahmen sind bis auf ein paar Schnitten die ich über die Software selber mache nicht bearbeitet
  • Anzeige
    dann wäre das ja echt bescheiden wenn ich keinerlei schnitte machen dürfte in der Aufnahme mit der Software die extra mit ausgegeben wird O,o

    Denn wie gesagt bis auf ein paar Ladezeiten "rausschneiden" über den Editor der Software und dann das auswerfen als Mp4 mach ich an der aufnahme nichts aber dann muss ich wohl versuchen alles aus dem Softwareordner selber hochzuladen ohne es auswerfen zu lassen
  • Julien schrieb:

    Naradem schrieb:

    dann das auswerfen als Mp4

    Exakt das ist der Fehler. Diese Kodierung in MP4 klaut dir nämlich nicht nur Qualität, sondern wandelt auch alles in variable Frameraten um und sorgt somit für Asynchronitätsfehler.

    Naja wenn ich der Media Info glauben darf is die "Ur-Datei" aber auch mit variablen Frames ausgestattet

    Ur - Datei
    Video
    ID : 100 (0x64)
    Menü-ID : 2 (0x2)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L3.1
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 2 frames
    Format_Settings_GOP : M=3, N=9
    Codec-ID : 27
    Dauer : 42min
    Bitraten-Modus : variabel
    Bitrate : 4 027 Kbps
    maximale Bitrate : 8 000 Kbps
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 29,970 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.146
    Stream-Größe : 1,18 GiB (90%)
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 101 (0x65)
    Menü-ID : 2 (0x2)
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Version : Version 4
    Format-Profil : LC
    Muxing-Modus : ADTS
    Codec-ID : 15
    Dauer : 42min
    Bitraten-Modus : variabel
    Bitrate : 220 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Video Verzögerung : -345ms
    Stream-Größe : 66,1 MiB (5%)
    Sprache : Deutsch


    Versteh mich nicht falsch aber kann es dann wirklich daran liegen oder liegt es evtl nur an den Schnitten die ich in der Software mache? dann frage ich mich aber warum das bei Aufnahmen bei denen ich überhaupt nicht schneide auch zu solchen Problemen kommt
  • also schneide auch mit der Elgato und habe noch nie deswegen Asynchronitätsfehler gehabt...
    Grüß Euch Leute!!! :D

    Machen auf unserem YT-Kanal "PentaSquasAustria" alles mögliche an Spielen was uns gerade so einfällt! ;)
    Wir sind alles Österreicher und sind zu fünft also Phil, Hilli, JP, Schobi und Höfi! :D

    Würden uns freuen wenn ihr mal vorbei schaut und euch vielleicht mal das ein oder andere abo oder like ausrutscht! :P
    Aber am meisten freuen wir uns über feedback von euch! :)

    Kanal: youtube.com/channel/UCWbNCk1w1O-U6SPW0GjcGvA
  • hmm okay also liegt das Problem am auswerfen allerdings dachte ich nicht das die Elegato da so viel dran rumkodiert wenn man das Ding doch als sogenanntes "Mp4 Original" ausgibt
    Dann werde ich mir wohl das schneiden sparen und einfach die Datei so aus dem Ordner ziehen und sie dann so hochladen vom Mb Unterschied is da nicht die Rede
  • Wie gesagt ich hatte das Problem noch nie und das kann auch ehrlich gesagt nicht sein außer du nimmst den Sound nicht zusammen mit dem Gameplay auf!
    Falls es der Fall wäre müsstest du extern cuten
    Grüß Euch Leute!!! :D

    Machen auf unserem YT-Kanal "PentaSquasAustria" alles mögliche an Spielen was uns gerade so einfällt! ;)
    Wir sind alles Österreicher und sind zu fünft also Phil, Hilli, JP, Schobi und Höfi! :D

    Würden uns freuen wenn ihr mal vorbei schaut und euch vielleicht mal das ein oder andere abo oder like ausrutscht! :P
    Aber am meisten freuen wir uns über feedback von euch! :)

    Kanal: youtube.com/channel/UCWbNCk1w1O-U6SPW0GjcGvA
  • PentaSquadAustria schrieb:

    Wie gesagt ich hatte das Problem noch nie und das kann auch ehrlich gesagt nicht sein außer du nimmst den Sound nicht zusammen mit dem Gameplay auf!
    Falls es der Fall wäre müsstest du extern cuten

    Nope nehme das Commentary ganz normal mit dem IGS über die Software auf weiß also nicht woran das dabei liegen kann

    @Sagaras
    Das Problem ist das Sony Vegas die Urdatei leider nicht lesen kann/will weswegen ich die nicht zur verarbeitung nutzen + ich will eigentlich wenig daran rumfuchteln
  • Kannst dir gerne auf meinem Kanal die PRTG videos ansehen, sind alle mit Elgato geschnitten worden und ich erkenne keine Asynchronität. Wäre sonst dumm wenn es Elgato anbietet weil es negativ werbung für die elgato wäre^^
    Grüß Euch Leute!!! :D

    Machen auf unserem YT-Kanal "PentaSquasAustria" alles mögliche an Spielen was uns gerade so einfällt! ;)
    Wir sind alles Österreicher und sind zu fünft also Phil, Hilli, JP, Schobi und Höfi! :D

    Würden uns freuen wenn ihr mal vorbei schaut und euch vielleicht mal das ein oder andere abo oder like ausrutscht! :P
    Aber am meisten freuen wir uns über feedback von euch! :)

    Kanal: youtube.com/channel/UCWbNCk1w1O-U6SPW0GjcGvA
  • Naradem schrieb:

    Das Problem ist das Sony Vegas die Urdatei leider nicht lesen kann/will weswegen ich die nicht zur verarbeitung nutzen + ich will eigentlich wenig daran rumfuchteln

    Die musste ja auch anders anordnen. Daher demuxt man eine TS Datei und muxt sie hinterher geordnet wieder an.

    Deine NLE kennt die ID 100 oder 101 nicht. Sie beginnt mit ID 0 immer. Daher demuxen und dann wieder die Streams muxen. Damit die ID die richtige Reihenfolge hat.

    AVISynth wär das wieder egal. Weil mit FFMS2 kann man die Stream ID ansteuern lassen im Skript.

    Find ich persönlich ganz schön daneben das NLEs das nicht können, wo es doch gerade BluRay und DVB Geräte in Transport Streams gespeichert sind.

    Auch VOB Datein einer DVD haben ne ganz andere ID Anordnung. NLEs können zwars MPEG2 lesen. Aber keine VOB Datei was auch nix anderes ist als MPEG2. xD

    @PentaSquadAustria
    VFR kodierte Videos wie Julien es ganz oben schon aus der Mediainfo rauszitiert hat, kann (muss nicht) asynchron werden. Das Ding heißt nun mal VFR, weil es eine Variable Frame Rate ist. Und wie der Name schon hindeutet ist die Variable. Nicht alle Bearbungssoftwares können damit umgehen. Ein CFR Schnittprogramm was ein VFR Video läd kann asynchron nur aufgrund dessen sein das die VFR eine größere Schwankungen drin hat. Weil das CFR Programm ließt die Frames die vorhanden sind als Konstant ein. Und somit sind die unregelmäßigen Zeitabständer der VFR in CFR regelmäßig angeordnet. Dadurch kann Zeitlängenverlust auftreten. Das ist ein sehr typisches Klischee bei VFR Videos.

    Man kann auch VFR in CFR wandeln. Dafür gibt es natürlich mathematische Algorithmen. Bei FFMS2, DSS2 oder DSS wäre sowas enthalten direkt.

    Asynchronität kann aber auch dadurch entstehen das 2 Audiospuren die zusammengemixt werden sollen unterschiedliche Abtastraten haben.
    z.B. läuft eines mit 48000Hz und die andere mit 44100Hz. Beim mischen kann es bei einigen Anwendungen durchaus vorkommen das sie keine Samples entfernen, sondern einfach die eine Samplerate auf die andere angleichen (für gewöhnlich kleinere auf höhere). Damit würde die Audiospur mit 44100Hz auf 48000Hz geändert und somit die Abspielzeit verkürzt, weil die Sampleanzahl immer noch die gleiche wäre wie bei 44100Hz.
    Das kann auch schon passieren wenn eine Projekteinstellung auf eine bestimmte Hertzzahl aus festgelegt ist.
    In diesem Falle sollte man Audio entweder immer mit der gleichen Abtastrate aufnehmen oder changen bzw ändern lassen, indem einfach Samples entfallen oder intelligent wieder zugerechnet werden in die Frequenzkurve.

    Ja. Das sind so die üblichen Klischees bei Asynchronitäten. Man denkt oft nicht dran oder hat keine Ahnung was man da tut.

    Und bei VFR gibt es ja auch noch andere Situationen. Die VFR an der Elgato kommt ja dadurch zustande das man sich gesagt hat das es für Spiele ideal ist. So ist es ja auch. Spiele haben nun mal keine CFR. Spiele laufen immer mit VFR. Und bei VFR kann man Glück haben das es nicht asynchron wird. Oftmals das es bei 30Minuten einen erst richtig auffällt oder nach 20 Minuten. Wie gesagt: Es kann.

    CFR Aufnahmen sind daher immer sicherer und auch die mit unter am kompatibelsten für NLEs und andere Videoprogramme.

    VFR hat eigentlich nur 2 wesentliche Vorteile gegenüber dem CFR. VFR kann Speicher sparen (was auch nicht grad so gewaltig wäre) und die Darstellung sieht auch gescheiter aus aus solch einer Quelle. Aber nur wenn die Quelle ebenfalls VFR war. CFR nach VFR ist in meinen Augen dann doch etwas daneben und ergibt irgendwie kein echten Vorteil für den PC Gebrauch.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sagaras ()

  • Soo nach stundenlangem rumschrauben und probieren + Sp1 neuinstallation hat man mir endlich mal das neue Update für die Software angeboten rausgekommen is folgende Media Datei

    Test
    Allgemein
    Vollständiger Name: Testaufnahme - #4 - 2015-01-17 20-33-15 (p).mp4
    Format : MPEG-4
    Codec-ID : M4V
    Dateigröße : 11,7 MiB
    Dauer : 10s 430ms
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 9 390 Kbps
    Filmname : #4
    Aufnahmedatum : 2015-01-17
    Kodierungs-Datum : UTC 2015-01-17 18:35:58
    Tagging-Datum : UTC 2015-01-17 18:35:58

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.0
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 2 frames
    Format_Settings_GOP : M=3, N=15
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 10s 425ms
    Duration_LastFrame : 48ms
    Bitraten-Modus : variabel
    Bitrate : 9 201 Kbps
    maximale Bitrate : 17,4 Mbps
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 59,940 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.167
    Stream-Größe : 11,4 MiB (97%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-01-17 18:35:58
    Tagging-Datum : UTC 2015-01-17 18:35:58
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 10s 430ms
    Source_Duration/String : 10s 411ms
    Bitraten-Modus : konstant
    nominale Bitrate : 216 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Source_StreamSize/String : 281 KiB (2%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-01-17 18:35:58
    Tagging-Datum : UTC 2015-01-17 18:35:58
    mdhd_Duration : 10430


    Mit der Konstanten Bildwiederhoflungsrate (vorher Variabel) sollten die Probleme eigentlich nicht mehr auftreten, die Vorschau die ich endlich abstellen kann schont meine CPU und das ich endlich in 720 in 60 FPS aufnehmen kann is auch ne schnieke Sache :huh:
  • Jo. Dann achte wie schon über dir im Beitrag erwähnt auf Audio noch. Ansonsten sieht die Aufnahme laut Mediainfo recht gut aus.

    Und PS: Es ist kein vollwertiges 60FPS. Du hast ledeglich nur 59,940 FPS. Sprich 60/1,001 FPS

    Das ist so ein übliches Amerikanischer Standard mal wieder für Videos direkt. Aber für Spiele eigentlich auch daneben. Naja... die üblichen Standards für solche Geräte, die eigentlich keine Standards sind, weil am PC haste ja 60 angegeben gewiss xD Also schon ne komplette Lüge was se dir da auftischen :D
  • Sagaras schrieb:

    Jo. Dann achte wie schon über dir im Beitrag erwähnt auf Audio noch. Ansonsten sieht die Aufnahme laut Mediainfo recht gut aus.

    Und PS: Es ist kein vollwertiges 60FPS. Du hast ledeglich nur 59,940 FPS. Sprich 60/1,001 FPS

    Das ist so ein übliches Amerikanischer Standard mal wieder für Videos direkt. Aber für Spiele eigentlich auch daneben. Naja... die üblichen Standards für solche Geräte, die eigentlich keine Standards sind, weil am PC haste ja 60 angegeben gewiss xD Also schon ne komplette Lüge was se dir da auftischen :D


    das mit dem Audio is schon beachtet hab ich damals im ersten Post geschrieben war so ziemlich die erste Maßnahme das Aufnahme Mikro von 44100 auf 48000 zu stellen da das Video an sich auch mit 48000 aufgenommen wurde das war damals also nicht das problem schätze es lag echt an der Variabelen Bildwiederholung weil das Audio Konstant war :D

    Ja ich weiß keine Vollwertigen 60 FPS aber immerhin kann ich das jetzt auch auf 720 p machen im vorherigen Menü ging das nur wenn ich künstlich auf 1080 gestreckt habe xD

    zur Not könnte ich jetzt die Elegato anweisen das Commentary seperat zu speichern damit ich das wenn es sein muss über NLE nachbearbeiten kann (hoffe dazu kommt es nicht bin nämlich naturfaul xD)
  • Sagaras schrieb:

    Find ich persönlich ganz schön daneben das NLEs das nicht können, wo es doch gerade BluRay und DVB Geräte in Transport Streams gespeichert sind.


    Jap. Extrem traurig. TMPGEnc kanns immerhin.

    Und das Ding heißt Elgato und nicht elegato.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7