MeGUI arbeitet mit geringer FPS und braucht sehr lange

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MeGUI arbeitet mit geringer FPS und braucht sehr lange

    Anzeige
    Guten Tag liebe Mitglieder,

    ich mache schon seit einiger zeit Let's Plays und habe angefangen meine Vorgehensweise zum Rendern (Codieren) abzuändern.

    Ich verwende von Adobe das Premiere Elements 12 zum schneiden, dann sende ich das Video / die Videos an den DebugMode FrameServer und Rendere die Videos mit MeGUI.

    Wenn ich Videos durch MeGUI jage ohne Webcam mit 720p / 1080p dann habe ich eine Processing rate von 25-30FPS / 15-20FPS,
    aber wenn das ganze mit Webcam läuft auf 1080p habe ich eine rate von 2-3FPS.

    Okey ich meine die Qualität ist echt Top, aber für ein 25min Video braucht das dann 4-5h und das ist es mir dann aber auch nicht wert.
    So überlegt muss ich bei jedem Abend eine Folge ca 25min muss ich ja ca. mind. 28h rendern lassen...

    Webcam wird mir OBS aufgenommen in 1080p und Game wird mit Fraps oder Dxtory in 1080p aufgenommen.

    Das Script sieht so aus:

    Quellcode

    1. AVISource("G:\Adobe\Premiere Elements 12\DMFS\Unbenannt.avi", audio=true)
    2. ConvertToYV12()
    3. __film = last
    4. __t0 = __film.trim(1817, 45987).FadeIn(30).FadeOut(30) + __film.trim(0, 1816).FadeIn(30).FadeOut(30)
    5. __t0

    Das Script sieht momentan noch so aus das ich die Outros am anfang im Video reinpacke um die Automatisch an das Ende jeder Folge zu packen, werde das später so machen das es nur noch die AVI File des Outros von der Platte zieht, aber das ist ja unwichtig.

    Der Codec den ich in MeGUI verwende ist der x264 im Mode ABR mit unterschiedlichen Bitrates, je nach Spiel von 4mb - 10mb,
    mehr habe ich nicht eingestellt da die Qualität und die Größe der File optimal sind. (30min == ca 1,2GB)

    Gibt es eine Möglichkeit mit einer höheren Processing rate trotz das die Webcam mit drin ist?
    Habe die Webcam auch schon in einer kleineren Auflösung rein gepackt aber ohne Verbesserung...


    Ich bedanke mich in voraus für eure schnellen Antworten.

    Mit freundlichen Grüßen
    DominatorLP
  • Naja da kann ja MeGUI nichts für, wenn du mit Premiere die Webcam einbindest, nehme mal an das machst du nämlich auch über Premiere, statt über Avisynth. Also liegts ja an Premiere's Arbeitszeit.

    Warum zur Hölle ABR Encoding in einer Zeit von CRF (constant quality) Encoding? ?(

    Aber wenn schon bitrate, dann doch bitte automated 2pass.


    Alles mit Avisynth machen wäre bereits schneller. SSM benutzen ebenso, dank multithreading avisynth: letsplayforum.de/index.php/Thr…aker-GUI/?action=firstNew
    Aktuelle Projekte/Videos


  • Ich habe vergessen zu erwähnen das ich mit Green-Screen arbeite und auch einen Filter über das Video (Webcam) lege das es bei Horror Games dunkler wird.

    Zu der Sache mit ABR und CRF, ich arbeite noch nicht so lange mit MeGUI, darum bin ich da auch noch nicht so weit.

    ich habe gerade bemerkt, das wenn das Script so aussieht:

    Quellcode

    1. AVISource("G:\Adobe\Premiere Elements 12\DMFS\Unbenannt.avi", audio=true)
    2. ConvertToYV12()


    Es mit ca 20FPS rendert, sobald ich den Befehl TRIM einsetze habe ich nur 2-3FPS.

    Kennst du da eine Möglichkeit das ich z.B. 4h Video habe und das über jeweilige Scripte dann in Folgen aufteilen kann?

    Ich schaue mir gleich mal den Link von dir an.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DominatorLP ()

  • DominatorLP schrieb:

    Ich habe vergessen zu erwähnen das ich mit Green-Screen arbeite und auch einen Filter über das Video (Webcam) lege das es bei Horror Games dunkler wird.


    Auch sowas würde via Avisynth gehen.

    Premiere ist da nicht wirklich nötig. Unterschied ist halt nur die grafische Oberfläche. Aber möglich und schneller wäre Avisynth und würde auch eine Farbraumkonvertierung vermeiden.

    Trim sollte dennoch eig. überhaupt nicht ausbremsen. Fade eig. auch nicht, wenn dann nur marginal. Seltsam.
    Aktuelle Projekte/Videos


  • Anzeige
    Okey, jetzt sinken die FPS langsam.

    Ich kenne mich halt nicht so gut aus was das Rendern über andere Software betrifft, ist alles Neuland.

    Ich mache das ganze gerne über Pre12 da ich im Nachhinein einiges schneide und anpasse.
    Ich habe eine Virtuelle Soundkarte auf dem PC was Musik, TS und Gamesound separat ausspuckt, so das man es im Nachhinein noch einzeln bearbeiten kann.

    Ich hab auch nen kleines Script selber geschrieben in dem ich die schnitte des gesamten Videos sage und wie jede Folge heißt und das erzeugt mir dann die AVS Files.



    Nachtrag:
    Ich habe mal getestet zwei .AVI Files zu rendern und es hat mit 10FPS gerendert.
    Kann es sein das es probleme mit .MP4 Files gibt, die Webcam aufnahme ist in .MP4.

    Damals vor meinen neuen Festplatten ging das auch, nur das die Webcam .AVI Files waren.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von DominatorLP ()