Magix Video deluxe 2015 Premium manche Schnipsel werden schwarz...

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Magix Video deluxe 2015 Premium manche Schnipsel werden schwarz...

    Anzeige
    Vegane Grüße,

    ich mache gerade meine ersten Schritte mit Video deluxe 2015 Premium und habe ein paar Videoschnipsel aneinandergefügt und durch verschiedene "Titel" miteinander verbunden. Die Titel, habe ich rechts und links jeweils etwas in die Videospuren reingeschoben, damit eine Überblendung entsteht (einige Schnipsel wurden auch einfach direkt ineinander geschoben, ohne sie mit Titeln zu trennen). In der Vorschau ist auch alles noch ok, aber wenn ich den file exportiere, dann werden einige der Schnipsel im Endprodukt schwarz und einige nicht (Ton ist weiterhin zu hören). Die, die schwarz werden, werden noch solange angezeigt, wie die Überblendung läuft (egal, ob ein- oder ausgeblendet wird und egal, ob es ein Titel, oder ein neuer Videoschnipsel ist).

    Ich hoffe, ich habe mich verständlich ausdrücken können... ^^

    Woran kann das liegen?
    Ich bin kein Arsch, ich bin nur ehrlich...!

    Besuch' mich doch mal auf YouTube
  • Anzeige

    GrandFiredust schrieb:

    Wie sieht denn die Mediainfo (Ansicht: Text) des Ursprungsmaterial aus?

    Unterschiedlich, da es unterschiedliche Dateien sind...

    Aber danke für den Anstoß... Ich habe eben mal alles durchgesehen und es scheint am Lagarith zu liegen, mit dem ich aufnehme... Alle Dateien, die ich direkt von der Source genommen habe (Lagarith), werden beim Exportieren schwarz. Alle anderen Dateien habe ich nicht mehr als Source gehabt, sondern nur noch als bereits in MKV gewandeltes Material und habe es daher nochmal extra in AVI wandeln müssen, weil magix meine MKVs mit h264 nicht lesen kann... Alle im Vorfeld bereits umgewandelten Dateien, werden auch nicht schwarz!

    Hier mal eine Lagarith Datei:
    Spoiler anzeigen
    Allgemein
    Vollständiger Name : L:\LPs\Trailer\Bisher drin\tiefe einbliecke in die abgründe meiner seele.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Dateigröße : 675 MiB
    Dauer : 26s 120ms
    Gesamte Bitrate : 217 Mbps
    Originale Source-Form/Vertrieb durch : Video:Lagarith Lossless Codec Audio0:Lautsprecher (Razer Surround Audio Controller) Audio1:Mikrofon (2- USB Microphone )
    Kodierendes Programm : VirtualDubMod 1.5.10.2 (build 2540/release)
    verwendete Encoder-Bibliothek : VirtualDubMod build 2540/release

    Video
    ID : 0
    Format : Lagarith
    Codec-ID : LAGS
    Dauer : 26s 120ms
    Bitrate : 215 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 25,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Bits/(Pixel*Frame) : 4.140
    Stream-Größe : 668 MiB (99%)

    Audio #1
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 26s 120ms
    Bitraten-Modus : konstant
    Bitrate : 1 411,2 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 4,39 MiB (1%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 41 ms (1,02 Video-Frame)
    Interleave, Vorlaufsdauer : 500 ms

    Audio #2
    ID : 2
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 26s 120ms
    Bitraten-Modus : konstant
    Bitrate : 705,6 Kbps
    Kanäle : 1 Kanal
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 2,20 MiB (0%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 41 ms (1,02 Video-Frame)
    Interleave, Vorlaufsdauer : 500 ms


    Und hier mal eine der im Vorfeld bereit umgewandelten:
    Spoiler anzeigen
    Allgemein
    Vollständiger Name : L:\LPs\Trailer\Bisher drin\Assassin's Creed 1 #08 - Ab nach Akkon [Let's Play HD 1440p Deutsch] (1)-001.mkv.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Dateigröße : 11,1 MiB
    Dauer : 1min 3s
    Gesamte Bitrate : 1 480 Kbps

    Video
    ID : 0
    Format : MPEG-4 Visual
    Format-Profil : Advanced Simple@L5
    Format-Einstellungen für BVOP : 1
    Format-Einstellungen für Qpel : Ja
    Format-Einstellungen für GMC : Keine warppoints
    Format-Einstellungen für Matrix : Default (MPEG)
    Codec-ID : XVID
    Codec-ID/Hinweis : XviD
    Dauer : 1min 3s
    Bitrate : 1 474 Kbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 25,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.028
    Stream-Größe : 11,1 MiB (100%)
    verwendete Encoder-Bibliothek : XviD 1.2.1 (UTC 2008-12-04)


    Könnte es vielleicht auch daran liegen, dass alle originalen Source Dateien bereits 2 Tonspuren beinhalten, wohingegen die umgewandelten ohne TS daherkommen??
    Ich bin kein Arsch, ich bin nur ehrlich...!

    Besuch' mich doch mal auf YouTube
  • Achso...das liegt an Lagarith. Magix kann Lagarith weder richtig lesen noch schreiben.

    Aber vorher encodieren ist doch doof. Und dann noch mit XIVID in MPEG-4 Simple... Und dann noch in den AVI-Container <X Nicht nur das das Video hinterher schlechter aussieht, du machst dir noch mehr Arbeit.

    Nimm einfach ein anderen Aufnahme Codec: Statt Lagarith, MagicYUV MagicYUV - Ein neuer Lossless Codec!

    Dann musst du das vorher nicht umwandeln ;)
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • GrandFiredust schrieb:

    Achso...das liegt an Lagarith. Magix kann Lagarith weder richtig lesen noch schreiben.
    Das habe ich schon beim Einlesen bemerkt, habe es aber hinbekommen und bin daher davon ausgegangen, dass er es dann auch richtig schreiben kann...

    GrandFiredust schrieb:

    Aber vorher encodieren ist doch doof. Und dann noch mit XIVID in MPEG-4 Simple... Und dann noch in den AVI-Container <X Nicht nur das das Video hinterher schlechter aussieht, du machst dir noch mehr Arbeit.
    Nuja... Umwandeln musste sein, da Magix meine MKVs mit h264 erst gar nicht fressen will... ^^ MPEG4 in AVI wusste ich, dass er es lesen kann, daher war das meine Wahl. Von der Qualität her bin ich eigentlich zufrieden, dafür, dass das Material ja dann immerhin schon zum zweiten Mal neu codiert wurde (man kann Xvid ja mit Matrizen & Co. einigermaßen gute Qualität entlocken - ich kenne die Geschichten noch aus Zeiten, als es noch kein MKV gab... ^^). Der Rest war nur ein erster Versuch, ob Magix die Dateien dann überhaupt auch frisst, wollte mir nicht ewig Arbeit (und Encodierzeit) machen, nur um dann festzustellen, dass Magix sie dennoch nicht frisst ^^

    GrandFiredust schrieb:

    Nimm einfach ein anderen Aufnahme Codec: Statt Lagarith, MagicYUV MagicYUV - Ein neuer Lossless Codec!
    Der ist zwar schon seit ein paar Tagen installiert, aber das Material ist eben noch mit Lagarith aufgenommen (soll eine Collage für den Kanaltrailer werden und muss daher entweder so genommen, oder eben umgewandelt werden ;) ).

    Thorhall schrieb:

    MarioZockt schrieb:

    es scheint am Lagarith zu liegen
    ...
    s.o. ;)

    Danke Jungs!
    Ich bin kein Arsch, ich bin nur ehrlich...!

    Besuch' mich doch mal auf YouTube
  • GrandFiredust schrieb:

    Einfacherer Weg: ...


    Leider nicht, denn wie ich schon geschrieben habe, frisst Magix meine h264 nicht...



    Auf die Idee mit dem ummuxen bin ich auch schon gekommen (dennoch danke dafür!), da ich dachte, Magix könne nur nichts mit dem Container anfangen, aber dem war leider nicht so. Ich hatte mal irgendwo gelesen, dass man 2 bestimmte Importfilter deaktivieren müsse, um mit h264 arbeiten zu können, aber ich kann das Forum, bzw. den Thread über Google nicht mehr finden...

    Wobei ich den Schritt ohnehin nicht nachvollziehen kann, da Magix ja eigentlich h264 können müsste...
    Ich bin kein Arsch, ich bin nur ehrlich...!

    Besuch' mich doch mal auf YouTube
  • MarioZockt schrieb:

    da Magix ja eigentlich h264 können müsste...


    Leider ist H.264 nicht gleich H.264. Das ist lediglich der Standard, also die Richtlinien und die Grundfunktionen des Formats. Jedoch kann theoretisch jeder diesen Standard nehmen und ein Codec schreiben, welcher spezifisch das Video codiert. Jeder Encoder der verwendet wird schreibt theoretisch also in einem anderen Format, obwohl das immer noch ein AVC Stream ist.

    Magix benutzt als Encoder Bibliothek auch nicht ffmpeg, welches fast alle bekannten Codecs beinhaltet, sondern benutzt erstens die VFW-Codecs (MagicYUV, UT-Video,...), dann die Windows und Apple Codecs (Mov, ...) und schließlich interne Codecs (MPEG-1, MJPEG, MPEG-2, MPEG-4 Simple [weswegen auch XIVID akzeptiert wird], ein paar 3D-Formate und schließlich MPEG-4 AVC [H.264] Codecs) Von diesen jedoch nur die bekanntesten, wie MainConcept, IntelH.264, NVENC, ... Jedoch nicht alle H.264 Implementionen.

    KP, jedoch welcher Codec für deine H.264 Videos benutzt werden.... Mit was hast du denn encodiert?
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D