Adobe Media Encoder/Premiere > Audioprobleme

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Adobe Media Encoder/Premiere > Audioprobleme

    Anzeige
    Mahlzeit zusammen,

    ich habe ein recht komisches Problem beim exportieren/rendern meiner Videos.

    Um dies einfach zu halten, erkläre ich dies anhand eines Beispiels, welches so bei mir fast in jeder Bearbeitung stattfindet:

    Bearbeitung findet unter Adobe Premiere CC 2014 statt.

    Kanalteaser auf Videospur 1 / Audiospur 1

    Video auf Videospur 2 / Audiospur 2

    Nun gehts via Export zum Media Encoder (auch aktuelle Version).

    Ich nutze hier eine leicht angepasste Youtube Vorlage.

    Wenn ich dieses Video render, ist das Ergebnis tadellos.

    Falls ich nun noch ein Video unter den SELBEN Umständen exportiere und render,

    ohne beide Programme vorher einmal geschlossen zu haben, gibt er mir im Endergebnis auf der ersten Audiospur keinen Ton, auf der zweiten Audiospur nur Ton links aus.

    Das macht es mir unmöglich, die Funktion zu nutzen, mehrere Videos über Nacht zu rendern.

    Ich kann mir da keinen Reim draus machen.

    Also noch mal in Kurzform:

    erstes Video bearbeitet > Export > Vorlage anpassen

    zweites Video bearbeitet > Export > Vorlage anpassen (selbe Einstellung wie im ersten)

    drittes Video bearbeitet > Export > Vorlage anpassen (selbe Einstellung wie im ersten)

    Warteschlange wird gestartet

    Erstes Video ok, alle folgenden defekt.

    Ich hoffe, ich konnte das halbwegs verständlich erklären.

    Ich bedanke mich für´s lesen! Grüße :)
  • Also.... um das Problem am Video feststellen zu können läds du dir erstmal Mediainfo runter. Dort dann bei "Ansicht" auf "Text" stellen.
    Dann eine Mediainfo von dem defektem Rohvideo (vor dem Bearbeiten) und nach dem Encode (also das fertige Video).

    Damit können wir dir mehr helfen :)
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Part 1 (trailer)

    Format : Windows Media
    Dateigröße : 6,02 MiB
    Dauer : 10s 476ms
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 4 824 Kbps
    maximale Gesamtbitrate : 10,4 Mbps
    Kodierungs-Datum : UTC 2014-12-01 20:09:36.165

    Video
    ID : 2
    Format : VC-1
    Format-Profil : MP@HL
    Codec-ID : WMV3
    Codec-ID/Info : Windows Media Video 9
    Codec-ID/Hinweis : WMV3
    Beschreibung zum Codec : Windows Media Video 9 - Professional
    Dauer : 10s 477ms
    Bitraten-Modus : variabel
    Bitrate : 8 000 Kbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 29,970 FPS
    BitDepth/String : 8 bits
    Bits/(Pixel*Frame) : 0.129
    Stream-Größe : 9,99 MiB
    Sprache : Deutsch
    NumberOfFrames : 300

    Audio
    ID : 1
    Format : WMA
    Format-Profil : Pro
    Codec-ID : 162
    Codec-ID/Info : Windows Media Audio
    Beschreibung zum Codec : Windows Media Audio 10 Professional - 440 kbps, 44 kHz, 2 channel 24 bit 2-pass VBR
    Dauer : 10s 476ms
    Bitraten-Modus : variabel
    Bitrate : 378 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    BitDepth/String : 24 bits
    Stream-Größe : 483 KiB (8%)
    Sprache : Deutsch
    NumberOfFrames : 23


    Part 2 (eigentliches LP)

    Format : MPEG-4
    Format-Profil : Base Media
    Codec-ID : isom
    Dateigröße : 6,14 GiB
    Dauer : 21min
    Gesamte Bitrate : 40,2 Mbps
    Kodierungs-Datum : UTC 2015-03-15 21:54:29
    Tagging-Datum : UTC 2015-03-15 21:54:29
    Kodierendes Programm : Open Broadcaster Software v0.65b

    Video
    ID : 2
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.2
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 4 frames
    Muxing-Modus : Container profile=High@3.1
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 21min
    Source_Duration/String : 21min
    Bitrate : 40,0 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 35,000 FPS
    minimale Bildwiederholungsrate : 34,483 FPS
    maximale Bildwiederholungsrate : 35,714 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.551
    Stream-Größe : 6,11 GiB (100%)
    Source_StreamSize/String : 6,11 GiB (100%)
    verwendete Encoder-Bibliothek : x264 core 146 r2538 121396c
    Kodierungseinstellungen : cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x3:0x3 / me=dia / subme=1 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=70 / keyint_min=7 / scenecut=40 / intra_refresh=0 / rc_lookahead=0 / rc=cbr / mbtree=0 / bitrate=40000 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=40000 / vbv_bufsize=40000 / nal_hrd=none / filler=1 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
    Kodierungs-Datum : UTC 2015-03-15 21:54:29
    Tagging-Datum : UTC 2015-03-15 21:54:29
    colour_primaries : BT.709
    transfer_characteristics : sYCC
    matrix_coefficients : BT.709
    colour_range : Full
    mdhd_Duration : 1312400

    Audio
    ID : 1
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 21min
    Source_Duration/String : 21min
    Bitraten-Modus : konstant
    Bitrate : 181 Kbps
    nominale Bitrate : 192 Kbps
    Kanäle : channel0
    Channel(s)_Original : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Stream-Größe : 28,3 MiB (0%)
    Source_StreamSize/String : 28,3 MiB (0%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-03-15 21:54:29
    Tagging-Datum : UTC 2015-03-15 21:54:29



    Das fertige Ergebnis:

    Format : MPEG-4
    Format-Profil : Base Media / Version 2
    Codec-ID : mp42
    Dateigröße : 2,23 GiB
    Dauer : 22min
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 14,5 Mbps
    Kodierungs-Datum : UTC 2015-03-16 13:57:48
    Tagging-Datum : UTC 2015-03-16 14:00:42
    ©TIM : 00;00;00;00
    ©TSC : 30000
    ©TSZ : 1001

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.2
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 3 frames
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 22min
    Bitraten-Modus : variabel
    Bitrate : 14,3 Mbps
    maximale Bitrate : 14,6 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 29,970 FPS
    Standard : NTSC
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.230
    Stream-Größe : 2,20 GiB (99%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-03-16 13:57:48
    Tagging-Datum : UTC 2015-03-16 13:57:48
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709
    colour_range : Limited

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 22min
    Source_Duration/String : 22min
    Bitraten-Modus : variabel
    Bitrate : 192 Kbps
    maximale Bitrate : 253 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Stream-Größe : 29,9 MiB (1%)
    Source_StreamSize/String : 29,9 MiB (1%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-03-16 13:57:48
    Tagging-Datum : UTC 2015-03-16 13:57:48
  • 1. Problem

    Kunstkerze schrieb:

    Samplingrate : 48,0 KHz

    Kunstkerze schrieb:

    Samplingrate : 44,1 KHz


    Du encodierst mit einer Abtastrate von 48 khz obwohl der Trailer nur 41,1 khz hat.

    2. Problem

    Kunstkerze schrieb:

    Bildwiederholungsrate : 29,970 FPS

    Kunstkerze schrieb:

    Bildwiederholungsrate : 29,970 FPS

    Kunstkerze schrieb:

    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 35,000 FPS
    minimale Bildwiederholungsrate : 34,483 FPS
    maximale Bildwiederholungsrate : 35,714 FPS


    Dein Trailer hat 29,970 FPS. Dein richtiges Video hat 35 FPS. (KP ob jetzt variabel oder nicht). Encodieren tust du in 29,970 FPS. Dein Hauptteil des Videos ist also mit der falschen FPS Rate encodiert.

    Beides kann dazu führen, dass Probleme mit dem Audio entstehen.

    Abtastrate: OBS auf 44.1 khz stellen. Auch auf 44,1 khz in den Adobe Einstellungen zum laden der Videos und zum Rendern stellen.
    FPS: Ist schon schwieriger. 29,970 brauchst du eigentlich gar nicht, außer für US TV Standard. Am besten wäre es, wenn sowohl OBS als auch dein Trailer auf 30FPS stehen und auch in 30FPS encodiert wird.

    Warum das alles so plötzlich kam und anscheinend auch die Kanäle davon betroffen sind, kann ich nicht sagen. Ich tippe mal auf das Codierungschaos was sich bemerkbar gemacht hat :D

    Allein der WMV/WMA Codec.....

    Kunstkerze schrieb:

    NumberOfFrames : 23

    KP...was das alles soll... xD
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Anzeige
    NLEs mögen auch nicht so gerne wenn da Variable Framerate im Spiel ist. Kann zwar sein das der Header bloß falsch angelegt wurde, aber es steht nunmal VFR im Header.

    Nicht mit OBS aufnehmen wäre von daher schonmal ein richtig toller zielführender Weg. Zum einen aus Qualitätsgründen, zum anderen wegen Kompatibilität.

    Verlustkompression durch weitere Filter & Encoder zu schicken und dann youtube ein drittes Mal ranlassen ist echt nicht sonderlich intelligent gewählt. Die späteren Audio- und Videofilter und Audio- und Video Encoder müssen mit dem vorbelasteten Zeug dann auskommen. Natürlich geht das nicht so effizient dann und ist qualitätsmindernd. Kennt man eig. schon von MP3. Da sollte eig. auch jeder wissen, das es qualitätsmindernd ist, wenn man die mehrfach codiert. Das ist ja bei Videos und bei Filter nicht anders.


    Abgesehen davon das auch Premiere keine optimalen Encoder hat, könnte man dir eher das ans Herz legen:

    letsplayforum.de/index.php/Thr…me-Erkl%C3%A4rt-an-Magix/

    wenn du dich von premiere unabdingbar nicht trennen magst. Ansonsten gleich zu einer x264 GUI greifen ala Sagaras Scriptmaker für die avisynth scripterstellung und für die codierung dann MeGUI. MeGUI dann noch 10bit encoding anhaken und quality auf mind 23. kleinere werte = bessere qualität.

    Dennoch zu den internen Premiere H.264 Encoder 'nen wort:

    Bitte 2 durchgänge (2pass) (wichtig!) und nicht die max bitrate beschränken.. das macht einfach kein sinn den encoder bei der peak einzuschränken ...

    Dazu einfach mal diesen Post lesen von mir: Möglichkeiten das Enkodieren zu optimieren / beschleunigen

    Da erklär ichs ausführlicher. Und auch den Unterschied Konstante bitrate vs variable bitrate @ 2pass mit beispielvideos.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Hallo zusammen.

    Jetzt bin ich sprichwörtlich hin und her gerissen.
    Das alles erklärt natürlich nicht, warum jeweils das erste Video einer Warteschleife funktioniert,
    nach der Theorie von GrandFiredust, kann dies eigentlich auch nicht klappen :D

    Jedenfalls bedanke ich mich schonmal für diese Ausführungen. Ich bin noch nicht lange dabei, dies hat mir jedenfalls einiges klar gemacht.
    Danke für das weitergegebene Wissen :)

    Ich gebe zu, OBS ist für mich nur eine Lösung, das ich mit selbigen auch streame. Man kann halt schnell und einfach zwischen den Einstellungen switchen.
    Und nachdem ich die Bitrate auf 50k gestellt habe, war für mich auch das Qualitätsproblem gelöst.

    Zum rendern habe ich auch verschiedene Dinge gesichtet, so z.B. das Movie Studio von Sony. Das Problem ist, das ich Wert auf effektive Workflows lege,
    und das bietet mir momentan nur die Funktion des Encoders. Eine Alternative dazu habe ich noch nicht gefunden. Ich werde aber beim rendern heute Nacht eure Ergebnisse einfließen lassen und teile euch das Ergebnis mit :)
  • Ich würde gern mal aufzählen wollen was alles so "Untypisch/ein Grauen" ist bei den Quellen.
    1. Video sitzt auf ID2, statt ID1. Im Normalfall gehört dies exakt anders herum. Für Audio das gleiche Spiel.
      Erst Video, dann Audio. Und nicht erst Audio und dann Video ;D
    2. WMV und WMA Files sind nicht grade die beste Basis. Das sind Verlustkomprimierte Windowsformate. Aber allein schon wie diese WMV bei dir codiert wurde ist ein Graus. 1080p und nur 8000kbps, aber Audio mit 440 kbps und 24 Bit. Jaa.... klar. Sinnfrei... aber nagut. xD
    3. Und das bei der WMA Pro Audio Spur eine [lexicon]Frame[/lexicon] Nummer steht ist auch schon mehr als Fragwürdig. Audiospuren haben keine Bilder. In diesem Falle darf man sich nicht wundern warum später nix klappt. Allein weil die Streams der Datein schon so komisch erzeugt bzw. angeordnet wurden.
    4. Der Witz an der Sache ist aber dann die [lexicon]OBS[/lexicon] Aufnahme. Audio mit 181kbps und die Abtastrate natürlich auf 48Khz. Also zwischen dem Trailer und der [lexicon]OBS[/lexicon] Aufnahme liegen regelrecht Welten in Bereich Audio. xD
      Hinzu kommt das das Video satte 40000kbps bekommt bei deiner [lexicon]OBS[/lexicon] Aufnahme. Dein Trailer braucht aber nur 8000kbps. Finde den Fehler und die Ironie an den zwei Input Mediainfos selbst :D
    5. Dann kommt aber das Schärfste und zwars der Encode an sich in Premiere. Ein 29.970 FPS Encode. Warum haste in [lexicon]OBS[/lexicon] dann überhaupt in 35 FPS aufgenommen, wenn du es eh wieder in 29.970 FPS [lexicon]encodieren[/lexicon] tust? ^^
      Und dann mit 14Mbps das Ganze. Das ist mehr als nur Verschwendung.
      Audio machste dann in 192kbps.

    Ein gut gemeinter Tipp:

    Im Falle Audioaufnahmen. Nimm PCM WAV. PCM ist Verlustfrei und überall einsetzbar.
    Man sollte auch nicht übertreiben bei der Sache.
    Absolut für Youtube reicht es wenn man seine Aufnahme mit 44100Hz, 16Bit, Stereo macht. Das ist CD-Qualität und entspricht Musicalben die man sich in Läden kaufen kann. Der Standard einer jeden Musik CD oder Multitrack CD.
    PCM Standard Verfahren ist für Gewöhnlich "signed 16Bit Little Endian".

    Da braucht man sich keine Gedanken machen was für Bitrate die verwenden, weil es halt wie gesagt Verlustfrei ist. FLAC wäre ein komprimierter Verlustfreier Codec. Den kann man dann später z.B. für den Encode nutzen wenn man das möchte.

    AAC Encodes der Audiostreams sollte aus solchen Quellen dann so ungefähr bei 256kbps liegen für YT. Und die geben dir die PCM WAV Datein auch. Weil die haben über 1000kbps+ meist.

    Im Falle Video ist es besser eine Verlustfreien Codec zu verwenden, anstatt bereits Verlustbehaftete wie WMV oder AVC. Zumal OBS zum Streamen gedacht ist und nicht für Lokalaufnahmen.

    Aufnehmen sollte man immer Verlustfrei wenn es geht. Dir dankt später das Video dafür indem es besser aussieht ;D

    Kostenlos wäre der MSI Afterburner für solche Aufnahmen geeignet. In Kombination mit dem MagicYUV, UTVideo oder Lagarith Codec. Diese 3 sind Verlustfreie Codecs und speichern das Video genauso wie dann auch Audio Lossless ab.


    Zu deinem Encoding in Premiere.

    Du hast mit Premiere 3 Möglichkeiten effizient zu encodieren.
    Am effizientesten wäre der Weg über einem Frameserver das Ganze mit MeGUI zu encodieren, der dann den x264cli Encoder hat. Der würde dir dann auch eine 10Bit Encodierung ermöglichen. Bestes Encode Verfahren wäre dann via einem "Constant Rate Factor"

    Der zweite nicht ganz so Spektakuläre Weg wäre über x264vfw. Dort würde dir gegenüber dem ersten Verfahren von eben der 10Bit Encoder wegfallen. Zusätzlich auch die Frameserver wie AVISynth der mit seinen Skalierern auch noch was rausholen hätte können. Das würde dir alles bei x264vfw fehlen. Und bei deiner NLE sowieso.

    Der dritte und teuerste Weg ist den x264pro zu kaufen von Adobe. Kostet locker ca. 235€. Kann weniger als x264vfw und x264cli. Aber für viele Leute ist Bequemlichkeit und Unwissen halt viel Geld wert ^^


    Zu deinem eigentlichen Problem: Ich habe es unter anderem schon angesprochen anhand der kuriosen Quellen. Dein Problem besteht darin eine WMA Datei mit etwas zu kombinieren was in keinster Weise mit dem anderen passt.

    Es ist nicht mal ein Fehler der NLE, sondern vielmehr das Unwissen das der NLE entgegengesetzt wird. Und natürlich kommen dann die Bugs einer NLE auch noch hinzu. Keine Software ist perfekt. Nicht mal MeGUI. Aber MeGUI hingegen habe ich seit gut 2 Jahren keine Probleme mit. Generell habe ich mit AVISynth noch nie Probleme gehabt ^^ Stürzt nur dann ab wenn ich Mist gebaut habe.

    Eine NLE aber bugt dann rum wenn man als User nix dafür kann. Das ist ein Unterschied wie Tag und Nacht ^^

    Aber ich denke wenn die Quellen richtig angelegt werden und der Encode richtig eingestellt würde, dann würde es auch mit dem Ton in der NLE klappen. Kann mir nicht vorstellen das selbst NLEs bei Quellen gleichen Typs rumspacken.

    Und Verlustmaterial ist sowieso in einer NLE sehr anfällig. Vor allem dann wenn sie einen sehr verkorksten Header besitzen. NLEs wollen wenn überhaupt saubere Headers am liebsten. Und ich denke wenn man mit Verlustfreien Codecs arbeitet wird auch die NLE richtig arbeiten.

    Weil wie gesagt. PCM WAV ist Standard und das würde jedes anständige Schnittprogramm erkennen.

    Videos mit Verlustfreien Codecs wie MagicYUV, UTVideo, Lagarith werden in AVI Containern gespeichert, da sie VFW Codecs sind. Und AVI ist auch seit Windows existiert ein Standard für Videos. Also wenn eine NLE mit AVIs nix angfangen kann, dann weiß ich auch nicht.

    Und MKV und MP4 mit einem h264 AVC Stream und AAC Audiostream sind gerade bei LPs die Sache die man zum Schluss macht.

    Man macht für gewöhnlich nur ein einzigen Encode und nicht mehrere wie die OBS Aufnahme von dir die du dann mit h264 ind MP4 wandeln tust. Sowas nennt man Doppelencodierung oder Mehrfachcodierung und ist niemals gut.

    Immerhin Encodiert Youtube nochmals. Und da sollte man halt so wenig wie möglich encoden.

    Kunstkerze schrieb:

    Das Problem ist, das ich Wert auf effektive Workflows lege,
    und das bietet mir momentan nur die Funktion des Encoders


    Definition Encoder:
    Ein Encoder (deu. Kodierer/Verschlüssler) verschlüsselt und komprimiert Datenmengen.

    Die meistgenutzte Encodertechnik in Schnittprogrammen wird Transcoding genannt. Hierbei handelt es sich um das Umwandeln von Video/Audio in ein entsprechendes anderes Format.

    Transcoding wird oftmals in Kombination durch neu berechnete Bilder oder Samples ausgeführt (eng. Rendern / deu. Bildsynthese oder bei Audio nur Berechnen).

    Ein Decoder wird in Playern, Vorschaus oder für Inputs in Verarbeitungsprogramme verwendet. Ein Decoder (deu. Dekodierer/Entschlüssler) entschlüsselt Datenmengen und kann diese mit einen Ausgabe Renderer darstellen bzw. bei Audio in die akustische Signale dem Audioendgerät zukommen lassen was dann wieder in Klarton zu hören ist.

    Encoder und Decoder haben ein Kofferwort der sich Codec entsprechend nennt.

    Deine NLE (non-linear editing / nichtlineare Videoschnitt), sprich dein Vegas oder Premiere wird zig Encoder und Decoder verstehen können. Viele aber auch nur bis zu einem bestimmten Grad.

    z.B. schafft es bis jetzt noch keine NLE ein High 10 Profile eines AVC Streams zu öffnen. Geschweige die höheren Profile.
    Sind aber bei AVC notwendig wenn man mit h264 entweder 10Bit Encoding betreiben will oder Lossless aufzeichnen will.
    Also mit OBS Lossless aufzuzeichnen geht. Aber keine NLE wird dann damit was anfangen können. Sowas können bis jetzt nur kostenlose Programme ^^

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sagaras ()

  • Kunstkerze schrieb:

    Das alles erklärt natürlich nicht, warum jeweils das erste Video einer Warteschleife funktioniert,
    nach der Theorie von GrandFiredust, kann dies eigentlich auch nicht klappen


    Wie schon gesagt wurde sind NLEs sehr... ich sag mal empfindlich :D Sobald man die mit einem Codierungs-Chaos beschäftigt, können irgendwo Fehler auftreten. Die teilweise ungünstige Programmierung tut ihren Rest. Schließlich treten plötzlich irgendwo Fehler auf, die logisch keinen Sinn mehr ergeben. Da ich auch nicht in das Programm hineinblicken kann und auch nicht weiß, welche Decoder und Renderer Adobe jetzt verwendet, bzw. das Prinzip, wie es bestimmte Videos decodiert, bearbeitet, pre-rendert und schließlich encodiert, kann man schlecht den eigentlichen Fehler herausfinden

    Je komplizierter und unnormaler die geladenen Videos sind, desto häufiger erlebst du, dass deine NLE ein schlechten Tag hat und irgendwo Fehler einbaut. Deswegen sollte man immer auf bestimmte Grundsätze achten um die NLE nicht zu überfordern und das Ganze nicht noch mit falschen Einstellungen exportieren:

    1. Input FPS = Output FPS
    2. Geladene Videos sollten die gleiche FPS haben
    3. Geladene Videos sollten die gleiche Samplerate haben
    4. CFR statt VFR Aufnahmen
    5. Keine "seltenen" AVC Codecs verwenden, genauso wenig wie höhere Bittiefe als 8 oder ein High 4:4:4 Profil
    6. Am besten immer das gleiche Inputformat nehmen, nicht ein AVC und ein WMV Stream

    Diese Tipps erleichtern dir die Arbeit mit NLEs und beugen diese ungewöhnlichen Fehler vor.

    Dazu kommen noch die qualitativen Tipps von @Sagaras ;)
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Sagaras schrieb:

    Und die geben dir die PCM WAV Datein auch. Weil die haben über 1000kbps+ meist.


    Die haben immer die gleiche Datenrate. Weil halt unkomprimiert.

    Bei 44100hz, 16bit, Stereo sind es 1411 kbit/s

    FLAC pendelt sich ungefähr bei 1000 kbit rum mit genannter hz, bittiefe und kanalmenge.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Mahlzeit!

    Ihr habt mein Leben verändert ;)

    Sagaras schrieb:

    Video sitzt auf ID2, statt ID1. Im Normalfall gehört dies exakt anders herum. Für Audio das gleiche Spiel.
    Erst Video, dann Audio. Und nicht erst Audio und dann Video ;D
    WMV und WMA Files sind nicht grade die beste Basis. Das sind Verlustkomprimierte Windowsformate. Aber allein schon wie diese WMV bei dir codiert wurde ist ein Graus. 1080p und nur 8000kbps, aber Audio mit 440 kbps und 24 Bit. Jaa.... klar. Sinnfrei... aber nagut. xD
    Und das bei der WMA Pro Audio Spur eine Frame Nummer steht ist auch schon mehr als Fragwürdig. Audiospuren haben keine Bilder. In diesem Falle darf man sich nicht wundern warum später nix klappt. Allein weil die Streams der Datein schon so komisch erzeugt bzw. angeordnet wurden.
    Der Witz an der Sache ist aber dann die OBS Aufnahme. Audio mit 181kbps und die Abtastrate natürlich auf 48Khz. Also zwischen dem Trailer und der OBS Aufnahme liegen regelrecht Welten in Bereich Audio. xD
    Hinzu kommt das das Video satte 40000kbps bekommt bei deiner OBS Aufnahme. Dein Trailer braucht aber nur 8000kbps. Finde den Fehler und die Ironie an den zwei Input Mediainfos selbst
    Dann kommt aber das Schärfste und zwars der Encode an sich in Premiere. Ein 29.970 FPS Encode. Warum haste in OBS dann überhaupt in 35 FPS aufgenommen, wenn du es eh wieder in 29.970 FPS encodieren tust?
    Und dann mit 14Mbps das Ganze. Das ist mehr als nur Verschwendung.
    Audio machste dann in 192kbps.


    Ich habe dies zum Anlass genommen, und den Trailer nochmals angefertigt und dies direkt auf 60fps gerendert. Neue Aufnahmen kommen jetzt auch mit 60fps daher.
    (Ich wollte mir diese Option offen halten, damit ich Zweifelsfalle eine vernünftige Slowmotion erstellen kann)
    Dies wird dann natürlich im Endergebnis alles auf 60fps gerendert und ist so stimmig.

    Sagaras schrieb:

    Es ist nicht mal ein Fehler der NLE, sondern vielmehr das Unwissen das der NLE entgegengesetzt wird. Und natürlich kommen dann die Bugs einer NLE auch noch hinzu. Keine Software ist perfekt. Nicht mal MeGUI. Aber MeGUI hingegen habe ich seit gut 2 Jahren keine Probleme mit. Generell habe ich mit AVISynth noch nie Probleme gehabt Stürzt nur dann ab wenn ich Mist gebaut habe.

    Eine NLE aber bugt dann rum wenn man als User nix dafür kann. Das ist ein Unterschied wie Tag und Nacht


    Dazu gleich noch ein Wort von mir.

    GrandFiredust schrieb:

    1. Input FPS = Output FPS
    2. Geladene Videos sollten die gleiche FPS haben
    3. Geladene Videos sollten die gleiche Samplerate haben
    4. CFR statt VFR Aufnahmen
    5. Keine "seltenen" AVC Codecs verwenden, genauso wenig wie höhere Bittiefe als 8 oder ein High 4:4:4 Profil
    6. Am besten immer das gleiche Inputformat nehmen, nicht ein AVC und ein WMV Stream



    Auch im Bereich Audio bin ich den Schritt höher gegangen, nehme in 320er auf und fertige dies schlußendlich auch bis zum Endergebnis durch.
    Bitrate ist nun konstant.

    Fazit: Natürlich brauche ich jetzt die doppelte Zeit zum rendern, als auch die Datenmengen sind um 200% größer.
    ABER: Das ist für mich egal, weil die Warteschleife im Encoder nun funzt! Damit ist das Problem gelöst und sogar das Ergebnis wurde verbessert.

    Vielen, vielen Dank an Euch!
  • Kunstkerze schrieb:

    (...)
    Fazit: Natürlich brauche ich jetzt die doppelte Zeit zum rendern, als auch die Datenmengen sind um 200% größer.
    ABER: Das ist für mich egal, weil die Warteschleife im Encoder nun funzt! Damit ist das Problem gelöst und sogar das Ergebnis wurde verbessert.

    Vielen, vielen Dank an Euch!
    Ich denke, dann kann ich hier mal schließen, da die Frage geklärt zu sein scheint.
    Falls noch Rückfragen auftauchen, oder ich anderwertig zu früh geschlossen haben sollte, so genügt eine kleine PN des Threaderstellers an mich.

    Bitte beim nächsten Mal als 'erledigt' markieren mit Doppelklick auf das rote Kästchen:



    #CLOSED