Dxtory 60 FPS Ruckeln

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Dxtory 60 FPS Ruckeln

    Anzeige
    Hi,

    ich habe das Problem das meine Dxtory Aufnahmen bei 60 FPS leicht ruckeln, es wirkt dabei als wären die FPS im Video nicht 60 sondern eher so 30-45 fps. Das ganze Video ist dabei ganz schön unruhig.
    Mit dem selben Codec habe ich das Problem nicht wenn ich den MSI AB benutze, auf den will ich aber nicht umsteigen weil der zum einen keinen Hardware Curser erfasst und zum anderen mir schon öfters die Aufnahmen zerschossen hat und einen Soundcrash herbei führen kann wegen dem ich den PC neu starten muss.

    Es ist übrigens egal welchen Codec ich benutze und welche Einstellungen. Magig YUV z.B. mit der Einstellung 4:2:0 geht es noch so mit Dxtory, beim AB ist die Aufnahme aber sehr viel flüssiger, auch wenn ich in YUV 4:4:4 aufnehmen will, aber bei Dxtory ist das am schlimmsten und beim AB noch hinnehmbar.
    Das Spielen selbst bleibt aber flüssig.

    Ich glaube auch nicht das es an der HDD liegt, die schreibt mit bis zu 200 MB/s und beide Aufnahmeprogramme wären dann davon betroffen. Am Player liegt es auch nicht weil es egal ist ob ich auf dem Windows Media Player,VLC, Sony Movie Studios Vorschau, oder bei YT schaue, DXT scheint es einfach ruckeliger aufzunehmen. (Rohaufnahme und nach dem encoding ruckeln)

    Die FPS festzusetzen ist für mich auch nicht immer eine Option (bei Shooter z.B. will ich ohne lock spielen und aufnehmen können), der MSI AB schafft das ja auch ohne ein flüssiges Video aufzunehmen und das selbe will ich auch bei DXT.


    DIe Einstellungen interessieren euch bestimmt auch noch.
    Beim MSI wären das die Einstellungen von De-M-ON außer das ich beim RTSS das detection lvl wieder auf Low habe und den Custom Direct 3D Support auf ON weil eine dieser Einstellungen DXT blockt.
    BEi DXT sind in den Advanced Settings nur die Threads auf 8 festgelegt und beim Codec auch auf Auto gestellt.
    Bei Den Codec Einstellungen habe ich immer mit den gleichen Einstellungen getestet, ansonsten sind die auf den empfohlenden Einstellungen.

    Der PC:
    i7 4790k
    Gigabyte z87x-D3
    MSI GTX 770
    8GB G.Skill TridentX DDR3 2400Mhz
    SSDs für Win7 und Zeugs
    HDD ist extern eine Seagate Barracuda 7200.14 1TB im USB 3 Gehäuse und auch damit angeschlossen

    Wenn das Problem an Dxtory selbst liegt kann ich damit leben, aber mich interessiert es trotzdem ob man durch andere Einstellungen das ruckeln weg bekommt.
  • Anzeige

    Kraxell schrieb:

    MSI AB ist nicht so ressourcenlastig wie Dxtory ;)

    Also liegt das wirklich einfach nur an DXT. Ich teste gerade mit dem DXT Codec rum, soll ich da compress ja oder nein?

    Edit: mit compress ists sehr flüssig, allerdings sieht 4:2:0 extrem ausgewaschen aus.

    Edit2: Hohe Farbquali will mein PC wohl einfach nicht und ruckelt bei 60 FPS, bleibt das halt für 30 FPS mit upsampling gemerkt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dragobee ()

  • OverDev schrieb:

    Wenn du den VLC Player nutzt ist es kein Wunder das er die Farben so ausgewaschen darstellt.
    Das liegt am VLC Player.
    MPC HC zeigt die Farben richtig an.

    Versuchs mal mit dem UT Video Codec.


    Dieses Problem habe ich schon laaange gelöst. Im Nvidia Treiber kann man die Farben für die Videoplayer auf full 0-255 stellen und wenn man die OpenGL Ausgabe aktiviert bekommt man auch die richtigen Farben.

    Die Farben werden, wenn ich das richtig verstanden habe, durch das Chromasampling (oder heißt das Farbmatrix, ka.) verursacht. Spielausgabe ist RGB. Aufnahme ist wie mans einstellt und encoding ist mit H264 standard 4:2:0 und das lässt es im direkten Vergleich blasser wirken. Nimmt man mit 4:2:0 auf und encodet ind 4:2:0 wird es wieder etwas blasser.

    Ich habe mich mit dem Thema seit diesem Thread Ausblutende Schriften lange damit auseinander gesetzt und viel rumprobiert, darum ist mir das mit der ruckelnden 60 FPS Aufnahme auch erst aufgefallen.

    Das mit dem UT Codec kann ich mal testen.
  • AFAIK im Vergleich ist RGB und 420 für das menschliche Auge nicht zu sehen bzw sehr sehr sehr sehr schwer zu sehen.
    Wenn man 420 nimmt und auch damit encodiert sollte sich überhaupt nichts verändern, aber von einem anderen Farbraum auf 420 kann es durch aus sein (außer RGB zu 420 denke ich mal).
    Aber dazu können die Profis hier im Forum dir mehr dazu sagen
  • OverDev schrieb:

    AFAIK im Vergleich ist RGB und 420 für das menschliche Auge nicht zu sehen bzw sehr sehr sehr sehr schwer zu sehen.
    Wenn man 420 nimmt und auch damit encodiert sollte sich überhaupt nichts verändern, aber von einem anderen Farbraum auf 420 kann es durch aus sein (außer RGB zu 420 denke ich mal).
    Aber dazu können die Profis hier im Forum dir mehr dazu sagen

    Dann muss ich ein Übermensch sein, ich sehe den Unterschied, zumindestens im direkten Vergleich. Ich habe vom MSI AB das OSD aktiv und die Farbe davon ist ja sehr kräftig und daran erkennt man sofort das es schlechter ist.
    Mich hatte dieses Problem auch schon länger gestört (rot wird orange), ich wusste nur nicht das es daran lag.

    BTW. Der Tipp mit UT Video Codec war sehr gut, RGB in 60fps ist damit viel flüssiger.
  • OverDev schrieb:

    Da bringt dir RGB recht wenig.

    Das hängt davon ab, was er mit seinem Material machen möchte.
    Hochskalieren auf 1152p oder gar 1800p? Super, RGB Material wird dir das beste Ergebnis liefern.
    Auch YouTube freut sich aber über höherqualitative Quellen, dazu zählt auch RGB.
    Der Qualitätsunterschied mag gering sein, aber ein hochgeladenes RGB/YUV444 Video sollte besser aussehen als das selbe Video in YUV420.
    Unter welchen Umständen es wirklich sichtbar ist, wird jemand anderes wohl eher beurteilen können.

    Hätte mich außerdem interessiert um welches Spiel es sich handelt und in welcher Auflösung aufgenommen wird.
  • Ich hab schon Material hochgeladen, der Farbunterschied ist gewaltig. Ich habe RGB zu YUV 4:4:4, YUV 4:2:2 und YUV 4:2:0 Videos für einen direkten Vergleich.
    youtube.com/watch?v=xWq7Na9-wRk&feature=youtu.be
    youtube.com/watch?v=-PogxD_f9Ds&feature=youtu.be
    youtube.com/watch?v=EM6HSmOBNWM&feature=youtu.be

    Wenn man 2 Fenster öffnet und die Videos aneinander hält sieht man den Unterschied sehr stark am OSD.
  • Nun gehört ein solches OSD aber allgemein nicht zu den üblichen Elementen eines Spiels.
    Klar, dass du es dort am ehesten bemerkst, aber gerade Battlefield ist nicht wirklich toll zum Vergleichen, verpixelt immerhin sofort, wenn du dich auch nur irgendwie bewegst.

    Desweiteren kommt hinzu, dass du schauen musst, ob du nun den VP9 oder den H264 Encode bekommst beim Vergleichen, das macht nämlich auch einen Unterschied. Dein YUV420 Material hat den VP9 Encode, welchen ich aber nur mit Chrome abrufen kann. Der Internet Explorer zeigt beim YUV420 Video dagegen den H264 Encode an. Hoffe mal du hast nicht mit Chrome verglichen, denn zusätzlich dazu zeigt Chrome H264 Material in PC Range an und verfälscht dir die Farben. Das passiert bei VP9 anscheinend nicht, der IE hingegen zeigt auch H264 mit korrekten Farben an.

    Hier mal ein paar Vergleiche. Links ist immer der Internet Explorer, rechts Chrome. Jeweils einmal mit Statistik und ohne.
  • Kayten schrieb:

    Nun gehört ein solches OSD aber allgemein nicht zu den üblichen Elementen eines Spiels.
    Klar, dass du es dort am ehesten bemerkst, aber gerade Battlefield ist nicht wirklich toll zum Vergleichen, verpixelt immerhin sofort, wenn du dich auch nur irgendwie bewegst.

    Desweiteren kommt hinzu, dass du schauen musst, ob du nun den VP9 oder den H264 Encode bekommst beim Vergleichen, das macht nämlich auch einen Unterschied. Dein YUV420 Material hat den VP9 Encode, welchen ich aber nur mit Chrome abrufen kann. Der Internet Explorer zeigt beim YUV420 Video dagegen den H264 Encode an. Hoffe mal du hast nicht mit Chrome verglichen, denn zusätzlich dazu zeigt Chrome H264 Material in PC Range an und verfälscht dir die Farben. Das passiert bei VP9 anscheinend nicht, der IE hingegen zeigt auch H264 mit korrekten Farben an.

    Hier mal ein paar Vergleiche. Links ist immer der Internet Explorer, rechts Chrome. Jeweils einmal mit Statistik und ohne.


    Battlefield ist nur ein Beispiel weil es schnell startet und ich sofort eine gleichbleibende Teststrecke habe an der ich schnell Fehler sehen kann, das OSD ist auch ein Teil davon.
    Battlefield ist auch nicht das einzige Spiel auf dem Markt, auf meinem Kanal habe ich gerade Child of Light abgeschlossen und die Trine Triologie soll folgen und das sind keine Battlefield Grau in Grau Spiele.
    Wenn ich mit dem Flashplayer vergleicheh habe ich genau den selben Unterschied, das YUV 420 ist am schlechtesten und das RGB zu YUV 444 ist am kräftigsten und das ist genau der selbe Unterschied den ich auch direkt am PC sehe.
  • Es klingt für mich ziemlich unlogisch, dass das funktioniert.
    Die Videos auf YT sind alle in TV Range und Chrome gibt in PC Range aus.
    Jetzt erzwinge ich im Treiber, dass alles in PC Range ausgegeben wird und es funktioniert?
    Dafür hätte ich gerne eine genauere Erklärung oder zumindest eine Korrektur dessen, was ich falsch verstanden habe.
  • GelberDrache92 schrieb:

    Youtube = TV Range
    Chrome = PC Range
    Es wird richtig von TV auf PC Range umgerechnet.
    Dadurch das die Grafikkarte in TV Range ausgibt wird das richtig Umgerechnete einfach abgeschnitten.
    Deswegen GPU auf Pc und fertig, damit nicht abgeschnitten wird.


    Ich hab was das angeht eine Frage wegen einer Einstellung im Sagaras SC. Man kann ja bei der Farbmatrix zwischen Dst TV.709 und PC.709 auswählen. Standardmäßig ist es auf TV und ich habe es auch so belassen.
    Soll ich es umstellen?

    Nochmal zum nachvollziehen wie ich das mache.

    Aufnahme in RGB 24 (oder wahlweise auch YUV444), Sony Vegas schneiden, dann über den Frameserver ins RGB und der Videoclip wird im SSG zu YV24 konvertiert mit aktivem Chroma Resample und die Farbmatrix Dst TV.709.
    In MeGui mit dem Befehl "--output-csp i444" dann encodet damit der nicht wieder ins YUV420 geht.

    Soweit alles richtig oder geht das besser? Es geht hier nur darum möglichst die Farben vom Spiel auch im fertigen Video zu haben bevor YT daran rumwerkeln darf.
  • Überzeugt mich immer noch nicht ganz, weshalb ist der Internet Explorer dann nicht auch davon betroffen wenn es die "Schuld" der Grafikkarte ist?
    Da dieser es vorher offensichtlich korrekt ausgegeben hat: Stellt er es nun falsch dar aufgrund der erzwungenen PC Range?

    GelberDrache92 schrieb:

    Dadurch das die Grafikkarte in TV Range ausgibt

    Das stört mich an deiner Erklärung. Ich könnte es dann verstehen, wenn Chrome TV Range in PC Range umrechnet und dann verlangt, dass es als TV Range ausgegeben wird (falsche Farben), was nun allerdings über den Treiber umgangen wird, während der IE von sich aus bereits möchte, dass in PC Range ausgegeben werden soll.
    Der Treiber hat hier aus meiner Sicht generell nichts damit zu tun und gibt nur das weiter, was ihm vorgesetzt wird.
    Außer man erzwingt es explizit.

    Dragobertel schrieb:

    der Videoclip wird im SSG zu YV24 konvertiert mit aktivem Chroma Resample

    Generelle Frage: Warum sollte man das (de)aktivieren?
    Der SSM gibt dafür keine Erklärung und verweist nur auf eine Website, die beim Beantworten dieser Frage kaum weiter hilft.