SagaraS Scriptmaker Error

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Dann einmal die Mediainfo der Aufnahme <- auf das Wort Mediainfo klicken und der Erklärung folgen
    Und das verwendete Skript.
    Bzw. Hattest du MeGui vor der Installation vom SSM und dem Avisynth das beim SSM dabei ist schon einmal geöffnet?
    Ansonsten noch mal kurz MeGui neu runterladen und dann sollte es gehen, weiß gerade nicht wo man in MeGui umstellt das es auf das installierte Avisynth zugreift @De-M-oN
  • Anzeige
    General
    Complete name : F:\Youtube Videos\arma3 2015-05-18 17-46-45-684.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format profile : OpenDML
    File size : 19.1 GiB
    Duration : 13mn 23s
    Overall bit rate : 204 Mbps
    Original source form/Distributed by : Video:MagicYUV lossless video codec v1.1 (32 bit) Audio0:Lautsprecher (Logitech G35 Headset) Audio1:Mikrofon (Logitech G35 Headset)
    Writing application : DxtoryCore ver2.0.0.122

    Video
    ID : 0
    Format : MAGY
    Codec ID : MAGY
    Duration : 13mn 23s
    Bit rate : 202 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate : 30.000 fps
    Bits/(Pixel*Frame) : 3.241
    Stream size : 18.9 GiB (99%)

    Audio #1
    ID : 1
    Format : PCM
    Format settings, Endianness : Little
    Format settings, Sign : Signed
    Codec ID : 1
    Duration : 13mn 23s
    Bit rate mode : Constant
    Bit rate : 1 536 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Bit depth : 16 bits
    Stream size : 147 MiB (1%)
    Alignment : Aligned on interleaves
    Interleave, duration : 999 ms (29.98 video frames)

    Audio #2
    ID : 2
    Format : PCM
    Format settings, Endianness : Little
    Format settings, Sign : Signed
    Codec ID : 1
    Duration : 13mn 23s
    Bit rate mode : Constant
    Bit rate : 1 152 Kbps
    Channel(s) : 1 channel
    Sampling rate : 48.0 KHz
    Bit depth : 24 bits
    Stream size : 110 MiB (1%)
    Alignment : Aligned on interleaves
    Interleave, duration : 999 ms (29.98 video frames)
  • MeGUI ist neu Installiert funktioniert aber immer noch nicht und wie stlle ich auf UT Video YUV 4:2:2 BT.709 mit Predic Media ?

    ### SagaraS Scriptmaker - Version 5.6 ###

    ### Lade Plugins und setze die globalen Variablen ###
    LoadPlugin("C:\Program Files (x86)\SagaraS Scriptmaker\Plugins\SplineResize.dll")
    Global breite = 2560
    Global hoehe = 1440
    Global AR = 0

    ### Lade Videoquellen ###
    AVIload("C:\Users\Tom\Desktop\Youtube\YouTube Videos\Altis Life Umschau #1.1new.avi", 0, 0, 0, -0, -0, "Auto", "Auto", 0, 0)

    ### Filter Verarbeitungszone ###

    ### Funktion für Video-Laderoutine ###
    Function AVIload (String file, int loading, int cl, int co, int cr, int cu, string pixtype, string afps, int fpsn, int fpsd) {
    (loading == 1) ? FFIndex(file) : nop()
    clip0 = (loading == 3) ? LWLibavVideoSource(file) : (loading == 2) ? Import(file).KillAudio() : (loading == 1) ? FFVideoSource(file, threads=1) : (pixtype == "Auto") ? AVISource(file, false).KillAudio() : AVISource(file, false, pixel_type=pixtype).KillAudio()
    clip1 = clip0.AutoFPS(afps, fpsn, fpsd).Cropping(cl, co, cr, cu)
    Return (clip1.width == breite && clip1.height == hoehe) ? clip1.ConvertToYV12(matrix = "Rec709", ChromaResample = "Spline16") : Clip1.Resize()
    }

    Function AutoFPS (Clip clip0, string afps, int fpsn, int fpsd) {
    rate1 = (afps == "Auto") ? (Round(Float(clip0.framerate * 1000)) / 1000) / 2 : nop()
    rate2 = (afps == "Auto") ? Round(clip0.framerate) / 2 : nop()
    rate = (afps == "Auto") ? (rate1 == rate2) ? 1 : 1001 : (afps == "Igno.") ? clip0.frameratedenominator : fpsd
    ratefaktor = (afps == "Auto") ? (rate == 1001) ? 1000 : 1 : nop()
    clip0 = (afps == "Auto") ? (rate == 1001) ? clip0.AssumeFPS(Round(clip0.Framerate) * 1000, rate) : clip0.AssumeFPS(round(clip0.framerate), rate) : (afps == "Igno.") ? clip0.AssumeFPS(clip0.frameratenumerator, rate) : clip0.AssumeFPS(fpsn, rate)
    Return clip0
    }

    Function Cropping (Clip clip0, int cl, int co, int cr, int cu) {
    clip0 = (clip0.IsRGB32() == True) ? clip0.ConvertToRGB24() : clip0
    Return (cl != 0 || co != 0 || cr != 0 || cu != 0) ? clip0.Crop(cl, co, cr, cu) : clip0
    }

    Function Resize (Clip clip1) {
    clip1 = (AR == 1) ? ((float(Clip1.height * breite) / clip1.width) / 2 == round((float(Clip1.height * breite) / clip1.width) / 2)) ? ((float(Clip1.width * hoehe) / clip1.height) / 2 == round((float(Clip1.width * hoehe) / clip1.height) / 2)) ? clip1 : clip1.ConvertToRGB24(matrix = "Rec709") : clip1.ConvertToRGB24(matrix = "Rec709") : clip1
    clip1 = (AR == 1) ? (((clip1.width * hoehe) / clip1.height > breite) ? Clip1.Spline100Resize(breite, ceil(float(Clip1.height * breite) / clip1.width)) : Clip1.Spline100Resize(ceil(float(clip1.width * hoehe) / clip1.height), hoehe)) : clip1.Spline100Resize(breite, hoehe).ConvertToYV12(matrix = "Rec709", ChromaResample = "Spline16")
    back = (AR == 1) ? (0 == 1) ? ImageReader("", 0, clip1.framecount - 1, clip1.framerate).ChangeFPS(clip1.frameratenumerator, clip1.frameratedenominator).Spline100Resize(breite, hoehe).ConvertToYV12(matrix = "Rec709", ChromaResample = "Spline16") : BlankClip(clip1, width = breite, height = hoehe, pixel_type = "YV12").KillAudio() : clip1
    Return (AR == 1) ? Overlay(back, clip1, (back.width - clip1.width) / 2, (back.height - clip1.height) / 2) : clip1
    }

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ArmA3Guy ()

  • Falsches AVISynth installiert.

    ChromaResample ist erst ab Version 2.6 bei den ConvertTo Befehlen enthalten. Solltest du die AVISynth Version 2.58 drauf haben, so solltest du den SSM noch mal installieren und dabei die mitgelieferte AVISynth Version anhaken um diese mitzuinstallieren.

    Ob du Version 2.58 installiert hast oder sogar ne ganz andere Version, siehst du in SSM unter Sonstiges bei Global installiertes AVISynth.

    Und wenn du 2.6 drauf hast, bzw. sogar noch die MT Version die beim SSM bei ist, so werden auch die Skripte laufen