Kurzzeitig auftretende Verpixelungen / Artefakte

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Kurzzeitig auftretende Verpixelungen / Artefakte

    Anzeige
    Hallu Leute,

    mich plagen seit einiger Zeit spontan auftretende Verpixelungen auf YouTube.
    Wenn ich mein Material gerendert habe, sieht die fertige Videodatei im Player super/fehlerfrei aus.

    Was mich jetzt nach dem Upload auf YT wundert:
    Bei komplexen Szenen sieht alles okay aus, dann "zuckt" das Bild immer mal wieder für ca. 1 Sekunde in Unschärfe (massive Artefaktanhäufung) und danach geht es normal scharf weiter. Obwohl sich die Komplexität des Materials an den Stellen nicht ändert und keine radikalen Bewegungen stattfinden.

    Hier ein Video von mir, wo es die ersten 30 Sekunden einige Male passiert:
    youtu.be/N7oIYMOdg8g

    Ich schneide in Sony Vegas und rendere über den Frameserver mit MeGUI.
    Script sieht derzeit so aus:

    Quellcode

    1. AVISource("F:\GamesNine\Morrowind Pixelung Test.avi", audio=false).AssumeFPS(60,1)
    2. #deinterlace
    3. #crop
    4. Spline16Resize(2048,1152)
    5. #denoise
    6. ConvertToYV12()

    Nutze CRF 19 für x264
    Aufnahme erfolgt mit FRAPS in 60fps
    Falls ihr mehr Informationen braucht, gerne sagen.

    Sicher kann man einiges am Setup noch verbessern und damit bekomme ich auch nicht die optimale Farbwiedergabe und Schärfe auf YouTube.
    Ich spiele generell Games mit einer enormen Komplexität, was viele Szenen schnell nach Brei aussehen lässt.
    Wer das verlinkte Video im Vollbild auf 1080p anschaut, wird auch sehen, dass ich wohl einiges mehr an den Einstellungen drehen muss, damit ich ein klares Bild bekomme.

    Falls es dafür eine offensichtliche Lösung gibt - gerne her damit!

    10bit-Encode soll angeblich auch einiges bringen, aber ich habe gelesen, dass die Dateien dadurch nicht mehr abspielbar sind mit einem Player?
    Wäre mir persönlich wichtig, da ich meine Videos vor einem Upload immer auf Fehler überprüfe.

    Mir geht es primär darum, diese scheußlichen spontan auftretenden Pixelbilder auszumerzen.

    Nach viel eigenem, erfolglosen Rumprobieren hoffe ich jetzt auf eure Hilfe.

    Vielen lieben Dank!

    Beste Grüße,
    St.One
  • St.One schrieb:

    10bit-Encode soll angeblich auch einiges bringen, aber ich habe gelesen, dass die Dateien dadurch nicht mehr abspielbar sind mit einem Player?


    Mit einem HARDWARE player.

    Ein Computer kann es selbstverständlich abspielen.

    __

    nenn mal eine Zeitstelle. Bis 1:10 war jedenfalls alles normaler Ablauf, wie eine 1080p auf youtube eben aussieht. Das beschriebene phänomen kann ich ebenso nicht bestätigen bis zu diesem Zeitpunkt.
    Aktuelle Projekte/Videos


  • De-M-oN schrieb:

    St.One schrieb:

    10bit-Encode soll angeblich auch einiges bringen, aber ich habe gelesen, dass die Dateien dadurch nicht mehr abspielbar sind mit einem Player?


    Mit einem HARDWARE player.

    Ein Computer kann es selbstverständlich abspielen.

    __

    nenn mal eine Zeitstelle. Bis 1:10 war jedenfalls alles normaler Ablauf, wie eine 1080p auf youtube eben aussieht. Das beschriebene phänomen kann ich ebenso nicht bestätigen bis zu diesem Zeitpunkt.


    Bei z.B. 0:10 und 0:15 pixelt das Bild deutlich kräftiger zu. Kurz danach "fängt" es sich wieder.
  • Anzeige

    GelberDrache92 schrieb:

    Da du 60 Fps hast musst du noch etwas bis zum besseren Encode von Youtube warten


    Wenn denn 308 überhaupt kommt. Bei mir war es ja nur 'nen reiner Glücksfall.

    Man kann ja schon dankbar sein, wenn VP9 auftaucht - denn das ist ja auch nicht immer der Fall :(
    Aktuelle Projekte/Videos


  • GelberDrache92 schrieb:

    Abwarten und Tee trinken, das ist der 1080p Encode von Youtube.
    Da du 60 Fps hast musst du noch etwas bis zum besseren Encode von Youtube warten


    Auch bei seit einer Weile hochgeladenen 60fps-Videos habe ich das :/

    Bei etwas älteren Videos in 30fps sind die Pixelungen brutal, z.B. youtu.be/vCdW8_tDYLo ab 12:40
    Muss ich das einfach hinnehmen bei dem Material?
  • St.One schrieb:

    Muss ich das einfach hinnehmen bei dem Material?


    Mach 50 oder 45 fps.

    Weniger Frames die mit bitrate versorgt werden müssen.

    Ansonsten 30fps @ 2048x1152 machen. Das gibt dir in jedem Fall die 10000er Bitrate.

    Ansonsten bei HFR drauf warten das Encode 308 für alle aktiviert wird. Deren HFR 1440 sieht jedenfalls fantastisch aus.
    Aktuelle Projekte/Videos


  • De-M-oN schrieb:

    St.One schrieb:

    Muss ich das einfach hinnehmen bei dem Material?


    Mach 50 oder 45 fps.

    Weniger Frames die mit bitrate versorgt werden müssen.

    Ansonsten 30fps @ 2048x1152 machen. Das gibt dir in jedem Fall die 10000er Bitrate.

    Ansonsten bei HFR drauf warten das Encode 308 für alle aktiviert wird. Deren HFR 1440 sieht jedenfalls fantastisch aus.


    Also bekomme ich ab 2048x1152 egal auf welcher Framezahl die gleiche Bitrate freigeschaltet? Hatte insgeheim auf mehr Bitrate gehofft, deswegen auch aufgestockt auf 60fps.
  • St.One schrieb:

    Also bekomme ich ab 2048x1152 egal auf welcher Framezahl die gleiche Bitrate freigeschaltet?

    Nein. Meines Wissens nach bekommst du ~10.000kbit/s bei 1152p (1440p). Ab 45FPS gibt es mehr Bitrate, ~14.000kbit/s bei 1152p, was von YouTube aber bisher nur in sehr wenigen Fällen freigeschaltet wurde.
    Wenn du daher definitiv eine höhere Bildqualität willst und auf die hohe Framerate verzichten kannst, dann wäre 1152p@30FPS eine Alternative für dich, eben weil du dann die 1440p definitiv bekommst (wenn auch als Ersatz für die eigentliche 1080p Stufe, aber das ist ein anderes Thema).

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Kayten ()

  • Kayten schrieb:


    ~14.000kbit/s bei 1152p, was von YouTube aber bisher nur in sehr wenigen Fällen freigeschaltet wurde.
    Wenn du daher definitiv eine höhere Bildqualität willst und auf die hohe Framerate verzichten kannst, dann wäre 1152p@30FPS eine Alternative für dich

    Jap, mir geht es wirklich nur um die Bildqualität.
    Woran erkenne ich (falls überhaupt), dass ich die erhöhte Bitrate freigeschaltet bekommen habe?
  • St.One schrieb:

    Woran erkenne ich (falls überhaupt), dass ich die erhöhte Bitrate freigeschaltet bekommen habe?


    Naja wenn die höhere Auflösung halt spielt und nicht 1080p.

    Rechtsklick aufs Video und dann statistiken aufrufen - da steht dann bei Resolution die Auflösung des Videos und auch die FPS.

    Und bei DASH steht die Encode ID Nummer von Video und Audio.

    308 wäre der HFR 1440p encode.
    Aktuelle Projekte/Videos


  • Danke für die Info!
    Dann werde ich vorerst wie es aussieht bei 30fps bleiben.
    Diese spontanen Verpixelungen sind mir aber immer noch ein Rätsel. Scheinbar gibt es dafür jedoch bei komplexem Material keine Lösung.

    Außer auf Spline100 umzusteigen, fällt mir sonst nichts ein, um das Problem einzudämmen.
    Gibt es sonst etwas, das ich übersehe, um die Bildqualität noch etwas zu pushen? Will Frameserver und Vegas beibehalten.