Elgato aufnahme Tonspur länger als Video

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Elgato aufnahme Tonspur länger als Video

    Anzeige
    Guten Tag zusammen,

    ich bin zur Zeit bei meinem Projekt the Witcher 3 dran und nehme mit der Elgato Game Capture Card auf.
    Nach der Aufnahme exportiere ich die Dateien auf den Dekstop und kann sie anschließend mit Sony Vegas Pro bearbeiten.

    in 90 % der Fälle ist die audio und bildspur in sony vegas pro dann auch synchron (also ingamesound und ingamebild). aber in den anderen 10% ist es manchmal so dass die Tonspur auf einmal länger ist. fast 1 minute.
    Video ist dann im media player oder auch bei Vegas in der vorschau asynchron.
    Im Programm Game Capture HD ist es aber komplett synchron.

    Nun dachte ich mir: ok da es nicht immer der fall ist ist es vllt ab und zu mal ein softwarefehler beim Export der die Tonspur langsamer verarbeitet, sodass sich am ende quasi 1 minute sammelt. deswegen habe ich dann bei sony vegas die Tonspur beschleunigt, sodass sie genau so lang war wie die bildspur, aber es passt nicht. habe auch die Bildspur verlangsamt bis sie so lange war wie die Tonspur. dies hat leider auch nicht geklappt.
    Um eine synchronität zu erhalten müsste ich jede minute paar sekunden abschneiden. aber das kann ja nicht die lösung sein...

    Jetzt bin ich ratlos wie ich:

    a) das problem mit Vegas pro vllt lösen kann bzw. eine einstellung im Programm Game Capture HD einstellen kann um das problem bei manchen exports zu beheben..

    b) wodurch dieses problem überhaupt entsteht. da ich heute 8 parts aufgenommen habe und alle anderen 7 perfekt sind. habe alle 25 minuten mal pause gemacht und den neuen part angefangen, aber alles am stück
    mit den gleichen einstellungen, der selben soft und hardware.
    (Im hintergrund am PC lief auch nichts außer audacity und game capture HD)

    hat hier jemand vllt erfahrungen?


    mfg Renso
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ
  • @renso

    Kann es eventuell sein das du beim Import in Sony Vegas eine andere FPS Zahl eingestellt hast als bei der Elgato?
    Wenn die Elgato mit 30 FPS aufnimmt und du in Sony Vegas mit 29,97 Importierst, wird die Videodatei länger oder Kürzer als das Audio.
    Check das mal, ich hatte dieses Problem auch schon und bin erst nach langem Suchen drauf gestossen.
  • Scrooge McDuck schrieb:

    @renso

    Kann es eventuell sein das du beim Import in Sony Vegas eine andere FPS Zahl eingestellt hast als bei der Elgato?
    Wenn die Elgato mit 30 FPS aufnimmt und du in Sony Vegas mit 29,97 Importierst, wird die Videodatei länger oder Kürzer als das Audio.
    Check das mal, ich hatte dieses Problem auch schon und bin erst nach langem Suchen drauf gestossen.


    gibt es noch extra importeinstellungen für vegas? oder meinst du jetzt nur die Projekteigenschaften? denn die sind auf 29,97 gestellt.
    Leider funktionieren ja manche gut und manche wiederum nicht. wenn der fehler immer wäre, wäre es verständlich aber so ist es bisschen komisch.

    Fehlerhafte datei:

    General
    Complete name : C:\Users\Rene\Desktop\twpart11.mp4
    Format : MPEG-4
    Codec ID : M4V
    File size : 4.25 GiB
    Duration : 20mn 43s
    Overall bit rate mode : Variable
    Overall bit rate : 29.3 Mbps
    Movie name : Meine großartige Aufnahme
    Description : Hier Beschreibung einfügen.
    Recorded date : 2015-05-30
    Encoded date : UTC 2015-05-30 13:13:49
    Tagged date : UTC 2015-05-30 13:13:49

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4
    Format settings, CABAC : Yes
    Format settings, ReFrames : 2 frames
    Format settings, GOP : M=2, N=8
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 19mn 43s
    Bit rate mode : Variable
    Bit rate : 30.6 Mbps
    Maximum bit rate : 40.0 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Variable
    Frame rate : 29.970 fps
    Minimum frame rate : 8.815 fps
    Maximum frame rate : 29.970 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.493
    Stream size : 4.21 GiB (99%)
    Language : English
    Encoded date : UTC 2015-05-30 13:13:49
    Tagged date : UTC 2015-05-30 13:13:49
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 20mn 43s
    Source duration : 20mn 43s
    Bit rate mode : Constant
    Bit rate : 216 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 32.0 MiB (1%)
    Source stream size : 32.0 MiB (1%)
    Language : English
    Encoded date : UTC 2015-05-30 13:13:49
    Tagged date : UTC 2015-05-30 13:13:49
    mdhd_Duration : 1243222


    Mediainfo einer datei wo es klappt:

    General
    Complete name : C:\Users\Rene\Desktop\Letsplaysalt\twpart12.mp4
    Format : MPEG-4
    Codec ID : M4V
    File size : 4.95 GiB
    Duration : 23mn 25s
    Overall bit rate mode : Variable
    Overall bit rate : 30.2 Mbps
    Movie name : Meine großartige Aufnahme
    Description : Hier Beschreibung einfügen.
    Recorded date : 2015-05-31
    Encoded date : UTC 2015-05-31 13:20:12
    Tagged date : UTC 2015-05-31 13:20:12

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4
    Format settings, CABAC : Yes
    Format settings, ReFrames : 2 frames
    Format settings, GOP : M=2, N=8
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 23mn 25s
    Bit rate mode : Variable
    Bit rate : 30.0 Mbps
    Maximum bit rate : 40.0 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 29.970 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.483
    Stream size : 4.91 GiB (99%)
    Language : English
    Encoded date : UTC 2015-05-31 13:20:12
    Tagged date : UTC 2015-05-31 13:20:12
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 23mn 25s
    Source duration : 23mn 25s
    Bit rate mode : Constant
    Bit rate : 216 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 37.1 MiB (1%)
    Source stream size : 37.1 MiB (1%)
    Language : English
    Encoded date : UTC 2015-05-31 13:20:12
    Tagged date : UTC 2015-05-31 13:20:12
    mdhd_Duration : 1405550
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ
  • Anzeige
    Wie du siehst, ist bei der fehlerhaften Datei die Tonspur 1 Minute länger als das Video, wodurch du da auch mit den Einstellungen aus Vegas nichts mehr ändern kannst.

    Das Problem liegt also an dem, was die Elgato ausgibt....
    Hast du denn irgendwelche Einstellmöglichkeiten, was die Elgato betrifft?
    #1 (Shinigami) -- Let's Play Bound By Flame #53 Irrwege und starke Gegner
    --
    (Dieses Video ist Teil einer Community-Aktion:
    Komm in meine Signatur)
  • jops das ist mir auch direkt aufgefallen. genauso wie das die datei eigentlich 29,97 fps haben sollte aber in vegas dann nur 29,450 fps.

    einstellungen der elgato sehen so aus:

    bilder-upload.eu/show.php?file=39b508-1433172185.jpg


    wenn ich es vor dem export in der Software abspiele läuft es perfekt ;/
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von renso ()

  • renso schrieb:

    gibt es noch extra importeinstellungen für vegas? oder meinst du jetzt nur die Projekteigenschaften? denn die sind auf 29,97 gestellt.
    Leider funktionieren ja manche gut und manche wiederum nicht. wenn der fehler immer wäre, wäre es verständlich aber so ist es bisschen komisch.
    Ja genau die mein ich. Stell da mal auf dassselbe wie in der elgato und das müsste dann wieder gleich lang sein.
  • hier ein video dazu:

    dann sieht man das problem und alle einstellungen.

    früher hatte hier jemand mal das gleich eproblem. er meinte seine lösung sei bei win7 das audioformat für die aufnahme zu ändern. aber daraus wurde ich nicht schlau.

    hier das video:

    youtu.be/ZbqKE1R5qp0
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ
  • Genau dasselbe Problem hatte ich auch und zwar hab ich die Lösung schon oben gepostet ;)
    Die Aufnahmenframerate muss dieselbe sein wie in den Projekteinstellungen von Sony Vegas. Du nimmst mit 30FPS auf, dann stell mal das Vegas Projekt auf 30 FPS und importiere die Dateien neu (vorher aber das gespeicherte Projekt löschen und neu anlegen sonst funktionierts nicht). Dann dürftest du dein Problem los sein.
  • Wie schon gesagt, der Fehler liegt bereits in der Rohdatei, wie du anhand der MediaInfo siehst. Klar, das mit Vegas kann er natürlich ausprobieren, aber obs was bringt? Ich habe meine Zweifel.

    Zumal er ja keine konstanten 30FPS hat, sondern mit VFR aufgenommen wurde...
    #1 (Shinigami) -- Let's Play Bound By Flame #53 Irrwege und starke Gegner
    --
    (Dieses Video ist Teil einer Community-Aktion:
    Komm in meine Signatur)
  • ja ich denke meine parts sind verloren. ich bräuchte nur den Tipp wie man bei der software der elgato konstante FPS einstellen kann, weil das will ich sowieso haben.
    ich dachte das sei automatisch so, weil die anderen 10 aufnahmen vorher auch top waren :D.

    wenn ich die konstanste FPS rate bei dem Elgatoprogramm einstellen könnte, wäre alles perfekt.

    Scrooge:
    laut mediainfo sind die datei normalerweiße immer 29,97 fps. und das projekt bei Sony vegas ist immer auf 29,97 eingestellt.
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ
  • ich habe die FR nun von variable auf constant bei dem video ändern können und es neu damit rendern lassen. nun hat es konstant eine FR von 29,97, aber leider ist der Ton immer noch fast 1 minute länger als das video und alles ist asynchron.

    hat jemand vllt noch eine idee was es sein könnte?
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ
  • Natürlich sind die Änderungen erst in der nächsten Aufnahme aktiv.

    Zeig uns doch bitte mal noch die anderen Registerkarten, wenn ich mir das oben durchlese sehe ich bei deinen Einstellungen mehr als nur Optimierungsbedarf.
    Und 29.97 FPS sind auch nix, weil Ghostinggefahr - geh hoch auf 30.
    #1 (Shinigami) -- Let's Play Bound By Flame #53 Irrwege und starke Gegner
    --
    (Dieses Video ist Teil einer Community-Aktion:
    Komm in meine Signatur)
  • also auf 30 fps würde ich sehr gerne gehen, aber soweit ich weiß nimmt die elgato nur 29,97 fps auf :(.

    Hier die registrierkarten:

    fotos-hochladen.net/uploads/einstellungenelwblnyacgiv.jpg
    Du spielst gerne Horrorspiele? Schaust auch gerne Rollenspiele und magst lustige Skype bzw TeamSpeak runden?
    Dann bist du bei meinem Kanal genau richtig! Er ist noch neu in der Entwicklung aber Horror, Spaß und tolle Skypeabende
    erwarten dich!

    youtube.com/channel/UCs0NDM4sIV2W_CTjpF7AaXQ