Sony Vegas will nicht 1920x1200 format rendern

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Sony Vegas will nicht 1920x1200 format rendern

    Anzeige
    Hey Leute.

    Ich versuche gerade mit sony vegas ein Video mit dem format 1920x1200 zu rendern.
    Irgendwie wird das aber von den codecs, die es da gibt, nicht unterstützt, beim rendern erhalte
    ich eine fehlermeldung von wegen fehlerhafte parameter.

    Hat da jemand eine Idee, oder selbst schon mal gemacht?

    Vielen Dank! :)
  • mymaksimus schrieb:

    Hat da jemand eine Idee, oder selbst schon mal gemacht?
    Konkret gesagt wär's zu empfehlen, den dürftigen internen Encoder von Vegas zu wechseln und x264 in irgendeiner Form zu verwenden, auch wenn's etwas aufwändiger wäre. Details dazu, was ich meine, gibt's z.B. hier. Man würde dann die 1680 x 1050 in Vegas belassen und erst im SSM die höhere Auflösung einstellen.

    Wenn du nur das Problem lösen willst, ohne den Encoder zu wechseln: Welche Version von Vegas nutzt du und was hast du beim Rendern genau eingestellt? Ich konnte mit Sony Vegas 12 Pro und dem Mainconcept AVC/AAC jedenfalls problemlos in 1920 x 1200 rausrechnen, tippe also nur darauf, dass du dir den falschen Codec gepickt hast.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • mymaksimus schrieb:

    einen anderen relevanten codec habe ich nicht gefunden, aber wahrscheinlich kenne ich mich da einfach nicht gut genug aus




    Der markierte Eintrag müsste vorhanden sein - dort findest du Codecs, die funktionieren sollen. Als Beispiel mal eine Vorlage für Mainconcept AVC/AAC, die bei mir fehlerfrei rendert. Oder, wie gesagt, mal das Tutorial geben - man könnte sich zwar dort ein, zwei Schritte sparen, es zeigt aber, wie man einen eigenen, besseren Encoder verwendet.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • Anzeige
    uhm okay.. ich werds mal versuchen... danke ^^
    wusst ich nicht, dass das so scheiße ist.. ^^

    @RealLiVe : Irgendetwas mache ich falsch. habe mehrmals probiert, einen tiel zu
    rendern, mit genau den gleichen einstellungen wie in deinem bild, aber die mp4 enthält am ende nur ton..

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mymaksimus ()

  • mymaksimus schrieb:

    wusst ich nicht, dass das so scheiße ist..
    Schreibe ich ggf. morgen etwas dazu, wenn's dich interessiert und andere noch nichts dazu geschrieben haben. Kernaussage wäre, dass x264 gut an die eigenen Anforderungen anpassbar ist, generell sparsamer mit der Bitrate umgeht und bei gleicher Qualität weniger braucht - insbesondere dann, wenn die meisten Einstellungen von Mainconcept nicht anpassbar sind, wie es in Vegas leider der Fall ist.

    mymaksimus schrieb:

    @RealLiVe : Irgendetwas mache ich falsch. habe mehrmals probiert, einen tiel zu rendern, mit genau den gleichen einstellungen wie in deinem bild, aber die mp4 enthält am ende nur ton..
    Kannst du mal eine MediaInfo vom Ergebnis und Screenshots von deinen Einstellungen posten?
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • uff.. hier..
    (wieso steht da 29 fps, 60 ist eingestellt?.. naja..)

    Quellcode

    1. Allgemein
    2. Vollständiger Name : Y:\Recordings\Ohne Titel.mp4
    3. Format : MPEG-4
    4. Format-Profil : Base Media / Version 2
    5. Codec-ID : mp42
    6. Dateigröße : 3,23 MiB
    7. Dauer : 2s 236ms
    8. Modus der Gesamtbitrate : variabel
    9. Gesamte Bitrate : 12,1 Mbps
    10. Kodierungs-Datum : UTC 2015-06-24 00:12:39
    11. Tagging-Datum : UTC 2015-06-24 00:12:39
    12. Video
    13. ID : 2
    14. Format : AVC
    15. Format/Info : Advanced Video Codec
    16. Format-Profil : High@L5.1
    17. Format-Einstellungen für CABAC : Ja
    18. Format-Einstellungen für ReFrames : 5 frames
    19. Codec-ID : avc1
    20. Codec-ID/Info : Advanced Video Coding
    21. Dauer : 2s 236ms
    22. Bitraten-Modus : variabel
    23. Bitrate : 11,9 Mbps
    24. maximale Bitrate : 240 Mbps
    25. Breite : 1 920 Pixel
    26. Höhe : 1 200 Pixel
    27. Bildseitenverhältnis : 16:10
    28. Modus der Bildwiederholungsrate : konstant
    29. Bildwiederholungsrate : 29,970 FPS
    30. Standard : NTSC
    31. ColorSpace : YUV
    32. ChromaSubsampling : 4:2:0
    33. BitDepth/String : 8 bits
    34. Scantyp : progressiv
    35. Bits/(Pixel*Frame) : 0.173
    36. Stream-Größe : 3,18 MiB (98%)
    37. Sprache : Englisch
    38. Kodierungs-Datum : UTC 2015-06-24 00:12:39
    39. Tagging-Datum : UTC 2015-06-24 00:12:39
    40. colour_range : Limited
    41. colour_primaries : BT.709
    42. transfer_characteristics : BT.709
    43. matrix_coefficients : BT.709
    44. Audio
    45. ID : 1
    46. Format : AAC
    47. Format/Info : Advanced Audio Codec
    48. Format-Profil : LC
    49. Codec-ID : 40
    50. Dauer : 2s 197ms
    51. Bitraten-Modus : konstant
    52. Bitrate : 192 Kbps
    53. Kanäle : channel0
    54. Channel(s)_Original : 2 Kanäle
    55. Kanal-Positionen : Front: L R
    56. Samplingrate : 48,0 KHz
    57. Stream-Größe : 51,5 KiB (2%)
    58. Sprache : Englisch
    59. Kodierungs-Datum : UTC 2015-06-24 00:12:39
    60. Tagging-Datum : UTC 2015-06-24 00:12:39
    Alles anzeigen







    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mymaksimus ()

  • Okay, die Videospur ist vorhanden. Tippe darauf, dass dein Player Probleme macht oder ggf. der Decoder Probleme macht. Ich tippe mal drauf, dass du den Windows Media Player nutzt und keine Codecs etc. installiert hast, oder? Probier's mal stattdessen mit dem MPC-HC in der 32 Bit - Version - der bringt alles nötige mit und müsste in der Lage sein, die Datei zu öffnen. Wenn du beim Windows Media Player bleiben willst, dann müsste man was nachinstallieren - suche ich dir bei Bedarf raus.

    mymaksimus schrieb:

    (wieso steht da 29 fps, 60 ist eingestellt?.. naja..)
    Liegt an dem Haken bei "Anpassen der Framerate durch Quelle zulassen" - wenn der gesetzt ist, dann rechnet Vegas mit irgendeinem FPS-Wert - nur nicht mit dem, den du haben willst ;)

    Vegas Hilfe schrieb:

    Ist die Quellframerate größer als die Framerate der Vorlage, verwendet der Encoder entweder einen Wert, der 50 % der Quellframerate entspricht, oder den in der Einstellung Framerate ausgewählten Wert. (Es wird jeweils der niedrigere Wert verwendet.)

    Da dein Rohvideo wohl einen anderen FPS-Wert als 60.0 hat, denke daran, dass du das "Intelligente Resampling" deaktivierst. Weiß gerade nicht, wie Vegas in dem Fall genau handhabt, aber mit dem Intelligenten Resampling kommt's, wenn die FPS nicht überall gleich sind, häufig zu Ghosting-Effekten (Zwischenbilder). Manchmal ist der Effekt zwar gewünscht, meistens ist's aber schlicht hässlich :whistling:
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von RealLiVe ()

  • okay, mit dem mpc ding funktioniert es. ist wohl tatsächlich ein video.

    Stimmt.. der haken war noch drin

    Hmmm. Hab nochmal nachgeschaut.. Shadow Play nimmt anscheinend mit 59 statt wie angegeben mit 60 fps auf. Und ja, in dem Video ist tatsächlich ghosting zu sehen. Sollte ich jetzt einfach die ausgabe fps auf 59 stellen oder intelligentes Resampling deaktivieren?

    momentmal.. was ist das überhaupt, intelligentes Resampling??
  • mymaksimus schrieb:

    Shadow Play nimmt anscheinend mit 59 statt wie angegeben mit 60 fps auf. Und ja, in dem Video ist tatsächlich ghosting zu sehen. Sollte ich jetzt einfach die ausgabe fps auf 59 stellen oder intelligentes Resampling deaktivieren?
    Würde das Resampling deaktivieren, allerdings möchte ich zu ShadowPlay noch was einwerfen. Das Teil nimmt nicht mit konstanter Framerate, sondern mit variabler auf. Viele Programme setzen einen konstanten Wert voraus und es würde mich arg wundern, wenn Vegas das korrekt einlesen kann und dabei synchron bleibt. Probier's jedenfalls mal aus, bevor du dich darauf verlässt - auch mal mit einem längeren Video.

    Deswegen, und weil die Qualität bei der Aufnahme bereits arg angegriffen wird, wird eigentlich jeder hier von ShadowPlay abraten und dir nahelegen, das Aufnahmeprogramm zu wechseln, wenn möglich. Zumindest, wenn du noch mal rendern musst/willst und die Daten nicht direkt auf Youtube klatschen kannst.

    MfG
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von RealLiVe ()

  • die vorteile von shadow play überwiegen in meinem fall.
    Ich habe keine externe Festplatte, deshalb fallen die meisten Aufnahmeprogramme wie Fraps zB weg.
    Außerdem ist der Performance Verlust gleich null.

    Da wir uns mit einem Freund sowieso erst seit vorgestern mit youtube beschäftigen, reicht die qualität vorerst wahrscheinlich sogar aus ^^ Ich poste mal morgen Mittag das Video, das ich gerade dank deiner Hilfe hoffentlich richtig zum rendern bekomme. Das versuche ich übriges mal mit 59fps, wenn's schlecht wird deaktiviere ich mal morgen das resampling und dann halt nochmal rendern.
    Hier das erste "Test-Video", da ist die qualität aber komplett kacke. youtube.com/watch?v=83NJmExM13k
  • mymaksimus schrieb:

    Hier das erste "Test-Video", da ist die qualität aber komplett kacke. youtube.com/watch?v=83NJmExM13k
    Bei 720p ist wenig zu holen, wundert mich jetzt nicht ;) .

    mymaksimus schrieb:

    Da wir uns mit einem Freund sowieso erst seit vorgestern mit youtube beschäftigen, reicht die qualität vorerst wahrscheinlich sogar aus Ich poste mal morgen Mittag das Video, das ich gerade dank deiner Hilfe hoffentlich richtig zum rendern bekomme.
    Wünsch dir jedenfalls viel Glück dabei und achte drauf, ob das Video synchron bleibt. Das wäre ein Punkt, der bei ShadowPlay in Kombination mit so ziemlich allen Bearbeitungsprogrammen gerne mal in die Hose geht.

    Sollte es dazu kommen: OBS müsste mit Minecraft gut klar kommen, dort vergleichsweise wenig auf die FPS gehen und kann auch kleine Dateien ausspucken. Ist zwar etwas umständlicher in der Konfiguration, aber falls ShadowPlay failed, vielleicht einen Blick wert. Wenn man keine enorm hohen Qualitätsansprüche hat und auf verlustfreie Aufnahme verzichtet, dann lässt sich das relativ leicht mit einem Trick - neu muxen, ansonsten nimmt Vegas auch die falsche FPS-Zahl an, weil OBS das falsch in die Datei schreibt - fehlerfrei und synchron in Vegas laden.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von RealLiVe ()

  • hm naja, soll ja nicht nur minecraft aufgenommen werden. mein "kollege" nimmt noch csgo und terraria auf, ich werde wohl auch soetwas wie osu oder neverwinter, hochladen. Zusammen wollen wir auch noch planetside aufnehmen. (Also das sind jetzt "Projekt" - Ideen)
    Mal schauen. Ich werd drauf achten, und wenns gar nicht geht, befolge ich deinen rat und wechsel ^^

    an dieser stelle vielleicht mal gute nacht und vielen dank vorerst ;)

    Hier ist das gestrige Ergebnis:
    youtu.be/10sJENqGusg (yt bearbeitet noch)
    Eigentlich bin ich ganz zufrieden.. ^^

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mymaksimus ()

  • mymaksimus schrieb:

    Eigentlich bin ich ganz zufrieden..


    Ich will dir ja nicht deine optimistische Einstellung nehmen... aber.... naja....
    Ich sag es mal so, da du mit dem MainConcept Encode eh die Qualität in den Keller gekloppt hast, fällt wenigstens das Ghosting in den Macroblöcken nicht mehr so auf. ^^

    Ne, Shadowplay + MainConcept sind so das schlimmst, was du deinem Video antun kannst ;)

    Bei Shadowplay fallen schon mal sehr viele schlechte Eigenschaften an:
    - Variable Framerate (macht Vegas eigentlich schon untauglich zur Verarbeitung des Videos)
    - Falsche Farbmatrix - BT.601 (Farben vergrauen)

    - Farbraum YUV 4:2:0 (verlustreichster Farbraum)
    - Audio ist verlustbehaftet
    - Video ist verlustbehaftet

    Letzteres ist der entscheidende Punkt, warum die Videos stark an Qualität verlieren. Insgesamt wird dein Video dann 3 mal verlustbehaftet encodiert. Beim letzten Encode von Youtube selbst, ist das Video in so undeutliche Macroblöcke zerlegt, dass keine vernünftigen Bewegungsvektoren mehr gesetzt werden können. Genauso fehlen dann entscheidende B- und P-Frames. Youtube muss dann mehr Bitrate für die schlechte Komprimierbarkeit dalassen und das Video wird verschwommen und blockig.

    Sony Vegas:
    - erneute Verlustkomprimierung des Videos (siehe oben)
    - erneute Verlustkomprimierung des Audios (nochmal AAC, Tonqualität geht verloren)
    - Sony konvertiert den Farbraum von YUV nach RGB und wieder zurück (=Rundungsfehler: Farbverluste)
    - Die variable Framerate macht es unmöglich kein Ghosting zu haben.
    - MainConcept zerschießt dir auch noch das letzte bisschen Qualität mit der VBR

    Die einzige Lösung das Problem an der Wurzel zu lösen, ist das Aufnahmeprogramm zu wechseln.
    Zum Beispiel der kostenlose MSI Afterburner. Dazu einen Codec, der entweder deine Festplatte nicht belastet oder deine CPU nicht belastet (musst du entscheiden was wichtiger ist)

    In Sony Vegas entweder auf den Frameserver + SSM + MeGUI oder auf x264vfw zurückgreifen. ( x264vfw für Videoschnittprogramme (Erklärt an Magix) )
    Die Anleitung lässt sich auf Vegas übertragen ;)

    Sowohl Video als auch Audio bekommen dabei sehr viel an Qualität und das Ghosting wäre auch weg :D

    MfG
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • GrandFiredust schrieb:

    Ne, Shadowplay + MainConcept sind so das schlimmst, was du deinem Video antun kannst
    Och, was hältst du von ShadowPlay-Aufnahme und XVID-Kompression? Oder ShadowPlay-Aufnahme und CUDA-Encoding? :D Es geht immer schlimmer :D :P

    mymaksimus schrieb:

    das mit x264vfw probiere ich auch mal aus. das ist also ein anderer encoder oder?
    Ja, das ist der x264. Bitte aber hierzu der Anleitung folgen, die @GrandFiredust gepostet hat und erstmal nicht wild ausprobieren. Da gibt's 1 - 2 Dinge zu beachten, damit der halbwegs stabil läuft. Alternativ das von mir oben erwähnte Tutorial geben.

    mymaksimus schrieb:

    ich hätte gern einen codec, der meine spielperformance nicht belastet, gibt's sowas? xD (dann wohl eher einen nicht cpu lastigen oder?)
    UT-Video YUV422 BT.709 wäre da zu empfehlen, braucht allerdings ne starke und große Festplatte. Allerdings kann's sein, dass die Performance trotzdem etwas drunter leidet - die Hauptursache für die FPS-Einbusen liegt lt. Unwinder (dem Afterburner-Entwickler) nicht am Codec, sondern am Verfahren vom Aufnahmeprogramm, wie das Bild abgegriffen wird. ShadowPlay hat da ein eigenes, enorm performantes Verfahren, was aber nur Nvidia selbst zugänglich ist.

    Was mir aber an dem Testvideo aufgefallen ist: Die 1920 x 1200 sind nicht verfügbar, es wird "nur" 1728 x 1080 abgespielt - der "gute" Encode liegt nicht vor. Scheint wohl doch noch nicht durchgängig ausgerollt worden zu sein.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • GrandFiredust schrieb:

    - Falsche Farbmatrix - BT.601 (Farben vergrauen)

    Naja sie verlieren an Sättigung. Nicht mit pc vs tv range verwechseln.

    mymaksimus schrieb:

    ich hätte gern einen codec, der meine spielperformance nicht belastet, gibt's sowas?


    Wenn die Festplatte nicht der Flaschenhals darstellt ist der Performanceverlust nicht durch dem Codieren, sondern durch den Eingriff in die Grafik API.

    Dieser Text hier ist extrem interessant. Und nur deswegen ist auch Shadowplay schnell.
    forums.guru3d.com/showpost.php?p=4687310&postcount=61

    Und Nvidia reagiert darauf so:

    forums.guru3d.com/showpost.php?p=4983364&postcount=5


    Toll oder? Für andere software gesperrt, aber nvidia selber tut ihr shadowplay auch nicht richten. Ich finds auch krass, das die Maxwell Karten (GTX 9xx serie) Lossless KÖNNEN, aber Shadowplay nicht -.-


    RealLiVe schrieb:

    Was mir aber an dem Testvideo aufgefallen ist: Die 1920 x 1200 sind nicht verfügbar, es wird "nur" 1728 x 1080 abgespielt - der "gute" Encode liegt nicht vor. Scheint wohl doch noch nicht durchgängig ausgerollt worden zu sein.


    Isses. Aber nicht jeder mini Kanal bekommt direkt VP9 Codierungen. GelberDrache ist zwar ein Gegenbeweis, aber vllt spielt ja die Kanalexistenzzeit eine Rolle. Oder die Monetarisierung muss aktiv sein (addet ja so einige features). Ich weißes nicht ;D

    Aber solange da kein VP9 auftaucht, bekommt er es nicht. 1440 HFR gibt es nur in VP9.
    Er hat aber nur H.264 bekommen.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • De-M-oN schrieb:

    Isses. Aber nicht jeder mini Kanal bekommt direkt VP9 Codierungen. GelberDrache ist zwar ein Gegenbeweis, aber vllt spielt ja die Kanalexistenzzeit eine Rolle. Oder die Monetarisierung muss aktiv sein (addet ja so einige features). Ich weißes nicht ;D
    Das mit dem Alter könnte sein, mein Kanal ist ziemlich alt und die Grenze kann ja sonst wo liegen. Müsste man mal ausprobieren oder ein paar Berichte sammeln.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • GrandFiredust schrieb:

    - Falsche Farbmatrix - BT.601 (Farben vergrauen)

    WTF xD Die vergrauen nicht ^^
    Vergrauen tut es wenn PC Range in TV Range geändert wird. ^^

    Bei einem PC Range Output:


    Bei einen TV Range Output:


    RGB bleibt unverändert, da RGB keine Matrix besitzt und immer im PC Range vorliegt. RGB kann man aber in TV Range konvertieren (siehe Bilder).

    Die Matrix gibt nur die Farbkoeffizienten vor mit denen der UV (Chroma) Anteil errechnet wird. Je nach Matrix kann sie mal etwas sätiger sein oder etwas weniger sätigend.

    Den Grauton jedoch bewirkt nur wenn ein TV Range Video in einem PC Range Video abgespielt wird.

    Bei dem 2ten Bild siehst du keinen Grauschleier bei den YUV Farbräumen. Weil halt 16 - 235 als Absolut Werte gelten.

    TV vs PC Range oder besser gesagt noch Begrenzt oder Vollbereich immer zwischen kodierten Video und Ausgabe des Players betrachten. ^^