.avs in VirtualDub Frameserver -> Megui - Wie?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • .avs in VirtualDub Frameserver -> Megui - Wie?

    Anzeige
    Hallo,
    wie geht das mit dem Frameserver in Virtualdub.
    Ich komme soweit das ich meine .avs Datei in VirtualDub öffnen kann. Dort wende ich den Filter "Logoaway" an. Wie bekomme ich das Skript mit angewendetem Logoawy in Megui zum encodieren ? :)
    So lautet das Schema von Sagaras:
    Quell Video -> AVISynth -> VDUB (logoaway) - VDub Frameserver -> AVISynth -> MeGUI -> fertiges Video
    Kennt sich damit jemand aus?

    LG
  • soweit war ich fast auch - wie öffne ich die mti avisynth ? kenn mich da nicht aus weils keine gui hat :)

    Wenn ich auf Start Frameserver gehe kommt das : 2015-07-28_20-10-01_Super RTL_Sams in Gefahr.avs - das lasse ich so klicke auf start

    dann kommt das speicherfenster und ich speicher es als fim.avi z.b.

    und dann öffnet sich ein kleines fenster in dem sich nichts tut und ich habe eine fil.avi datei in meinm explorer, die ich aber nicht öffnen kann . diese muss ich jetzt in avisynth öffnen oder?

    Nur wie ?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ancrion ()

  • MeGUI öffnen - Tools - AVS Skript Creator - Video input - Video öffnen (AviSource)

    Dann ist das Video in AviSynth

    Dann ggf. Filter hinzufügen - Skript - audio=true (ersetzen) - Save

    Dann die Einstellungen für x264 (scratchpad) übernehmen und den Audio Encoder (z.B. flac) bestimmen. Und bei Audio und Video auf Queue drücken

    Zum Schluss mit mkv Merge GUI oder My MP4 Box GUI muxen und fertig ist :D
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • ja das Frameserver Mode Fesnter und Virtua Dub sind noch geöffnet.

    Graphstudio kann die Datei nicht öffnen. "Cannot open file"

    Villeicht mache ich was falsch :



    In dem ersten Fenster steht am Ende .avs

    Habe auch das Auxsetup gemacht im VirtualDub Ordner


    Dieser Beitrag wurde bereits 9 mal editiert, zuletzt von Ancrion ()

  • Versuch das mal mit der Anleitung: doom9.org/index.html?/capture/frameserving.html

    Die .vdr Datei dann mal versuchen mit AviSynth zu öffnen, bzw. wenn das nicht geht gleich mit MeGUI (also bei Video Input)

    PS: Das kommt mir generell sehr schwammig vor, da du ja versuchst die Datei aus einem (veraltetem) Frameserver (VDub) mit einem anderen Frameserver zu öffnen, also so gesehen über 2 Frameserver. Aber wenn Sagaras sagt das geht.... :whistling:
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Zoke grad Lol fertig, danach . Anleitung sieht einfach aus - Danke schonmal :))

    Ich denke es war falsch, dass ich als avi und nicht als vdr gespeichert hab - ich meld mich gleich mit dem Ergebnis:)

    EDIT : Also es geht nicht, kann die VDR bei Video Input nicht reintun Im Script creator. Kommt ne Fehlermeldung.
    Wenn ichs als Avi speicher, und bei AVS SCript Creator reintu, kommt wieder die Meldung mit dem you dont have the corect Filters installed


    Die .vdr Datei dann mal versuchen mit AviSynth zu öffnen, bzw. wenn das nicht geht gleich mit MeGUI (also bei Video Input)

    In AviSynth öffnen und in Megui bei AVS Script Creator in Video Input reinzutun ist doch das gleiche oder


    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von Ancrion ()

  • Leider nicht :( würds gerne mit Megui machen da hab ich die Einstellungen und alles schon

    Villeicht liegts auch an meinem PC dass der Frameserver nicht geht,.
    Hab Widnows 10
    weil Graphstudio kann die avi ja auch nicht öffnen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ancrion ()

  • Wie bekomm ich dann das Logoaway in mein Video'?
    Wenn ich die Settings speicher und den Logoaway Code in mein vorhandene Skript kopiere, ist der Filter viel zu groß und verschoben, obwogl ich es in VirtualDub ja passend eingestellt habe.



    in VirtualDubMod ging das, da konnte ich das Ausgangsvideo reinladen, Logoaway passend einstellen, den Code speichern und in das avs script tun.
    Aber in Virtualdubmod kanb ich keine avs dateien laden..
    also virtualdub speichet andere koordinaten in die settings als ich einstelle

    Ich denke virtualdub benutzt da andere Zahelnkombinationen als AvsPmod - wenn ich die Settings wieder in Virtual Dub lade, stimmen die Koordinaten ..

    Seit eben kann ich AVS in VirtualDubMod öffnen ahhhh :)')

    ich denke jetzt sollte es gehen ich meld mich nochmal
    Wenn das mit dem Frameserver doch nur gehen würde :(

    Kann die avs jetzt in VirtualDubMOD öffnen, aber der code bleibt die gleiche. anscheinend liegt es daran, dass ich eine avs öffne ..

    EDIT:

    Habs Problem gefunden - Ich musste diese Zeile raustun dann Logoaway einsteleln und die Zeile wieder rein:

    Spline36Resize(last.width * faktor,(last.width * 9 / 16) * faktor)


    hat jemand eine Ahnung wieso?

    Dieser Beitrag wurde bereits 10 mal editiert, zuletzt von Ancrion ()

  • Ancrion schrieb:

    hat jemand eine Ahnung wieso?


    Weil bei dir das Logoaway auf die Grundauflösung wirkt und nicht auf die Skalierauflösung.

    Siehste doch im Skript selbst das logoaway noch vor Spline36 kommt. Du hast ja vor Spline36 eine ganz andere Auflösung gehabt worauf Logoaway lief. Erst NACH logoaway skalierste das Video ja.

    Darum mussteste die Zeile entfernen, damit die Einstellungen passten. Kannst ja nicht von einer Auflösung die Werte nehmen für ein Filter der noch vor dieser Skalierung angesprochen wird.

    Einfache Logikreihenfolge beachten. AVISynth immer von Oben nach Unten lesen und entsprechend die Filter positionieren. Nicht einfach Wahllos drauf los in der Hoffnung das wird schon.
  • Ancrion schrieb:

    Ja danke habs ja durch probieren rausgefunden ;)

    jetzt klappt alles - läuft auch perfekt auf dem fernseher ohne ränderr ich danke dir Sagaras :)
    Ich denke, dann kann ich hier mal schließen, da die Frage geklärt zu sein scheint.
    Falls noch Rückfragen auftauchen, oder ich anderwertig zu früh geschlossen haben sollte, so genügt eine kleine PN des Threaderstellers an mich.

    Bitte beim nächsten Mal als 'erledigt' markieren mit Doppelklick auf das rote Kästchen:



    #CLOSED