Wie kann ich diesen Meguifehler wegbekommen ? ("Job creation aborted due to invalid AviSynth script")

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Wie kann ich diesen Meguifehler wegbekommen ? ("Job creation aborted due to invalid AviSynth script")

    Anzeige
    Hallo,
    ich habe mal wieder ein Problem. Und zwar diesmal mit Megui:
    Ich musste Megui neu installieren, weil ich es wegen einem Error nicht mehr öffnen konnte. Habe jetzt wieder meine Encodier-Vorlage bei Megui eingerichtet. Aber jetzt kommt dieser Fehler ( "Job creation aborted due to invalid AviSynth script" ), wenn ich das Skript reinlade und auf "Queue" klicke.

    Was ist das für ein Fehler und wie bekomme ich diesen weg ?

    obiwanjunobi
  • Das schaut wie alle anderen davor aus. Ich habe sogar mal eins von vorher reingeladen, das vorher auch funktioniert hat. Aber da kam die Meldung auch...
    Script:

    ### SagaraS Scriptmaker - Version 5.4 ###

    ### Lade Plugins und setze die globalen Variablen ###
    Global breite = 2048
    Global hoehe = 1152
    Global AR = 0

    ### Lade Videoquellen ###
    SetMTMode(3,2)
    AVIload("D:\Fertige Videos\netserved.avi", 0, 0, 0, -0, -0, "Auto", "Auto", 0, 0)

    ### Filter Verarbeitungszone ###

    ### Funktion für Video-Laderoutine ###
    Function AVIload (String file, int loading, int cl, int co, int cr, int cu, string pixtype, string afps, int fpsn, int fpsd) {
    (loading == 1) ? FFIndex(file) : nop()
    clip0 = (loading == 3) ? LWLibavVideoSource(file) : (loading == 2) ? Import(file).KillAudio() : (loading == 1) ? FFVideoSource(file, threads=1) : (pixtype == "Auto") ? AVISource(file, false).KillAudio() : AVISource(file, false, pixel_type=pixtype).KillAudio()
    rate1 = (afps == "Auto") ? (Round(Float(clip0.framerate * 1000)) / 1000) / 2 : nop()
    rate2 = (afps == "Auto") ? Round(clip0.framerate) / 2 : nop()
    rate = (afps == "Auto") ? (rate1 == rate2) ? 1 : 1001 : (afps == "Igno.") ? clip0.frameratedenominator : fpsd
    ratefaktor = (afps == "Auto") ? (rate == 1001) ? 1000 : 1 : nop()
    clip1 = (afps == "Auto") ? (rate == 1001) ? clip0.AssumeFPS(Round(clip0.Framerate) * 1000, rate) : clip0.AssumeFPS(round(clip0.framerate), rate) : (afps == "Igno.") ? clip0.AssumeFPS(clip0.frameratenumerator, rate) : clip0.AssumeFPS(fpsn, rate)
    clip1 = (clip1.IsRGB32() == True) ? clip1.ConvertToRGB24() : clip1
    clip1 = (cl != 0) ? clip1.Crop(cl, co, cr, cu) : (co != 0) ? clip1.Crop(cl, co, cr, cu) : (cr != 0) ? clip1.Crop(cl, co, cr, cu) : (cu != 0) ? clip1.Crop(cl, co, cr, cu) : clip1
    clip1 = (clip1.width == breite && clip1.height == hoehe) ? clip1 : (AR == 1) ? ((float(Clip1.height * breite) / clip1.width) / 2 == round((float(Clip1.height * breite) / clip1.width) / 2)) ? ((float(Clip1.width * hoehe) / clip1.height) / 2 == round((float(Clip1.width * hoehe) / clip1.height) / 2)) ? clip1 : clip1.ConvertToRGB24(matrix = "Rec709") : clip1.ConvertToRGB24(matrix = "Rec709") : clip1
    clip1 = (clip1.width == breite && clip1.height == hoehe) ? clip1 : (AR == 1) ? (((clip1.width * hoehe) / clip1.height > breite) ? Clip1.Spline36Resize(breite, ceil(float(Clip1.height * breite) / clip1.width)) : Clip1.Spline36Resize(ceil(float(clip1.width * hoehe) / clip1.height), hoehe)) : clip1.Spline36Resize(breite, hoehe).ConvertToYV24(matrix = "Rec709", ChromaResample = "Spline36")
    back = (clip1.width == breite && clip1.height == hoehe) ? clip1 : (AR == 1) ? (afps == "Auto") ? (0 == 1) ? ImageReader("", 0, clip1.framecount - 1, clip1.framerate).ChangeFPS(round(clip1.framerate) * ratefaktor, rate).Spline36Resize(breite, hoehe).ConvertToYV24(matrix = "Rec709", ChromaResample = "Spline36") : BlankClip(clip1.framecount, breite, hoehe, "YV24", round(Clip1.framerate) * ratefaktor, rate).KillAudio() : (0 == 1) ? ImageReader("", 0, clip1.framecount - 1, clip1.framerate).ChangeFPS(clip1.frameratenumerator, clip1.frameratedenominator).Spline36Resize(breite, hoehe).ConvertToYV24(matrix = "Rec709", ChromaResample = "Spline36") : BlankClip(clip1.framecount, breite, hoehe, "YV24", clip1.frameratenumerator, clip1.frameratedenominator).KillAudio() : clip1
    Return (clip1.width == breite && clip1.height == hoehe) ? clip1.ConvertToYV24(matrix = "Rec709", ChromaResample = "Spline36") : (AR == 1) ? Overlay(back, clip1, (back.width - clip1.width) / 2, (back.height - clip1.height) / 2).ConvertToYV24(matrix = "Rec709", ChromaResample = "Spline36") : clip1
    }

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von obiwanjunobi ()

  • Es kann eigentlich nicht an dem Script bzw. an dem SSM liegen, weil ich da ja nichts verändert habe. Der Fehler muss mMn bei Megui liegen, weil ich das neu entpackt habe. Gibt es da irgendwelche Möglichkeiten ?

    Zum AVS Script Creator: Ich kann keine Auflösung über 1920x1080 einstellen. Alles drunter geht. Höher allerdings nicht. Wie mach ich das denn, dass ich was höheres als Full HD bekomme ?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von obiwanjunobi ()

  • Vielen Dank. Damit geht es jetzt wieder. War das eine ältere Version oder inwiefern war das jetzt was anderes als mein Megui ?

    Allerdings kommt jetzt ein Warndreieck: abload.de/img/meguidreiecksilq9.png
    Vielleicht hilft da das weiter : program --preset slow --crf 18 --keyint infinite --min-keyint 1 --bframes 0 --output-csp i444 --output "output" "input"

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von obiwanjunobi ()