Nach Rendern Sound asynchron

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Nach Rendern Sound asynchron

    Anzeige
    Hey brauche mal dringend hilfe. Ich habe ein Video das ich einfach nicht vernünftig gerendert bekomme.
    Nachdem das Video fertig gerendert wurde (in mp4) habe ich das Problem das der Sound des Videos bis ganz grob zur hälfte top ist, dann aber asynchron wird. heisst der Sound kommt bevor das passende Bild erscheint.
    habe den Adobe Media Encoder und rendere im Youtube üblichen Format.
    Ich habe zwei rechner bei beiden das gleiche resultat. Beides sehr starke Gaming Rechner.

    Kann es was mit den Render eisntellungen zu tun haben? habe da nicht all zu viel Ahnung von. :)
  • Also kurze Erklärung wie ich vorgehe:
    1. Ich nehme mit Bandicam ein Video im mp4 h.264 auf (wegen Festplattenspeicher und geschwindigkeit)
    2. Gehe ich in mein Video Schnitt Programm und Schneide es und erstelle einzelne Sequenzen. Das Projekt speichere ich dann.
    3. Ich lade das Projekt (indem die einzelnen Sequenzen sind) in den Media Encoder und lasse das mit diesen Einstellungen Rendern:

    Video:
    Breite: 1920
    Höhe: 1080
    Basierend auf quelle
    Progressiv
    Quadratische Pixel 1.0
    Basierend auf quelle
    High
    4,2
    VBR, 1 Durchgang
    10
    10

    Audio:
    AAC
    AAC
    44100Hz
    Stereo
    Hoch
    320
    Bitrate


    So und hier die gewünschten Media Infos




    Allgemein
    Vollständiger Name : I:\Layer of Fear\bandicam 2015-09-19 20-16-25-738.mp4
    Format : MPEG-4
    Format-Profil : Base Media
    Codec-ID : isom
    Dateigröße : 14,1 GiB
    Dauer : 1h 36min
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 20,9 Mbps
    Kodierungs-Datum : UTC 2015-09-19 18:16:26
    Tagging-Datum : UTC 2015-09-19 18:16:26
    Kodierendes Programm : BandiMp4Muxer 1.0

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : Main@L4
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 1 frame
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 1h 36min
    Bitrate : 20,7 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 28,703 FPS
    originale Bildwiederholungsrate : 30,000 FPS
    minimale Bildwiederholungsrate : 9,997 FPS
    maximale Bildwiederholungsrate : 30,030 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.348
    Stream-Größe : 14,0 GiB (99%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-09-19 18:16:26
    Tagging-Datum : UTC 2015-09-19 18:16:26

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 1h 36min
    Duration_LastFrame : -1ms
    Bitraten-Modus : variabel
    Bitrate : 164 Kbps
    maximale Bitrate : 327 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 KHz
    Stream-Größe : 113 MiB (1%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-09-19 18:16:26
    Tagging-Datum : UTC 2015-09-19 18:16:26

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ripoli ()

  • Ripoli schrieb:


    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : Main@L4
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 1 frame
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 1h 36min
    Bitrate : 20,7 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 28,703 FPS
    originale Bildwiederholungsrate : 30,000 FPS
    minimale Bildwiederholungsrate : 9,997 FPS
    maximale Bildwiederholungsrate : 30,030 FPS

    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.348
    Stream-Größe : 14,0 GiB (99%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2015-09-19 18:16:26
    Tagging-Datum : UTC 2015-09-19 18:16:26
    Bin jetzt kein Experte aber das sieht nach ganz großem Quark aus
  • Anzeige
    Tippe auch, dass das das Problem verursacht. Adobe wird dann das Video falsch einlesen, was häufig zu asynchronem Ton führt. Lösung für die Datei wäre, sie irgendwie in CFR (Constant FrameRate) zu konvertieren. Ich hab mich damit nicht so genau beschäftigt, würde es wohl selber mit nem AVISynth-Skript probieren und über VirtualDub in einen Lossless-Codec ausgeben lassen - eine fette Datei wird denke ich zu verkraften sein :P Den entsprechenden Skript könntest du dir im SSM unter "Video" -> "VFR to CFR" generieren.

    Ich hoffe das war genau genug und du kannst mit der Anleitung was anfangen - kann gerade nicht stärker ins Detail gehen. Wenn du mit der Beschreibung nicht klar kommst, sag einfach bescheid. Ich oder jmd. anders wird dann mehr dazu schreiben.

    Verhindern kann man das, indem man gleich in CFR aufnimmt. Müsste Bandicam sogar können, wenn es in den Formateinstellungen unter FPS so eingestellt ist. Wenn's dann das durchgängig macht - 0 Ahnung, ich nutz' es nicht - dann sollten die Videos synchron bleiben.

    EDIT: Buchstabendreher ... Meinte CFR und nicht CRF :P
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von RealLiVe ()

  • Ripoli schrieb:

    1. Ich nehme mit Bandicam ein Video im mp4 h.264 auf (wegen Festplattenspeicher und geschwindigkeit)


    Das ist aber denkbar suboptimal für die Qualität. Und vor allem diese mehrfache Verlustkompressionen die du drin hast (Aufnahme, dann nochmal) Ne das würd ich definitiv nicht so machen..

    Wenn du in AVI mit UTVideo aufnimmst, und Audio in PCM WAVE, löst sich das problem mit der synchronisation gleich mit.

    Nimm nicht so beschissen auf ;)
    Aktuelle Projekte/Videos


  • Okay hab verstanden :) allerding wie löst ihr das mit eurem Festplatten Speicher? Also ich Produziere immer so 3 3 Spiele a 1 Stunde Spielzeit. Heisst ich habe eine 2 TB Platte ja ruckzuck voll. Wie soll ich das lösen?

    Desweiteren habe ich im AVI das Problem das meine Festplatte nicht hinterher kommt mit schreiben.


    PS: Die Asynchronität bin ich los, für alle die Probleme mit Asynchronität haben: Ihr dürft nicht in VFR sondern müsst in CFR aufnehmen, sofern ihr es später noch auf einer Timeline bearbeiten wollt.
  • Ripoli schrieb:

    PS: Die Asynchronität bin ich los, für alle die Probleme mit Asynchronität haben: Ihr dürft nicht in VFR sondern müsst in CFR aufnehmen, sofern ihr es später noch auf einer Timeline bearbeiten wollt.

    Wissen wir xD
    Auch auch wenn man in VFR aufnimmt und es direkt auf Youtube hochladet, kann es zu Asynchronität kommen.

    Test doch mal deine Festplatte mit CrystalDiskMark
    Dann können wir dir mehr sagen, zu Codec Einstellungen und Co.
  • Ripoli schrieb:

    Das mit der Umstellung auf CFR hat schon geholfen. Seitdem ist alles super. Also kann geschlossen werden.
    Ich denke, dann kann ich hier mal schließen, da die Frage geklärt zu sein scheint.
    Falls noch Rückfragen auftauchen, oder ich anderwertig zu früh geschlossen haben sollte, so genügt eine kleine PN des Threaderstellers an mich.

    Bitte beim nächsten Mal als 'erledigt' markieren mit Doppelklick auf das rote Kästchen:



    #CLOSED