Dxtory plötzlich Framedrops beim Schreiben auf HDD

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Dxtory plötzlich Framedrops beim Schreiben auf HDD

    Anzeige
    Hey! Ich hab mir ja als ich hier vor paar Wochen neu war extra zum Aufzeichnen eine neue 1TB Platte von WD geholt (155mb/s). Anfangs lief alles perfekt, aber jetzt nach längerem Gebrauch, stelle ich jetzt fest dass die Schreibeschwindigkeit statt 60 auf 50 und 49 runtertanzt, obwohl in 60 aufgenommen wird und ich im Spiel auch konstant 60 FPS habe, nicht den kleinsten Mikroruckler.

    Legidlich die Schreibgeschwindigkeit fällt und das macht sich dann eben in der Aufnahme bemerkbar. Ist jetzt die neue Platte direkt hinüber oder womit hängt das zusammen.. ?
    Nehme nach wie vor mit MagicYUV auf (hab Utvideo ausprobiert gleiches Problem), lief vorher reibungslos habe auch nichts an den Einstellungen verändert.
    Mein Kanal:

  • Auf der Platte waren noch 850GB von 1000GB frei, ich hab bis auf eine Folge die ich behalten wollte alles runtergeschmissen.
    Raid 0 stelle ich im Bios um oder wie? Ich muss meine alte Platte die's nicht mehr lange machen soll gleich ersetzen. Ich bau 'ne neue für das Hauptsystem ein und Spiel Windows komplett neu drauf.
    Mein Kanal:

  • Chron schrieb:

    Raid 0 stelle ich im Bios um oder wie?

    Lässt sich im BIOS umstellen, dafür bräuchtest du aber mindestens zwei identische Festplatten.

    Probier eine Aufnahme mit dem Afterburner aus, hast du dort das gleiche Problem, so ist Dxtory nicht der Grund.
    Ansonsten könntest du in Dxtory noch Synchronous Surface Lock samt Wait for available buffer bei den Advanced Settings testen.
    Nutzt du Multi Device Processing? Deaktiviere das mal zum Testen.
  • Anzeige

    Kayten schrieb:

    Lässt sich im BIOS umstellen, dafür bräuchtest du aber mindestens zwei identische Festplatten.

    Probier eine Aufnahme mit dem Afterburner aus, hast du dort das gleiche Problem, so ist Dxtory nicht der Grund.
    Ansonsten könntest du in Dxtory noch Synchronous Surface Lock samt Wait for available buffer bei den Advanced Settings testen.
    Nutzt du Multi Device Processing? Deaktiviere das mal zum Testen.


    Hab ja dann ab morgen zwei identische drin. Solange Raid 0 keine Nachteile bringt werde ich das dann gern umstellen.

    Afterburner lief bei mir von vorneherein nicht so gut wie Dxtory deshalb hab ich mich für letzteres entschieden.

    Die Tests werde ich morgen mal nach der Neuinstallation des Systemes durchführen, da checke ich dann die die Einstellungen.
    Allerdings sei nach wie vor bitte beachtet, dass es vorher nicht so war und erst neuerdings so ist.

    Frage: Angenommen, diese FPS-Drops beim Schreiben würden passieren wenn das Spiel "aufwendiger" ist (an orten wo viel los ist und viel geladen werden muss), würde es sich dann genau wie jetzt nur an den Schreib-FPS äußern können oder müssten die FPS im Spiel mit runtergehen? Sprich, kann es sein dass das Spiel super läuft aber die zweite Platte trotzdem wenn viel los ist mit dem Schreiben nicht hinterherkommt, oder sind Abweichungen da völlig unnatürlich wenn das Spiel selbst auf 60FPS läuft?
    Mein Kanal:

  • Abweichungen sind total unnatürlich.
    Wenn die File Fps niedriger als die Ingame Fps ist, ist zu mehr als 90% die Festplatte dran schuld, weil sie mit dem schreiben der Dateien nicht hinterher kommt.

    Und ja nach Spiel und Einstellungen sind 155 MB/s schon recht knapp.
    Ich hab in 1440@60@RGB24 aufgenommen und Ark Survival Evolved hat im durchschnitt mir 150 MB/s geschrieben, das heitß die Peaks lagen irgendwo bei 200+ MB/s
  • Chron schrieb:

    Frage: Angenommen, diese FPS-Drops beim Schreiben würden passieren wenn das Spiel "aufwendiger" ist (an orten wo viel los ist und viel geladen werden muss), würde es sich dann genau wie jetzt nur an den Schreib-FPS äußern können oder müssten die FPS im Spiel mit runtergehen?


    Hängt davon ab, ob du halt auf die HDD wartest, oder eben nicht :

    Kayten, schrieb:

    noch Synchronous Surface Lock
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • GelberDrache92 schrieb:

    Und ja nach Spiel und Einstellungen sind 155 MB/s schon recht knapp.
    Ich hab in 1440@60@RGB24 aufgenommen und Ark Survival Evolved hat im durchschnitt mir 150 MB/s geschrieben, das heitß die Peaks lagen irgendwo bei 200+ MB/s


    Ich nehm nur in 1080@60 auf, dafür müssten die 155mb/s doch reichen oder..?

    De-M-oN schrieb:

    Hängt davon ab, ob du halt auf die HDD wartest, oder eben nicht :


    "es werden keine Frames verworfen".. wie darf man sich das vorstellen? Am Ende sinds trotzdem 60Fps aber ich hab ingame zwischendurch 'laggs' ? Dann würde aber doch das Gameplay unnatürlich aussehen wenn man entsprechend spielt..
    Mein Kanal:

  • Chron schrieb:

    Ich nehm nur in 1080@60 auf, dafür müssten die 155mb/s doch reichen oder..?

    Wenn man meine Aufnahme dann auf 1080p runterrechnet, sind es 112,5 MB/s im Durchschnitt.
    Das heißt die Peaks sind noch mal höher.
    So auch wenn du nur etwas aufgenommen hast, wird die Festplatte langsamer und das kann dann schon reichen das nicht mehr Geschwindigkeit für die Peaks da sind.
  • Also mit Synchronous Surface Lock + Wait for available buffer läuft es auf grauenvollen 20FPS überruckelig.
    Multi Device habe ich nicht an.

    Wie sieht's nun mit der Raid 0 Lösung aus - einfach ins Bios, das einstellen rebooten und feddich? Muss ich das pro Platte oder nur 1x global machen? Hat das Nachteile?
    Mein Kanal:

  • Chron schrieb:

    Wie sieht's nun mit der Raid 0 Lösung aus

    Brauchst du mindestens zwei identische HDDs für. Sollte dann entsprechend im BIOS umgestellt werden können. Wo genau hängt vom BIOS ab.
    Beim RAID0 werden die jeweiligen HDDs zusammengeschlossen, sodass ihr Speicherplatz und ihre Lese-/Schreibgeschwindigkeit summiert wird.
    Fällt eine der HDDs aus, sind beim RAID0 demnach alle Daten des Verbunds weg.

    Wenn der Afterburner bei dir auch so schlecht läuft, kommt deine HDD definitiv nicht hinterher und dann würde ich Drache zustimmen.

    GelberDrache92 schrieb:

    Je voller eine Festplatte wird, umso langsamer wird sie, da ist ganz normal.
  • Ich habe ja bereits erwähnt dass die Platte fast leer ist, 820GB von 931GB sind unbelegt. Trotzdem ist die Aufnahmeperformance jetzt schlechter als vor einer Woche bei gleichem freien Platz.

    Was bedeutet alle Daten des verbunds sind weg? Alles was vom Tag der Umstellung auf Raid0 gemacht wurde geht verloren?

    MSI Afterburner lief wie gesagt insgesamt nicht so gut bei mir, das war ja der Grund warum ich mir Dxtory zugelegt habe.


    Mein Kanal:

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Chron ()

  • Chron schrieb:

    Alles was vom Tag der Umstellung auf Raid0 gemacht wurde geht verloren?

    Das sowieso. Stellst du auf RAID0 um, sind die bisherigen Daten auf den HDDs weg.
    Es war aber gemeint, dass bei einem RAID0 alle Daten weg sind, auch wenn nur eine der HDDs defekt ist.
    Und ich hoffe mal, dass dein RAID0 nur zum Aufnehmen ist. Solltest du das RAID0 auch noch zusätzlich mit Windows und dem Spiel belasten, wäre das kontraproduktiv.

    Chron schrieb:

    Trotzdem ist die Aufnahmeperformance jetzt schlechter als vor einer Woche bei gleichem freien Platz.

    Wenn du dir da so sicher bist, würde ich beobachten was währenddessen noch auf die Festplatte zugreift. Da müsste dann aber jemand anderes bei helfen.
  • Kayten schrieb:

    Das sowieso. Stellst du auf RAID0 um, sind die bisherigen Daten auf den HDDs weg.
    Es war aber gemeint, dass bei einem RAID0 alle Daten weg sind, auch wenn nur eine der HDDs defekt ist.
    Und ich hoffe mal, dass dein RAID0 nur zum Aufnehmen ist. Solltest du das RAID0 auch noch zusätzlich mit Windows und dem Spiel belasten, wäre das kontraproduktiv.


    Ahso.. nee dann ist das sowieso nix für mich. Hab nur 2 Platten, eine mit Win10 und Games und eine wo die die Aufnahme hin gespeichert wird ausschließlich für die Aufnahmen.

    Kayten schrieb:

    Wenn du dir da so sicher bist, würde ich beobachten was währenddessen noch auf die Festplatte zugreift. Da müsste dann aber jemand anderes bei helfen.


    Ich hab gerade Windows 10 neu installiert und hier ist kaum was drauf. Wenn ich die Festplatte jetzt in Dxtory teste kommt sie auf 150mb/s, genau wie vor etwas mehr als 'ner Woche (wobei das da vllt 170mb/s waren) aber ingame tanzt die Aufzeichnungszahl einfach total. Das war vorher nicht so da lief alles von vorn bis hinten flüssig, erst seit nem bestimmten Zeitpunkt vor paar Tagen ist das so und seitdem wird es auch nicht besser. Dabei hat sich inhaltlich nix an Rechenleistung getan und es kommt genauso mal in kleinen geschlossenen Räumen wie in weiteren Ebenen vor.

    Wenn ich nicht in RGB ohne Konvertierung sondern in YUV4:4:4 aufnehme habe ich 60fps/60mb/s. Hab's jetzt nur kurz getestet aber Performance scheint ja stark zu steigen.
    Das erklärt natürlich nicht den plötzlichen Performance-Verlust seit paar Tagen aber ist eine Option, solange ich nicht durch Vegas gehe. Aber wenn ich Vegas mal für viele Schnitte benutzen möchte dann wär's schon gut wenn das auch in RGB mit der Aufnahme klappt so wie's vor kurzem noch ging, damit ich nicht den Qualitätsverlust durch die doppelte Farbkonvertierung durch Vegas habe.

    Also irgendwie muss ne Lösung her um bei 1080@60 ohne Farbkonvertierung weiterhin mit tadelloser Performance aufnehmen zu können..
    Mein Kanal:

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Chron ()

  • GelberDrache92 schrieb:

    Von YV24 auf RGB24 ist in einem Bereich den man nicht sehen kann, nur messen.


    Es ging darum, dass Demon damals zu mir sagte, dass durch Vegas YUV 4:4:4 -> Rgb -> YUV 4:4:4 entsteht und durch die unnötige RGB Konvertierung in der Mitte Qualität verloren geht. Deshalb habe ich einfach direkt in RGB aufgenommen damit dann bei Vegas keine Konvertierung stattfindet sondern nur ein Mal eben am Ende beim encodieren.

    Edit: 4:4:4 läuft auch nur einen Hauch besser. Hab jetzt eine 20 Min Folge damit hinter mir und zu 90% springen die Schreibframes immer noch auf bis zu 48 runter.
    Wenn's am anfang reibungslos lief und jetzt nicht mehr, jedoch die Platte nicht voller ist (hab ausgemistet) dann muss der Fehler an der Platte liegen oder nicht?
    Ist das gleiche Spiel.
    Mein Kanal:

    Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von Chron ()

  • Chron schrieb:

    Es ging darum, dass Demon damals zu mir sagte, dass durch Vegas YUV 4:4:4 -> Rgb -> YUV 4:4:4 entsteht und durch die unnötige RGB Konvertierung in der Mitte Qualität verloren geht.


    Sorry für den OT:
    Ist das ebenfalls der Fall, wenn von Vegas über den FrameServer an MeGUI übergeben wird?
    Dann würde mir, wenn das stimmt, tatsächlich Qualität verloren gehen.. 8|
  • Chron schrieb:

    Wenn nicht, kann ich mir ne große Leistungssteigerung versprechen wenn ich mir ne 250GB SSD extra für die Aufnahmen anschaffe?


    Eine sehr gute SSD erreicht weitaus größere Schreibraten als ein RAID 0. Vom P/L-Verhältnis kauf dir zwei Festplatten und bastel einen RAID 0 Verbund, sofern dein Board das unterstützt und genügen SATA Ports frei sind. Mit meinem RAID 0 bestehend aus 2x WD 1TB Festplatten erreiche ich zw. 200-350 mb/s (der kleinere Wert wird bei einem recht vollen RAID 0 Verbund erreicht). Das kostet vielleicht 30-40 Eur mehr, aber dafür hast du 8x soviel Speicher. Ich hätte keinen Bock nach 30 Minuten Aufnahme eine Pause einzulegen um das Video zu verarbeiten..

    Nur so ein Tipp von mir. Ich denke da würden dir viele zu raten bevor du eine SSD dafür "missbrauchst" ;)