Grünes Bild in TMPGEnc 6 bei High 4:4:4 Video

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Grünes Bild in TMPGEnc 6 bei High 4:4:4 Video

    Anzeige
    N'Abend zusammen!

    Nachdem ich heute mittag ja schon viel Hilfe von @GelberDrache92 bekommen habe, hier noch eine Frage die im Raum steht:

    Wenn ich eine lossless Aufnahme im High 4:4:4 Profil in die NLE einfüge, die ja eigentlich das Profil verarbeiten kann, bekomme ich nur ein grünes verzerrtes Bild.

    Drache hat gemeint, dass das mit dem Decoder-Einstellungen zu tun haben kann.

    Hat denn jemand ne Ahnung mit was das zusammen hängt respektive wie die Einstellungen auszusehen haben, damit ich das Profil bearbeiten kann?

    Danke schon mal im Voraus und nen schönen Samstag Abend!!!

    Gruß
    Toppa
    Hier geht es zu meinem kleinen/feinen Kanal:

  • Korrekt. Keine einzige mir bekannte NLE unterstützt bisher high444.

    Aber mit TMPGEnc haste unter den NLEs zumindest den mit Abstand am weitesten entwickelten H.264 Decoder und ist eig. auch das einzige mir gerad einfallende Manko an dem. Den Rest kann er alles decoden, wenn ich mich nicht irre.
    Du kannst in qp=1 aufnehmen, das kann TMPGEnc dann auch öffnen. Allerdings greifen mit 1 natürlich sämtliche lossy mechanismen wieder und ggf gegen checken ob die passen in OBS oder zuviel Leistung vom System fordern.
    Aktuelle Projekte/Videos


  • De-M-oN schrieb:

    Korrekt. Keine einzige mir bekannte NLE unterstützt bisher high444.

    Aber mit TMPGEnc haste unter den NLEs zumindest den mit Abstand am weitesten entwickelten H.264 Decoder und ist eig. auch das einzige mir gerad einfallende Manko an dem. Den Rest kann er alles decoden, wenn ich mich nicht irre.
    Du kannst in qp=1 aufnehmen, das kann TMPGEnc dann auch öffnen. Allerdings greifen mit 1 natürlich sämtliche lossy mechanismen wieder und ggf gegen checken ob die passen in OBS oder zuviel Leistung vom System fordern.


    OK, das ist tatsächlich schade. Aber danke dir für die Info!!!

    Auf der Website steht folgendes bei der x264 Lizenzierung, dass sowohl die Ausgabe in High 4:4:4 als auch die Eingabe in dem Profil möglich ist (steht als Anmerkung klein drunter).

    Wird das dann evtl aufgrund dessen was auf der Website steht noch nachgefügt oder wird damit was anderes Gemeint?
    Hier geht es zu meinem kleinen/feinen Kanal:

  • GelberDrache92 schrieb:

    Wäre qp=1 oder crf=1 besser?


    qualitativ qp 1 weil er dann gezwungen wird jeden Frame mit 1er Quantizer zu komprimieren.

    CRF 1 würde sich bei Komplexität höheren Quantizern bedienen, die für's Auge seiner Meinung nach der 1er Qualität identisch sind. Das typische CRF System eben.

    Toppa schrieb:

    Auf der Website steht folgendes bei der x264 Lizenzierung, dass sowohl die Ausgabe in High 4:4:4 als auch die Eingabe in dem Profil möglich ist (steht als Anmerkung klein drunter).


    * YUV-Format der H.264/AVC-Datei darf nicht höher als 10-Bit / 4:2:2 sein.

    tmpgenc.pegasys-inc.com/de/product/tvmw6_spec.html
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • GelberDrache92 schrieb:

    Wieso genauer durchlesen? o.o
    Genau der verlinkte Post von Reallive, erklärt kurz wie man das High 4:4:4 Profil zum laufen kriegt.


    Mit durchlesen meine ich mich damit zu 100% beschäftigen, falsche Wortwahl meinerseits. Wegen der ffdshow etc muss ich halt noch schauen ob es klappt etc.

    Danke euch zwei und schönen Abend noch!!!
    Hier geht es zu meinem kleinen/feinen Kanal:

  • Theoretisch könnte man vom integrierten Decoder auf den DirectShow-Decoder vom System zurückgreifen, wenn du mit den Dateien arbeiten musst. Sprich: Alles, was der Windows Media Player öffnen kann, würde dann auch in TMPGEnc geladen werden können. Ich setze mal ein System ohne Codec Packs und Splitter voraus - falls du irgendwas in die Richtung installiert hast, dann sag uns bitte was du da nutzt, bevor du dieser Anleitung folgst:Im Haali-Splitter (Startmenü - Programme - Haali - Media Splitter Settings, oder einfach in der Suche Media Splitter Settings eingeben) müsstest du dann noch eine Einstellung ändern - unter "Output" gibt's den Eintrag "Use custom media type for h.264" - der müsste auf "Yes" gesetzt werden. Hintergrund ist, dass DirectShow bestimmte Decoder anderen vorzieht und ohne die Einstellung FFDShow bei den Dateien nicht nutzen würde. Stichwort dazu wäre Preferred Filters, wenn ich mich richtig erinnere.

    Dann müsste der Windows Media Player die High444 - Datei laden können. TMPGEnc müsstest du dann noch so einstellen, dass es bei der Datei den DirectShow-Decoder nutzt. Das ginge entweder nur für die Datei, indem du den Importassistenten nutzt und da auf den "Kraftleser DirectShow-Dateianzeiger" stellst ...


    ... oder global in den Einstellungen, was in etwa so geht:
    1. Optionen -> Voreinstellungen -> Ein-/Ausgabe-Formatliste
    2. Haken bei MPEG-Dateianzeiger entfernen
    3. Das dann übernehmen
    Da ich TMPGEnc nicht nutze und meine High 4:4:4 - Dateien anders lade kann ich dir keine Erfahrungen geben, ob da irgendwelche Defizite auftreten können - ich könnte mir vorstellen, dass es ggf. etwas auf die Performance geht oder nicht ganz so stabil arbeitet.

    Steht zwar alles im verlinkten Thread, aber etwas weniger wortkarg nochmal beschrieben.

    Ciao.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • RealLiVe schrieb:

    Theoretisch könnte man vom integrierten Decoder auf den DirectShow-Decoder vom System zurückgreifen, wenn du mit den Dateien arbeiten musst. Sprich: Alles, was der Windows Media Player öffnen kann, würde dann auch in TMPGEnc geladen werden können. Ich setze mal ein System ohne Codec Packs und Splitter voraus - falls du irgendwas in die Richtung installiert hast, dann sag uns bitte was du da nutzt, bevor du dieser Anleitung folgst:Im Haali-Splitter (Startmenü - Programme - Haali - Media Splitter Settings, oder einfach in der Suche Media Splitter Settings eingeben) müsstest du dann noch eine Einstellung ändern - unter "Output" gibt's den Eintrag "Use custom media type for h.264" - der müsste auf "Yes" gesetzt werden. Hintergrund ist, dass DirectShow bestimmte Decoder anderen vorzieht und ohne die Einstellung FFDShow bei den Dateien nicht nutzen würde. Stichwort dazu wäre Preferred Filters, wenn ich mich richtig erinnere.

    Dann müsste der Windows Media Player die High444 - Datei laden können. TMPGEnc müsstest du dann noch so einstellen, dass es bei der Datei den DirectShow-Decoder nutzt. Das ginge entweder nur für die Datei, indem du den Importassistenten nutzt und da auf den "Kraftleser DirectShow-Dateianzeiger" stellst ...


    ... oder global in den Einstellungen, was in etwa so geht:
    1. Optionen -> Voreinstellungen -> Ein-/Ausgabe-Formatliste
    2. Haken bei MPEG-Dateianzeiger entfernen
    3. Das dann übernehmen
    Da ich TMPGEnc nicht nutze und meine High 4:4:4 - Dateien anders lade kann ich dir keine Erfahrungen geben, ob da irgendwelche Defizite auftreten können - ich könnte mir vorstellen, dass es ggf. etwas auf die Performance geht oder nicht ganz so stabil arbeitet.

    Steht zwar alles im verlinkten Thread, aber etwas weniger wortkarg nochmal beschrieben.

    Ciao.


    Moinsen :)

    Habe das mal so eingestellt von dir beschrieben. Codecs sind bis auf die obligatorischen Geschichten wie UTVideo oder MagicYUV und x264vfw nichts installiert.

    Habe in den Decodereinstellungen dann noch Standarddecoder ausgewählt sonst würde er den Intel SDK Decoder benutzen.

    Allerdings habe ich bis jetzt immer noch keinen Erfolg leider :(

    Nachtrag:

    Die Videos werden jetzt mit DirectShow als Decoder angezeigt (Nachdem ich auch noch einen Haken bei Quicktime Anzeiger entfernt habe) und über ffdshow.

    Im direkten Schneidefenster kann ich das Video auch abspielen etc, allerdings kann ich im TimelineModus nix damit machen. Es ist da, allerdings gibt es keine Anzeige im Vorschaufenster.

    Achja, und mir wird in der Info trotzdem 4:2:2 angezeigt obwohl qp=0 Aufnahme mit OBS, woran kann das liegen?
    Hier geht es zu meinem kleinen/feinen Kanal:

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Toppa ()