MSI Afterburner Aufnahme asynchron

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MSI Afterburner Aufnahme asynchron

    Anzeige
    Hallo und guten Morgen,

    ich muss mich nun mit einem Thread an Euch wenden, weil ich nicht weiter weiß.

    Meine Aufnahmen mit dem MSI Afterburner sind leider asynchron.
    Erst dachte ich, es liegt am Player, der beides nicht synchron abspielen kann, aber daraufhin extrahierte ich die Tonspur via SSM und fügte sie in MeGUI wieder mit dem Script zusammen -> leider immernoch asynchron.

    Meine Frage nun:
    Wie bekomme ich es nun hin, dass beides wieder sauber synchron zusammengesetzt wird?


    Danke & Gruß
  • Ist das nur bei der Desktop-Aufnahme so? Ein Update könnte helfen, ansonsten musste ich da runter auf 15FPS gehen (was für Spiele aber nicht so toll ist).

    Ansonsten das Video in VirtualDub öffnen.
    Video - Framerate - Punkte an: "Change so Video and audio durations match" und "Convert to FPS" die korrekte FPS angeben.

    Datei - Speichern als AVI
  • sem schrieb:

    Ist das nur bei der Desktop-Aufnahme so? Ein Update könnte helfen, ansonsten musste ich da runter auf 15FPS gehen (was für Spiele aber nicht so toll ist).


    Nein, ich nehme nur BF3 auf :)
    Das Runterschrauben der FPS ist keine Option.


    sem schrieb:


    Ansonsten das Video in VirtualDub öffnen.
    Video - Framerate - Punkte an: "Change so Video and audio durations match" und "Convert to FPS" die korrekte FPS angeben.
    Datei - Speichern als AVI


    Danke, das werde ich noch testen!


    Ich find es komisch, dass dies erst auftaucht, nachdem ich VSync aktiviert habe im Spiel.
    Aber ich will darauf nicht verzichten, denn ohne VSync hab ich ständig Tearing, und das nervt.


    //Edit:
    Könnt ihr mir beschreiben, wie ich via SSM den Ton synchron bekomme?
    Ich glaube, das Extrahieren und späteres Hinzufügen via MeGUI ist nicht das, was ich benötige, odeR?

    Danke soweit!


    //Edit:Leider hat die Anspassung in Virtual Dub nicht gebracht, außer, dass es vor und nach dem encodieren angefangen hat zu laggen.
    Das Bild hängt immernoch dem Tob nach, was super schade ist, weil die restlichen Einstellungen ein super Ergebnis liefern.

    Wie kann es sein, dass es bei der Aufnahme so daneben ging?
    Und gibt es noch eine Möglichkeit die Rohdatei zu retten?

    Ein neues (kurzes) Testvideo brachte wieder dieses Verhalten...

    Ich hab wirklich keine Ahnung mehr was ich machen kann.

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von wlfnkls ()

  • Könnte sich bitte jemand meinem Problem annehmen?

    Manchmal sind die Aufnahmen synchron, manchmal nicht.
    Wenn ich die Audiospur via SSM extrahiere bringt es mir eher wenig, da es immer nur um einen Film geht.

    Falls weitere Informationen nötig sind, reiche ich sie natürlich nach, wenn gefordert.


    Danke!
  • Weiß jetzt nicht, ob das schon beachtet wurde, aber ich schreibe es trotzdem mal auf:
    • Mal dran gedacht das Rohaufnahmen die [lexicon]Lossless[/lexicon] sind und 60 [lexicon]FPS[/lexicon] haben, von einem Mediaplayer nicht korrekt synchron wiedergegeben werden können, weil die [lexicon]Decoder[/lexicon] das nicht so schnell schaffen?
    • Oder wenn du ein Skript erstellt hast, mal daran gedacht das ein Skript durch seine Filter und dem Decodieren der Videos auch nachhängen kann mit dem Ton?

    Weil das sind Punkte wo man sich nicht wundern darf das sie Asynchron wirken. Man muss sie erst encodieren und erst die encodierte Version anschauen. Sprich das was man hochläd später.

    Wenn das Finale Video allerdings Asynchron wirkt, was ich beim MSI AB eigentlich so noch nicht erlebt habe, dann könnte man es ja nochmal anpassen.

    Oder du hast wärend deiner Bearbeitung irgendwas schon verhauen. Das du irgendwo 60 FPS aufgenommen hast, irgendwo es als 59,98 FPS durchjagst und im SSM oder MeGUI wieder als 60 interpretierst. Dann würde es auch zu Asynchronität kommen. Daher der Rat: FPS Werte immer exakt einhalten. Höstens im SSM oder spätestens in MeGUI runterbrechen lassen dann, wenn man das möchte mit ChangeFPS.
  • Danke für die vielen Punkte.
    Aber:
    Ich habe durchaus immer die encodierte Version als Referenz herangezogen.
    Ich nutze nur MeGUI und SSM, bei den fps Zahlen bin ich sehr achtsam gewesen (ausschließen will ich es aber nicht).

    Ich habe noch die Rohdatei mit der Asynchronität auf der Platte und prüfe alles nochmal.
  • Hier die mediainfo und danke soweit

    Quellcode

    1. ​General
    2. Complete name : D:\Videos\Aufnahmen\bf3_2015_10_29_17_44_01_362.avi
    3. Format : AVI
    4. Format/Info : Audio Video Interleave
    5. Format profile : OpenDML
    6. File size : 23.4 GiB
    7. Duration : 5mn 52s
    8. Overall bit rate : 571 Mbps
    9. Video
    10. ID : 0
    11. Format : YUV
    12. Codec ID : ULH2
    13. Codec ID/Info : Ut Video Lossless Codec
    14. Codec ID/Hint : Ut Video
    15. Duration : 5mn 52s
    16. Bit rate : 570 Mbps
    17. Width : 1 680 pixels
    18. Height : 1 050 pixels
    19. Display aspect ratio : 16:10
    20. Frame rate : 60.000 fps
    21. Color space : YUV
    22. Chroma subsampling : 4:2:2
    23. Compression mode : Lossless
    24. Bits/(Pixel*Frame) : 5.383
    25. Stream size : 23.4 GiB (100%)
    26. Audio
    27. ID : 1
    28. Format : PCM
    29. Format settings, Endianness : Little
    30. Format settings, Sign : Signed
    31. Codec ID : 00001000-0000-0100-8000-00AA00389B71
    32. Duration : 5mn 50s
    33. Bit rate mode : Constant
    34. Bit rate : 1 536 Kbps
    35. Channel(s) : 2 channels
    36. Channel positions : Front: L R
    37. Sampling rate : 48.0 KHz
    38. Bit depth : 16 bits
    39. Stream size : 64.2 MiB (0%)
    40. Alignment : Aligned on interleaves
    41. Interleave, duration : 17 ms (1.01 video frame)
    Alles anzeigen
  • wlfnkls schrieb:

    Ich habe die Rate von 48kHz bemerkt und im SSM auch 48kHz mit 16bit eingegeben, was leider keine Besserung ergab

    Was haste denn davon erhofft? ^^

    48KHz nach 48KHz zu changen ist doch ein Effekt von +/- 0 xD

    Gibt nur 3 Arten der Audio/Video-Anpassung.
    1. Audio oder Videospur der jeweiligen anderen Spur anpassen indem entweder die Hz Frequenz vom Audio der [lexicon]FPS[/lexicon] des Videos angepasst wird oder die [lexicon]FPS[/lexicon] der Frequenz vom Audio. Der Effekt wäre das beide Spuren (Audio- und Videospur) exakt gleich lang wären.
    2. Eine Anfangsverzögerung hinzufügen von x ms oder sek.
    3. Ein Endverzögerung hinzufügen. Sprich das Audio vorher aufhört und der Rest des Videos Stumm ist. Der Effekt davon wäre das die Audiospur zusammengequetscht wird um so eine Synchronisation zu ermöglichen. Das würde dann aber nur gehen, wenn Video länger als Audio ist.
    Such dir eine Methode aus. Die erste kann man automatisch ermitteln lassen. Die letzten beiden Methoden müsste man gut Schätzen können. Eventuell wäre es für Anfänger sogar besser dies mit einem Timelineprogramm zu machen, bevor se ganz Verzweifeln ;D
  • Dein Video geht 5:52 und dein Audio 5:50 lang.

    Hast du mal versucht, in deinem Videobearbeitungsprogramm die Audiospur tatsächlich erst nach der Differenzzeit zu starten?
    Also erst nach zwei Sekunden Video die Audiospur einsetzen zu lassen?

    Darin liegt meistens der Hund begraben. Afterburner nimmt nicht exakt mit Tastendruck auf und schließt die Video- und Audiospuren auch bisweilen unterschiedlich ab, zumindest im Betrieb mit AVI Dateien ist das der Fall. Bei einer entsprechenden Zeitdifferenz kommt man der Synchronität aber deutlich näher, wenn man die unterschiedlichen Längen berücksichtigt und im Videoeditor eben diese Differenz als Anlass nimmt, wann die eine Spur bei der anderen beginnt.
    Oder wird der Ton erst im Laufe der fünf Minuten immer asynchroner? Dann ist da hingegen eher nur mit großen Aufwand was zu retten.

    Bei Afterburner empfiehlt es sich daher auch gerne mal 1-2 Sekunden Vor- und Nachlaufzeit zu haben. Dort das Programm eben länger aufnehmen zu lassen, bevor man wirklich mit der eigentlichen Aufnahme beginnt bzw. sie beendet. Die überschüssigen Sekunden dann eben wegschneiden.
    Bei mir gibt es die Spiele aus den unbekannten Weiten des Alls
    Zum Kanal

    Momentan im Anflug:
    Star Trek: Virtual Dreadnought
  • Deepstar schrieb:

    Darin liegt meistens der Hund begraben. Afterburner schließt nicht exakt die Audiospuren ab.


    SSM exportiert es an die Videolängen angepasst. Dann wäres synchron.

    Außerdem beträfe das nur mehrere Videos.

    Bei einem einzelnen Video würde nichts passieren, wenn nur die Längen abweichen.

    Das wird eine innerliche Asynchronität sein.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • De-M-oN schrieb:

    Deepstar schrieb:

    Darin liegt meistens der Hund begraben. Afterburner schließt nicht exakt die Audiospuren ab.


    SSM exportiert es an die Videolängen angepasst. Dann wäres synchron.


    Nein, wäre es nicht. Da der SSM die Audiospur nur entsprechend gleich lang macht wie das Video, also ggf. am Ende was kürzt oder verlängert.
    Wenn das Audio aber zwei Sekunden später beginnt, ändert das grundsätzlich nichts, ist ja dann nur am Ende zwei Sekunden länger.
    Bei mir gibt es die Spiele aus den unbekannten Weiten des Alls
    Zum Kanal

    Momentan im Anflug:
    Star Trek: Virtual Dreadnought
  • Deepstar schrieb:

    Nein, wäre es nicht. Da der SSM die Audiospur nur entsprechend gleich lang macht wie das Video, also ggf. am Ende was kürzt oder verlängert.

    Ja reicht ja auch aus.

    Deepstar schrieb:

    Wenn das Audio aber zwei Sekunden später beginnt, ändert das grundsätzlich nichts, ist ja dann nur am Ende zwei Sekunden länger.

    So ein Verhalten hab ich mit Afterburner noch nie erlebt.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7