MeGUI Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Anzeige
    Hallo Community.

    Ich habe folgendes Problem.

    Ich nehme mit Dxtory auf, bearbeite die Audio mit Audacity, bearbeite alles mit Sony Vegas und Komprimiere es über MeGUI und DebugFrameServer.
    Es lief vor paar tagen alles gut.

    Seid genau 2 tagen, kann ich die Datei zwar bei MeGUI reinziehen, doch er sagt mir:

    DirectShow error

    Unable to render the file

    Ich mache es genau wie in diesem Video beschrieben:
    youtube.com/watch?v=Co_bmU563lk

    Ich bin für jede Frage/Antwort dankbar

    Ich bin schräg, aber nicht schief
  • Dann beschreibe doch mal deinen Workflow und poste auch die Einstellungen die du von überall verwendest beim Vorgehen.

    Es ist zwars schön das du das Video postest das schon Outdatet ist, aber gut. Ist ja noch ein relativ brauchbares Verfahren.

    Empfehlen kann ich dir den SSM zwischen dem DebugMode Frameserver und MeGUI zu schalten. Dann kannste dir das mit den AVS Script Creator sparen und hättest sogar noch mehr Einstellungsmöglichkeiten, sowie auch eine schnellere Encodierung dank AVISynth Multithreading.

    Ein DirectShow Error kann durch eine falsche Laderoutine in AVISynth Skript ausgegeben werden. z.B. wenn du mit DirectShowSource die Frameserver Datei geöffnet hast.

    Oder du hast etwas an deinem Video Filterwerken irgendwas geändert. z.B. Einstellungen verstellt oder einen Codec Pack installiert.

    Aber poste uns erst einmal deinen Workflow wie am Anfang schon genannt. Und dann sehen wir weiter.
  • Ok danke für die Antwort.
    Also ich gehe wie folgt vor:
    Aufnehmen mit Dxtory


    Dann ziehe ich die datei in Sony Vegas rein
    Klicke auf die Datei und gehe auf Eigenschaften


    Gehe oben auf Projekteigenschaften


    Dann auf Rendern als und wähle den DebugFrameServer aus



    Dann starte ich MeGUI




    Öffne den AVI Creator und ziehe die Datei da rein



    und erhalte folgende Meldung



    unter Settings habe ich folgende Einstellungen




    Ich bin schräg, aber nicht schief
  • Da ist ja alles durcheinander und die FPS beträgt 1 / 1000 = 0,001 FPS

    Also... das sieht aus als würde da gar nix hinhauen.


    Dann zu deiner Aufnahme. Du nimmst mit 60 auf und verarbeitest es zu 59,940 FPS ? Warum?


    Dann bitte auch mal eine Mediainfo (auf das Wort klicken und der Anleitung folgen) von der AVI Datei posten die du mit dem Frameserver raussenden tust.
  • Zaryon schrieb:

    In vielen Tutorials wurde gesagt das man beim aufnehmen 60 fps machen soll und beim verarbeiten dann 59,940..
    Die meinten, es sei verlustfrei

    Verlustfrei ist es immer noch, aber dir werden Frames rausgeworfen, weshalb die Frage kommen müsste: Warum nimmst du nicht gleich in 59,940 FPS auf? Oder die Frage: Warum verarbeitest du nicht dein Video mit exakt 60 FPS?

    Eines dieser Fragen sollteste dir mal selbst beantworten ;D

    Zaryon schrieb:

    Wäre dann sinnvoll bei 30 fps beim verarbeiten zu bleiben ?


    Kannst auch mit 120 FPS aufnehmen oder mit 15. Aber Aufnahme FPS und Projekt FPS in deinem Schnittprogramm sollten wenn möglich identisch sein. Wäre halt ideal



    Sieht ok aus soweit. Dein Problem liegt bei MeGUI selbst. Hast du irgendwas am Profil rumgeschraubt beim AVS Script Creator?

    Da sollte exakt drin stehen:

    Quellcode

    1. ​<input>
    2. <deinterlace>
    3. <crop>
    4. <resize>
    5. <denoise>


    Bei dir sieht es nämlich aus als würde es so drin stehen:

    Quellcode

    1. <crop><resize>
    2. <denoise><deinterlace><input>


    Das wäre dann falsch und würde nur ein Chaos ergeben.

    Zu den FPS mit AssumeFPS(1,1000), sieht es aus als würde er den Standard Assume Befehl drin haben.

    Überprüfe mal dein Profil und korrigiere es mal. Vllt erledigt sich das dann schon.
  • Des Weiteren beim Frameserver RGB24 wählen, das erspart schonmal 2 Farbkonvertierungen.

    Zaryon schrieb:

    In vielen Tutorials wurde gesagt das man beim aufnehmen 60 fps machen soll und beim verarbeiten dann 59,940..


    Haben die das auch wenigstens begründet? Weil das ist ziemlicher Schwachsinn. Warum sollte man das tun? XD

    Das sind dann wieder so Leute die selber ein Tutorial bräuchten :D

    __

    oh und nimmt doch einfach Sagaras Scriptmaker, dann brauchste mit dem Script gar nicht manuell rumhantieren.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Problem hat sich bis jetzt wohl gelöst.
    Habe den Debug deinstalliert und neu rauf getan.
    Lag wohl dann am FrameServer <.<

    Ich danke dir trotzdem für die Großartige Hilfe :D

    Hätte dennoch eine paar fragen zwecks das Aufnehmen?

    Wenn ich z.b. mit 60 Fps aufnehme, ist es dann besser wenn ich auch bei den 60 Fps beim verarbeiten bleibe ?
    Zwecks, damit es identisch bleibt und somit weniger Verlust entsteht .

    Bei Dxtory ist das hchste exakt die 60 zum auswählen
    Bei Sony ist das höchste zum auswählen 59,940

    Villt habe ich mir nur das falsche Tutorial angeguckt :/

    Ich bin schräg, aber nicht schief

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Zaryon ()

  • Zaryon schrieb:

    Wenn ich z.b. mit 60 Fps aufnehme, ist es dann besser wenn ich auch bei den 60 Fps beim verarbeiten bleibe ?


    Sagt das nicht schon die Logik?^^

    Zaryon schrieb:

    Bei Sony ist das höchste zum auswählen 59,940

    Vor dir liegt eine Tastatur. Die kann man bei beiden Programmen benutzen! ;D

    Zaryon schrieb:

    Villt habe ich mir nur das falsche Tutorial angeguckt

    das sowieso.

    Zaryon schrieb:

    Mir wäre so das 30 fps doch eig ausreichen oder ?

    Ich finde, insbesondere auf meinem 30" Monitor, 60fps unwahrscheinlich angenehm für's Auge, während 30, insbesondere wenn man 60 gewohnt ist, doch echt arg flau sind..
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Haha ich sollte mir nicht zu vieleTutorials angucken, jeder erzählt was anderes ^^

    Ah ok, es war mir bewusst da was einzugeben, war mir aber nicht ganz sicher ob der das auch so übernimmt, da es manuell eingegeben worden ist :)

    Ist es denn überhaupt sinnvoll in 60 fps aufzunehmen und in 60 fps zu bearbeiten ? Mir wäre so das 30 fps doch eig ausreichen oder ?

    Ich danke euch auf jeden Fall für die Hilfe:D


    Edit: Habe zu spät gesehen, dass du deinen Beitrag editiert hast :)
    Also kann es nicht Schaden auf 60 FPS aufzunehmen und zu verarbeiten ?
    Die Dauer ist mir eig egal, solange es für den Zuschauer angenehm zum gucken ist.

    Ich bin schräg, aber nicht schief

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Zaryon ()

  • Zaryon schrieb:

    Also kann es nicht Schaden auf 60 FPS aufzunehmen und zu verarbeiten ?


    Es ist halt wesentlich weicheres Bild :)
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Ok dann mache ich es wie bisher und stelle von 59,940 auf 60 um.
    Vielen lieben Dank.

    Ich hoffe dadurch wird die Quali besser, hab das Gefühl das auf YT die Videos unscharf sind :/

    Ich denke das dann soweit alles geklärt ist und theoretisch der Thread zu gemacht werden kann ?! :)

    Ich bin schräg, aber nicht schief
  • Zaryon schrieb:

    Ich hoffe dadurch wird die Quali besser, hab das Gefühl das auf YT die Videos unscharf sind


    2048x1152 nehmen -> 3-fache bitrate von yt.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Ne der Scaler taugt nix.

    Skalier nachher via Spline36 hoch (SSM)

    Und statt Lagarith würd ich dir MagicYUV oder UTVideo vorschlagen. Weil Lagarith zieht viel Leistung und hat die farbsättigungslosere tv.601 Matrix.
    Verlangt aber mehr Schreibrate von der HDD. Aber vllt packt sie es ja. Dann hast mehr FPS.

    Include Mouse Cursor würd ich anhaken.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7