Elemente im fertigen Video sind "wabbelig"

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Elemente im fertigen Video sind "wabbelig"

    Anzeige
    Hi! Wie der Titel schon sagt, sind Dinge in meinem Video plötzlich wabbelig. Das ist in der Rohaufnahme nicht so, als beim encodieren passiert.
    Vorab: Wenn es sich hier wieder nur um starkes Banding handelt, dann wird es keine Lösung geben. Darüber haben wir ja schon ausführlich gesprochen.

    Aber ich kann derzeit nicht erkennen, ob das einfach nur Banding oder irgendetwas anderes ist, weil es ganz ausgewählte Stellen betrifft.

    Beispielweise den Holzpfahl und die Kisten links im Bild bei 03:15min oder das Fenster mit dem Mond links bei 21:00

    youtube.com/watch?v=rvr7GUt02oI
    Mein Kanal:

  • Ich glaube, im Spiel ist das nicht so. Im lossless Video ist das selten an manchen Stellen zu sehen, z.B. der Haustreppe, aber in viel leichterer Form. Man muss dafür wirklich drauf achten.
    Es ist ein Effekt der bei Bewegung der Kamera eintritt, das ist ja auch so bei den Balken oben z.B. Sobald ich stehe und die Kamera nachgezogen und fertig ist, ist alles wieder ganz - gleiches gilt für die Schrift.
    Mein Kanal:

  • Erstmal: Das ist kein Banding. Banding sind Farbübergänge, die dann halt auch gestaffelt sein können. Das hängt dann meist mit Bittiefen zusammen. Erklärt also nicht warum es bei dir im Video einige Stellen umherzittern.

    Das Zittern kommt vermutlich von der Aufnahme selbst. Erläutere doch mal wie genau und vor allem mit was du aufnehmen tust. Einstellungen, Mediainfo der Aufnahme, Workflow Beschreibung für die Aufnahme.
  • Anzeige
    Die Aufnahme selbst weist das so an sich nicht auf.. das ist erst nach dem encodieren entstanden. Gut, vielleicht ein bisschen, aber wesentlich weniger als nach dem encodieren, kaum spürbar. Das Spiel hatte aber ohnehin leichte Aufnahmeprobleme am Anfang. Das Hauptmenü zeigt das Hintergrundbild nicht an sondern ist da schwarz, und in der Introsquenz bleiben die ersten 10 sec weiss anstatt zu zeigen, wie der Junge von weiss in schwarz fällt. Ansonsten funktioniert alles. Ich nehme mit Dxtory auf, in 1920x1080 bei 60 FPS - losless.
    Die Aufnahme wird direkt mit deinem Script in MeGUI encodiert und dann mit der Audiodatei gemuxt. Keine Schnitte, nichts.

    Einstellungen:



    Mediainfo des fertigen Videos:
    Spoiler anzeigen
    Allgemein
    UniqueID/String : 181771874927569630691943280429760141663 (0x88BFFD5CC90B6150A19CC04FBD1A595F)
    Vollständiger Name : D:\Aviscripte\Between Me and The Night Folge 3-muxed.mkv
    Format : Matroska
    Format-Version : Version 2
    Dateigröße : 477 MiB
    Dauer : 21min
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 3 125 Kbps
    Kodierungs-Datum : UTC 2016-01-26 18:45:57
    Kodierendes Programm : mkvmerge v8.5.2 ('Crosses') 32bit
    verwendete Encoder-Bibliothek : libebml v1.3.3 + libmatroska v1.4.4

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High 4:4:4 Predictive@L5
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 4 frames
    Codec-ID : V_MPEG4/ISO/AVC
    Dauer : 21min
    Bitrate : 2 812 Kbps
    Breite : 2 048 Pixel
    Höhe : 1 152 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:4:4
    BitDepth/String : 10 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.020
    Stream-Größe : 429 MiB (90%)
    verwendete Encoder-Bibliothek : x264 core 148 r2638 7599210
    Kodierungseinstellungen : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=4 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=600 / keyint_min=60 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=17.0 / qcomp=0.60 / qpmin=0 / qpmax=81 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
    Default : Ja
    Forced : Nein
    colour_range : Limited
    colour_primaries : BT.709
    transfer_characteristics : BT.709
    matrix_coefficients : BT.709

    Audio
    ID : 2
    Format : FLAC
    Format/Info : Free Lossless Audio Codec
    Codec-ID : A_FLAC
    Dauer : 21min
    Bitraten-Modus : variabel
    Bitrate : 309 Kbps
    Kanäle : 1 Kanal
    Kanal-Positionen : Front: C
    Samplingrate : 44,1 KHz
    Bildwiederholungsrate : 38,282 FPS (1152 spf)
    BitDepth/String : 16 bits
    Stream-Größe : 47,1 MiB (10%)
    verwendete Encoder-Bibliothek : libFLAC 1.3.1 (UTC 2014-11-25)
    Default : Ja
    Forced : Nein


    Mediainfo der Aufnahme:
    Spoiler anzeigen
    Allgemein
    Vollständiger Name : D:\Dxtory Aufnahme\Between Me and The Night 2016-01-23 20-06-59-884.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 36,6 GiB
    Dauer : 21min
    Gesamte Bitrate : 246 Mbps
    Originale Source-Form/Vertrieb durch : Video:MagicYUV lossless v1.2rev0 (64 bit) Audio:Lautsprecher (High Definition Audio-Gerät)
    Kodierendes Programm : DxtoryCore ver2.0.0.133

    Video
    ID : 0
    Format : MAGY
    Codec-ID : MAGY
    Dauer : 21min
    Bitrate : 245 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 60,000 FPS
    Bits/(Pixel*Frame) : 1.966
    Stream-Größe : 36,4 GiB (99%)

    Audio
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 21min
    Bitraten-Modus : konstant
    Bitrate : 1 411,2 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 215 MiB (1%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 100 ms (6,00 Video-Frames)
    Mein Kanal:

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Chron ()

  • Ich glaube nicht, dass das ein generelles Problem ist. Wahrscheinlich kannst dus minimieren indem du an den Encoding Settings schraubst, aber wenn das die anderen auch haben hat es wahrscheinlich auch etwas mit dem Spiel zu tun. Ich hätte es jetzt auch nicht gesehen wenn dus nicht gesagt hast.
    Mein Let's Play Channel

    Gute Musik gefällig? Hier gehts zu meinem Heavy Metal Channel. :evil:
  • Das ist ein Problem zwischen der Engine und dem Hooking. Probiere mal ein anderes Aufnahmeprogramm. z.B. MSI Afterburner.

    Und zwars ist es ein Problem das einige Grfiken der Spielengine nicht rechtzeitig in den Speicher gelangen und in der Aufnahme dann selbstverständlich nachziehen.

    Im Spiel selbst sieht man es nicht, da der Frontbuffer dies übertüncht.

    Eventuell kann man im Spiel noch ein paar Grafikeinstellungen machen, bzw. an der Grafikkarte selbst. z.B. Tripplebuffering aktivieren etc. oder Vsync. Das sollte dann auf jedenfalls Besserung bringen.