MP4 in MKV encodieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • MP4 in MKV encodieren

    Anzeige
    Heyho beisammen,

    ich habe bisher immer den Lagarith-Codec verwendet. Nun habe ich dank Demon meine Encodierungssettings umgestellt um bessere Qualität zu erzielen. Nun wollte ich mein Intro, welches ich im MP4-Format vorliegen habe, ebenfalls neu encodieren, damit ich das nach mit meinen Vids muxen kann.

    Nun weiß ich nicht genau, wie ich da am Besten vorgehe.

    Hat jemand eine Idee?

    Gruß
  • Wenn du ganz spezifische Kodierungseinstellungen für die Folgen gewählt hast, dann müssen diese Einstellungen auch exakt (!) für das Intro übernommen werden, sonst klappt das mit dem Muxen nicht. Wenn du die Rohdateien vom Intro noch hast, könntest du es mit ebendiesen Einstellungen neu kodieren, ansonsten musst du eben das bereits kodierte Intro nochmal durchjagen und den Qualitätsverlust in Kauf nehmen. :/
  • Anzeige
    Ach so, das meinst du. Doch, das geht schon, allerdings musst du dafür halt irgendwas am Einleseprozess umändern, damit MP4 korrekt eingelesen wird. Was genau das ist, weiß ich halt auch nicht, weil ich nicht damit arbeite. Da wartest du am besten mal auf jemanden, der sich gut damit auskennt. ;)
  • Ich habe das jetzt nochmal neu encodiert und wollte das Intro vor ein Video muxen (MKVMerge), erhalte aber folgenden Fehler:

    mkvmerge v6.0.0 ('Coming Up For Air') gebaut am Jan 20 2013 09:52:00
    'F:\Downloads\Intro\Kraxell Intro-muxed.mkv': Der Demultiplexer für das folgende Format wird benutzt: 'Matroska'.
    'X:\Diablo III 2016-01-31 17-27-57-575-muxed.mkv': Der Demultiplexer für das folgende Format wird benutzt: 'Matroska'.
    'F:\Downloads\Intro\Kraxell Intro-muxed.mkv' Track 0: Das Ausgabemodul für das folgende Format wird benutzt: 'AVC/h.264'.
    'F:\Downloads\Intro\Kraxell Intro-muxed.mkv' Track 1: Das Ausgabemodul für das folgende Format wird benutzt: 'FLAC'.
    'X:\Diablo III 2016-01-31 17-27-57-575-muxed.mkv' Track 0: Das Ausgabemodul für das folgende Format wird benutzt: 'AVC/h.264'.
    'X:\Diablo III 2016-01-31 17-27-57-575-muxed.mkv' Track 1: Das Ausgabemodul für das folgende Format wird benutzt: 'FLAC'.


    Warnungen:
    Warnung: Der Track Nummer 0 aus Datei 'X:\Diablo III 2016-01-31 17-27-57-575-muxed.mkv' kann vermutlich nicht korrekt an Track Nummer 0 aus Datei 'F:\Downloads\Intro\Kraxell Intro-muxed.mkv' angehängt werden: Die privaten Codec-Konfigurationsdaten stimmen nicht überein (Längen: 42 und 45). Bitte stellen Sie sicher, dass sich die resultierende Datei über ihre gesamte Laufzeit korrekt abspielen lässt. Der Autor dieses Programmes wird vermutlich keinen Support leisten, falls Sie Probleme beim Abspielen der Datei haben.

    Fehler:
    Fehler: Der Track Nummer 1 aus der Datei 'X:\Diablo III 2016-01-31 17-27-57-575-muxed.mkv' kann nicht an den Track Nummer 1 aus der Datei 'F:\Downloads\Intro\Kraxell Intro-muxed.mkv' angehängt werden. Die Trackparameter stimmen nicht überein.


    Wie man oben sieht, stimmen die Datei-Typen überein. Wo liegt nun das Problem?

    PS: Bewusst ältere Version von MKVMerge verwendet, da die neuste nur Videos bis 2GB unterstützt...
  • Kraxell schrieb:

    Wie man oben sieht, stimmen die Datei-Typen überein. Wo liegt nun das Problem?

    Steht doch da was das Problem ist.

    Kraxell schrieb:

    Die privaten Codec-Konfigurationsdaten stimmen nicht überein (Längen: 42 und 45). Bitte stellen Sie sicher, dass sich die resultierende Datei über ihre gesamte Laufzeit korrekt abspielen lässt.


    Du hast ja recht das die Dateitypen von allen die gleichen sind, aber da sind Videos bzw. sogar Audio Tracks drin, die unterschiedlich Encodiert wurden und daher nicht zusammengemuxt werden können.

    Das ist wie als würdest du versuchen ein Video mit 1080p30 und eins mit 1080p60 zusammenmuxen. Geht einfach nicht.

    Alle Settings für den Encode müssen die gleichen sein. GOP, FPS, Auflösung, Farbraum, Farbmatrix, etc. pp.
    Bei Audio muss Abtastrate, Abtasttiefe und vermutlich sogar der Grad der Komperssion übereinstimmen.

    FLAC hat in älteren Versionen eventuell sogar Probleme, wenn es nicht sogar generell unmöglich ist FLAC an FLAC zusammen zu muxen. Selbst wenn sie gleich moderat von den Einstellungen sind.


    Das Problem wirst du mittels Muxen nicht lösen können so.


    Warum nimmst du nicht den SSM und wirst Intro und dein Mainvideo da rein und lässt es über MeGUI encodieren? Dann wärste dein Problem ganz schnell los.

    Ansonsten, wenn es mit dem muxen sein soll, dann muss dein Diablo Video genauso (mit gleichen Einstellungen (Video und Sound)) encodiert werden wie dein Intro Video. Ansonsten kannste das ohnehin vergessen.
  • Ich habe beides über SSM encodiert ^^

    Intro:
    Video: MPEG4 Video (H264) 2560x1440 60fps [V: h264 high 4:2:2 L5.2, yuv422p10le, 2560x1440 [default]]
    Audio: FLAC (framed) 44100Hz stereo 1411kbps [A: flac, 44100 Hz, stereo, s16 [default]]

    Video:
    Video: MPEG4 Video (H264) 2560x1440 60fps [V: h264 high 4:2:2 L5.1, yuv422p10le, 2560x1440 [default]]
    Audio: FLAC (framed) 44100Hz stereo 2116kbps [A: flac, 44100 Hz, stereo, s24 [default]]


    Wären die Media-Infos....
  • Unterschiedliche Level Profile. Reicht schon aus. Und bei FLAC halt einmal signed 16Bit und einmal signed 24Bit

    Sind Unterschiedlich schon mal vom Video als auch von Audio.

    Zudem hat @sem und ich das schon angesprochen. FLAC wird höstwahrscheinlich nicht gehen das man sie zusammenmuxen kann.

    Warum hast du nicht Intro und dein Spielvideo in die SSM Liste geworfen? Wäre doch einfacher gewesen und hättest dir halt auch keine Gedanken machen müssen.

    So machste dir das Leben mit den Muxen und Einstellungen angleichen selbst extrem schwierig, obwohl es hätte einfacher gemacht werden können. ^^