OBS Studio Aufnahmen ruckeln, was tun?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS Studio Aufnahmen ruckeln, was tun?

    Anzeige
    Hallo,

    ich nehme mit OBS Studio auf, nun ist mir aufgefallen, dass die Aufnahmen ruckeln. Während den Aufnahmen läuft alles konstant mit 60Fps.
    An meinem Rechner kann es kaum liegen, was habe ich falsch eingestellt?
    • Grafikarte: Geforce GTX 770
    • Prozessor: Intel i7 4790K
    • RAM: 16GB
    • SSD
    • 2TB HDD
    Anbei meine Einstellungen:




    Danke im voraus!

    VG
  • Was für eine HDD hast du? Läuft über die HDD alles oder hast du noch eine für Spiele und die 2 TB ist nur für Aufnahmen? Check mal mit HD Tune die Schreibgeschwindigkeit.
    Welche sind deine Kodiereinstellungen für OBS?

    Gruß

    Max


    Edit: Sorry hab die Bilder nicht gesehen mit OBS MP hatte ich nur Probleme hab es direkt wieder runtergeworfen. Ich werde es mir aber gleich mal laden und mal schauen.
    Authentisch durch Authentizität: InfamousMax :thumbup:
  • Das ruckeln in der Aufnahme bei OBS ist ein typisches Indiz dafür das dein Prozessor zu schwach ist und nicht mit dem encoden hinterher kommt.

    Entweder du stellst die Prozessorauslastung von "fast" auf etwas niedrigeres und nimmst Qualitätseinbußen in kauf oder du solltest ein anderes Programm wie dxtory etc. benutzen.

    Edit: Auflösung runterschrauben könnte auch helfen.

  • Anzeige
    Also dein Prozessor ist auf jeden Fall nicht zu schwach. :D
    Du hast lediglich deine Grafikkarte vergessen in den Einstellung einzutragen.
    Das Feld ist bei dir nämlich leer.
    Versuche das Programm über Administratorrechte und in 64bit auszuführen.
    Dann die 770Gtx auswählen bei dem Reiter Grafikkarte und die Ruckler sollten verschwinden.
    Andere Möglichkeit wäre die Bitrate zu verringern. :)
    Beste Grüße

    Rocdoge
  • BlackLion768 schrieb:

    Das soll heißen, dass ein i7 4970K dafür zu langsam ist?
    Ja? OBS braucht massive Leistung und ist eigentlich fürs Streamen konzipiert..nicht fürs Aufnehmen.

    Ich benutze selbst OBS und mein Prozessor ist uralt..dort bekomme ich regelmässig dieses Ergebnis wenn ich irgendwas mit 3D und etwas besserer Grafik aufnehmen möchte.

    Das Spiel ist ultra flüssig aber die Aufnahme ruckelt wie ein abgestorbenes Auto vor sich hin.
    Da hilft nur das Preset für die Prozessorauslastung oder die Auflösung zu senken.

    Oder halt ein anderes Programm fürs Aufnehmen benutzen.

  • Brapchu schrieb:

    BlackLion768 schrieb:

    Das soll heißen, dass ein i7 4970K dafür zu langsam ist?
    Ja? OBS braucht massive Leistung und ist eigentlich fürs Streamen konzipiert..nicht fürs Aufnehmen.
    Ich benutze selbst OBS und mein Prozessor ist uralt..dort bekomme ich regelmässig dieses Ergebnis wenn ich irgendwas mit 3D und etwas besserer Grafik aufnehmen möchte.

    Das Spiel ist ultra flüssig aber die Aufnahme ruckelt wie ein abgestorbenes Auto vor sich hin.
    Da hilft nur das Preset für die Prozessorauslastung oder die Auflösung zu senken.

    Oder halt ein anderes Programm fürs Aufnehmen benutzen.
    Das ist nicht ganz richtig. :) Je nach Einstellung kann man das Programm eben ans Streamen anpassen oder an normale Aufnahmen für Youtube.
    Es ist kein reines Streamprogramm. :D

    Wenn es bei dir extrem geruckelt hat, dann hat etwas mit den Einstellungen nicht gestimmt. :)
    Beste Grüße

    Rocdoge
  • Rocdoge schrieb:

    Das ist nicht ganz richtig. Je nach Einstellung kann man das Programm eben ans Streamen anpassen oder an normale Aufnahmen für Youtube.
    Es ist kein reines Streamprogramm.

    Wenn es bei dir extrem geruckelt hat, dann hat etwas mit den Einstellungen nicht gestimmt.
    Meine ich auch, denn ein i7 4970K sollte mit sowas fertig werden.
    Aber wie schon gesagt kann ich bei der Grafikkarte nichts auswählen, das Feld ist ausgegraut, was nun?
  • @BlackLion768 hast du versucht das Program in 64bit auszuführen? Die Desktopverknüpfung öffnet meistens nur die 32bit Variante des Programms.

    Ich würde einfach mal beide Varianten ausprobieren und schauen ob das etwas ändert.

    Einmal bei den Ordnern Programme(x86), und bei Programme nach OBS schauen.
    In Programme(x86) ist die 32bit und in Programme die 64bit Version.
    Beste Grüße

    Rocdoge
  • Es ist echt der Hammer was hier momentan für "Tipps" gegeben werden...

    Ja deine CPU ist für Fast viel zu schwach, es gibt keine CPU die das schafft.
    Mein i7-3930k bricht bei allen unter Veryfast ein.

    Erstmal das Preset wieder auf mindestens Veryfast stellen.
    Zudem ist die Einstellung für die Aufnahme sehr bescheiden.
    Umso stärker die Aufnahme bereits an Qualität eingebüßt hat, umso schlechter wird auch das Ergebnis auf Youtube werden.
    Bei x264 Option, entweder qp=0 (lossless, hier könnte man dann sogar Ultrafast nutzen um die CPU extrem zu entlasten) oder qp=1 (falls dein Videobeabeitungsprogramm kein High 4:4:4 Profil öffnen kann)
    Keyframeinterfall würde ich noch auf 1 stellen, spart CPU Leistung.
    Und unter Erweitert die YUV-Farbmatrix auf 709 stellen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GelberDrache92 ()

  • Du hast ja momentan OBS Studio offen.
    Versuch doch mal das selbe mit OBS Classic 0.657.

    Das Overlay mag etwas anders aussehen, ist aber von den Funktionen fast das selbe.
    OBS Studio ist ja relativ neu. Könnte womöglich ein Bug sein. Das Programm hat noch einige Kinderkrankheiten. :)

    OBS Classic 0.657 solltest du mit einer 770Gtx 100% keine Probleme haben, sollte diese ordnungsgemäß laufen. :D
    Ich habe nämlich auch eine 770GTX.

    Edit:

    @GelberDrache92 Ich habe eine 4770k und diese läuft unter veryfast. Niemand hat davon gesprochen dass seine CPU "Fast" schafft.
    Das war garnicht der Punkt worauf ich momentan geschaut habe. Aber danke für den Tipp.

    Übrigens war die Rede davon, dass sein Prozessor es schaffen sollte Aufzunehmen. Keiner hat gesagt, dass die Einstellungen zu 100% passen.
    Dem Fehler auf den Grund zu gehen wurde gerade versucht. Also danke, dass du meinst das sarkastisch als "Hammer Tipps" bezeichnen zu müssen. :)
    Beste Grüße

    Rocdoge

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Rocdoge ()

  • InfamousMax schrieb:

    Was für eine HDD hast du? Läuft über die HDD alles oder hast du noch eine für Spiele und die 2 TB ist nur für Aufnahmen? Check mal mit HD Tune die Schreibgeschwindigkeit.
    Welche sind deine Kodiereinstellungen für OBS?
    Auf der 2TB HDD werden die Aufnahmen gespeichert, auf einer 500GB HDD habe ich all die Games und auf meiner 256GB SSD habe ich OBS Studio.

    SSD: Average: 427,4MB/sec.
    500GB HDD: Max: 129,7MB/sec Averange: 98,2MB/sec
    2TB HDD: Max: 200MB/sec Averange: 154,7MB/sec
  • GelberDrache92 schrieb:

    Bei x264 Option, entweder qp=0 (lossless, hier könnte man dann sogar Ultrafast nutzen um die CPU extrem zu entlasten) oder qp=1 (falls dein Videobeabeitungsprogramm kein High 4:4:4 Profil öffnen kann)
    Was genau muss ich jetzt bei "Aufnehmen" einstellen? Da gibt es ja noch mehr was man einstellen muss?
    Kannst du mir die idealen Einstellungen mitteilen?
  • Also hab jetzt auch nen bisschen rumprobiert kam auch zu keinem vernünftigen Ergebnis, weder mit OBS noch mit OBS MP komische Sache.
    Die CPU-Auslastung des Programms ist aber auch immer irgendwo zwischen 40 und 60%, okay hab jetzt auch mit GTA5 getestet ist zwar nen mega CPUfresser aber wenns damit klappt klappts auch bei allen anderen - denke ich mir zumindest ^^
    Authentisch durch Authentizität: InfamousMax :thumbup: