Ruckler im Livestream und OBS Mutliplattform, aber das Spiel läuft flüssig.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ruckler im Livestream und OBS Mutliplattform, aber das Spiel läuft flüssig.

    Anzeige
    Hallo, ich habe ein Problem mit meinem OBS.

    Ich wollte da ist seit kurzen eine 100K VDSL Leitung habe wieder mit dem Livestreamen anfangen.
    Allerdings habe ich das Problem das OBS in der Vorschau leichte Ruckler zusehen sind. Diese sind auch bei Twitch leider sichbar und sehr störend. Die Spiele hingegen laufen absolut flüssig mit mindestens 60 FPS.

    Mein PC:

    CPU: Intel I7 5820K @ 4,2 GHz
    GPU: Nvidia GTX 660 SLI x2
    Ram: 32GB DDR4 2400MHZ

    Ich wolle mal fragen ob Hier jemand weiß wie man dies eventuell beheben kann.

    OBS Log:


    Spoiler anzeigen
    02:29:24.106: CPU Name: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz
    02:29:24.106: CPU Speed: 3300MHz
    02:29:24.106: Physical Cores: 6, Logical Cores: 12
    02:29:24.106: Physical Memory: 32669MB Total, 27882MB Free
    02:29:24.106: Windows Version: 10.0 Build 10586 (revision: 0)
    02:29:24.106: Aero is Enabled (Aero is always on for windows 8 and above)
    02:29:24.119: OBS 0.13.4 (64bit, windows)
    02:29:24.119: ---------------------------------
    02:29:24.120: ---------------------------------
    02:29:24.120: audio settings reset:
    02:29:24.120: samples per sec: 48000
    02:29:24.120: speakers: 2
    02:29:24.121: ---------------------------------
    02:29:24.121: Initializing D3D11..
    02:29:24.121: Available Video Adapters:
    02:29:24.122: Adapter 1: NVIDIA GeForce GTX 660
    02:29:24.122: Dedicated VRAM: 4098097152
    02:29:24.122: Shared VRAM: 4243382272
    02:29:24.122: output 1: pos={0, 0}, size={1920, 1080}, attached=true
    02:29:24.122: output 2: pos={-1920, 0}, size={1920, 1080}, attached=true
    02:29:24.122: output 3: pos={2474, -768}, size={1366, 768}, attached=true
    02:29:24.122: output 4: pos={1920, 0}, size={1920, 1080}, attached=true
    02:29:24.123: Loading up D3D11 on adapter NVIDIA GeForce GTX 660 (0)
    02:29:24.139: D3D11 loaded sucessfully, feature level used: 45056
    02:29:24.490: ---------------------------------
    02:29:24.490: video settings reset:
    02:29:24.490: base resolution: 1920x1080
    02:29:24.490: output resolution: 1280x720
    02:29:24.490: fps: 60/1
    02:29:24.490: format: NV12
    02:29:24.492: ---------------------------------
    02:29:24.492: Loading module: coreaudio-encoder.dll
    02:29:24.496: [CoreAudio encoder]: Adding CoreAudio AAC encoder
    02:29:24.496: ---------------------------------
    02:29:24.496: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/ffmpegsumo.dll' not found, loading of module failed
    02:29:24.496: ---------------------------------
    02:29:24.496: Loading module: image-source.dll
    02:29:24.496: ---------------------------------
    02:29:24.504: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
    02:29:24.504: ---------------------------------
    02:29:24.505: Loading module: obs-browser.dll
    02:29:24.505: Failed to load 'en-US' text for module: 'obs-browser.dll'
    02:29:24.505: ---------------------------------
    02:29:24.505: Loading module: obs-ffmpeg.dll
    02:29:24.505: ---------------------------------
    02:29:24.506: Loading module: obs-filters.dll
    02:29:24.506: ---------------------------------
    02:29:24.506: Loading module: obs-outputs.dll
    02:29:24.506: ---------------------------------
    02:29:24.507: Loading module: obs-transitions.dll
    02:29:24.507: ---------------------------------
    02:29:24.507: Loading module: obs-x264.dll
    02:29:24.507: ---------------------------------
    02:29:24.508: Loading module: rtmp-services.dll
    02:29:24.508: ---------------------------------
    02:29:24.508: Loading module: text-freetype2.dll
    02:29:24.510: ---------------------------------
    02:29:24.510: Loading module: win-capture.dll
    02:29:24.875: ---------------------------------
    02:29:24.875: Loading module: win-decklink.dll
    02:29:24.877: No blackmagic support
    02:29:24.877: Failed to start search for DeckLink devices
    02:29:24.877: ---------------------------------
    02:29:24.877: Loading module: win-dshow.dll
    02:29:24.878: ---------------------------------
    02:29:24.879: Loading module: win-mf.dll
    02:29:24.879: [Media Foundation encoder]: Adding Media Foundation AAC Encoder
    02:29:24.898: ---------------------------------
    02:29:24.898: Loading module: win-wasapi.dll
    02:29:24.899: =====================================================================
    02:29:24.899: output 'adv_stream' (rtmp_output) created
    02:29:24.899: output 'adv_file_output' (ffmpeg_muxer) created
    02:29:24.899: encoder 'streaming_h264' (obs_x264) created
    02:29:24.904: AAC encoder bitrate mapping:
    02:29:24.904: 32 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 40 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 48 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 56 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 64 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 72 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 80 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 96 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 112 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 128 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 144 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 160 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 192 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 224 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 256 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 288 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: 320 kbit/s: 'CoreAudio AAC encoder' (CoreAudio_AAC)
    02:29:24.904: encoder 'adv_aac0' (CoreAudio_AAC) created
    02:29:24.904: encoder 'adv_aac1' (CoreAudio_AAC) created
    02:29:24.904: encoder 'adv_aac2' (CoreAudio_AAC) created
    02:29:24.904: encoder 'adv_aac3' (CoreAudio_AAC) created
    02:29:24.904: service 'default_service' (rtmp_common) created
    02:29:24.907: All scene data cleared
    02:29:24.907: ------------------------------------------------
    02:29:24.925: WASAPI: Device 'Senheiser HD 598 (Sound Blaster Z)' initialized
    02:29:24.925: source 'Desktop Audio' (wasapi_output_capture) created
    02:29:24.928: WASAPI: Device 'Rode NT1-A (Sound Blaster Z)' initialized
    02:29:24.928: source 'Mic/Aux' (wasapi_input_capture) created
    02:29:24.928: source 'Noise Gate' (noise_gate_filter) created
    02:29:24.928: source 'CoD MW2' (scene) created
    02:29:24.933: source 'Overlay Rechts' (image_source) created
    02:29:24.938: source 'Donation Goal' (browser_source) created
    02:29:24.941: source 'Spenden Raufrad' (browser_source) created
    02:29:24.941: source 'GTA' (game_capture) created
    02:29:24.941: source 'GTA V' (scene) created
    02:29:24.941: source 'CSGO' (game_capture) created
    02:29:24.978: source 'Kurze Pause' (text_ft2_source) created
    02:29:24.996: source 'Gleich geht es weiter ' (text_ft2_source) created
    02:29:24.996: source 'Pause' (scene) created
    02:29:24.997: source 'CoD MW3' (scene) created
    02:29:24.997: source 'MW3' (game_capture) created
    02:29:24.997: source 'Rocket League Game' (game_capture) created
    02:29:24.997: source 'Rocket League' (scene) created
    02:29:24.999: source 'Store Games' (monitor_capture) created
    02:29:24.999: source 'Windows Store Games' (scene) created
    02:29:25.001: source 'Chat' (browser_source) created
    02:29:25.004: source 'Alerts' (browser_source) created
    02:29:25.005: source 'Minecraft Game' (game_capture) created
    02:29:25.005: source 'Webcam' (dshow_input) created
    02:29:25.026: ---------------------------------
    02:29:25.026: [DShow Device: 'Webcam'] settings updated:
    02:29:25.026: video device: Logitech HD Pro Webcam C920
    02:29:25.026: video path: \\?\usb#vid_046d&pid_082d&mi_00#6&7dda7a7&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{bbefb6c7-2fc4-4139-bb8b-a58bba724083}
    02:29:25.026: resolution: 640x480
    02:29:25.026: fps: 30.00 (interval: 333333)
    02:29:25.026: format: I420
    02:29:25.032: adding 21 milliseconds of audio buffering, total audio buffering is now 21 milliseconds
    02:29:25.038: source 'Chroma Key' (chroma_key_filter) created
    02:29:25.038: source 'Laberecke' (scene) created
    02:29:25.215: source 'YouTube Hintergrund' (image_source) created
    02:29:25.215: source 'LoL Client' (scene) created
    02:29:25.215: source 'Client' (window_capture) created
    02:29:25.215: source 'Minecraft' (scene) created
    02:29:25.215: source 'Counter Strike GO' (scene) created
    02:29:25.216: source 'LoL Ingame' (scene) created
    02:29:25.216: source 'LoL' (game_capture) created
    02:29:25.249: == Profiler Results =============================
    02:29:25.249: run_program_init: 1163.85 ms
    02:29:25.249: ┣OBSApp::AppInit: 1.427 ms
    02:29:25.249: ┃ ┗OBSApp::InitLocale: 0.939 ms
    02:29:25.249: ┗OBSApp::OBSInit: 1157.9 ms
    02:29:25.249: ┣obs_startup: 0.67 ms
    02:29:25.249: ┗OBSBasic::OBSInit: 1129.67 ms
    02:29:25.249: ┣OBSBasic::InitBasicConfig: 0.273 ms
    02:29:25.249: ┣OBSBasic::ResetAudio: 0.214 ms
    02:29:25.249: ┣OBSBasic::ResetVideo: 371.824 ms
    02:29:25.249: ┣OBSBasic::InitOBSCallbacks: 0.007 ms
    02:29:25.249: ┣OBSBasic::InitHotkeys: 0.034 ms
    02:29:25.249: ┣obs_load_all_modules: 406.789 ms
    02:29:25.249: ┃ ┣obs_init_module(coreaudio-encoder.dll): 3.056 ms
    02:29:25.249: ┃ ┣obs_init_module(image-source.dll): 0.002 ms
    02:29:25.249: ┃ ┣obs_init_module(obs-browser.dll): 0.032 ms
    02:29:25.249: ┃ ┣obs_init_module(obs-ffmpeg.dll): 0.005 ms
    02:29:25.249: ┃ ┣obs_init_module(obs-filters.dll): 0.005 ms
    02:29:25.249: ┃ ┣obs_init_module(obs-outputs.dll): 0.002 ms
    02:29:25.249: ┃ ┣obs_init_module(obs-transitions.dll): 0.005 ms
    02:29:25.249: ┃ ┣obs_init_module(obs-x264.dll): 0.001 ms
    02:29:25.249: ┃ ┣obs_init_module(rtmp-services.dll): 0.17 ms
    02:29:25.250: ┃ ┣obs_init_module(text-freetype2.dll): 1.492 ms
    02:29:25.250: ┃ ┣obs_init_module(win-capture.dll): 363.867 ms
    02:29:25.250: ┃ ┣obs_init_module(win-decklink.dll): 1.864 ms
    02:29:25.250: ┃ ┣obs_init_module(win-dshow.dll): 0.809 ms
    02:29:25.250: ┃ ┣obs_init_module(win-mf.dll): 18.308 ms
    02:29:25.250: ┃ ┣obs_init_module(win-wasapi.dll): 0.005 ms
    02:29:25.250: ┃ ┗reset_win32_symbol_paths: 0.371 ms
    02:29:25.250: ┣OBSBasic::ResetOutputs: 5.617 ms
    02:29:25.250: ┣OBSBasic::CreateHotkeys: 0.03 ms
    02:29:25.250: ┣OBSBasic::InitService: 0.122 ms
    02:29:25.250: ┣OBSBasic::InitPrimitives: 0.206 ms
    02:29:25.250: ┗OBSBasic::Load: 320.369 ms
    02:29:25.250: =================================================
    02:29:25.705: Update check: last known remote version is 0.13.4
    02:29:41.868: adding 21 milliseconds of audio buffering, total audio buffering is now 42 milliseconds



    Bei weiteren Fragen stehe ich natürlich zu verfügung.

    MFG
  • Hier sind meine OBS Einstellungen.

    Ich habe auch schon mit den Prozessorauslastungs-Voreinstellungen herumgespielt, dies brachte allerdings keine Verbesserung.

    Allerdings wenn ich den Renderer auf OpenGL umstelle habe ich bei manchen Spielen eine kleine Verbesserung feststellen können,

    aber das war auch nicht so der bringer.



    MFG

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ccxp21 ()

  • Leute ich hab dieses problem auch, spiel und in OBS alles flüssig, aber der stream laggt für meine Zuschauer und läd langsam.
    Lösung: Es liegt an Twitch, Twitch scheint ein Problem mit den Servern zu haben, versuch mal auf den London oder Amsterdam Server zu wechseln, wenns nicht klapt dann musse warten.
    Was ich vieleicht auch noch empfehlen würde, Stell die Frames auf 30, vielleicht hilft dir das ja.
    Edit: Guck ob OBS bei dir die priorität auf hoch ist. Kann dazu führen das ob die Gesamte Leistung Saugt um aufzunehmen/Streamen
    Retro Games und andere sachen. Schaut doch mal vorbei :D
    youtube.com/channel/UCzo4qxd46CXLuKqu1F7ezgw
  • Lakota schrieb:

    Leute ich hab dieses problem auch, spiel und in OBS alles flüssig, aber der stream laggt für meine Zuschauer und läd langsam.
    Lösung: Es liegt an Twitch, Twitch scheint ein Problem mit den Servern zu haben, versuch mal auf den London oder Amsterdam Server zu wechseln, wenns nicht klapt dann musse warten.
    Was ich vieleicht auch noch empfehlen würde, Stell die Frames auf 30, vielleicht hilft dir das ja.
    Bei ihm ruckelt es aber schon in der OBS Vorschau :/ Dann liegt es erstmal nicht an der Verbindung, sondern schon in der Encodierung. Da wäre vielleicht auch mal die CPU-Last interessant.

    Bei Lags im Stream selber: Bitrate runter (Non-Partner max. 2500 / Partner evtl max. 3500) und der angesprochene Serverwechsel.
  • Also den Farbmatrix nun auf 709 umgestellt und es hat bei League of Legends zu eine minimale Verbesserung gebracht.

    Allerdings wenn ich die Frame begrenzung auf 144FPS umstelle hat dies bei League of Legends die Ruckler fast komplett entfernt.

    [Edit]

    Ne OBS zeigt nichts an, erst wenn ich die CPU Einstellung auf Slower stelle sagt er mir das der Codierer Überlastet ist.
  • Och man Leute xD
    Bitrate + Puffergröße = 7000 Peaks.... und dann kommt noch Audio dazu xD

    So erstmal, Video auf 720p mit oder ohne 60 Fps ist dabei.
    720p = weniger Pixel als 1080p = mehr Bitrate pro Pixel = bessere Qualität.
    Hierbei wird sollte man dann etwas eine Bitrate von 2500 anpeilen oder sogar nur 2000...
    Dabei geht dann Bitrate + Puffergröße also zum Beispiel 2000 + 500 oder 1500 + 500, oder man setzt gleich auf eine constante Bitrate, also Haken bei Puffergröße raus und einfach die Bitrate eintragen.

    Audio auf 44.100 und 160 Bitrate, gleiche Spiel wie bei den Pixel...

    Preset auf Very Fast, Super Fast ist fürs Streamen schon wieder zu hoch.
    YV12, 709, Teilweise