Ich brauche Hilfen beim Encoden mit Magix MX

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ich brauche Hilfen beim Encoden mit Magix MX

    Anzeige
    Moin moin!
    Ich habe mich gerade hier im Forum angemeldet, weil es mir scheint, dass hier einige kompetente Leute unterwegs sind und ich mir ein paar Tipps zu Magix MX erhoffe :)

    Kurz zur Erklärung:
    Ich mache seit etwa 2 Jahren Youtube Videos, zu Beginn hauptsächlich Let's Plays, heute fast nur noch "Realvideos". Von Anfang an benutze ich als Schnittprogramm VDL MX und bin so weit auch zufrieden damit. Ist zwar recht ruckelig, wenn man mit HD files hantiert, aber ist zu verkraften. Encodiert habe ich bisher immer mehr schlecht als recht mit Zufallswerten bzw. Einstellungen, die ich mir online zusammengesucht habe. Zufrieden war ich bisher aber nie so richtig. Mal zu schlechte Qualität, dann zu große Files oder das rendern dauert 20 Stunden etc.
    Irgendwann hatte ich durch Versuch und Irrtum ein gutes Mittelmaß gefunden, was bisher funktionierte. Jetzt aber nicht mehr.
    Ich bearbeite gerade ein Video, wo ich die Kamera auf dem Armaturenbrett meines Wagens befestigt hatte und halt bei viel Sonnenschein durch die Gegend fahre... Etwa 20 Minuten ist das Video lang, aufgenommen in 1920x1080p 50fps (Originaldatei liegt als MTS vor bei einer Gesamtbitrate von 27278 kbit/s). - Zur Info: Auflösung und fps leuchtet mir ein, die restlichen Werte sind für mich allerdings Böhmische Dörfer!!!
    Jedenfalls encodiert Magix dieses Video mit meinen Standarteinstellungen nicht richtig. Es produziert stattdessen eine MP4-Datei, die mehrere hundert GB groß ist. Irgendwann ist die Festplatte dann voll und Magix bleibt stehen. Ich habe das Video mal um ein paar Sekunden gekürzt und es noch mal versucht, aber keine Änderung.
    Letzte Nacht habe ich es dann mal mit WMV als Ausgangsdatei versucht, das hat er auch gemacht, aber das File war 5 GB groß und die Qualität sauschlecht. Geht gar nicht!

    Jetzt stehe ich also vor der Herausforderung, endlich mal die zu mir passenden Einstellungen bei Magix MX zu finden. Ich hoffe, da kann mir jemand aus diesem Forum behilflich sein...

    Mein PC ist nicht der neueste und meine Grafikkarte unterstützt kein CUDA o.ä. Meine Internet-Verbindung ist momentan auch eher bescheiden (6k Leitung), daher dürfen die Videos nicht zu groß werden. Außerdem sollten Render-Zeiten von 10 Stunden nicht überschritten werden (für Videos von ca. 30 Minuten Länge). Bisher waren meine Videos bei 30 Minuten Spieldauer so ca. 1GB groß. Mehr sollte es auch nicht werden. Eher weniger bei möglichst guter Qualität.

    Da mir die Einstellungen wie z.B. GOP, B-frame und slice count sowieso nichts sagen, wäre es mir am liebsten, wenn mir jemand Schritt für Schritt die Werte nennen könnte die ich einstellen soll... Ich weiß, das ist viel verlangt, aber vielleicht kennt sich ja jemand so weit aus...
    Und noch etwas, ich möchte allein mit Magix encoden. Dieses Geraffel mit dem x264vfw und MeGUI, von dem ich gelesen habe, ist mir zu kompliziert und aufwändig. :thumbdown:

    LG
    Rick
    .
    --------------------------------------
    --- Kaldan DE auf YouTube ---
    --------------------------------------
  • Hi Rick
    ich nutze "Magix Video Deluxe 2015" und ich rendere meine Filme (Gameplays) in folgender Einstellung:

    1.) Video als Mpeg4
    2.)Auflösung / Framerate einstellen wie im Rohfilm
    3.) Auf den Schalter Erweitert gehen und folgende Einstellung wählen( Spalte Video H.264):
    Bitratenmodus: Variabel
    Durchschnittliche Bitrate: 25000
    Maximale Bitrate: 28000
    CPB: 0
    Maximale GOP Länge: 30
    GOP Struktur: IBBP
    Profil: High
    Level: 4.0
    Kodierqualität: Ausgewogen (Bei Bedarf höher stellen)

    Spalte Audio (AAC):
    Samplerate: 44100
    Bitrate: 160


    Bei diesen Einstellungen erreiche ich bei einem Film von 30 Minuten Länge eine Dateigröße von ca. 1,5 GB
    Renderzeit für den Film je nach Rechnergeschwindigkeit Filmlänge mal 3.


    Gruß, Zap
    ____________________________________
    Youtube: youtube.com/c/Zap2PlayDE
    Facebook: facebook.com/zap2play/
  • So, mein Testvideo mit deinen Einstellungen ist fertig... 6 Minuten ist das Ganze lang und ist 2GB groß geworden. Und das bei mäßiger Qualität, viele Details sind verpixelt (vor allem dunklere Bereiche) und es gibt 2 fatale Fehler im Video, bei denen das Bild gut eine Sekunde lang stehen bleibt.
    Hinzu kommt noch, dass der Ton nicht synchron mit dem Video ist, das hatte ich bisher noch nie.

    Also leider unbrauchbar.

    OK, CPB und GOP Struktur konnte ich nicht einstellen (GOP Struktur fehlte bei den Einstellungen ganz und CPB war grau, sprich nicht änderbar). Kodierqualität hatte ich auf 12, also recht hoch.

    Ich brauche da also definitv eine Alternative...
    .
    --------------------------------------
    --- Kaldan DE auf YouTube ---
    --------------------------------------
  • Anzeige
    Dann stimmt was mit deiner Installation nicht. mal den Installer starten und auf reparieren klicken.
    6 Min 2 GB ist ein unkomprimiertes AVI.das geht gar nicht!
    Da läuft was in deinem System gewaltig schief,
    Die oben angegebenen Einstellungen nutze ich für alle meine Vids die ich hochlade, und schlecht sind die nicht- finde ich.

    Gruß Zap
    ____________________________________
    Youtube: youtube.com/c/Zap2PlayDE
    Facebook: facebook.com/zap2play/
  • Ich war heute den ganzen Tag über unterwegs und hab das Video noch mal versucht, encoden zu lassen, diesmal mit Quantizer... Wieder das selbe Problem, Video 179GB groß und Festplatte dicht!
    Das muss am Video liegen. Evtl. weil das Bild sehr schnell bewegt und zitterig ist. Ich hatte nämlich vergessen, den Stabilisator bei der Aufnahme zuzuschalten. Auf dem Armaturenbrett auf kleinen Deichstraßen hat es doch schon ganz schön gerüttelt. Das ist wohl zu viel für Magix.

    Ich hatte ja nichts geändert und vorher war es ziemlich gut eingestellt. Ca. 50 Videos lang hat es funktioniert, nun bei dieser speziellen Aufnahme nicht mehr. Ich bräuchte nun halt eine Lösung nur für dieses eine Video, auch wenn ich die Qualität runter schrauben muss. Wie könnte das klappen?
    Ich denke nicht, dass eine Neuinstallation etwas bringen würde.
    .
    --------------------------------------
    --- Kaldan DE auf YouTube ---
    --------------------------------------
  • Wenn das Material so derart komplex ist, musst du wohl oder übel mit schlechterer Qualität leben, um dieselbe Dateigröße zu bekommen. :/ Also einfach den Quantizer-Wert so lange erhöhen, bis du mit dem Ergebnis (oder vielmehr dem Kompromiss aus Bildqualität und Dateigröße) leben kannst.

    Alternativ könntest du natürlich auch einfach eine feste Bitrate eingeben (das kannst du ja errechnen, wie hoch die sein muss für deine Schmerzgrenze von 1GB), 2-Pass aktivieren und abwarten.

    Das sind so in etwa deine Möglichkeiten. Für bessere Bildqualität bei weniger Dateigröße wird dir nichts anderes übrig bleiben als x264vfw, was durchaus auch in Magix integrierbar ist: x264vfw für Videoschnittprogramme (Erklärt an Magix)
  • Ich hab heute noch mal ein paar Tests mit meinem 3-Minuten Testvideo gemacht...
    Wenn ich mit den Magix Standarteinstellungen encodiere, ist das Video 412MB groß und die Qualität mäßig, aber noch erträglich.
    Wenn ich aber anfange, die Einstellungen zu ändern wird die Tonspur asychron. Viel mehr noch, das Video läuft langsamer als der Ton und ist 6 Minuten lang. Wie kann denn sowas kommen?

    Zum 264vfw hätte ich auch noch mal eine Frage: Kann man den irgendwie anwenden, ohne getrennte Video- und Tonspuren zu bekommen? Das Muxen ist mir ehrlich gesagt zu umständlich. Ich mag es so gar nicht, wenn nachher der Ton nicht Lippensynchron ist...
    .
    --------------------------------------
    --- Kaldan DE auf YouTube ---
    --------------------------------------
  • Kaldan DE schrieb:

    Wenn ich mit den Magix Standarteinstellungen encodiere, ist das Video 412MB groß und die Qualität mäßig, aber noch erträglich.
    Erst einmal kannst du die Standencoder von Magix vergessen.
    Nicht nur weil die qualitativ schlechter sind, sondern auch verbuggt wie sonstwas. Insbesondere die Einstellungen vom Rate-Control (Bitratenverteilung). Targeting Quality und die Quantizer arbeiten nach mehreren Test von mir anscheinend nicht so wie sie sollen sondern werden durch Einstellungen der GUI überschrieben.

    x264vfw erstellt dir eine AVI mit der Audiospur und eine H.264 Roh Datei. So arbeitet die vfw-Schnittstelle grundsätzlich.

    Das Muxen bedeutet nichts anderes als, dass Audio und Video in einen Container gesteckt werden. Das macht auch der Standard Encoder von Magix.
    Asynchronität entsteht daher nicht durchs Muxen, sondern durch falsche FPS Angaben
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Mein nächstes Testvideo ist gerade fertig geworden, diesmal hatte ich wieder die Standarteinstellungen benutzt, diesmal aber per 2Pass encodiert... Die Bildqualität ist besser, so weit ganz gut. Allerdings ist es auch 613MB groß geworden (3:39 Min), was definitiv zu viel ist. Da wäre mein 30 Minuten-Video ja dann um die 6GB groß, das ist zu viel. Was kann ich tun,um das kleiner zu bekommen ohne viel an Bildqualität zu verlieren?
    (wie gesagt, eingestellt ist sonst der Magix Standart.)
    .
    --------------------------------------
    --- Kaldan DE auf YouTube ---
    --------------------------------------
  • Kaldan DE schrieb:

    Was kann ich tun,um das kleiner zu bekommen ohne viel an Bildqualität zu verlieren?
    2pass Encode bringt beim Standard Encoder von Magix nicht. Diese Einstellungen ist dafür ausgelegt eine vorher genau festgelegte Zielbitrate zu treffen, die man bei Magix nicht angeben kann, bzw. nicht ausrechnen kann. 2pass Encode ist daher eine reine Zeitverschwendung und dazu auch gar nicht für Internetvideos ausgelegt sondern eher für DVDs/Blu-Rays ...
    ~ Let's plays, Animes, Cinematics, Zeichnungen ~ :D
  • Moin, über Nacht habe ich das Video mal mit dem x264vfw encodiert (also das ganze Video, nicht den Schnipsel) und gerade mit MeGUI gefinished...
    25 Minuten sind 2GB geworden. Die Qualität ist so ganz gut, aber an manchen Stellen ruckelt es ziemlich (also nicht im Bild, sondern im Videofluss), aber das ist zu verkraften. Aber eine Sache stört: Ich kann nicht vorspulen. Wenn er von Anfang an läuft, geht es, aber wenn ich einen Sprung machen will, streikt VLC. Und der Windows Media Player spielt es erst gar nicht. Ich weiß allerdings nicht, ob das an meinem schwachen System liegt, oder ob das ein Encodierungsproblem ist.

    Ich habe mich beim encodieren und muxen an die Anleitung von GrandFiredust gehalten.
    Hab ich irgendwo etwas falsch gemacht?
    .
    --------------------------------------
    --- Kaldan DE auf YouTube ---
    --------------------------------------