Video laggt nach Encodierung

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Video laggt nach Encodierung

    Anzeige
    Hi! Ich habe ein sehr kniffliges Problem. Ich habe gestern zwei Videos direkt hintereinander aufgenommen, das erste ist nun auf meinem Kanal und hat zwischendurch Passagen, wo die FPS nicht so optimal ist und das Bild manchmal ganz kurze Hänger hat. Davon gibt's zwei Sorten:

    1. Hänger die nur auf Youtube passieren. Wenn man zurückspult sind sie nicht mehr da - keine Ahnung warum, hab ich sonst bei keinem Video, benutze Chrome. Jemand hat mir sogar gesagt, dass er dort (allerdings mit Firefox) 4-5 Sekunden Aufhänger hatte. Ich tippe hier auf Firefox da der ja sowieso Probleme mit Videos hat.
    2. Passagen wo die FPS etwas einbricht, gibt es auch bei der Lokal encodierten Datei, nicht aber bei der Rohdatei (Mit MPC-HC geprüft).

    Nun, ich habe nur Video 2 geprüft, aber da ich die direkt hintereinander aufgenommen habe dürften die identische Performance haben. Fakt ist aber, dass durch die Encodierung FPS-Schwache Passagen entstanden sind, die es so vorher nicht gab. Egal wo ich in der 25 Minuten langen zweiten Aufnahme lokal reinspule, alles bleibt super flüssig.

    Also es gibt praktisch nun zwei Probleme:
    1. Die Laggs durch die Encodierung entstanden sind.
    2. Dass Youtube dem Video nochmal Extra-Bildaufhänger spendiert, die es in keiner der lokalen (auch nicht encodierten) Datei gibt. Passiert vorrangig beim Spulen, jedenfalls bei mir. Wobei ich mir das schwer erklären kann da Youtube ja neu enkodiert.

    Primär ist mir aber wichtig warum aus meiner sauberen Rohdatei eine encodierte laggy rauskommt. Meine Einstellungen:

    MeGUI: picload.org/image/rrdaicaa/ssm.png
    SSM: picload.org/image/rrdaicar/megui.png

    Mediainfo (Von der Rohdatei des zweiten Videos, wie gesagt, identische Einstellungen)
    Spoiler anzeigen

    Quellcode

    1. Allgemein
    2. Vollständiger Name : D:\Dxtory Aufnahme\UE4Game-Win32-Shipping 2016-07-08 22-34-21-400.avi
    3. Format : AVI
    4. Format/Info : Audio Video Interleave
    5. Format-Profil : OpenDML
    6. Dateigröße : 147 GiB
    7. Dauer : 24min
    8. Gesamte Bitrate : 856 Mbps
    9. Originale Source-Form/Vertrieb durch : Video:MagicYUV lossless v1.2rev0 (64 bit) Audio:Lautsprecher (High Definition Audio-Gerät)
    10. Kodierendes Programm : DxtoryCore ver2.0.0.134
    11. Video
    12. ID : 0
    13. Format : MAGY
    14. Codec-ID : MAGY
    15. Dauer : 24min
    16. Bitrate : 859 Mbps
    17. Breite : 1 600 Pixel
    18. Höhe : 900 Pixel
    19. Bildseitenverhältnis : 16:9
    20. Bildwiederholungsrate : 60,000 FPS
    21. Bits/(Pixel*Frame) : 9.941
    22. Stream-Größe : 147 GiB (100%)
    23. Audio
    24. ID : 1
    25. Format : PCM
    26. Format-Einstellungen für Endianess : Little
    27. Format-Einstellungen für Sign : Signed
    28. Codec-ID : 1
    29. Dauer : 24min
    30. Bitraten-Modus : konstant
    31. Bitrate : 1 536 Kbps
    32. Kanäle : 1 Kanal
    33. Samplingrate : 48,0 KHz
    34. BitDepth/String : 32 bits
    35. Stream-Größe : 271 MiB (0%)
    36. Ausrichtung : Ausgerichtet an Interleaves
    37. Interleave, Dauer : 99 ms (5,97 Video-Frames)
    Alles anzeigen




    Mediainfo (Von der encodierten Version des ersten Videos, also dem auf YT um das es geht)
    Spoiler anzeigen


    Quellcode

    1. Allgemein
    2. UniqueID/String : 201665364982630245889604412943651134908 (0x97B75625F365FBEB8F60F6A6335D5DBC)
    3. Vollständiger Name : D:\Aviscripte\Watch This Folge 1-muxed.mkv
    4. Format : Matroska
    5. Format-Version : Version 2
    6. Dateigröße : 7,68 GiB
    7. Dauer : 27min
    8. Modus der Gesamtbitrate : variabel
    9. Gesamte Bitrate : 40,1 Mbps
    10. Kodierungs-Datum : UTC 2016-07-09 10:09:49
    11. Kodierendes Programm : mkvmerge v8.5.2 ('Crosses') 32bit
    12. verwendete Encoder-Bibliothek : libebml v1.3.3 + libmatroska v1.4.4
    13. Video
    14. ID : 1
    15. Format : AVC
    16. Format/Info : Advanced Video Codec
    17. Format-Profil : High 4:4:4 Predictive@L5
    18. Format-Einstellungen für CABAC : Ja
    19. Format-Einstellungen für ReFrames : 4 frames
    20. Codec-ID : V_MPEG4/ISO/AVC
    21. Dauer : 27min
    22. Bitrate : 39,4 Mbps
    23. Breite : 2 048 Pixel
    24. Höhe : 1 152 Pixel
    25. Bildseitenverhältnis : 16:9
    26. Modus der Bildwiederholungsrate : konstant
    27. Bildwiederholungsrate : 60,000 FPS
    28. ColorSpace : YUV
    29. ChromaSubsampling/String : 4:4:4
    30. BitDepth/String : 10 bits
    31. Scantyp : progressiv
    32. Bits/(Pixel*Frame) : 0.278
    33. Stream-Größe : 7,54 GiB (98%)
    34. verwendete Encoder-Bibliothek : x264 core 148 r2638 7599210
    35. Kodierungseinstellungen : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=4 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=600 / keyint_min=60 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=17.0 / qcomp=0.60 / qpmin=0 / qpmax=81 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
    36. Default : Ja
    37. Forced : Nein
    38. colour_range : Limited
    39. colour_primaries : BT.709
    40. transfer_characteristics : BT.709
    41. matrix_coefficients : BT.709
    42. Audio
    43. ID : 2
    44. Format : FLAC
    45. Format/Info : Free Lossless Audio Codec
    46. Codec-ID : A_FLAC
    47. Dauer : 27min
    48. Bitraten-Modus : variabel
    49. Bitrate : 723 Kbps
    50. Kanäle : 2 Kanäle
    51. Kanal-Positionen : Front: L R
    52. Samplingrate : 48,0 KHz
    53. Bildwiederholungsrate : 41,667 FPS (1152 spf)
    54. BitDepth/String : 16 bits
    55. Stream-Größe : 142 MiB (2%)
    56. verwendete Encoder-Bibliothek : libFLAC 1.3.1 (UTC 2014-11-25)
    57. Default : Ja
    58. Forced : Nein
    Alles anzeigen


    Link zum Video (Lautsprecher für den Anfang runterdrehen sonst R.I.P.) :

    Mein Kanal:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Chron ()

  • Chron schrieb:

    Fakt ist aber, dass durch die Encodierung FPS-Schwache Passagen entstanden sind, die es so vorher nicht gab.
    Das bezweifle ich erstmal, was ich allerdings kenne sind Mikroruckler/Stottern beim Abspielen von H.264 Material mit MPC-HC. Zurückspulen und die betreffende Stelle nochmals anschauen.

    Du müsstest schon genaue Zeitangaben machen, da ich mir das Video nicht vollständig anschauen werde nur um mögliche Ruckler zu finden.

    Chron schrieb:

    Passiert vorrangig beim Spulen
    Bedeutet das Video wird höchstwahrscheinlich erstmal neu gebuffert. Da wäre es mehr als verständlich, warum es kurz hängt.
  • Das Video wird irgendwie noch verarbeitet wie es aussieht.

    Auf YT habe ich nur 720p zur Verfügung auf dieses Video, obwohl er in 1152p hochgeladen hat.

    Hin und wieder kommt dann mal 1080p zum Vorscheinen, wenn ich die Seite neu lade. Habe das mal bei anderen Videos getestet wie die von De-M-oN oder meinen. Aber da sehe ich nicht solch ein Verhalten grad.

    Daher würde ich einfach sagen: Abwarten und Tee trinken. Sollte es nach 48h nicht besser geworden sein, müsste man noch mal schauen.

    Hier würde ich jetzt einfach mal sagen das YT da irgendwie rum hantiert.
  • @Kayten zurückspulen hat die laggs reproduziert, hab mir die stellen mehrfach angeschaut. Also die im lokalen encodierten Material, und die sind eben im Rohmaterial definitiv nicht drin. Ich kann mir nicht vorstellen, dass MPC-HC mit kompromierten 7GB Dateien Problemen hat, das noch viel massivere Rohmaterial mit 150GB aber absolut flüssig abspielen kann. Die Aufhänger sind definitiv kein Buffer, nicht nur, weil der Kreis nicht da ist, sondern auch weil die Sekunden weiterlaufen und auch der Ton und nur das Bild sowas hat.

    Genaue Zeitangaben kann ich gern heute nach dem Schlafen machen, bin gerade Hundemüde :sleeping:

    @Sagaras Das hört sich interessant an. Das Video hatte auch anfangs nachdem es hochgeladen war ja erstmal nur schwarzes Bild und legidlich Ton - und dann kam es sofort in 1080p@60 raus, fand ich auch schon komisch. Hab bisher kein Video gehabt was anfangs kein Bild lieferte, wenn auch nur 360p.
    Mein Kanal: