TS3 in OBS Studio stumm schalten aber wie?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • TS3 in OBS Studio stumm schalten aber wie?

    Anzeige
    Ich habe mal ein nettes Problem. Ich streame zwischen durch mal meine spiele auf Twitch. Meine Kollegen wollen aber nicht, das ich den TS mit streame.
    Also bin ich auf die suche gegangen, nach Guide die das eventuell verhindern.
    Und tatsächlich habe ich auch was gefunden. Virtual Audio Cables. Guide angeschaut. Funktioniert auch einige maßen.
    Hab mich nach diesem Guide gehalten.


    Da es aber OBS Studio ist, habe ich zwei Tonspuren, Desktop ist auf Lautsprecher und Desktop 2 ist mit den Virtual Cable verknüpft.
    Im TS unter Sound habe ich die Lautsprecher aus gewählt.

    Wenn ich in OBS auf Aufnahme klicke neben bei Musik höre und die Tonspur Desktop Audio stumm schalte, wird der TS nicht aufgenommen. Aber auch das Mikrofon wird nicht auf gezeichnet. Schalte ich aber den Desktop Audio wieder dazu, höre ich zwar den TS und das Mikrofon, aber die Musik im VLC ( ist auf Virtual Auido Cable verknüpft ) wird dann doppel abgespielt. Verzögerung von eine Sek.

    Habe ich irgendwo ein Denkfehler?
    Wenn ich mit meine Kollegen un Dungeon laufen möchte, darf ich halt den Stream mit TS übertragen. Möchte das halt, das ich switchen kann.
  • Da wäre es ganz gut mal Deinen (virtuellen) Aufbau zu sehen, klingt aktuell nämlich so, als hättest Du etwas verknüpft, was so nicht gehört :)

    Primär: Hast Du im Hauptfenster von OBS nur zwei Audio Quellen?

    EDIT: Du benutzt ja das VAC in OBS über Desktop-Audio - was ist, wenn Du es unter Mikro/Externes Gerät verwendest?
    Deskop-Audio benutzt nämlich den Virtual Input, während Mikro/Externes Gerät den Virtual Output benutzt ^^

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von CoRori ()

  • Okidoki, dann versuch es mal wie folgt:

    Du müsstest ja in den Windows-Audioeinstellungen ein VoiceMeeter Input (VB-Audio Virtual Cable) im Tab 'Wiedergabe' haben - das wählst Du als Standard aus.

    Im Tab 'Aufnahme' gehst Du auf VoiceMeeter Output (VB-Audio Virtual Cable) , dann auf 'Eigenschaften' -> 'Abhören' - dort aktivierst Du 'Dieses Gerät als Wiedergabequelle verwenden' und wählst unten Deine Lautsprecher (also das Gerät, worüber Du hörst) aus.

    In TS wählst Du als Wiedergabegerät VoiceMeeter Input (VB-Audio VoiceMeeter VAIO) aus.
    Wieder in den Windows-Soundeinstellungen gehst Du erneut auf den Tab 'Aufnahme' und wählst VoiceMeeter Output (VB-Audio VoiceMeeter VAIO) , dann 'Eigenschaften' -> 'Abhören' und hier das gleiche wie bereits oben einstellen.

    Du hast jetzt also quasi TS und den normalen Sound auf zwei verschiedenen Spuren, und beide führen auf einer anderen wieder zusammen.

    In OBS gehst Du nun in die Einstellungen -> 'Audio' und ordnest die Geräte so zu:
    Desktop Audiogerät 1 und 2 lässt Du LEER (Disabled)
    Bei Mikrofon 1 wählst Du Dein Mikro aus
    Bei Mikrofon 2 wählst Du VB-Audio Virtual Cable aus
    Bei Mikrofon 3 wählst Du VB-Audio VoiceMeeter VAIO aus

    Somit hast Du in der Übersicht ganz oben Dein Mikro
    An zweiter Stelle den Windows-Sound
    Und an Dritter den TS Sound

    Bedeutet, Du kannst Dich, Windows und TS unabhängig von einander Muten, bzw. Pegeln

    Zu guter Letzt noch einmal VoiceMeeter Banana öffnen auf 'Menu' und dann 'Reset-Settings' , damit keine Geräte gewählt sind, dieses Interface hier brauchst Du dann auch nicht weiter :)

    Das Problem zum obigen Video war halt, dass dort nur beschrieben wurde, wie man TS überhaupt nicht aufnimmt und nicht, wie man es togglet ^^

    Tut mir Leid, dass die Antwort etwas gebraucht hat, ich musste es eben erst installieren um zu Schauen :saint:
  • Ok erst mal vielen dank für die Mühe ;)

    CoRori schrieb:

    Okidoki, dann versuch es mal wie folgt:

    Du müsstest ja in den Windows-Audioeinstellungen ein VoiceMeeter Input (VB-Audio Virtual Cable) im Tab 'Wiedergabe' haben - das wählst Du als Standard aus.
    Ok erst mal vielen dank für die Mühe ;)in meine Windows-Audioeinstellungen ist nur ein Lautsprecher ( VB-Audio VoiceMeeter AUX VAIO ) und ein Lautsprecher mit ( VB-Audio Voicemeeter VAIO) vorhanden und mein Lautsprecher VIA HD Sound.Es gibt da nichts mit Imput.
  • Hab' mir das noch mal in Audacity angesehen, das ist ja wirklich arg leise :huh:

    Da aber Dein Mikro auch so leise ist, glaube ich jetzt auf Anhieb nicht, dass es etwas mit den VACs zu tun hat... Eine Lösung weiß ich aber spontan auch nicht :/

    Teste vielleicht mal in Audacity, wie laut Dein Mikro dort ist, dann hab' ich zum. einen Anhaltspunkt mehr ^^