Mit OBS Studio als .AVI aufnehmen? | Fehlerhaftes Bild im Schnittprogramm

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Mit OBS Studio als .AVI aufnehmen? | Fehlerhaftes Bild im Schnittprogramm

    Anzeige
    Hallo zusammen :)

    Der Titel sagt eigentlich schon alles.
    Ich habe eines meiner Projekte (mit Facecam) bislang mit Mirillis Action aufgenommen, da dort die Einbindung der Webcam total einfach gemacht ist.
    Nun würde ich aber gerne auf OBS umsteigen, da ich damit 1. lossless aufnehmen kann und 2. Action immer mehr Fehler einbaut mit jedem Update.


    Mein Problem: mein Schnittprogramm (Sony Movie Studio Platinum Suite 12) öffnet keine MP4-Dateien, außer interessanter Weise die Videos von einer Film-Kamera, die ich in MP4 geändert habe.
    Bei Aufnahmen aus OBS kommt dann das raus:



    Daher meine Frage: kann ich mit OBS irgendwie als .AVI aufnehmen?
    Oder liegt das am Ende evtl. gar nicht daran, sondern an einem anderen Problem?

    Weiß jemand wie man das lösen kann?

    Danke euch schon mal!
  • Danke euch :)

    Jetzt stehe ich vor dem nächsten Rätsel: Movie Studio will nun die .avi nicht öffnen, was es aber mit den .avi-Aufnahmen von Action oder Fraps ohne Probleme macht:




    Media Info der Videodatei:
    Allgemein
    Vollständiger Name : Z:\2016-09-15 12-52-53.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 1,41 GiB
    Dauer : 23s 615ms
    Gesamte Bitrate : 514 Mbps
    Kodierendes Programm : Lavf57.41.100

    Video
    ID : 0
    Format : YUV
    Codec-ID : ULY0
    Codec-ID/Info : Ut Video Lossless Codec
    Codec-ID/Hinweis : Ut Video
    Dauer : 23s 567ms
    Bitrate : 515 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    Bits/(Pixel*Frame) : 4.139
    Stream-Größe : 1,41 GiB (100%)

    Audio
    ID : 1
    Format : AC-3
    Format/Info : Audio Coding 3
    Format_Settings_ModeExtension : CM (complete main)
    Format-Einstellungen für Endianess : Big
    Codec-ID : 2000
    Dauer : 23s 615ms
    Bitraten-Modus : konstant
    Bitrate : 160 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 461 KiB (0%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 35 ms (2,09 Video-Frames)
  • RealLiVe schrieb:

    Vegas greift anders als OBS auf die installierten VFW-Decoder zurück - ich denke, du hast vergessen, UtVideo zu installieren.

    Zwar nichts mit dem Problem zu tun, aber ...

    Kaddi288 schrieb:

    Format : AC-3
    ... weil's geht, würde ich da eher auf PCM wechseln. Das ist verlustfrei.
    Ich wusste nicht mal, dass ich das installieren muss, da ich das ja in OBS einfach auswählen kann^^ Danke ^^
    Die neueste Version konnte ich nicht installieren...da trat immer ein Fehler auf. Mit der letzten ging es dann aber.


    Was das Audioformat angeht...
    Ich habe da einige Möglichkeiten mit PCM. Welche davon soll ich denn nutzen?^^


    Nun habe ich aber das nächste Problem: wenn ich mir die Aufnahme mit VLC anschaue, habe ich ganz normal Ton.
    Öffne ich die Datei aber in Sony Movie Studio wird mir nicht eine einzige Tonspur angezeigt ?( ?(

    Ich habe die Einstellungen dafür getroffen, dass ich Ingamespur und Mikro getrennt aufnehme...denke ich zumindest.
    So sehen meine Audio Einstellungen aus:





    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Kaddi288 ()

  • Northgate schrieb:

    Kaddi288 schrieb:

    Ich wusste nicht mal, dass ich das installieren muss, da ich das ja in OBS einfach auswählen kann^^
    Bei der Installation tritt folgender Fehler auf:
    Naja steht ja da: Zugriff verweigert. Es sieht so aus als hättest du keine Admin Rechte. ;)

    Habe das Problem gelöst^^ Die neueste Version hat Probleme gemacht. Mit letzten Version hat es sich problemlos installieren lassen.
    Nun habe ich "nur noch" oben gepostetes Problem mit den Audiospuren und dass ich nicht weiß welchen PCM Audiocodec ich nutzen soll^^

    Im Mixer habe ich es so eingestellt, dass ich zwei Spuren haben sollte:


    Im VLC Media Player wird mir aber irgendwie nur eine Spur gezeigt ?(
    Wenn ich dort auf Audio gehe und dann auf Audiospur habe ich dort nur "Deaktivieren" oder "Titel 1" zur Wahl ;(

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Kaddi288 ()

  • pcm_s16le (PCM, Signed, 16 bit, Little Endian) ist das, was du generell benötigst, hängt aber auch von deinen Windows Einstellungen ab.
    Solltest du in Windows beim Standardformat eine Bittiefe von 16bit eingestellt haben, wäre das korrekt.

    Über die FFmpeg Variante in OBS kann man bisher nur eine Audiospur aufnehmen. Einfachste Lösung wäre hier eine zweite OBS Instanz zu starten mit einem anderen Profil, welche nur ein 16x16 Schwarzbild und die jeweilig andere Audiospur aufnimmt. Beide so einstellen, dass auf die gleichen Hotkeys reagiert wird und man erspart sich das synchronisieren im Gegensatz zur Audacity Alternative.
  • Kaddi288 schrieb:

    Wenn ich dort auf Audio gehe und dann auf Audiospur habe ich dort nur "Deaktivieren" oder "Titel 1" zur Wahl
    Das ist der Haken, wenn du in OBS den Weg über FFmpeg gehst - darüber wird nur eine Audiospur unterstützt. Die zweite Spur musst du dir entweder mit Audacity aufnehmen, oder über ein 2. OBS. Zumindest derzeit.

    Alternativ könnten wir schauen, ob wir den Weg mit der MP4 hinbekommen - manche frisst Vegas ja.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von RealLiVe ()

  • Kayten schrieb:

    pcm_s16le (PCM, Signed, 16 bit, Little Endian) ist das, was du generell benötigst, hängt aber auch von deinen Windows Einstellungen ab.
    Solltest du in Windows beim Standardformat eine Bittiefe von 16bit eingestellt haben, wäre das korrekt.

    Über die FFmpeg Variante in OBS kann man bisher nur eine Audiospur aufnehmen. Einfachste Lösung wäre hier eine zweite OBS Instanz zu starten mit einem anderen Profil, welche nur ein 16x16 Schwarzbild und die jeweilig andere Audiospur aufnimmt. Beide so einstellen, dass auf die gleichen Hotkeys reagiert wird und man erspart sich das synchronisieren im Gegensatz zur Audacity Alternative.
    Danke dir :)
    Okay...dann bleibt mir wohl aktuell nur abzuwarten bis das geht, deine Variante mit 2x OBS laufen zu haben, mit Geduld die Tonspur anzupassen (habe die Tonspur der Aufnahme sowieso nur als Hilfe genommen, wo ich die Audacity Spur starten muss) oder in Movie Studio 13 zu investieren und doch als MP4 aufzunehmen^^

    Das soll sich wohl bei MP4 Dateien nicht so krass anstellen, wie das 12er -.-

    Aber das sollte dennoch die bessere Wahl sein, als weiter mit Mirillis Action aufzunehmen...
    Sind die MP4 Aufnahmen bei OBS Studio denn auch lossless? Oder sind sie es nur mit dem UTVideo Codec?

    Beim "alten" OBS musste man ja "qp=0" bei den Encoding Einstellungen eingeben.
  • Kaddi288 schrieb:

    Sind die MP4 Aufnahmen bei OBS Studio denn auch lossless? Oder sind sie es nur mit dem UTVideo Codec? Beim "alten" OBS musste man ja "qp=0" bei den Encoding Einstellungen eingeben.
    Kommt auf die Einstellungen an - mach davon bitte mal einen Screenshot oder eine MediaInfo von der MP4-Datei. Mit CRF0 oder qp0 sind sie verlustfrei - und das kann Vegas nicht lesen, auch das neue nicht.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • Ich weiß nicht, was du die ganze Zeit mit Vegas hast :D Es wäre schön, wenn ich das hätte, aber das ist entschieden zu teuer :D

    Ein Freund von mir nimmt mit OBS mp4 Dateien auf und kann sie in Movie Studio 13 problemlos reinladen, wie er mir sagte.
    Daher hat er mir empfohlen die 13er Version zu kaufen.

    Das hier wäre die Media-Info einer kurzen Desktopaufnahme (qp0 wie schon geschrieben natürlich in den Einstellungen drin).
    Audio Codec usw habe ich da jetzt alles nicht umgestellt. Die Info dient rein zum Zeigen der Video-Einstellungen.

    Allgemein
    Vollständiger Name : Z:\Aufnahme\MOV0DF.mp4
    Format : MPEG-4
    Format-Profil : Base Media
    Codec-ID : isom
    Dateigröße : 8,40 MiB
    Dauer : 5s 121ms
    Gesamte Bitrate : 13,8 Mbps
    Kodierungs-Datum : UTC 2016-09-15 18:41:06
    Tagging-Datum : UTC 2016-09-15 18:41:06
    Kodierendes Programm : Open Broadcaster Software v0.658b

    Video
    ID : 2
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High 4:4:4 Predictive@L4.2
    Format-Einstellungen für CABAC : Nein
    Format-Einstellungen für ReFrames : 1 frame
    Muxing-Modus : Container profile=High@3.1
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 5s 116ms
    Source_Duration/String : 5s 100ms
    Bitrate : 13,7 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : variabel
    Bildwiederholungsrate : 60,000 FPS
    minimale Bildwiederholungsrate : 58,824 FPS
    maximale Bildwiederholungsrate : 62,500 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.110
    Stream-Größe : 8,31 MiB (99%)
    Source_StreamSize/String : 8,32 MiB (99%)
    verwendete Encoder-Bibliothek : x264 core 146 r2538 121396c
    Kodierungseinstellungen : cabac=0 / ref=1 / deblock=0:0:0 / analyse=0:0 / me=dia / subme=0 / psy=0 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=0 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=0 / keyint=240 / keyint_min=24 / scenecut=0 / intra_refresh=0 / rc=cqp / mbtree=0 / qp=0
    Kodierungs-Datum : UTC 2016-09-15 18:41:06
    Tagging-Datum : UTC 2016-09-15 18:41:06
    colour_range : Limited
    colour_primaries : BT.709
    transfer_characteristics : sYCC
    matrix_coefficients : BT.709
    mdhd_Duration : 5116

    Audio
    ID : 1
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 5s 121ms
    Source_Duration/String : 5s 77ms
    Bitraten-Modus : konstant
    nominale Bitrate : 128 Kbps
    Kanäle : channel0
    Channel(s)_Original : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    Source_StreamSize/String : 70,4 KiB (1%)
    Sprache : Englisch
    Kodierungs-Datum : UTC 2016-09-15 18:41:06
    Tagging-Datum : UTC 2016-09-15 18:41:06
  • Kaddi288 schrieb:

    Ein Freund von mir nimmt mit OBS mp4 Dateien auf und kann sie in Movie Studio 13 problemlos reinladen, wie er mir sagte.
    Daher hat er mir empfohlen die 13er Version zu kaufen.
    Ja der wird dann auch lossy aufgenommen haben. Lossless (constant quantizer @ 0 (qp 0) ) benötigt das High 4:4:4 Predictive Profil, was die halbfertigen Decoder von Timeline Software nich hinkriegen. Die kriegen ja nichtmal 10bit videos hin, geschweige denn höhere Farb Subsamplings als 4:2:0
    Timeline NLEs sind einfach eine Katastrophe in Hinsicht de- und encoder

    Zudem solltest du nicht in variabler framerate aufnehmen, sonst haste direkt das nächste Problem mit Timeline Software: Alles asynchron wenn du Pech hast
    Aktuelle Projekte/Videos


  • Kaddi288 schrieb:

    Ich weiß nicht, was du die ganze Zeit mit Vegas hast Es wäre schön, wenn ich das hätte, aber das ist entschieden zu teuer
    Movie Studio gehört zu der Produktfamilie und ist quasi "Vegas Lite". Müsste sich beim Decoding in dem Fall auch nicht unterscheiden soweit ich weiß. Ich schreib halt Vegas, weil es kürzer ist :D

    Kaddi288 schrieb:

    Das hier wäre die Media-Info einer kurzen Desktopaufnahme (qp0 wie schon geschrieben natürlich in den Einstellungen drin).
    Ich sehe an der Datei 3 Auffälligkeiten.
    • Sie scheint mit der alten OBS-Version aufgenommen worden zu sein.
    • Im Header steht, dass es sich um eine variable Framerate handelt. Das kann entweder durch eine Einstellung verursacht worden sein, oder es ist der "übliche" Bug vom alten OBS, dass es falsch im Header steht.
    • Die Datei liegt im High 4:4:4 - Profil vor und ist verlustfrei - weder Vegas, noch Movie Studio können damit was anfangen. Gängige Empfehlung ist es, hier einen kleinen Verlust in Kauf zu nehmen und statt qp=0 eben qp=1 zu nutzen. Sofern die restlichen Einstellungen stimmen, müsste dein Movie Studio das dann lesen können.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • RealLiVe schrieb:

    Kaddi288 schrieb:

    Ich weiß nicht, was du die ganze Zeit mit Vegas hast Es wäre schön, wenn ich das hätte, aber das ist entschieden zu teuer
    Movie Studio gehört zu der Produktfamilie und ist quasi "Vegas Lite". Müsste sich beim Decoding in dem Fall auch nicht unterscheiden soweit ich weiß. Ich schreib halt Vegas, weil es kürzer ist :D

    Kaddi288 schrieb:

    Das hier wäre die Media-Info einer kurzen Desktopaufnahme (qp0 wie schon geschrieben natürlich in den Einstellungen drin).
    Ich sehe an der Datei 3 Auffälligkeiten.
    • Sie scheint mit der alten OBS-Version aufgenommen worden zu sein.
    • Im Header steht, dass es sich um eine variable Framerate handelt. Das kann entweder durch eine Einstellung verursacht worden sein, oder es ist der "übliche" Bug vom alten OBS, dass es falsch im Header steht.
    • Die Datei liegt im High 4:4:4 - Profil vor und ist verlustfrei - weder Vegas, noch Movie Studio können damit was anfangen. Gängige Empfehlung ist es, hier einen kleinen Verlust in Kauf zu nehmen und statt qp=0 eben qp=1 zu nutzen. Sofern die restlichen Einstellungen stimmen, müsste dein Movie Studio das dann lesen können.

    Ja, dachte ich mir schon - schreibt sich schneller :D

    Die Datei habe ich mit der alten aufgenommen, jap :)
    Hmmm...dann versuche ich also einfach nochmal eine MP4 Aufnahme mit dem neuen und qp=1 und schaue mal, ob er dann frisst, was ich ihm zum Fraß vorwerfe^^

    @RealLiVe
    Okay. Danke für den super Tipp! Ich weiß nicht wie viel der Unterschied von qp=0 zu qp=1 an Qualität ausmacht, aber so erkennt Movie Studio es und VLC zeigt mir auch 2 Audiospuren an :)

    Nun aber der nächste Knackpunkt: Movie Studio erkennt keine einzige Audiospur.

    Das ist die Media Info der MP4 Aufnahme:
    Allgemein
    Vollständiger Name : Z:\2016-09-15 22-06-45.mp4
    Format : MPEG-4
    Format-Profil : Base Media
    Codec-ID : isom
    Dateigröße : 872 MiB
    Dauer : 26s 17ms
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 281 Mbps
    Kodierendes Programm : Lavf57.41.100

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : Baseline@L4.2
    Format-Einstellungen für CABAC : Nein
    Format-Einstellungen für ReFrames : 1 frame
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 26s 17ms
    Bitrate : 281 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 2.256
    Stream-Größe : 871 MiB (100%)
    verwendete Encoder-Bibliothek : x264 core 148 r2705 3f5ed56
    Kodierungseinstellungen : cabac=0 / ref=1 / deblock=0:0:0 / analyse=0:0 / me=dia / subme=0 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=0 / keyint=250 / keyint_min=25 / scenecut=0 / intra_refresh=0 / rc=cqp / mbtree=0 / qp=1 / ip_ratio=1.40 / aq=0

    Audio #1
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 25s 982ms
    Bitraten-Modus : variabel
    Bitrate : 158 Kbps
    maximale Bitrate : 160 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 KHz
    Stream-Größe : 500 KiB (0%)
    Titel : Ingame

    Audio #2
    ID : 3
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 25s 982ms
    Bitraten-Modus : variabel
    Bitrate : 139 Kbps
    maximale Bitrate : 160 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 KHz
    Stream-Größe : 440 KiB (0%)
    Titel : Mikro

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Kaddi288 ()

  • Kaddi288 schrieb:

    Nun aber der nächste Knackpunkt: Movie Studio erkennt keine einzige Audiospur.
    Kann ich hier gerade nicht reproduzieren - bei mir werden alle Spuren erkannt, und davon bin ich ein Stück weit selbst überrascht. Kannst du eine Testdatei mit dem Problem hochladen? Ein paar Sekunden genügen.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • RealLiVe schrieb:

    Kaddi288 schrieb:

    Nun aber der nächste Knackpunkt: Movie Studio erkennt keine einzige Audiospur.
    Kann ich hier gerade nicht reproduzieren - bei mir werden alle Spuren erkannt, und davon bin ich ein Stück weit selbst überrascht. Kannst du eine Testdatei mit dem Problem hochladen? Ein paar Sekunden genügen.

    Hm...welches Programm nutzt du denn zum Schneiden? Vielleicht mag Movie Studio einfach kein AAC...aber das scheine ich nicht umstellen zu können, wenn ich nicht in den erweiterten Modus gehe.

    Und da wiederum kann ich ja leider keine getrennten Tonspuren machen :(


    Hier ist eine kurze Test-File:
    2016-09-1522-59-45.mp4
  • Kaddi288 schrieb:

    Hm...welches Programm nutzt du denn zum Schneiden?
    Ich selbst verwende Vegas 12 Pro, das konnte deine Datei problemlos lesen. Habe mir noch die Testversion von Movie Studio 12 Platinum besorgt, da konnte ich letztendlich den Fehler reproduzieren.

    Auch wenn ich noch keine Zeit hatte, um die genaue Ursache zu verifizieren, hätte ich zumindest einen Workaround. Bei mir hat es funktioniert, wenn ich die problematische Aufnahme neu gemuxt habe. OBS Studio stellt dazu im Menü Datei die Funktion Remuxe Aufnahmen bereit.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von RealLiVe ()