OBS Studio - Verlustfreie Aufnahme & Sammelthread

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Anzeige

      MisterSic schrieb:

      Modus der Bildwiederholungsrate : variabel
      Bildwiederholungsrate : 60,000 FPS
      minimale Bildwiederholungsrate : 58,851 FPS
      maximale Bildwiederholungsrate : 1 024,000 FPS
      Zeig mal deine Einstellungen. Player kommen mit variabler Framerate klar, die meisten Bearbeitungsprogramme dagegen nicht.

      Ansonsten solltest du mal einen Blick auf die Bitrate deiner Audiospuren werfen.

      MisterSic schrieb:

      Bitrate : 29,0 kb/s
      Die erscheint mir etwas gering.
    • Moinsen,

      hab jetzt nochmal eine neue Aufnahme gemacht mit folgenden Settings:





      Und die MediaInfo dazu:

      Spoiler anzeigen

      Allgemein
      Vollständiger Name : D:\Test\2017-05-26 16-06-35.mp4
      Format : MPEG-4
      Format-Profil : Base Media
      Codec-ID : isom (isom/iso2/avc1/mp41)
      Dateigröße : 328 GiB
      Dauer : 1 h 46 min
      Modus der Gesamtbitrate : variabel
      Gesamte Bitrate : 442 Mb/s
      Kodierendes Programm : Lavf57.66.102

      Video
      ID : 1
      Format : AVC
      Format/Info : Advanced Video Codec
      Format-Profil : High 4:4:4 Predictive@L5.1
      Format-Einstellungen für CABAC : Nein
      Format-Einstellungen für ReFrames : 1 frame
      Format_Settings_GOP : M=1, N=60
      Codec-ID : avc1
      Codec-ID/Info : Advanced Video Coding
      Dauer : 1 h 46 min
      Bitrate : 442 Mb/s
      Breite : 2 560 Pixel
      Höhe : 1 080 Pixel
      Bildseitenverhältnis : 2,40:1
      Modus der Bildwiederholungsrate : konstant
      Bildwiederholungsrate : 60,000 FPS
      ColorSpace : YUV
      ChromaSubsampling/String : 4:2:0
      BitDepth/String : 8 bits
      Scantyp : progressiv
      Bits/(Pixel*Frame) : 2.662
      Stream-Größe : 327 GiB (100%)
      colour_range : Limited
      matrix_coefficients : BT.709

      Audio #1
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 1 h 46 min
      Bitraten-Modus : variabel
      Bitrate : 188 kb/s
      maximale Bitrate : 192 kb/s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 kHz
      Bildwiederholungsrate : 43,066 FPS (1024 spf)
      Stream-Größe : 143 MiB (0%)
      Titel : Track1
      Default : Ja
      AlternateGroup/String : 1

      Audio #2
      ID : 3
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 1 h 46 min
      Bitraten-Modus : variabel
      Bitrate : 119 kb/s
      maximale Bitrate : 192 kb/s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 kHz
      Bildwiederholungsrate : 43,066 FPS (1024 spf)
      Stream-Größe : 90,0 MiB (0%)
      Titel : Track2
      Default : Nein
      AlternateGroup/String : 1


      Da entstand das Problem nun nicht. Jetzt bin ich mir nicht mehr 100% sicher ob ich vorher immer nur in MKV Aufgenommen habe und dann in Mp4 umgewandelt habe oder auch aufnahmen dabei waren, die in Mp4 das selbige Problem ausgelöst haben. Waren dann doch zu viele Aufnahmen in den letzten Wochen.
      Hatte jetzt hier mal die kb vom Audio runter genommen von 320 auf 190. Um zu sehen ob es daran liegen könnte

      Allerdings bei einer anderen Aufnahme von heute morgen hat dann ebenfalls geklappt. Und da war nun auch alles auf 320 eingestellt.
      MediaInfo ebenfalls hier:

      Spoiler anzeigen

      Allgemein
      Vollständiger Name : D:\Test\Quarantine - Folge 001.mp4
      Format : MPEG-4
      Format-Profil : Base Media
      Codec-ID : isom (isom/iso2/avc1/mp41)
      Dateigröße : 66,4 GiB
      Dauer : 51 min 6s
      Modus der Gesamtbitrate : variabel
      Gesamte Bitrate : 186 Mb/s
      Kodierendes Programm : Lavf57.66.102

      Video
      ID : 1
      Format : AVC
      Format/Info : Advanced Video Codec
      Format-Profil : High 4:4:4 Predictive@L5.1
      Format-Einstellungen für CABAC : Nein
      Format-Einstellungen für ReFrames : 1 frame
      Format_Settings_GOP : M=1, N=60
      Codec-ID : avc1
      Codec-ID/Info : Advanced Video Coding
      Dauer : 51 min 6s
      Bitrate : 185 Mb/s
      Breite : 2 560 Pixel
      Höhe : 1 080 Pixel
      Bildseitenverhältnis : 2,40:1
      Modus der Bildwiederholungsrate : konstant
      Bildwiederholungsrate : 60,000 FPS
      ColorSpace : YUV
      ChromaSubsampling/String : 4:2:0
      BitDepth/String : 8 bits
      Scantyp : progressiv
      Bits/(Pixel*Frame) : 1.118
      Stream-Größe : 66,2 GiB (100%)
      colour_range : Limited
      matrix_coefficients : BT.709

      Audio #1
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 51 min 6s
      Bitraten-Modus : variabel
      Bitrate : 288 kb/s
      maximale Bitrate : 320 kb/s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 kHz
      Bildwiederholungsrate : 43,066 FPS (1024 spf)
      Stream-Größe : 107 MiB (0%)
      Titel : Track1
      Default : Ja
      AlternateGroup/String : 1

      Audio #2
      ID : 3
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 51 min 6s
      Bitraten-Modus : variabel
      Bitrate : 154 kb/s
      maximale Bitrate : 320 kb/s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 kHz
      Bildwiederholungsrate : 43,066 FPS (1024 spf)
      Stream-Größe : 56,2 MiB (0%)
      Titel : Track2
      Default : Nein
      AlternateGroup/String : 1


      Ich würde gerne die Zusammenhänge verstehen, lag das am File Format?
    • NV12 wäre performanter als i420.

      MisterSic schrieb:

      Modus der Bildwiederholungsrate : konstant
      Bildwiederholungsrate : 60,000 FPS
      Diesma hastes in Konstanter Framerate. Das war wohl oben anders.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • Anzeige
      Allgemein





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • Hab eben wieder eine Aufnahme gemacht, bin mir ziemlich sicher das ich nichts umgestellt habe und es ist wieder Asynchron geworden.
      In der Media Info steht auch wieder Variabel drinnen. Ich versteh das nicht, das kann doch kein 50:50 Joker werden, welche Aufnahme dann mal so klappt und welche nicht.

      Anbei die Screens und Logs:

      Einstellungen:







      MediaInfo:

      Spoiler anzeigen

      Allgemein
      Vollständiger Name : D:\Test\2017-05-28 22-15-53.mp4
      Format : MPEG-4
      Format-Profil : Base Media
      Codec-ID : isom (isom/iso2/avc1/mp41)
      Dateigröße : 337 GiB
      Dauer : 2 h 3 min
      Modus der Gesamtbitrate : variabel
      Gesamte Bitrate : 391 Mb/s
      Kodierendes Programm : Lavf57.66.102

      Video
      ID : 1
      Format : AVC
      Format/Info : Advanced Video Codec
      Format-Profil : High 4:4:4 Predictive@L5.1
      Format-Einstellungen für CABAC : Nein
      Format-Einstellungen für ReFrames : 1 frame
      Format_Settings_GOP : M=1, N=60
      Codec-ID : avc1
      Codec-ID/Info : Advanced Video Coding
      Dauer : 2 h 3 min
      Bitrate : 390 Mb/s
      Breite : 2 560 Pixel
      Höhe : 1 080 Pixel
      Bildseitenverhältnis : 2,40:1
      Modus der Bildwiederholungsrate : konstant
      Bildwiederholungsrate : 60,000 FPS
      ColorSpace : YUV
      ChromaSubsampling/String : 4:2:0
      BitDepth/String : 8 bits
      Scantyp : progressiv
      Bits/(Pixel*Frame) : 2.354
      Stream-Größe : 337 GiB (100%)
      colour_range : Limited
      matrix_coefficients : BT.709

      Audio #1
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 2 h 3 min
      Bitraten-Modus : variabel
      Bitrate : 185 kb/s
      maximale Bitrate : 192 kb/s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 kHz
      Bildwiederholungsrate : 43,066 FPS (1024 spf)
      Stream-Größe : 163 MiB (0%)
      Titel : Track1
      Default : Ja
      AlternateGroup/String : 1

      Audio #2
      ID : 3
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 2 h 3 min
      Bitraten-Modus : variabel
      Bitrate : 118 kb/s
      maximale Bitrate : 192 kb/s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 kHz
      Bildwiederholungsrate : 43,066 FPS (1024 spf)
      Stream-Größe : 105 MiB (0%)
      Titel : Track2
      Default : Nein
      AlternateGroup/String : 1



      OBS Log:

      Klick mich.
      Seht ihr woran das liegen könnte? Werde langsam bekloppt...
    • MisterSic schrieb:

      In der Media Info steht auch wieder Variabel drinnen.
      Wo denn?

      Video hat ne konstante Framerate laut Mediainfo.

      Und die Bitrate kann und sollte auch Variable sein.

      Obwohl das bei Audio recht komisch aussieht was er bei dir da macht. Für Gewöhnlich nimmt OBS eigentlich mit einer konstanten Bitrate die Audio-Aufnahmen auf.

      Aber ist eigentlich egal, kann auch eine Variable sein.

      Wichtig bei Audio ist die Hertz Zahl. So wie bei Video die FPS. Und die sind in beiden Fällen konstant laut deiner Mediainfo.

      Schon mal geprüft ob du HPET aktiv hast unter Windows? Nicht das es inaktiv ist. Weil das könnte eventuell der Grund sein warum das nicht so läuft wie gedacht bei dir.
      Ausgeschrieben ist das der High Precision Event Timer, der einen erheblichen höheren Takt vorgibt und damit um weiten Präziser ist.
      Er dient vor allem um Parallel laufende Datenströme besser zu synchronisieren. z.B. bei Aufnahme von Bild und Ton für Video. Auch für Abspiel-Player unter Windows wie VLC oder MPC, etc. ist ein aktives HPET besser.

      Ob es aktiv ist oder nicht kannst du z.B. mit den WinTimerTester überprüfen.

      Wenn der Test eine Taktfrequenz von 14,xxx anzeigt, wäre HPET aktiv auf dem Rechner/Windows.

      Kannst es, wenn es nicht so ist und die Frequenz sonstwie niedriger ist als 14,xxx, HPET folgendermaßen aktivieren:

      Start -> "CMD" im Suchfeld eingeben und die CMD.exe starten. -> und dann folgendes in der Kommandokonsole eingeben:
      bcdedit /set useplatformclock true
    • Wäre in meinem Falle nicht Aktiv. Dächte auch irgendwo hier mal gelesen haben das es unter Windows 10 nicht mehr so relevant ist?
      Was mich zusätzlich verwirrt ist der Punkt, das es vorher ja auch alles gut geklappt hat mit den Aufnahmen und dann nicht mehr. Okay ich hab nicht mit diesen Settings aufgenommen sondern mit den Settings für UT Video Codec, was dann bedeuten kann das es jetzt erst auffällt.
    • Schauerland schrieb:

      @MisterSic hast du iTunes installiert bzw das CoreAudio package davon?
      Wenn nein, mach es mal. Sonst verwendet er nen encoder der nicht so toll ist für audio.

      obsproject.com/forum/resources…-aac-encoder-windows.220/
      Hatte ich jetzt auch noch nicht, hab es mal eben Installiert und werde morgen mal eine Test Aufnahme machen.
      Kann mit mir einer das HPET noch näher erläutern ob das unter Win10 gemacht werden sollte oder ob das nicht mehr Relevant ist, hatte das mal hier im Forum gelesen.
    • Ich hab nun mal Zeit gefunden noch eine Aufnahme von Watch Dogs 2 zu probieren, leider ist das ruckeln nnoch da.
      Was ich mir nur schwer vorstellen kann, dass es am Prozessor liegt da mit Dxtory, Action, Shadowplay ohne Ruckler aufzunehmen geht.
      Braucht OBS wirklich so viel mehr Resourcen oder bin ich zu dumm das richtig einzustellen xD

      MediaInfo:

      Spoiler anzeigen

      Allgemein
      UniqueID/String : 189298868156517993967289459400037631772 (0x8E69A2C7DC376102F332A2A4C680071C)
      Vollständiger Name : B:\OBS Studio\2017-05-30 20-10-22.mkv
      Format : Matroska
      Format-Version : Version 4 / Version 2
      Dateigröße : 466 MiB
      Dauer : 2 min 39s
      Gesamte Bitrate : 24,5 Mb/s
      Kodierendes Programm : Lavf57.66.102
      verwendete Encoder-Bibliothek : Lavf57.66.102
      ErrorDetectionType : Per level 1


      Video
      ID : 1
      Format : AVC
      Format/Info : Advanced Video Codec
      Format-Profil : High 4:4:4 Predictive@L4.2
      Format-Einstellungen für CABAC : Nein
      Format-Einstellungen für ReFrames : 1 frame
      Format_Settings_GOP : M=1, N=60
      Codec-ID : V_MPEG4/ISO/AVC
      Dauer : 2 min 39s
      Breite : 1 920 Pixel
      Höhe : 1 080 Pixel
      Bildseitenverhältnis : 16:9
      Modus der Bildwiederholungsrate : konstant
      Bildwiederholungsrate : 60,119 FPS
      originale Bildwiederholungsrate : 60,000 FPS
      ColorSpace : YUV
      ChromaSubsampling/String : 4:2:0
      BitDepth/String : 8 bits
      Scantyp : progressiv
      verwendete Encoder-Bibliothek : x264 core 148 r2762 90a61ec
      Kodierungseinstellungen : cabac=0 / ref=1 / deblock=0:0:0 / analyse=0:0 / me=dia / subme=0 / psy=0 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=0 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=0 / keyint=60 / keyint_min=6 / scenecut=0 / intra_refresh=0 / rc=cqp / mbtree=0 / qp=0
      Default : Ja
      Forced : Nein
      colour_range : Limited
      colour_primaries : BT.709
      transfer_characteristics : BT.709
      matrix_coefficients : BT.709
      DURATION : 00:02:39.617000000


      Audio #1
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : A_AAC
      Dauer : 2 min 39s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 48,0 kHz
      Bildwiederholungsrate : 46,875 FPS (1024 spf)
      Titel : Track1
      Default : Ja
      Forced : Nein
      DURATION : 00:02:39.595000000


      Audio #2
      ID : 3
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : A_AAC
      Dauer : 2 min 39s
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 48,0 kHz
      Bildwiederholungsrate : 46,875 FPS (1024 spf)
      Titel : Track2
      Default : Ja
      Forced : Nein
      DURATION : 00:02:39.595000000


      Ich zocke :thumbsup:
    • Nimm halt NVEnc und nicht x264. Kann doch auch verlustfrei.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • Hallo zusammen,

      woran kann es liegen, dass das Bild in meiner Videobearbeitungssoftware (in diesem Fall Vegas Pro 13) bei Variante 2: x264 und dem Farbraum I444 schwarz bleibt? Sofern ich zurück auf I420 stelle wird mein Videomaterial importiert und angezeigt.

      Ich habe 3 verschiedene Audiospuren mit Virtual Audio Cable in OBS konfiguriert, die ich gerne mit aufzeichnen würde. Das funktioniert lt. Angaben nur mit *.mkv oder *.mp4. Ich selbst habe die Testaufnahmen in *.mkv aufgenommen und remuxe diese über OBS in *.mp4, sodass ich das Material in Vegas einbinden kann.

      Danke für die Hilfe.
    • weil dessen decoder zum kotzen sind.
      2017 und noch immer h.264 decoder die die hälfte der h.264 features nicht können..
      Das übliche manko von windows timeline software





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      weil dessen decoder zum kotzen sind.
      2017 und noch immer h.264 decoder die die hälfte der h.264 features nicht können..
      Das übliche manko von windows timeline software
      Danke für die Antwort.

      Lässt sich da was ändern, sodass ich trotzdem meine 3 Tonspuren nutzen kann?

      PS: Du meinst sicherlich den Decoder von Vegas? Ich hätte noch über Steam Vegas Pro 14 Steam Edition - ist das ggf. dort anders bzw. besser umgesetzt? Selbst ausprobiert hab ich es bisher nicht, da ich für meine LPs bisher immer Vegas Pro 13 genommen habe.

      PPS: Ist das Gleiche in Grün unter Vegas Pro 14 Steam Edition. Soviel Geld für Schrott - im wahrsten Sinne des Wortes.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von fr0st ()

    • fr0st schrieb:

      Lässt sich da was ändern, sodass ich trotzdem meine 3 Tonspuren nutzen kann?
      Nein, die Decoder von Vegas sind derzeit nicht in der Lage, das Material auszulesen und ein Plug-In wäre mir nicht bekannt. Du kannst lediglich entweder ...
      • ... das Video vorher in ein für Vegas lesbares Format konvertieren. Das kostet sich halt Zeit und viel Speicherplatz.
      • ... oder auf ein anderes Programm wechseln. Ein paar können ja damit umgehen.
      • ... oder, meine bevorzugte Variante, so aufnehmen, dass Vegas deine Videos lesen kann. In dem Fall würde ich einen marginalen Qualitätsverlust hinnehmen und in YUV 4:2:0 und einem möglichst niedrigen QP (bevorzugt) oder CRF aufnehmen. Das kann Vegas lesen.
      Java is to JavaScript what Fun is to Funeral

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von RealLiVe ()

    • Danke für die Antwort @RealLiVe

      RealLiVe schrieb:


      • ... oder auf ein anderes Programm wechseln. Ein paar können ja damit umgehen.

      Welche Alternativen kannst du mir denn nennen? Spontan würe mir TMPGEnc Video Mastering Works 6 einfallen. Damit wäre das Auslesen von YUV 4:4:4 (ggf. auch RGB?) sicherlich möglich - oder?


      RealLiVe schrieb:


      • ... oder, meine bevorzugte Variante, so aufnehmen, dass Vegas deine Videos lesen kann. In dem Fall würde ich einen marginalen Qualitätsverlust hinnehmen und in YUV 4:2:0 und einem möglichst niedrigen QP (bevorzugt) oder CRF aufnehmen. Das kann Vegas lesen.

      Könnte ich ausprobieren und mich ggf. sogar abfinden mit sofern ich weiterhin meine 3 Tonspuren verwenden kann. Dafür müsste ich von x264 auf NVENC H.264 welchseln und CQP auswählen, richtig? Wie siehts mit den anderen Einstellungen aus wie z.B. Voreinstellung, Profile, Level doer B-Frames? Die Anleitung im ersten Beitrag gibt das leider nicht her. Ich habe anbei einen Screenshot angehängt mit meinen derzeitigen Einstellungen. Vegas kann das Format auslesen.

      Ich weiß nur nicht, ob der CQP Wert 0 in diesem Fall übertrieben ist oder nicht. Hab mich nur an CRF 1 orientiert, da CRF 0 von Vegas nicht gelesen werden kann.

      [IMG:http://i.imgur.com/MEEy1XT.png]