OBS Studio - Verlustfreie Aufnahme & Sammelthread

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Das Internet ist in Gefahr, und du kannst es retten! Die geplante Urheberrechts-Richtlinie des EU-Parlaments bedroht jeden Let's Player und gefährdet das Fortbestehen des LetsPlayForums. Klicke hier, um mehr zu erfahren!

    • Anzeige
      CQP 0 ist ja auch wieder lossless ;D Nichts für Vegas xD

      CQP 1 bis maximal 15 würd ich für die Aufnahme empfehlen.
      preset auf high performance
      bframes auf 0

      Das ist zwar effizienzmindernd, aber mit niedrigen CQPs sowieso nur auf die Dateigröße schlagend. Wichtiger ist ja das der fps loss ingame gering bleibt und im Video möglichst keine Duplikatframes/Dropped Frames drin sind. Den Keyframeintervall würde ich auf auto lassen. Dürfte dann 250 Frames sein.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • fr0st schrieb:

      Könnte ich ausprobieren und mich ggf. sogar abfinden mit sofern ich weiterhin meine 3 Tonspuren verwenden kann. Dafür müsste ich von x264 auf NVENC H.264 welchseln und CQP auswählen, richtig?
      Müssen nicht - du kannst auch bei X.264 die Qualitätsregulierungsmethode CRF nehmen und den Wert 1 benutzen. Oder, falls du QP benutzen willst, die Sache über die benutzerdefinierte Kommandozeile regeln.

      Zu NVEnc kann ich dir keine Auskunft geben, sorry.

      fr0st schrieb:

      Welche Alternativen kannst du mir denn nennen? Spontan würe mir TMPGEnc Video Mastering Works 6 einfallen. Damit wäre das Auslesen von YUV 4:4:4 (ggf. auch RGB?) sicherlich möglich - oder?
      Shotcut und Openshot müssten damit klar kommen - beide kostenfrei, aber beide auch bei der Nachbearbeitung deutlich schlechter als Vegas. Premiere Pro kann glaube ich mittlerweile auch verlustfreies H.264 lesen. TMPGEnc bin ich mir nicht sicher, ob das schon eingebaut wurde - hat glaub ich nur bis 4:2:2 gelesen, für den Rest müsste man den DirectShow-Öffner benutzen.
      Java is to JavaScript what Fun is to Funeral
    • De-M-oN schrieb:

      CQP 0 ist ja auch wieder lossless ;D Nichts für Vegas xD

      CQP 1 bis maximal 15 würd ich für die Aufnahme empfehlen.
      preset auf high performance
      bframes auf 0

      Das ist zwar effizienzmindernd, aber mit niedrigen CQPs sowieso nur auf die Dateigröße schlagend. Wichtiger ist ja das der fps loss ingame gering bleibt und im Video möglichst keine Duplikatframes/Dropped Frames drin sind. Den Keyframeintervall würde ich auf auto lassen. Dürfte dann 250 Frames sein.
      Seltsamerweise kann ich den die Aufnahme mit einem CQP Wert von 0 in Vegas importieren. Die Dateigröße ist jedoch mit ~270 MB für ein 1 minütiges Video wenig. Da habe ich unter x264 und CRF 1 weitaus mehr Speicherplatz verbraten bei dem gleichen Spiel.

      Sobald ich den Preset oder auch Profile verändere lässt sich die Aufnahme starten, es wird keine Datei erzeugt und beenden kann ich die Aufnahme ebenfalls nicht. Nur noch das Schließen von OBS über den Taskmanager geht.

      RealLiVe schrieb:

      Müssen nicht - du kannst auch bei X.264 die Qualitätsregulierungsmethode CRF nehmen und den Wert 1 benutzen. Oder, falls du QP benutzen willst, die Sache über die benutzerdefinierte Kommandozeile regeln.
      Bin etwas überfragt.. Wenn ich QP nutzen will muss ich das Feld unter x264 Optionen mit 'qp=1' ausfüllen? Oder meinst du mit der Kommandozeile etwas ganz anderes?
    • Für CQP 0 musst du das high444p profil nehmen. Sonst geht CQP 0 sowieso nicht. Und bei High444 predictive steigt Vegas dann wieder aus. Mit main oder high biste aber nicht lossless. Da kannste kein CQP 0 machen. Wird dann einen Fallback Setting genommen haben oder was auch immer.
      _
      CQP 1 würde den Quantizer fest auf 1 setzen. CRF geht bei komplexen Teilen höher als 1, wo der Encoder meint, das es für's Auge noch gleichwertig wie 1 aussieht (mal jetzt abgesehen davon das das Auge das eh nicht mehr unterscheiden könnte bei solchen Werten. Aber das interessiert ja dem adaptiven Quantizer des Encoders nicht^^

      Ich würde NVEnc nehmen, da du dann die CPU Last nicht hast.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • Anzeige

      De-M-oN schrieb:

      Für CQP 0 musst du das high444p profil nehmen. Sonst geht CQP 0 sowieso nicht. Und bei High444 predictive steigt Vegas dann wieder aus. Mit main oder high biste aber nicht lossless. Da kannste kein CQP 0 machen. Wird dann einen Fallback Setting genommen haben oder was auch immer.
      Ich würde es auch optional mit NVEnc probieren und schauen was für meine Bedürfnisse besser geeignet ist - falls das nach deiner Erklärung überhaupt noch zur Diskussion steht.

      Doch sobald ich auf high444p wechsle, die Aufnahme starte, bin ich nicht mehr in der Lage die Aufnahme zu stoppen und muss OBS über den TaskManager schließen. Anscheinend wird auch keine Datei erstellt/geschrieben. Fehlt hier eine Einstellung oder muss ich für NVEnc und high444p zusätzlich noch etwas auf meinem System installieren?
    • @De-M-oN
      Vielleicht kannst du mir nochmal einen Tipp geben, da ich mit deinen genannten Einstellungen kleinere Schwierigkeiten habe.

      De-M-oN schrieb:

      CQP 0 ist ja auch wieder lossless ;D Nichts für Vegas xD

      CQP 1 bis maximal 15 würd ich für die Aufnahme empfehlen.
      preset auf high performance
      bframes auf 0

      Das ist zwar effizienzmindernd, aber mit niedrigen CQPs sowieso nur auf die Dateigröße schlagend. Wichtiger ist ja das der fps loss ingame gering bleibt und im Video möglichst keine Duplikatframes/Dropped Frames drin sind. Den Keyframeintervall würde ich auf auto lassen. Dürfte dann 250 Frames sein.

      Meine Einstellungen kannst du den Screenshots entnehmen:

      [IMG:http://i.imgur.com/yhBTuBT.png]

      [IMG:http://i.imgur.com/YOZAOIn.png]

      Sobald ich das Preset auf 'Hohe Leistung' einstelle - wie von dir beschrieben - lässt sich meine Aufnahme starten, aber nicht mehr beenden. Außer ich beende/schließe den kompletten Task von OBS über den Task Manager. Sofern ich das Preset auf 'Standard' stelle scheint es zu funktionieren leider weiß ich nicht welche Auswirkungen diese Einstellung für meine Aufnahmen haben wird. Entstehen dadurch mögliche Leistungseinbußen oder Fehlerquellen?

      So sieht es in OBS aus, wenn ich den Preset eingestellt habe und die Aufnahme beenden möchte:

      [IMG:http://i.imgur.com/oVs8wrV.png]

      'Stoppe Aufnahme...' wird angezeigt und der REC-Timer läuft immer weiter bis ich den Task schließe.

      Aufgenommen wird das Ganze auf einem RAID 0 mit einer GTX 1070.
    • Mahlzeit!

      Aufgrund von extremer Zickerei mit verschiedenen DxTory-Versionen, habe ich mich heute mal an OBS und NVENC versucht...und bin leider alles andere als zufrieden! :(

      Habe mich soweit an das Tutorial von hier gehalten, allerdings auch einige der danach angefügten Tipps und Ratschläge versucht umzusetzen.

      De facto möchte ich gerne weitestgehend Lossless aufnehmen, wobei ich es sowohl mit der Einstellung "Verlustfrei" also auch "GCP" nicht hin bekomme, eine fehlerfreie Aufnahme zu erreichen.

      Alle Aufnahmen sehen irgendwie so aus:


      Aufgenommen wurde nativ in 2560x1440 in 60FPS, als GPU werkelt eine GTX 1080 Ti Aorus Xtreme Edition.
      Wie auch bei DxTory läuft der Datenstrom auf einen internen Raid 0 mit ca. 370MB/s Übertragungsrate.

      Edit:
      GTX-Treiber sind die aktuellsten vom August 2017, OBS Studio (64 Bit) 20.0.1

      Seltsamerweise habe ich exakt das gleiche Fehlerbild wie @fr0st, sprich, mit high444p muss ich den Task killen, damit ich die Aufnahme beenden kann.

      Hat vielleicht jemand eine Idee an was es liegen kann?

      Danke & Gruß
      ZP
    • Mit CQP1 und dem high profil sollte es aber normal sein.
      Ist das Video auch nach einem Encode so?





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      Mit CQP1 und dem high profil sollte es aber normal sein.
      Ist das Video auch nach einem Encode so?
      Ich fress' echt nen Besen... nach zig Versuchen mit allen möglichen Einstellungen, klappt es nun auf einmal!!
      Muss man nicht verstehen. :-/

      Sollte das nochmal auftreten, probiere ich das mit dem Encode mal aus.

      Apropos: muss ich da im SSM noch etwas beachten bzgl. des Farbformates? Nehme in OBS jetzt NV12 auf.
    • Zwiebelpeter schrieb:

      Apropos: muss ich da im SSM noch etwas beachten bzgl. des Farbformates? Nehme in OBS jetzt NV12 auf.
      Wenn du lossless mit NVENC aufnimmst und den vollen Farbumfang behalten willst, solltest du das auf I444 stellen (Dateien werden dann noch größer)
      sonst wird vorher nämlich in NV12 kovbertiert (4:2:0)
      RGB wird übriegns auch in 4:2:0 konvertiert selbst wenn man lossless aufnimmt, weswegen man I444 einstellen sollte

      ah... wait ich glaube da ist immer noch dieser Bug in OBS bei I444 + NVENC - mit x264 geht es auf jeden Fall
    • Schauerland schrieb:

      Zwiebelpeter schrieb:

      Apropos: muss ich da im SSM noch etwas beachten bzgl. des Farbformates? Nehme in OBS jetzt NV12 auf.
      Wenn du lossless mit NVENC aufnimmst und den vollen Farbumfang behalten willst, solltest du das auf I444 stellen (Dateien werden dann noch größer)sonst wird vorher nämlich in NV12 kovbertiert (4:2:0)
      RGB wird übriegns auch in 4:2:0 konvertiert selbst wenn man lossless aufnimmt, weswegen man I444 einstellen sollte

      ah... wait ich glaube da ist immer noch dieser Bug in OBS bei I444 + NVENC - mit x264 geht es auf jeden Fall
      Ähm...also nun doch nix ändern im SSM? :huh:
    • Also irgendwo ist da ein ganz gewaltiger Haken an der Sache!

      Versuche die so aufgenommenen Files nun zu encoden und starre gerade auf diese Anzeige hier:
      [IMG:https://i.imgur.com/P0BXal1.png]

      Warum zum Kuckuck ist das soooo extrem langsam?

      Hier noch die Mediainfo:
      Spoiler anzeigen
      Allgemein
      Vollständiger Name : R:\OBS\2017-09-22 09-38-53.mp4
      Format : MPEG-4
      Format-Profil : Base Media
      Codec-ID : isom
      Dateigröße : 64,1 GiB
      Dauer : 37min
      Gesamte Bitrate : 247 Mbps
      Kodierendes Programm : Lavf57.66.102

      Video
      ID : 1
      Format : AVC
      Format/Info : Advanced Video Codec
      Format-Profil : High@L5.1
      Format-Einstellungen für CABAC : Ja
      Format-Einstellungen für ReFrames : 1 frame
      Codec-ID : avc1
      Codec-ID/Info : Advanced Video Coding
      Dauer : 37min
      Bitrate : 246 Mbps
      Breite : 2 560 Pixel
      Höhe : 1 440 Pixel
      Bildseitenverhältnis : 16:9
      Modus der Bildwiederholungsrate : variabel
      Bildwiederholungsrate : 60,000 FPS
      minimale Bildwiederholungsrate : 58,851 FPS
      maximale Bildwiederholungsrate : 1 024,000 FPS
      ColorSpace : YUV
      ChromaSubsampling : 4:2:0
      BitDepth/String : 8 bits
      Scantyp : progressiv
      Bits/(Pixel*Frame) : 1.114
      Stream-Größe : 63,8 GiB (100%)
      matrix_coefficients : BT.709

      Audio #1
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 37min
      Bitraten-Modus : konstant
      Bitrate : 320 Kbps
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 KHz
      Stream-Größe : 84,9 MiB (0%)

      Audio #2
      ID : 3
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 37min
      Bitraten-Modus : konstant
      Bitrate : 320 Kbps
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 KHz
      Stream-Größe : 84,9 MiB (0%)

      Audio #3
      ID : 4
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format-Profil : LC
      Codec-ID : 40
      Dauer : 37min
      Bitraten-Modus : konstant
      Bitrate : 320 Kbps
      Kanäle : 2 Kanäle
      Kanal-Positionen : Front: L R
      Samplingrate : 44,1 KHz
      Stream-Größe : 84,9 MiB (0%)



      Und die AVS:
      Spoiler anzeigen
      ### SagaraS Scriptmaker - Version 6.1 ###

      ### Lade Plugins und setze die globalen Variablen ###
      LoadPlugin("D:\Programme\SagaraS Scriptmaker\SagaraS Scriptmaker\Plugins\FFMS2.dll")
      Global breite = 2560
      Global hoehe = 1440
      Global AR = 0

      ### Lade Videoquellen ###
      SetMTMode(3,4)
      AVIload("R:\OBS\2017-09-22 09-38-53.mp4", 1, 0, 0, -0, -0, "Auto", "Igno.", 0, 0).FadeIn0(30).FadeOut0(30)

      ### Filter Verarbeitungszone ###

      (IsYUY2() == true) ? ConvertToYV16(matrix = "Rec709", ChromaResample = "Spline16") : Last

      ### Funktion für Video-Laderoutine ###
      Function AVIload (String file, int loading, int cl, int co, int cr, int cu, string pixtype, string afps, int fpsn, int fpsd) {
      pixtype2 = (pixtype == "YUY2") ? "YUY2" : (pixtype == "RGB24") ? "RGB24" : (pixtype == "Y8") ? "Y8" : (pixtype == "YV12") ? "YUV420P8" : (pixtype == "YV24") ? "YUV444P8" : pixtype
      (loading == 1) ? FFIndex(file) : nop()
      clip0 = (loading == 3) ? (pixtype == "Auto") ? LWLibavVideoSource(file) : LWLibavVideoSource(file, format = pixtype2) : (loading == 2) ? Import(file).KillAudio() : (loading == 1) ? (pixtype == "Auto") ? FFVideoSource(file, threads=1) : FFVideoSource(file, threads=1, colorspace=pixtype) : (pixtype == "Auto") ? AVISource(file, false).KillAudio() : AVISource(file, false, pixel_type=pixtype).KillAudio()
      clip1 = clip0.AutoFPS(afps, fpsn, fpsd).Cropping(cl, co, cr, cu)
      Return (clip1.width == breite && clip1.height == hoehe) ? clip1.ConvertToYV12(matrix = "Rec709", ChromaResample = "Spline16") : Clip1.Resize()
      }

      Function AutoFPS (Clip clip0, string afps, int fpsn, int fpsd) {
      rate1 = (afps == "Auto") ? (Round(Float(clip0.framerate * 1000)) / 1000) / 2 : nop()
      rate2 = (afps == "Auto") ? Round(clip0.framerate) / 2 : nop()
      rate = (afps == "Auto") ? (rate1 == rate2) ? 1 : 1001 : (afps == "Igno.") ? clip0.frameratedenominator : fpsd
      ratefaktor = (afps == "Auto") ? (rate == 1001) ? 1000 : 1 : nop()
      clip0 = (afps == "Auto") ? (rate == 1001) ? clip0.AssumeFPS(Round(clip0.Framerate) * 1000, rate) : clip0.AssumeFPS(round(clip0.framerate), rate) : (afps == "Igno.") ? clip0.AssumeFPS(clip0.frameratenumerator, rate) : clip0.AssumeFPS(fpsn, rate)
      Return clip0
      }

      Function Cropping (Clip clip0, int cl, int co, int cr, int cu) {
      clip0 = (clip0.IsRGB32() == True) ? clip0.ConvertToRGB24() : clip0
      Return (cl != 0 || co != 0 || cr != 0 || cu != 0) ? clip0.Crop(cl, co, cr, cu) : clip0
      }

      Function Resize (Clip clip1) {
      clip1 = (AR == 1) ? ((float(Clip1.height * breite) / clip1.width) / 2 == round((float(Clip1.height * breite) / clip1.width) / 2)) ? ((float(Clip1.width * hoehe) / clip1.height) / 2 == round((float(Clip1.width * hoehe) / clip1.height) / 2)) ? clip1 : clip1.ConvertToRGB24() : clip1.ConvertToRGB24() : clip1
      clip1 = (AR == 1) ? (((clip1.width * hoehe) / clip1.height > breite) ? Clip1.Spline16Resize(breite, ceil(float(Clip1.height * breite) / clip1.width)) : Clip1.Spline16Resize(ceil(float(clip1.width * hoehe) / clip1.height), hoehe)) : clip1.Spline16Resize(breite, hoehe).ConvertToYV12(matrix = "Rec709", ChromaResample = "Spline16")
      back = (AR == 1) ? (0 == 1) ? ImageReader("", 0, clip1.framecount - 1, clip1.framerate).ChangeFPS(clip1.frameratenumerator, clip1.frameratedenominator).Spline16Resize(breite, hoehe).ConvertToYV12(matrix = "Rec709", ChromaResample = "Spline16") : BlankClip(clip1, width = breite, height = hoehe, pixel_type = "YV12").KillAudio() : clip1
      Return (AR == 1) ? Overlay(back, clip1, (back.width - clip1.width) / 2, (back.height - clip1.height) / 2) : clip1
      }



      Bin für jeden Tipp mehr als dankbar! ;)
    • H.264 Quelle: langsamer
      OBS Quelle: Warum auch immer langsam, vllt wegen einer langen GOP, bin ich unsicher. Zumindest die mit NVEnc codierten Dateien sind sehr schlecht seekable, ka wie das bei x264 ist.
      OBS Quelle: Das man nicht direkt in MP4 aufnehmen sollte, inkl Erklärung wieso, steht in OBS, und steht nicht ohne Grund da.
      Dein MTMode ist: langsam
      Probier den Chroma Resizer auf den standardmäßigen Bicubic zu lassen (chroma resample deaktivieren)
      Du hast einen langsamen einleser genommen. Update LSmash in deinem MeGUI, kopier die neue lsmash dll von MeGUI rüber in dein SSM plugins ordner (ersetzen) und nimm Lsmash als einleser statt ffms2 und mach dann Multithreading in SSM aus, lsmash hat ein eigenes MT.
      Ist die Angabe in der Mediainfo das die Quelle Variable Framerate hat, korrekt? Wenn ja solltest du l-smash die als CFR einlesen lassen.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      OBS Quelle: Warum auch immer langsam, vllt wegen einer langen GOP, bin ich unsicher. Zumindest die mit NVEnc codierten Dateien sind sehr schlecht seekable, ka wie das bei x264 ist.
      Die x264-Dateien von OBS haben auch ewig zum Encodieren gebraucht, teilweise zwei- bis dreimal so lange. Von der Audioextraktion ganz zu schweigen. Aber das kann auch an FFMpeg gelegen haben. Auf jeden Fall waren die Dateien, die ich mit Dxtory aufgenommen hatte deutlich schneller encodiert und auch das Audio nur in wenigen Minuten entpackt. Deswegen nehme ich (wenn ich mal mit OBS aufnehmen muss) nur noch mit UT-Video auf.
      AKTUELLE PROJEKTE
      0 Uhr: indiziertes Spiel
      12 Uhr: indiziertes Spiel
      15 Uhr: Vampire - The Masquerade Redemption [BLIND]
      18 Uhr: Metro: Last Light [BLIND]
      21 Uhr: indiziertes Spiel

      Folge der Ziege
    • De-M-oN schrieb:

      OBS Quelle: Das man nicht direkt in MP4 aufnehmen sollte, inkl Erklärung wieso, steht in OBS, und steht nicht ohne Grund da.
      Aufgenommen habe ich in MKV, dann über OBS in MP4 remuxed.

      De-M-oN schrieb:

      Dein MTMode ist: langsam
      Probier den Chroma Resizer auf den standardmäßigen Bicubic zu lassen (chroma resample deaktivieren)
      Du hast einen langsamen einleser genommen. Update LSmash in deinem MeGUI, kopier die neue lsmash dll von MeGUI rüber in dein SSM plugins ordner (ersetzen) und nimm Lsmash als einleser statt ffms2 und mach dann Multithreading in SSM aus, lsmash hat ein eigenes MT.
      Ist die Angabe in der Mediainfo das die Quelle Variable Framerate hat, korrekt? Wenn ja solltest du l-smash die als CFR einlesen lassen.
      Die .DLL habe ich ersetzt, aber wo kann ich den anderen Einleser nun aktivieren? Reicht es, FFMS2 zu deaktivieren, damit der anspringt?
      Im aktuellen Encode schaut es so aus:
      [IMG:https://i.imgur.com/umV1YpF.png]


      In OBS habe ich 60 FPS eingestellt, von daher wundert mich diese Angabe schon sehr. Im Game selber war ich immer weit über 100 FPS, also gab keinen Flaschenhals.

      Peacemaker666 schrieb:

      De-M-oN schrieb:

      OBS Quelle: Warum auch immer langsam, vllt wegen einer langen GOP, bin ich unsicher. Zumindest die mit NVEnc codierten Dateien sind sehr schlecht seekable, ka wie das bei x264 ist.
      Die x264-Dateien von OBS haben auch ewig zum Encodieren gebraucht, teilweise zwei- bis dreimal so lange. Von der Audioextraktion ganz zu schweigen. Aber das kann auch an FFMpeg gelegen haben. Auf jeden Fall waren die Dateien, die ich mit Dxtory aufgenommen hatte deutlich schneller encodiert und auch das Audio nur in wenigen Minuten entpackt. Deswegen nehme ich (wenn ich mal mit OBS aufnehmen muss) nur noch mit UT-Video auf.

      Jup, braucht eine halbe Ewigkeit, bis die Tonspuren extrahiert und die Dateien selber in MeGUI geöffnet sind. :(
      Bin alles andere als zufrieden damit!
      Das mit UTvideo schaue ich mir mal an, danke für den Hinweis!
    • Julien schrieb:

      H.264 allgemein dauert einfach immer länger. Klar, ffmpeg ist alles andere als schnell, aber H.264 zu dekodieren dauert länger, es neu zu kodieren dauert länger, einfach alles dauert länger. Darauf muss man sich einfach einstellen, wenn man so aufnehmen will. :/
      Naja, ich WILL nicht unebdingt, aber ich brauche eine Alternative zu DxTory, da ich damit in letzter Zeit immer mehr Probleme bekomme und auch habe! :(
      Afterburner ist auch keine wirkliche Hilfe, da hier oft der Mauszeiger nicht aufgenommen wird und nur max. 2 Tonspuren unterstützt. Von daher habe ich mich für die Lossless-Version von OBS mit dem NVENC entschieden...und zahle nun das Lehrgeld. :(

      Schaue mir das mal mit dem UT-Codec an, ansonsten Muxe ich die aktuell mit NCENC erstellten Dateien einfach mit dem Mix der Aufnahme und lade die insgesamt 380 GB halt so hoch... :cursing:
    • Zwiebelpeter schrieb:

      Schaue mir das mal mit dem UT-Codec an
      Gut, das fällt für dich dann aber auch flach, über FFMpeg mit dem UT-Codec kann OBS nur eine Tonspur aufnehmen. Müsstest du dann wie anfangs im Thread beschrieben mehrere OBS-Instanzen für die einzelnen Tonspuren laufen lassen.
      AKTUELLE PROJEKTE
      0 Uhr: indiziertes Spiel
      12 Uhr: indiziertes Spiel
      15 Uhr: Vampire - The Masquerade Redemption [BLIND]
      18 Uhr: Metro: Last Light [BLIND]
      21 Uhr: indiziertes Spiel

      Folge der Ziege
    • Peacemaker666 schrieb:

      Zwiebelpeter schrieb:

      Schaue mir das mal mit dem UT-Codec an
      Gut, das fällt für dich dann aber auch flach, über FFMpeg mit dem UT-Codec kann OBS nur eine Tonspur aufnehmen. Müsstest du dann wie anfangs im Thread beschrieben mehrere OBS-Instanzen für die einzelnen Tonspuren laufen lassen.
      Narf...
      Dann fällt das tatsächlich auch flach. :(

      Soll ja eigentlich auch nur eine Notlösung sein, wenn eben das vermaledeite DxTory nicht will.
    • Peacemaker666 schrieb:

      Aber das kann auch an FFMpeg gelegen haben

      Julien schrieb:

      Klar, ffmpeg ist alles andere als schnell
      Liegt nicht an ffmpeg. Liegt irgendwie an OBS. Wenn ich mit ffmpeg beispielsweise ne capture karten aufnahme mache, dann sind die Dateien danach sehr gut seekable sogar.
      Also irgendwie liegt das einfach nur an OBS.
      Die GOP von 250 ist eig. auch nicht zu lang, vllt benutzt OBS langes Interleaving.
      Wie bei AVI kommt immer 'nen Teil Video, dann 'nen Teil Audio etc. Bei AVIs ohne Interleaving würde am Anfang das Komplette Video sein und am Ende das komplette Audio, was bedeutet die HDD muss ständig riesige Sprünge hinlegen beim Abspielen beider Spuren gleichzeitig.
      Deaktiviertes Interleaving glaub ich aber auch nicht, weil dann würde es, wenn nur eine Spur angefragt wird, sogar schneller gehen. Weil dann hat er ja nicht Audio und Video, sondern nur Audio.
      Ich würde daher vermuten, das OBS ein recht langes Interleaving benutzt.
      Andersrum dann wieder merkwürdig, das es selbst bei kleinen Dateien so lahm ist. Naja liegt aber irgendwie definitiv an OBS.

      Zwiebelpeter schrieb:

      Die .DLL habe ich ersetzt, aber wo kann ich den anderen Einleser nun aktivieren? Reicht es, FFMS2 zu deaktivieren, damit der anspringt?
      Bei Video mit dem > aufklappen und lsmash anhaken.


      Zwiebelpeter schrieb:

      In OBS habe ich 60 FPS eingestellt
      Worauf willste hinaus? Der Encode wird so schnell keine 60fps erreichen.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7