Shotcut: Gratis-Videoschnittprogramm

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Naja wenns die identishcen Dateien sind wie ffmpeg ausliefert und keine programmeigenen dlls, dann sollte das eig. immer gehen^^





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      RealLiVe schrieb:

      Dennis_50300 schrieb:

      anhand "preset=..." hab ich mal versucht den Commandlinekram zu übernehmen, theoretisch sollte das ja funktionieren wenn es tatsächlich auch ffmpeg nutzt.
      Kommt darauf an, ob deren FFmpeg mit NVEnc-Support kompiliert wurde. Du kannst ja beim Bauen auswählen, was drin sein soll und was nicht.
      Kann man nicht vllt das zeranoe build nehmen und in shotcut die dateien ersetzen?
      Genau das hab ich auch getan ;)
      nur so wirklich funktionieren will das leider eben nicht wie schon beschrieben


      Gruss Dennis
    • Anzeige
      Was irgendwie auch schon etwas merkwürdig ist, man kann es insgesamt 4x auswählen und nicht nur zweimal

      [IMG:http://fs5.directupload.net/images/170919/temp/9xv5twq3.jpg]

      es liegt nicht daran das ich zaranoe in shotcut eingefügt habe, ich hab mir nämlich nen Backupordner angelegt und testweise das "original" ffmpeg wieder reingelegt.

      es gibt:
      -h264_nvenc
      -hevc_nvenc

      und dann noch:
      -nvenc_h264
      -nvenc_hevc

      Edit:
      264 wäre mir lieber, GTA V mache ich nun für YouTube auch doch wieder gerade mit XMedia Recode wie schonmal in nem anderen Thread von mir mit Testvideos vom Euro Truck Simulator 2.
      Für mich persönlich werden sonst die Dateien einfach schlichtweg zu gross, zudem das es mit XMedia Recode noch etwas schneller geht. (bicubic spline, 2560x1440 aktuell gerade, 23 und bframes 2)


      Gruss Dennis

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dennis_50300 ()

    • RealLiVe schrieb:

      Dennis_50300 schrieb:

      Was irgendwie auch schon etwas merkwürdig ist, man kann es insgesamt 4x auswählen und nicht nur zweimal
      Man wollte die Namen von den Encodern den anderen angleichen. Irgendwann werden die alten Namen rausfliegen.
      Öhm, ok 8|

      Ich lasse nun einfach mal einen Test laufen:

      [IMG:http://fs5.directupload.net/images/170919/temp/gvnlrbvo.jpg]
      [IMG:http://fs5.directupload.net/images/170919/temp/7h2jawye.jpg]

      [IMG:http://fs5.directupload.net/images/170919/temp/stsejelo.jpg]

      [IMG:http://fs5.directupload.net/images/170919/temp/y2advyas.jpg]


      hab Preset, einfach auf Slow umgetippt und nutze halt wie man sieht einfach mal komplett die GUI für 264, in GPU-Z sieht es so aus als läufts, innerhalb "kürzester" Zeit hab ich nun 6%



      Ist ja schonmal ein fortschritt, Shotcut encodiert wohl zumindest schonmal mit der Grafikkarte, cpu geht mal so bis 21% hoch im Task-manager, läuft eine "qmelt.exe"

      Da lässt sich sicherlich noch einiges optimieren, aber immerhin steht mal ein Grundgerüst und eine prozentuale Angabe damit könnte ich auch leben, erinnert mit an AutoGoardian Knot oder wie es damals hiess, womit man so seine DVD's als xvid auf die Platte mit gehauen hatte :D :P


      Gruss Dennis
    • Dennis_50300 schrieb:

      bicubic spline
      was denn jetzt, bicubic oder spline? eins geht nur :D Oder skalierst du doppelt? :D

      Dennis_50300 schrieb:

      264 wäre mir lieber
      Wird aber größer. Oder meinst du x264?

      Dennis_50300 schrieb:

      Für mich persönlich werden sonst die Dateien einfach schlichtweg zu gross
      bei deinem uploadspeed zu groß, tzz.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      Dennis_50300 schrieb:

      bicubic spline
      was denn jetzt, bicubic oder spline? eins geht nur :D Oder skalierst du doppelt? :D

      Dennis_50300 schrieb:

      264 wäre mir lieber
      Wird aber größer. Oder meinst du x264?

      Dennis_50300 schrieb:

      Für mich persönlich werden sonst die Dateien einfach schlichtweg zu gross
      bei deinem uploadspeed zu groß, tzz.
      [IMG:http://fs5.directupload.net/images/170919/temp/row7d9ej.jpg]
      ;)

      ja x264

      t-online, das ändert sich nunmal nicht von jetzt auf gleich, mit so 4 bis 6GB könnte ich leben, aber nicht mit 8gb und mehr


      Gruss Dennis
    • öh ok merkwürdig. vllt nen mischling.
      _
      Achja. Naja ein VPN von perfect privacy würde für besseres routing sorgen. Der server4you root den ich ja vor dem jetzigen hatte bekam auch nur so 1,5 bis 3 mbyte/s durch statt 12 mbyte/s, da hatte der nürnberg server vom perfect privacy funktioniert, dann ging 12.
      Zudem weiß dein Internetanbieter dann auch nicht mehr, das du gerad auf Youtube hochlädst. Das kann etwaige Drosselungen mancher Anbieter auch dann gleich mit umgehen. Betrifft natürlich auch das Ansehen von Videos.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      öh ok merkwürdig. vllt nen mischling.
      _
      Achja. Naja ein VPN von perfect privacy würde für besseres routing sorgen. Der server4you root den ich ja vor dem jetzigen hatte bekam auch nur so 1,5 bis 3 mbyte/s durch statt 12 mbyte/s, da hatte der nürnberg server vom perfect privacy funktioniert, dann ging 12.
      Zudem weiß dein Internetanbieter dann auch nicht mehr, das du gerad auf Youtube hochlädst. Das kann etwaige Drosselungen mancher Anbieter auch dann gleich mit umgehen. Betrifft natürlich auch das Ansehen von Videos.
      joa kann gut sein cpu hatte dabei auch gut Dampf
      ---
      joa aber auch das war mir nachher noch zu gross, wieder knapp 8gb da hab ich es abgebrochen gehabt dann.
      ich mein gut es geht ne halbe Stunde, aber kann ja nich sein, ich nutzte zuvor zuletzt crf15 mit x264 mit MeGUI CPU-dampf und da war die Dateigrösse egal bei was immer voll i.O. gewesen auch bei GTA V.


      Gruss Dennis
    • Ich hab da was gefunden, allerdings sieht das nicht so erfreulich aus


      Shotcut Leader schrieb:

      nvenc is not yet included in our build of FFmpeg, and you cannot just drop in another ffmpeg executable because Shotcut uses the FFmpeg library APIs; it is not a simple command line front end. Thank you for sharing the news that nvenc can be used in a GPL build configuration! I will try to add support for it some day
      Hier der Link:
      forum.shotcut.org/t/trying-to-…resets-based-on-nvenc/903

      irgendwo hab ich auch noch was von GPL3 gelesen, hab also auch schon viel gesucht mit Google dazu.
      Die ffmpeg exe-dateien austauschen das funktioniert jedenfalls schonmal nicht so leicht wie es aussieht.

      scheint so als wenn das nicht so einfach möglich wäre, lasse mich aber natürlich sehr gerne eines besseren belehren

      kann natürlich sein das hier noch was verkehrt ist:

      Quellcode

      1. preset=slow
      2. movflags=+faststart
      3. pix_fmt=p010le
      4. profile=v main10
      5. tier=high
      6. rc=vbr_hq
      7. b=v 0
      8. qmin=1
      9. qmax=19
      10. rc-lookahead=60
      11. spatial_aq=1
      12. aq-strength=7
      13. weighted_pred=1
      Alles anzeigen

      Wenn ich nur die GUI verwende kam zumindest mal ein Bild dabei heraus von kleinen Testaufnahmen, wenn ich nichts selber eingebe und etwas damit herumgespielt habe.

      Also falls es doch geht, bin ich einfach unfähig :P

      Gruss Dennis
    • Dennis_50300 schrieb:

      profile=v main10
      b=v 0
      Halte ich für etwas unwahrscheinlich das die so greifen mit dem = statt :
      Weil das steht für:

      bitrate:video = 0

      in dieser form wie du es hast:

      bitrate = video 0





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • das mit dem = ist schon korrekt da die werte als x264-params durchgereicht werden
      der bekommen quasi nur den string. OBS macht das auch so leider

      zB

      ffmpeg -i input.mp4 -c:v libx264 -crf 18 -preset slow -g 300 -x264-params keyint=600:crf=23:preset=veryfast

      die params stehen auch über den ffmpeg parametern, somit würde im oben stehenden Beispiel crf 23 ein keyint von 600 und das preset veryfast verwendet werden anstatt crf 18, preset slow und gop von 300

      die -264-params parameter werden durch : getrennt und key=value angereiht und sind die originalen x264 parameter, da ffmpeg das einfach nur bei sich einkompiliert
    • Also ich hab geupdatet und vorher ging das dem Übergang, Seit dem Update allerdings nicht mehr, der Springt jedes mal wieder zurück. Dann das Nervige laden der Tonspur im Video auch wenn man das ab geschaltet hat, da ich selber die Tonspuren hinzufügen will...

      So ist das Programm klasse, aber bekommen die das nicht hin? Oder das man nicht ein Video in einzelteile schneiden kann um dadraus 2-3 Videos zu machen...

      Hat da jemand zufällig einen Tipp (evtl schaffe ich das gleich mal wieder selber^^)?

      Edit: Gut, wie gesagt, ich hab es doch selber hin bekommen... Erst ans Ende des ersten Videos, dann so weit ins andere Video ziehen wie gewünscht ....Tadaaa Feddisch^^

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von WoBra ()

    • hm zumindest bringe ich schonmal brauchbare Bilder raus mit nem Testvideo, der rotzt allerdings ziemlich krass Speicher weg, 37gb nachher gehabt und abgebrochen , weil für ein 17gb video ist das bissle komisch (nfs porsche über 20 minuten), konnte ich dann natürlich nicht abspielen.
      Hab es dann halt mit einer kurzen Desktopaufnahme angetestet.

      Beim speichern vom Preset sah es dann so aus

      Quellcode

      1. vpre=medium
      2. movflags=+faststart
      3. cbr=1
      4. strict_gop=1
      5. qmin=1
      6. qmax=19
      7. rc=constqp
      8. global_quality=1
      9. f=matroska
      10. acodec=flac
      11. ar=48000
      12. aq=501
      13. vcodec=h264_nvenc
      14. vq=1
      15. sc_threshold=0
      16. g=30
      17. bf=2
      18. width=3840
      19. height=2160
      20. aspect=1,77778
      21. progressive=1
      22. top_field_first=0
      23. deinterlace_method=yadif
      24. rescale=hyper
      25. r=60
      26. threads=7
      Alles anzeigen

      wenn es kein "nvencc64.exe" nutzt so wie StaxRip können wir Spline36 dann denke ich mal zwar knicken, aber gut letsplay videos muss man nun auch nicht unbedingt schneiden.

      zu anderen Zwecken käme man sicher mit dem klar was shotcut mit ffmpeg bietet


      Gruss Dennis
    • Moin moin,

      ich versuche gerade einen Text in das Video, als Filter, zu bekommen. Aber der Text ist dann nur von Anfang bis Ende... Kann man da nichts Einstellen von da bis da? Sonst muss ich mir die Texte über Photoshop erstellen und als bild da einfügen (wenn das überhaupt geht).

      Schon mal jemand sowas mit ShotCut gemacht?