OBS Studio - Probleme bei 4k Aufnahmen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS Studio - Probleme bei 4k Aufnahmen

    Anzeige
    Hallöchen :)

    Letztens hatte ich mit einem Spiel Probleme, dass ich es nicht mehr im Vollbild spielen konnte, daher waren Aufnahmen mit OBS Studio und Webcam uninteressant.
    Nun funktioniert es seit heute wieder, aaaaber ich habe das Problem, dass OBS Studio einfach nicht in 4k aufnehmen möchte.

    Jedes Mal kommt "Während der Aufnahme ist ein unbekannter Fehler aufgetreten".
    Ich fürchte, dass es an meinem PC liegt, da das Problem auftritt, sobald die Aufnahme ca. 10sek läuft. Wenn ich nur 3sek aufnehme, dann kommt der Fehler nicht, aber die Videos laggen extrem.

    Im Spiel jedoch habe ich dennoch gar keine Lags (90FPS), was wiederum gegen eine zu schwache CPU und für falsche Einstellungen spricht...


    Meine Einstallungen:







    Das Problem besteht nicht, wenn ich die Ausgabe auf 1080p skalieren lasse, aber wenn ich schon in 4k mit 90 FPS herum laufe, würde ich eben gern auch so aufnehmen :(
    Vielleicht fällt ja jemandem von euch ein Fehler in meinen Einstellungen auf, woran das liegen kann?

    CPU: i7 6700k
    GPU: GTX970 4G
    RAM: 16GB
  • Julien schrieb:

    Nach dem Fehler habe ich jetzt gar nicht geschaut, sondern kann dir sagen: 4K mit 60 FPS geht mit OBS leider nicht. Über ffmpeg und UT Video zumindest nicht, dafür ist der Encoder einfach viel zu langsam. Ich habe es auch ewig lange versucht und es wird niemals flüssig laufen. :/
    Ohje das klingt nicht gut :(

    Gibt es noch einen anderen Codec der möglichst ohne Verlust aufnimmt oder kann ich das mit OBS generell knicken mit den 4k, wenn ich nicht andere starke Einschränkungen hinnehmen möchte?

    Fraps nimmt zwar ohne Probleme in 4k auf (daher schiebe ich es auch nicht auf die Festplatte), aber in OBS ist die Sache mit der Facecam einfach sooo viel entspannter...
  • Quellcode

    1. Ohne Kompression (Sprich das Komplexeste Bild Material)
    2. 3840px * 2160px * 12bpp (YV12) * 60 FPS = 5971968000 Bit/s
    3. = 5695.3125 Mb/s
    4. = 711.9140625 MB/s
    Würde Kompression noch dazu kommen würde man irgendwo zwischen 400 - 600 MB/s liegen
    Und das nur bei YV12 schon

    Flaschenhals sind also Festplattengeschwindigkeiten und die Threadnutzung beim Encoder. Sprich von diesen riesigen Bildern müssen glatt 60 Stück pro Sekunde gespeichert werden. Wenn da der Encoder zu langsam für ist funzt das halt auch nicht. Gerade bei FFmpeg ist das immer so eine Frage mit wieviel Threads der gerade arbeitet. Weil UTVideo mit 1 Thread oder 2 ist ein bisschen lau. CPU sollte dann auch stark genug sein.

    Bei solchen Größen aber kann man aber auch schon Verlustbehaftet aufnehmen.
    Zum einen werdet ihr da eh nix mehr skalieren, zum anderen ist die Pixeldichte so hoch das ihr da eh kaum was seht, wenn ihr gute Lossy Encodes macht.

    Ein Raid0 mit einem 3er oder 4er Plattenverbund müsste aber die Lossless Aufnahme packen. Wenn nicht FFmpeg der Flaschenhals grad ist.
  • Kaddi288 schrieb:

    Gibt es noch einen anderen Codec der möglichst ohne Verlust aufnimmt oder kann ich das mit OBS generell knicken mit den 4k, wenn ich nicht andere starke Einschränkungen hinnehmen möchte?

    Ich habe vermutlich auch nicht alle Kombinationen innerhalb OBS ausprobiert, aber zumindest so die gröbsten Ideen habe ich alle durchgetestet und 4K60 ging mit keiner Einstellung wirklich sauber.

    ffmpeg UT Video - höchstens 40 FPS.
    x264 qp=0 - höchstens 20 FPS.
    x264 mit CRF - komplett unmöglich.

    4K und OBS sind zumindest laut meinen Tests momentan noch nicht miteinander vereinbar.
  • Kayten schrieb:

    1800p60FPS@I420 mit UtVideo bei mir brauchbar. Wird aber sehr von der CPU Leistung abhängen.

    Das merke ich mir mal für die Zukunft, denn in manchen Fällen ist OBS durchaus praktisch. Und ein 6700K mit 4.4 GHz sollte ja genügend Leistung liefern, zumal es in anderen Programmen ja klappt. Seit welcher Version das klappt, weißt du nicht zufällig? Ansonsten muss ich mal prüfen ob ich die neueste habe.
  • Kayten schrieb:

    Und in irgendeiner Version von OBS wurde ein Bug behoben, wodurch Encodes über FFmpeg nur mit einem Kern liefen. Nach diesem Fix waren zumindest 1440p60FPS@RGB und 1800p60FPS@I420 mit UtVideo bei mir brauchbar. Wird aber sehr von der CPU Leistung abhängen.
    Ansonsten mal eine Logdatei mit Aufnahmeversuch posten.
    Der ffmpeg UTVideo Encoder ist trotzdem massiv langsam insbesondere via OBS, wo auch x264 über ffmpeg stinkenlangsam ist. Erst mit dem internen x264 wird es besser.

    Die Farbmatrix würd ich ma auf 709 ändern.
    Aber sonderlich empfehlen kann ich OBS für Lossless einfach nicht. Da sind andere Programme mit VfW Schnittstelle einfach viel besser geeignet.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Jetzt habe ich eine Weile die Aufnahme einfach auf 1440p runter skalieren lassen.
    Ging 3 Wochen lang super.

    Und dann kam auch bei diesen Aufnahmen immer nach ca. 1min der Fehler.
    Die Videofile ist aber absolut Lagfrei...

    Gestern Abend ging es dann auf einmal wieder.
    Und jetzt geht es wieder nicht - ohne, dass ich etwas umgestellt habe...ich weiß mir langsam keinen Rat mehr, zumal ein Spiel, was ich gerne zeigen würde (Tales of Zestiria), mit allen anderen Programmen wie in Zeitlupe läuft...es lägt nicht, die FPS gehen auch nicht runter, aber es ist einfach wie in Zeitlupe...

    Nur OBS Studio macht das Problem nicht...aber das funktioniert, wie gesagt, seit heute morgen wieder nicht mehr und spuckt mir permanent den Fehler aus.

    Ich bin langsam echt am Verzweifeln und weiß mir keinen Rat mehr ;(
    Das ist die MediaInfo zur Video-Datei, wo die Aufnahme abgebrochen ist:

    Allgemein
    Vollständiger Name : Z:\2016-11-28 22-44-39.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 12,2 GiB
    Dauer : 1min 16s
    Gesamte Bitrate : 1 372 Mbps
    Kodierendes Programm : Lavf57.41.100

    Video
    ID : 0
    Format : YUV
    Codec-ID : ULY0
    Codec-ID/Info : Ut Video Lossless Codec
    Codec-ID/Hinweis : Ut Video
    Dauer : 1min 16s
    Bitrate : 1 372 Mbps
    Breite : 2 560 Pixel
    Höhe : 1 440 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    Bits/(Pixel*Frame) : 6.205
    Stream-Größe : 12,2 GiB (100%)

    Audio
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 1min 16s
    Bitraten-Modus : konstant
    Bitrate : 1 411,2 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 12,8 MiB (0%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 23 ms (1,39 Video-Frame)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Kaddi288 ()

  • Ich habe das Problem gefunden. Das tritt auf, egal ob ich in 1440p oder 1080p aufnehme.
    OBS belastet mit jeder Sekunde der Aufnahme den RAM mehr.

    Das geht hoch bis zu einer RAM Auslastung von 99%, wovon OBS einfach mal 11GB RAM ausmacht.
    Woran kann das denn liegen? Das ist doch nicht normal, dass der RAM immer mehr voll läuft?

    Sollte nicht die Auslastung gleich bleibend sein bei einem einzelnen Programm?