Importproblem: MAGIX importiert MP4 mit NVENC H.264 nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Importproblem: MAGIX importiert MP4 mit NVENC H.264 nicht

    Anzeige
    Hallo Leute,

    ich bin ganz kurz dabei und tatsächlich heute erst auf ein Problem gestoßen. Nach der ersten Testaufnahme mit OBSS wollte ich die Datei in MAGIX Video Deluxe 2016 Premium importieren. Das Programm sagt mir nun, dass die Datei nicht gelesen werden kann. Abspielen kann ich das Video in sämtlichen Playern.

    Aufgenommen habe ich in MP4 mit dem Codec NVENC H.264 bei High444p und Verlustfrei. Vorher habe ich x264 getestet, da ging es ohne Probleme.

    Ich denke, dass es am Codec liegt, aber wie löse ich dieses Problem? Hat jemand eine Idee?

    /Edit: MXMPEG2 Error 0801: cannot initialize Intel decoder - Das schmeißt es als Fehler raus.
  • Sagaras schrieb:

    Bexono schrieb:

    Kann MAGIX das nicht verarbeiten?
    Nein.Dein Magix kann nur ein H264 Video ala High420 verarbeiten. Maximal. Nicht mehr.
    NVEnc ist nix anderes als ein weiterer H264 Encoder.
    Ja, das mit dem Encoder ist mir soweit klar. Das Problem ist, wenn ich die Einstellungen ändere, dann importiert er immer noch nicht. Selbst auf main oder high nicht. Das müsste doch dann eigentlich funktionieren, oder nicht?
  • Spoiler anzeigen

    Allgemein
    Vollständiger Name : D:\Aufnahmen\LPs\2016-12-16 19-38-28.mp4
    Format : MPEG-4
    Format-Profil : Base Media
    Codec-ID : isom (isom/iso2/avc1/mp41)
    Dateigröße : 1,63 GiB
    Dauer : 1 min 15s
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 184 Mb/s
    Kodierendes Programm : Lavf57.41.100


    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High 4:4:4 Predictive@L4.2
    Format-Einstellungen für CABAC : Nein
    Format-Einstellungen für ReFrames : 1 frame
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 1 min 15s
    Bitrate : 184 Mb/s
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling/String : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 1.477
    Stream-Größe : 1,62 GiB (100%)
    colour_range : Limited
    matrix_coefficients : BT.709


    Audio #1
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 1 min 15s
    Bitraten-Modus : variabel
    Bitrate : 228 kb/s
    maximale Bitrate : 320 kb/s
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 kHz
    Bildwiederholungsrate : 43,066 FPS (1024 spf)
    Stream-Größe : 2,06 MiB (0%)
    Titel : Stimme
    Default : Ja
    Alternate group : 1


    Audio #2
    ID : 3
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 1 min 15s
    Bitraten-Modus : variabel
    Bitrate : 275 kb/s
    maximale Bitrate : 320 kb/s
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 kHz
    Bildwiederholungsrate : 43,066 FPS (1024 spf)
    Stream-Größe : 2,49 MiB (0%)
    Titel : Ingamesound
    Default : Nein
    Alternate group : 1


    Das ist schon die reduzierte Variante, also Profil auf High stehend. Hoffe ihr könnt damit etwas anfangen. :)

    Grundsätzlich macht mir aber eher die Fehlermeldung "MXMPEG2 Error 0801: cannot initialize Intel decoder" sorgen. Das kann ja nicht richtig sein.
  • Bexono schrieb:

    High 4:4:4

    Bexono schrieb:

    Das ist schon die reduzierte Variante, also Profil auf High stehend.
    Nein, es ist immer noch auf High444. Das geht nicht.

    PS: Sofern du Lossless aufnimmst, wird es immer in ein High444 Profil geschrieben. Also sofern du Lossless aufnehmen solltest kann das schon der Grund sein.
  • De-M-oN schrieb:

    Sagaras schrieb:

    PS: Sofern du Lossless aufnimmst
    Tut er. schrieb er ja^^
    Lossless wird nur vom high444 predictive profil unterstützt.
    Das bedeutet, dass ich die Lossless-Datei nicht importieren kann. Das ist doch totaler nonsense. :D

    Gibt es dafür denn Abhilfe, dass ich die Qualität beibehalte und trotzdem importieren kann. Umwandeln oder ähnliches? Irgendwie wurmt mich das jetzt.
  • Bexono schrieb:

    Gibt es dafür denn Abhilfe, dass ich die Qualität beibehalte und trotzdem importieren kann. Umwandeln oder ähnliches? Irgendwie wurmt mich das jetzt.
    Umkodieren oder ggf. über einen Frameserver - beides empfehle ich aber eher nur als Notlösung. Zu letzterem gäbe es hier ein Tutorial: Wie kann ich jedes Format in Videoschnittprogramme importieren.

    Auf Dauer solltest du dir eine Methode suchen, mit der dein Programm gleich zurechtkommt.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • De-M-oN schrieb:

    Musste NVEnc halt in Constant Quantizer @ 1 aufnehmen. 1 wäre ja nicht mehr technisch lossless und daher auch kein high444 predictive nötig. Farbraum wird sehr wahrscheinlich auch 4:2:0 sein müssen.
    Habe ich denn dadurch merklichen Verlust? Die Überlegung wäre natürlich ein anderes Programm zu nehmen. Hat da jemand eine Empfehlung. Magix bietet ja jetzt auch Vegas an ggf. wäre das eine Alternative.

    Ich wäre für Ratschläge dankbar. Ich hatte schonmal mit x264 aufgenommen, aber das sieht dann doch sehr unschön aus finde ich.
  • Julien schrieb:

    TMPGEnc VMW 6 wäre eventuell eine Alternative, das Programm kann auch High444 einlesen. Zudem hat es die bestmögliche Kodierung direkt mit an Bord und ist recht bezahlbar (100€).
    Das wäre eine Option, wobei mir eine andere Lösung, anstatt des Programmwechsels lieber wäre.

    Wie nehmt ihr eure LPs denn auf? Das Problem dürfte doch dann hier bei fast jedem auftauchen, der Lossless seine Aufnahmen macht. Egal, ob jetzt OBSS, DXtory oder MSIAB.

    De-M-oN schrieb:

    Musste NVEnc halt in Constant Quantizer @ 1 aufnehmen. 1 wäre ja nicht mehr technisch lossless und daher auch kein high444 predictive nötig. Farbraum wird sehr wahrscheinlich auch 4:2:0 sein müssen.
    Ich nehme an, dass du CQR meinst? Das zerschießt mir mein Video, wenn ich es auf 1 stelle. Import ist dann trotzdem nicht möglich.
  • Bexono schrieb:

    Das wäre eine Option, wobei mir eine andere Lösung, anstatt des Programmwechsels lieber wäre.

    Dann wirst du wohl um die Transkodierung der Aufnahmedateien nicht herumkommen - oder du nimmst eben den unsichtbaren Qualitätsverlust hin und gehst vom QP 0 weg.


    Bexono schrieb:

    Wie nehmt ihr eure LPs denn auf? Das Problem dürfte doch dann hier bei fast jedem auftauchen, der Lossless seine Aufnahmen macht. Egal, ob jetzt OBSS, DXtory oder MSIAB.

    Nein, bei Dxtory und Afterburner kann man ja Codecs wie MagicYUV oder UT Video wählen. Die nehmen verlustfrei auf und brauchen kein High 4:4:4 Profil.
  • Julien schrieb:


    Dann wirst du wohl um die Transkodierung der Aufnahmedateien nicht herumkommen - oder du nimmst eben den unsichtbaren Qualitätsverlust hin und gehst vom QP 0 weg.
    Ja, wenn ich den QP auf 1 stelle, dann kommt folgendes raus:

    Spoiler anzeigen

    Allgemein
    Vollständiger Name : D:\Aufnahmen\LPs\2016-12-16 21-51-55.mp4
    Format : MPEG-4
    Format-Profil : Base Media
    Codec-ID : isom (isom/iso2/avc1/mp41)
    Dateigröße : 1,96 GiB
    Dauer : 1 min 11s
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 236 Mb/s
    Kodierendes Programm : Lavf57.41.100


    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : Main@L4.2
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 1 frame
    Codec-ID : avc1
    Codec-ID/Info : Advanced Video Coding
    Dauer : 1 min 11s
    Bitrate : 235 Mb/s
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling/String : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 1.891
    Stream-Größe : 1,96 GiB (100%)
    colour_range : Limited
    matrix_coefficients : BT.709


    Audio #1
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 1 min 11s
    Bitraten-Modus : variabel
    Bitrate : 207 kb/s
    maximale Bitrate : 320 kb/s
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 kHz
    Bildwiederholungsrate : 43,066 FPS (1024 spf)
    Stream-Größe : 1,76 MiB (0%)
    Titel : Stimme
    Default : Ja
    Alternate group : 1


    Audio #2
    ID : 3
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format-Profil : LC
    Codec-ID : 40
    Dauer : 1 min 11s
    Bitraten-Modus : variabel
    Bitrate : 265 kb/s
    maximale Bitrate : 320 kb/s
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 kHz
    Bildwiederholungsrate : 43,066 FPS (1024 spf)
    Stream-Größe : 2,29 MiB (0%)
    Titel : Ingamesound
    Default : Nein
    Alternate group : 1


    Das Problem ist, dass meine Aufnahme dann verpixelt und laggt. Verstehe ich aber nicht ganz. Der Import ist trotzdem nicht möglich. Kann es sein, dass durch ein Codecpack das MAGIX zerschossen ist? Hatte nämlich vorhin eines installiert und jetzt wieder runtergeschmissen. Gleiches Problem bleibt aber bestehen.

    Ich verzweifel bald. :/