Beste Render Qualität

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Beste Render Qualität

    Anzeige
    Hi ich sitzte jetzt schon eine Weile und bekomm es nicht hin mein Lets Play in guter Qualität zu rendern.
    Ich benutzte Sony Vegas und habe es mit folgenden Einstellungen probiert:






    Vor allem mit den Farben sieht es komisch aus bzw die Quali ist einfach DEUTLICH schlechter als die Original Aufnahme.
    Was genau mache ich falsch bzw mit welchen Einstellungen bekomme ich eine Top Quali hin?
    Zeit ist nicht so wichtig.
    Mein Youtube Channel/Lets Plays
    Schaut mal vorbei und lasst ein Feedback da,
    ich freue mich über jeden Besucher


    youtube.com/channel/UC5eqmB7QFqtwJVW65HtJgUA
  • RealLiVe schrieb:

    Kannst du "komisch" näher definieren und uns ggf. einen Screenshot-Vergleich zwischen der Originalaufnahme und dem Endprodukt zeigen?

    Zu x264vfw gibt es hier ein Tutorial - ich würde vermuten, dass dir die Werte bei "Extra command line" weiterhelfen könnten: x264vfw für Videoschnittprogramme

    Davor:



    und nach der Bearbeitung:




    Komischerweise ist beim 2ten Bearbeitung das Bild bei jedem Screenshot verschwommen.

    Aber man erkennt ja trotzdem den Qualitätsunterschied.

    Habe übrigens die Einstellungen aus dem Tutorial genau so übernommen
    und selbst die "Extra command line" mit meinen Fps angepasst.
    Mein Youtube Channel/Lets Plays
    Schaut mal vorbei und lasst ein Feedback da,
    ich freue mich über jeden Besucher


    youtube.com/channel/UC5eqmB7QFqtwJVW65HtJgUA
  • Ist ein PC-/TV-Range Problem. Korrigier's vor'm Rendern in Vegas mit dem Filter Levels, Preset "Studio RGB in Computer RGB", das sollte das Problem beheben.

    EDIT: Ansonsten in den Rendereinstellungen noch die Feldreihenfolge auf Progressiv.

    Dass es verschwommen wirkt ... das müsste am "intelligenten Resampling" liegen, das raushauen. Geht entweder in den Projekteinstellungen (seit Vegas 14), oder mit einem Rechtsklicks auf dem jeweiligen Clip, unter "Umschalter" oder so.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von RealLiVe ()

  • Anzeige

    RealLiVe schrieb:

    Ist ein PC-/TV-Range Problem. Korrigier's vor'm Rendern in Vegas mit dem Filter Levels, Preset "Studio RGB in Computer RGB", das sollte das Problem beheben.

    EDIT: Ansonsten in den Rendereinstellungen noch die Feldreihenfolge auf Progressiv.

    Dass es verschwommen wirkt ... das müsste am "intelligenten Resampling" liegen, das raushauen. Geht entweder in den Projekteinstellungen (seit Vegas 14), oder mit einem Rechtsklicks auf dem jeweiligen Clip, unter "Umschalter" oder so.
    Habs alles gefunden, sieht auf jeden Fall besser aus,
    jedoch nicht so gut wie das Original.
    Hab das Gefühl alles ist heller und die Konturen sind schwächer.
    Siehe Screenshots.





    Was gibts noch zu beachten?
    Mein Youtube Channel/Lets Plays
    Schaut mal vorbei und lasst ein Feedback da,
    ich freue mich über jeden Besucher


    youtube.com/channel/UC5eqmB7QFqtwJVW65HtJgUA

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von AndiK ()

  • RealLiVe schrieb:

    Ist ein PC-/TV-Range Problem. Korrigier's vor'm Rendern in Vegas mit dem Filter Levels, Preset "Studio RGB in Computer RGB", das sollte das Problem beheben.
    Eher ein x264vfw fehlender Eintrag, denn:
    Das Video wird von Vegas aus über VFW als RGB Material übertragen. RGB = PC Range.
    Um dafür zu sorgen das x264vfw das Video vernünftig in TV.709 bringt gehört in der "Extra command line" folgende Einträge:
    --range tv --colorprim bt709 --transfer bt709 --colormatrix bt709

    Und dann stimmen die Farben auch wieder.

    So ziemlich jede VFW Schnittstelle eines Schnittprogrammes überträgt RGB Frames an den Encoder.

    Gibt aber auch Außnahmen was dies angeht. z.B. bei Bandicam. Das ist aber nicht mal die Schuld von der VFW Schnittstelle. Bandicam nimmt von sich aus bei Aufnahmen über VFW Codecs in YUV420 auf und überträgt die Frames bereits über die VFW Schnittstelle mit einem YUV Farbraum.
    Dem VFW interessiert das ja nicht was übertragen wird. Dem ist das schnurz ^^

    @AndiK
    Abgesehen von dem was ich @RealLiVe grad schrieb, musst du darauf achten das du ebenfalls in der "Extra command line" die FPS deines Videos mit angibst, die du bereits in deinem Vegas Projekt verwendest. Sonst passiert es mal ganz schnell das Sachen Asynchron werden, da der x264vfw nicht direkt mit anderen Programmen arbeiten kann. Sprich dein Vegas ist ein Programm und x264vfw ist ein Programm. Die sind beide separat. Der eine weiß also nicht was der andere tut.
    Also gibt man dem Encoder auch noch die FPS Info mit in die "Extra command line"
    --fps 50/1
    Steht z.B. für 50 FPS. Jeweils der Zähler und Nenner.
    Wenn ein Video 29.97 FPS haben soll, gibt man dies so an:
    --fps 30000/1001 oder so --fps 30/1.001

    Das ist ganz wichtig.


    Ein weiterer Punkt ist das Video was du mit x264vfw erstellst nicht in einen AVI Container ballerst. Du hast unter dem Punkt File die Möglichkeit auch MP4, MKV oder H264 auszuwählen, wenn du auf das "..." Symbol klickst. Diese Container sind besser dafür geeignet.

    Und den CRF nicht auf 1 stellen. Das ist total überzogen. Bleibe bitte bei einem CRF Encode zwischen 18 - 26 (Standard ist 23)
    18 für top Qualität
    23 für normale
    26, wenn dir der Schuh drücken sollte und deine Finger schon krabblig sind das Video hochladen zu wollen. Qualität ist dann immer noch gut.

    Den Rest belässt du einfach so wie es auf deinem Bild abgebildet war.

    Und dann kannst du loslegen.
  • Dem ist so.

    In Vegas kann man die Farben auch verhauen. So wie in jedem Schnittprogramm auch.

    Man kann RGB auf limitierte Farb Werte einstellen oder auf Vollbereich Werte. RGB bleibt aber immer im PC Range Bereich. Das wirst selbst du nicht ändern können.

    Das eine nennt sich Studio RGB, das andere Computer RGB meist in Schnittprogrammen.
    StudioRGB ist nix anderes als den Farbwert zu limitieren. Sprich diesen auf 16 - 235 zu bringen. Die Skala jedoch vom RGB bleibt bei 0 - 255 Vollbereich. StudioRGB ist dafür da, da mit YUV Farbräumen standardmäßig im TV Bereich gearbeitet wird. Somit hat man Banding besser in Griff beim Neuberechnen der Frames.

    ComputerRGB jedoch deckt den kompletten Farbspektrum ab. Auch diese RGB Skala ist von 0 - 255 wie die vom StudioRGB. Nur das hier die Höhen und Tiefen der Farben nicht terminiert wurden.

    x264vfw hat einen eigenen Farbbereich Wandler drin. Zusammen mit der Farbmatrixangabe ist diese TV Bereich Umrechnung viel besser als das man es hätte im Schnittprogramm angeben können.

    Die Farben werden nur dann verfälscht wenn man nicht drauf achtet was man tut. Dafür hat er ja 3 Stationen.
    1. Den Farbbereich + Farbraum mit dem er aufgenommen hat
    2. Den Farbbereich + Farbraum in was sein Schnittprogramm das jeweilige Video bringt (Die konvertieren oft gerne mal, also Einstellungen beachten)
      RGB ist in den meisten Fällen aller Schnittprogramme bei VFW als Ausgabe zu erwarten. Kann geprüft werden mit MagicYUV.
    3. Und den Farbbereich + Farbraum bei dem Encoder
    Kennt man diese Stationen, kann man sich seine Szenarien am Video ausmalen:
    TV -> PC -> TV (matt)
    PC -> TV -> TV (dunkel)
    TV -> TV -> PC (matt)
    TV -> TV -> TV (neutral)
    PC -> PC -> PC (neutral)

    Die neutralen sehen dann von den Farben her so aus wie die Aufnahme auch. Siehe dazu auch Farbräume (Tutorial) - erweiterte Erklärung und Zusammenhänge
    Besonders am Ende von Beitrag 11, da habe ich es dir versucht sogar mit Bildern zu erklären.
  • Sagaras schrieb:

    RealLiVe schrieb:

    Ist ein PC-/TV-Range Problem. Korrigier's vor'm Rendern in Vegas mit dem Filter Levels, Preset "Studio RGB in Computer RGB", das sollte das Problem beheben.
    Eher ein x264vfw fehlender Eintrag, denn:Das Video wird von Vegas aus über VFW als RGB Material übertragen. RGB = PC Range.
    Um dafür zu sorgen das x264vfw das Video vernünftig in TV.709 bringt gehört in der "Extra command line" folgende Einträge:
    --range tv --colorprim bt709 --transfer bt709 --colormatrix bt709

    Und dann stimmen die Farben auch wieder.

    So ziemlich jede VFW Schnittstelle eines Schnittprogrammes überträgt RGB Frames an den Encoder.

    Gibt aber auch Außnahmen was dies angeht. z.B. bei Bandicam. Das ist aber nicht mal die Schuld von der VFW Schnittstelle. Bandicam nimmt von sich aus bei Aufnahmen über VFW Codecs in YUV420 auf und überträgt die Frames bereits über die VFW Schnittstelle mit einem YUV Farbraum.
    Dem VFW interessiert das ja nicht was übertragen wird. Dem ist das schnurz ^^

    @AndiK
    Abgesehen von dem was ich @RealLiVe grad schrieb, musst du darauf achten das du ebenfalls in der "Extra command line" die FPS deines Videos mit angibst, die du bereits in deinem Vegas Projekt verwendest. Sonst passiert es mal ganz schnell das Sachen Asynchron werden, da der x264vfw nicht direkt mit anderen Programmen arbeiten kann. Sprich dein Vegas ist ein Programm und x264vfw ist ein Programm. Die sind beide separat. Der eine weiß also nicht was der andere tut.
    Also gibt man dem Encoder auch noch die FPS Info mit in die "Extra command line"
    --fps 50/1
    Steht z.B. für 50 FPS. Jeweils der Zähler und Nenner.
    Wenn ein Video 29.97 FPS haben soll, gibt man dies so an:
    --fps 30000/1001 oder so --fps 30/1.001

    Das ist ganz wichtig.


    Ein weiterer Punkt ist das Video was du mit x264vfw erstellst nicht in einen AVI Container ballerst. Du hast unter dem Punkt File die Möglichkeit auch MP4, MKV oder H264 auszuwählen, wenn du auf das "..." Symbol klickst. Diese Container sind besser dafür geeignet.

    Und den CRF nicht auf 1 stellen. Das ist total überzogen. Bleibe bitte bei einem CRF Encode zwischen 18 - 26 (Standard ist 23)
    18 für top Qualität
    23 für normale
    26, wenn dir der Schuh drücken sollte und deine Finger schon krabblig sind das Video hochladen zu wollen. Qualität ist dann immer noch gut.

    Den Rest belässt du einfach so wie es auf deinem Bild abgebildet war.

    Und dann kannst du loslegen.

    Danke für eure Hilfe

    Ich habe es jetzt wie ihr mir gesagt habt eingestellt,
    jedoch sieht das Bild anders aus als das Original.
    Heller und weniger Konturen.
    Wie kann ich es verbessern bzw was fehlt noch?
    Hab ich etwas übersehen.
    Könnt ihr bitte nochmal drüberschauen.

    Die Einstellungen:







    Und hier die Vorher - Nacher Bilder



    Mein Youtube Channel/Lets Plays
    Schaut mal vorbei und lasst ein Feedback da,
    ich freue mich über jeden Besucher


    youtube.com/channel/UC5eqmB7QFqtwJVW65HtJgUA
  • Sagaras schrieb:

    Man kann RGB auf limitierte Farb Werte einstellen oder auf Vollbereich Werte. RGB bleibt aber immer im PC Range Bereich. Das wirst selbst du nicht ändern können.
    Ist mir bekannt. Vegas streckt in dem Fall beim Konvertieren von YUV TV Range nach RGB nicht auf 0 - 255 ("Computer RGB"), sondern "belässt" die Werte im begrenzten Bereich. Du hast also Studio RGB - und das schickt Vegas auch über VfW raus, wenn du nicht eingreifst.

    Der Parameter --range tv bei x264vfw schadet nicht, in dem Fall ändert er aber auch nichts. Der Wandler in x264vfw konvertiert es in beiden Fällen von [0 - 255] zu [16 - 235] - wenn man so will, dann geht er davon aus, dass er bei RGB Computer RGB bekommt. Das macht Vegas aber nicht selbst - es schickt dir in dem Fall Studio RGB raus.

    Oder Kurz: Grauschleier / Matt - und keine Einstellung in x264vfw kann diesen Fall allein abdecken. Damit es auf YouTube passt, kommst du im Zusammenhang mit Vegas und x264vfw meines Wissens nach nicht um den Levels-Filter mit dem erwähnten Preset herum.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von RealLiVe ()

  • AndiK schrieb:

    Hab ich etwas übersehen.
    Auf den kleinen Screenshots kann ich wenig erkennen, aber wenn ich das richtig interpretiere, dann hast du den Levels-Filter nicht angewandt, sondern nur die Vorschau verstellt.

    Du brauchst den Levels - Effekt mit der Voreinstellung "Studio RGB in Computer RGB" auf dem Video. Das ist ein echter Video-Effekt / Video-FX, kein Haken in einer Einstellung ;)
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von RealLiVe ()

  • Hoppla, hier noch mal die Bilder mit den Einstellungen.
    Könnt ihr bitte nochmal drüberschauen.

    PS: Muss ich den Effekt "Studio RGB in Computer RGB" vom Levels Menü nur von oben ins Video ziehen?
    Also nichts da ändern?

    Edit: Habs hinbekommen, krasser Unterschied! das wars, jetzt sieht es viel besser aus !
    Vielen Dank!
    Wie um Himmels Willen soll man aber auch als Anfänger in dem Programm auf sowas kommen....

    Könnt ihr trotzdem nochmal bei den restlichen Einstellugen drüberschauen ob alles passt?
    Habs nochmal mit ordentlichen Bildern hochgeladen.












    Mein Youtube Channel/Lets Plays
    Schaut mal vorbei und lasst ein Feedback da,
    ich freue mich über jeden Besucher


    youtube.com/channel/UC5eqmB7QFqtwJVW65HtJgUA

    Dieser Beitrag wurde bereits 7 mal editiert, zuletzt von AndiK ()