Dxtory Aufnahme - Mikrofontonspur wird nach ca. 20 Minuten um 1 Sekunde schneller als der Spielsound

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Dxtory Aufnahme - Mikrofontonspur wird nach ca. 20 Minuten um 1 Sekunde schneller als der Spielsound

    Anzeige
    Hallo,

    ich habe wieder mal ein kleines aber lästiges Problem das ich beseitigen möchte. Dazu muss ich mal ein wenig weiter ausholen.
    Vor rund 2 Wochen musste ich meinen PC mit Windows 7 Professinal nach mehr als 1 Jahr wieder einmal platt machen. Er fror gerne einfach willkürlich mal ein. Sei es beim abspielen eines Videos oder beim Browsen im Netz. Aufnehmen mit DXtory ging zu dem Zeitpunkt merkwürdigerweise noch einwandfrei. Nichts war asynchron. Nach der Neuinstallation von Windows 7, allen benötigten Programmen, Treiber usw. traten dann diese Probleme mit der Asynchronität auf.
    Hier nochmal die aktuelle Hardware zum Aufnehmen und Bearbeiten der Videos.

    Intel Xeon E3-1271v3 Sockel 1150
    Asrock Z97 Extreme 6
    32 GB RAM von Corsair in 4 Riegeln zu je 8 GB
    Eine Western Digital Blue 1 TB (WD10EZEX-00WN4A0) 2 Partitionen zu je 465 GB für das OS und eingelagerte Daten.
    Eine Western Digital Blue 1 TB (WD10EZEX-00WN4A0) 2 Partitionen zu je 465 GB für das OS und weitere eingelagerte Daten.
    Eine Western Digital Red Pro 3 TB (WD3001FFSX) für die Aufnahme
    Eine Seagate 3 TB Platte (ST3000DM001) für Spiele, Programe, Thumbnails
    Eine Seagate 3 TB Platte (ST3000DM001) für Die fertig gerenderten Videos und Audiodateien.

    Als Software benutze ich Dxtory 2.0.140 mit Magic YUV v1.2 Rev2 (64Bit).
    Einstellungen Accepted Colorspace: All supported
    Mode(conversion) YUV 4:4:4
    YUV Color matrix: REC. 709
    Kein Häckchen bei Interlaced, Full Range YUV, Enable RGBA Compression und Interpolate
    Number of Threads: 3
    Compression method: Predict Left
    Es wird mit 30 Frames aufgenommen.
    Unter dem Reiter Audio sind meine Soundblaster Rx eingestellt, mein Logitech USB Headset und mein Steinberg UR22 MK II mit dem angeschlossenen Sennheiser 865-S Mikrofon. Vor der Formatierung war laut Yamaha Steinberg USB Driver bei 512 Samples Buffer die Input Latency 16,485 ms und Output Latency war 19,456 ms. Aktuell ist sie bei Input 15,458 ms und Output bei 18,458 ms.

    Unter dem Menüpunkt Advanced werden wie vor der Formatierung die Kerne 4 bis 7.
    Thread Priority ist normal.
    Schneidesoftware Adobe Premiere Pro 5.5 mit Advanced Frame Server und
    MeGui zum Rendern
    Sowohl beim Abspielen der Rohdaten im Media Player Classic als auch in Adobe Premiere weisen die Asynchronität auf.

    Kann mir da jemand weiter helfen?

    Viele Grüße

    Resso
  • Ok das habe ich da. Wo ist denn hier der Knopf zum kopieren des Textes?

    So hier:

    Allgemein
    Vollständiger Name : D:\Dxtory Videos\AssassinsCreedIIGame 2017-03-15 07-16-38-689.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 312 GiB
    Dauer : 1 h 48 min
    Gesamte Bitrate : 411 Mb/s
    Originale Source-Form/Vertrieb durch : Video:MagicYUV lossless v1.2rev2 (64 bit) Audio0:Lautsprecher (Sound Blaster Audigy 5/Rx) Audio1:Line (2- Steinberg UR22mkII ) Audio2:Lautsprecher (2- Logitech USB Headset)
    Kodierendes Programm : DxtoryCore ver2.0.0.140


    Video
    ID : 0
    Format : MAGY
    Codec-ID : MAGY
    Dauer : 1 h 48 min
    Bitrate : 406 Mb/s
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 30,000 FPS
    Bits/(Pixel*Frame) : 6.525
    Stream-Größe : 309 GiB (99%)


    Audio #1
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 1 h 48 min
    Bitraten-Modus : konstant
    Bitrate : 1 536 kb/s
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 kHz
    BitDepth/String : 16 bits
    Stream-Größe : 1,17 GiB (0%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 100 ms (3,00 Video-Frames)


    Audio #2
    ID : 2
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 1 h 48 min
    Bitraten-Modus : konstant
    Bitrate : 1 536 kb/s
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 kHz
    BitDepth/String : 16 bits
    Stream-Größe : 1,17 GiB (0%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 100 ms (3,00 Video-Frames)


    Audio #3
    ID : 3
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 1 h 48 min
    Bitraten-Modus : konstant
    Bitrate : 1 536 kb/s
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 kHz
    BitDepth/String : 16 bits
    Stream-Größe : 1,17 GiB (0%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 100 ms (3,00 Video-Frames)
  • Die Headset Tonspur ist das Teamspeak im Multiplayer bzw. LPT bzw. das Spiel im Singleplayer. Da lasse ich den Spielesound nicht über die Soundkarte laufen. Nur bei LPT wird der Spielesound über die Soundkarte angesteuert. Da benutze ich dann zusätzliche In-Ear Kopfhörer.
    Klingt komisch. Ist aber so. Das heisst das eine Tonspur im Singleplayer immer im Normalfall zwar mit aufgezeichnet wird aber leer bleibt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ressorator ()

  • Ihr müsst euch mal merken (an die die schon länger hier im Forum Support für Audio und Video geben), DXTory, MSI AB und auch Fraps können kein VFR.

    Das Kernproblem wenn Audio abdriftet zur Mikrofonspur ist das Timing von Windows, unterschiedliche Hertz Angaben (Wohl eher unwahrscheinlich bei der Aufnahme das da was Asynchron wird bei) ODER das verwendete Aufnahmegerät spielt nicht ganz mit (WASAPI vs. DirectSound).

    Zwecks Timing sollte überprüft werden ob HPET (High Precision Event Timer) aktiv ist im BIOS, als auch in Windows.
    Standardmäßig ist es meist so das es im BIOS an ist, aber in Windows aus.
    Überprüfen kann man das z.B. mit WinTimerTester (mediafire.com/file/p8dr93gvcyfg88c/WinTimerTester.7z)

    Steht dort irgendwas mit 3.xxx MHz, dann ist HPET inaktiv
    Wenn dort steht 14.xxx MHz, dann ist HPET aktiv

    Sollte es nicht aktiv sein, kann man es via der CMD und dem Befehl bcdedit /set useplatformclock true aktivieren.
    Der Rechner sollte nach dieser Aktion neu gestartet werden.
    Zum Deaktivieren den gleichen Eintrag nur mit false.


    Bei unterschiedlichen Hertz Frequenzen bei der Aufnahme zwischen Systemsound und Mikrofon, kommt es meist im Schnittprogramm zur Asyncronität, da meist versucht wird beide Spuren auf eine Frequenz anzupassen. Meist wird dann die eine damit beschleunigt oder verlangsamt.
    (Ist hier in dem Thread laut der Mediainfo nicht der Fall)


    Und es gibt einige Rechner die Probleme mit WASAPI haben. Falls dies der Fall ist, einfach mal DirectSound dann probieren. Oftmals das gerade Onboard Soundkarten damit oft Schwierigkeiten machen.


    Und was viele oftmals übersehen ist das es beim Abspielen von Lossless Material oftmals zu Nachladeproblemen kommt im Videoplayer. Daher kann es gut sein das es eine Folge von Ladeschwierigkeiten war. Wenn man sich da unsicher ist, hilft es meist die beiden Audiospuren heraus zu extrahieren und sich das ganze in Audacity oder was weiß ich zu überprüfen. So Audio only. ^^


    Das sind so Kernprobleme oftmals. Die sollte man selbst dann prüfen und ausprobieren.
  • Hat es eventuell damit zu tun, dass ich DirectX 9.29 nicht drauf hatte?
    Ich habe es auch mal getestet mit der Auslagerungsdatei auf eine Festplatte. Egal ob eine zugewiesen ist oder nicht machte keinen Unterschied.

    Nachtrag: Wenn ich versuche die HPET zu ändern wirft er folgendes aus: Der Speicher für die Startkonfigurationsdateien konnte nicht geöffnet werden. Zugrif verweigert.

    Mit Adminrechten geht es allerdings....
    Ok PC mal neu starten.

    Jetzt läuft es mit 14,xxx Mhz

    Sonst noch jemand Tipps oder Lösungsvorschläge? :)

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Ressorator ()

  • Ressorator schrieb:

    Compression method: Predict Left
    Median ist schneller für Game Capture. MagicYUV 2.0 kaufen = Performance ++
    Threads mach mal auf Vollgas. Sollte eig. genug für's Spiel über bleiben. Schnellere Codierverarbeitung kann jedenfalls auch der Latenz zugute kommen.

    HPET sollte natürlich in jedem Fall an sein. Bei manchen Spielen bringt es sogar zusätzliche FPS. Bei irgendnem Crysis teil (glaub 3? )war der Zuwachs dadurch sogar recht beträchtlich. HPET wird auf jeden Fall deutlich helfen, denn ohne HPET zerreißts dir spätestens nach 'ner stunde schon in den hörbaren bereich. Allerdings eher so ~200ms geschätzt, keine 1 Sekunde nach 20min ^^

    Audiospuren nur diese verwenden, die auch aktuell für die Aufnahme gebraucht werden. Jedes weitere Abgreifen von Soundgeräten produziert weitere Latenz. Das USB Headset wird zb alles andere als ein Latenzwunder sein :P
    Achte auch unbedingt drauf das in Windows Systemsteuerung die Geräte auf gleicher Samplerate, in deinem Falle 48khz, stehen wie in DXTory(!)
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Es gibt Gute Neuigkeiten:

    Heute vormittag habe ich eine 2 Stunden Aufnahme von AC Brotherhood erstellt. Nach 45 Minuten war der Ton immer noch perfekt synchron. HPET sei gepriesen. Ich werde die Session bis heute Nacht komplett fertig verarbeitet haben.
    Ich werde mir MagicYUV 2.0 im April zulegen De-M-oN. Wenn du sagst das Teil lockt noch mehr Saft raus, dann will ich davon natürlich auch profitieren. Ich hoffe das dieses HPET auch bei aktuellen bzw. im nächsten Jahr erscheinenden AMD Systemen vorhanden sein wird.
    Ich gehe mal davon aus das MeGUI auch von einem Achtkerner ein wenig profitieren wird.
    Mein Dank geht an an dieser Stelle an alle die mich hier mit Rat und Tat unterstützt haben.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Ressorator ()

  • Nachtrag: Nach knapp 90 Minuten war eine Diskrepanz von 2 Sekunden vorhanden. Ich bekomme eine Krise. Ich deinstalliere Dxtory mal und mache eine saubere Neuinstallation. Eventuell hilft das ja für die nächste Session.

    Zweier Nachtrag 16:38 Uhr: Neuinstallation mit der Version 2.0.0.128 zeigte keine Änderung.
    Mir ist aufgefallen dass ich die Soundeinstellungen am Mikrofon über das USB Interface nicht ändern kann. Es wird eingespeist mit 48000 Hz und 24'er Bitrate. Ich werde nun versuchen durch erhöhen des Buffers von 512 auf 768 eine Änderung zu erzielen.
    Oder hat sonst noch jemand einen Vorschlag?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ressorator ()

  • Dritter Nachtrag am 20.03.2017 um 16:23 Uhr: Ein älterer Nvidia Treiber zeigte ebenfalls keine Änderung. Es hat den Anschein als würde Dxtory stark unter den gewünschten 30 Frames fluktuieren und eher im Bereich der 29,8 bis 29,9 kratzen. Es erreicht selten Werte von genau oder über 30. Und es schien das vor der Formatierung das ganze immer leicht über der 30'er Marke war bzw. blieb. Hat denn noch jemand eine Idee was das Problem sein könnte? Ich tippe auf die Grafikkarte selber oder meine WD Red Pro.